Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
"ESP Not Available" and car goes into limp mode >

"ESP Not Available" and car goes into limp mode

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

"ESP Not Available" and car goes into limp mode

 
Old 11-03-2015, 09:55 AM
  #26  
Newbie
 
Join Date: Dec 2014
Location: Klerksdorp
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
2008 Mercedes Benz C220Cdi Avantgarde A/T
Found my Problem

Okay.

So i took it to a guy here who actually went out and investigated the problem. My EGR Cooler was completely blocked with Carbon. i Know it cools down the gasses that goes back in to the engine. It cost me about R5000 to repair this.

I am Attaching the pictures. Hope it will help someone else too.
Attached Thumbnails "ESP Not Available" and car goes into limp mode-20151030_135135_resized.jpg   "ESP Not Available" and car goes into limp mode-img-20151030-wa0007.jpg  
Bevill084 is offline  
Old 11-03-2015, 11:39 AM
  #27  
Junior Member
 
SB500's Avatar
 
Join Date: Sep 2015
Location: Queens, NY
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
2003 CLK500
Originally Posted by Bevill084 View Post
Okay.

So i took it to a guy here who actually went out and investigated the problem. My EGR Cooler was completely blocked with Carbon. i Know it cools down the gasses that goes back in to the engine. It cost me about R5000 to repair this.

I am Attaching the pictures. Hope it will help someone else too.
did this help with limp mode? I jus changed my transmission adapter, & 2 faulty fuel injectors. Waiting for a transmission dip tool to make sure its enough transmissiob fluid
SB500 is offline  
Old 11-05-2015, 02:28 AM
  #28  
Newbie
 
Join Date: Dec 2014
Location: Klerksdorp
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
2008 Mercedes Benz C220Cdi Avantgarde A/T
Hey Guys.
So you all read about my ESP Problem.
Here is my History.

1. Esp Unavailable and goes into Limp Mode. December 2014. I Replaced Boost Pipe. Problem Solved.
2. 10 Months Later it went into Esp Unavailable again. Took it to many workshops including Agents and no one could diagnose the problem. They told me that there must be a wire somewhere that is not making connections. Took it to electricians and they could not find anything wrong. So i started losing hope.
3. i Read on the blog about EGR valve being corroded. Took it out and cleaned it with Carb Cleaner. But still went into Limb. Especially when i was driving at low speeds.
4. Last Mechanic who actually went out of his way to find the problem . He found that the EGR Cooler was blocked with carbon. Unfortunately they cant clean that part and i had to get a decent used one as a new one will cost me my house. They replaced it and i can say that i have driven my car a few days now, And it has not yet given me any more problems. No Limp Modes or anything. It drives like a new car

again.

I Am going to Johannesburg this weekend with it. I will keep you posted on what happened on the road. But i Believe that my car is now sorted.


EGR Cooler





EGR Cooler Inside
Bevill084 is offline  
Old 11-05-2015, 03:15 AM
  #29  
Member
 
Join Date: Oct 2015
Location: Georgia, Batumi
Posts: 80
Received 1 Like on 1 Post
Mercedes Benz W204 C350
same problem with limp mode , i own c350 2008 heeellppp
dipdip19 is offline  
Old 11-11-2015, 05:07 PM
  #30  
Newbie
 
Join Date: Oct 2015
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
MB C200 CDI W204 2009
Same problem here.

Got a C200 CDI 2009 (w204).

Going to the shop tomorrow, hope it'll sort out in low cost.
Ill keep you guyz posted about the reason for this problem.
nnnsss888 is offline  
Old 06-07-2018, 07:52 AM
  #31  
Newbie
 
Join Date: Jun 2018
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Mercedes C220 w204
Hello all,

I had the same issue with my C220 w204. Did you managed to fix it and how?
LucianG is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: "ESP Not Available" and car goes into limp mode


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: