Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Dashboard not functional >

Dashboard not functional

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Dashboard not functional

 
Old 01-12-2019, 03:54 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
W204
Dashboard not functional

Today i turned on my w204 and it started normally, but the whole dashboard is not functional.
Check the below picture
any recommendation?

Base is offline  
Old 01-12-2019, 04:45 PM
  #2  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,714
Thanked 575 Times in 558 Posts
1999 E300TD
Sounds like you have a faulty ignition module
Plutoe is offline  
Old 01-14-2019, 10:51 AM
  #3  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
W204
Thanks for your quick reply.

I did change the fuse in the front engine box, I changed fuse number 5 and 28 and replaced them with a 7.5A new fuses, it seems to solve the problem.
Also, I used to have the front right parking light always on and I always had to keep the light switch on Auto (so it will turn off). Now it seems the problem is solved. I don't know if they were connected, but it seems its working fine now.

PS: the old fuses were not broken.
Base is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Dashboard not functional


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: