Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C Class (W205)
How to reset the Service Indicator >

How to reset the Service Indicator

Notices
C Class (W205) C 180 BlueTec,C 200 BlueTec,C 220 BlueTec,C 220 BlueTec BlueEfficiency,C 250 BlueTec,C 300 BlueTec Hybridplus,C 180,C 180 BlueEfficiency,C 200,C 250,C 300,C 400 Plug-in Hybrid,C 400

How to reset the Service Indicator

 
Old 09-18-2015, 08:12 PM
  #1  
Newbie
Thread Starter
 
Join Date: Mar 2004
Location: California
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
04 e320, 96 m3, 88 m3
Exclamation How to reset the Service Indicator

Hey everyone, just changed the oil in my C400. Does anyone know how to reset the service/oil indicator??

Thanks in advance

Last edited by Glyn M Ruck; 12-06-2015 at 11:44 AM.
marsfire is offline  
Old 09-18-2015, 08:18 PM
  #2  
Newbie
Thread Starter
 
Join Date: Mar 2004
Location: California
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
04 e320, 96 m3, 88 m3
By the way, I've done a search and found the following thread. It only unlocks additional information such as oil temp, but does NOT show how you actually reset the service...

https://mbworld.org/forums/c-class-w...nge-reset.html
marsfire is offline  
Old 09-18-2015, 10:37 PM
  #3  
Junior Member
 
deonsand's Avatar
 
Join Date: Jun 2010
Posts: 30
Thanks: 0
Thanked 2 Times in 2 Posts
w204


Originally Posted by marsfire View Post
Hey everyone, just changed the oil in my C400. Does anyone know how to reset the service/oil indicator??

Thanks in advance

Sit in the car and close the door.
Turn the ignition to position 1.
Get the instrument cluster to the screen where the odometer is displayed.
Press the left button once to highlight "trip".
Press and hold the "accept call" button.
While holding the "accept call" button press and hold the "OK" button.
After several seconds the service menu should come up.
Scroll to Assyst.
At this point it should be self explanatory... full service, yes, confirm...
Back out or cycle the ignition to exit the service menu


use for w204 and w205

also apply keyless entry model


hope it helps .
deonsand is offline  
The Following User Says Thank You to deonsand For This Useful Post:
Almashayekhi (10-08-2017)
Old 09-20-2015, 04:29 AM
  #4  
Senior Member
 
bartola's Avatar
 
Join Date: Mar 2011
Location: SF Bay Area
Posts: 366
Thanked 3 Times in 2 Posts
CLA-250, C-300
Yep, I can confirm, I have done the reset
bartola is offline  
Old 12-06-2015, 01:44 AM
  #5  
Newbie
Thread Starter
 
Join Date: Mar 2004
Location: California
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
04 e320, 96 m3, 88 m3
thanks, I can confirm that this worked as well!

To clarify, the "left button" that you reference is the "home" button with the picture of the little house on it.
marsfire is offline  
Old 02-01-2016, 11:33 AM
  #6  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by marsfire View Post
thanks, I can confirm that this worked as well!

To clarify, the "left button" that you reference is the "home" button with the picture of the little house on it.
Hmm. This is really weird. I tried multiple times, with key in both positions and when I pressed "OK", it just went into trip and show the mileage. Has anyone else tried this? Does this work with every w205?
huyuci is offline  
Old 02-26-2016, 04:43 PM
  #7  
Senior Member
 
V12toHybrid's Avatar
 
Join Date: May 2002
Location: Wyomissing, Pa
Posts: 275
Thanks: 0
Thanked 0 Times in 0 Posts
Kia Sedona
Originally Posted by huyuci View Post
Hmm. This is really weird. I tried multiple times, with key in both positions and when I pressed "OK", it just went into trip and show the mileage. Has anyone else tried this? Does this work with every w205?
need to hold both the answer and hang up bottoms- not just the answer.
see video:

V12toHybrid is offline  
Old 10-09-2016, 04:53 PM
  #8  
Newbie
 
Join Date: Dec 2015
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2016 C450 AMG
Here is a little more detailed explanation. With keyless ignition just push the start button twice with your foot off the brake.
http://oilreset.com/2015-mercedes-c-...nterval-reset/
Evasiveone is offline  
Old 03-24-2017, 11:46 AM
  #9  
Newbie
 
Join Date: Mar 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
GLC 300 2016
Hey everyone, just changed the oil in my GLC 300 2016 Does anyone know how to reset the service/oil indicator??

Thanks in advance

Last edited by Gigi Nicolae; 03-24-2017 at 12:31 PM.
Gigi Nicolae is offline  
Old 03-24-2017, 11:59 AM
  #10  
Newbie
 
Join Date: Mar 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
GLC 300 2016
Originally Posted by Gigi Nicolae View Post
Hey everyone, just changed the oil in my GLC 300 2016 Does anyone know how to reset the service/oil indicator??

Thanks in advance

Last edited by Gigi Nicolae; 03-24-2017 at 12:29 PM.
Gigi Nicolae is offline  
Old 03-24-2017, 12:31 PM
  #11  
Newbie
 
Join Date: Dec 2015
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2016 C450 AMG
Just follow the steps in this link.
https://redirect.viglink.com/?format...erval-reset%2F
Evasiveone is offline  
Old 02-03-2018, 04:41 AM
  #12  
Newbie
 
Join Date: Jan 2017
Posts: 9
Thanked 0 Times in 0 Posts
C 250
I was about to change brake pad with my C250 W205 from Germany
The instrument menu for Reset somehow different
1. Set key to position 1 (one detent to clockwise) check display in Trip/odometer x00km/xx000
2. Press Call (phone call) button and hold
3. After one second, followed by Cancell call (phone end) button and hold
4. After another second OK button
that will display service menu,
As I wanted to reset the electronic brake to change the brakepad, it said, the brake reset does not meet the condition ? any other input appreciated
oxxy is offline  
Old 07-05-2018, 11:12 PM
  #13  
Junior Member
 
Join Date: Jun 2018
Posts: 21
Thanked 1 Time in 1 Post
Ford Edge
When you reset the service indicator let's say for service A does it jump automatically to countdown for Service B?

P.S. I want to reset days, bud I don't want to mess up with Service A/B countdowns... I all I need is that next service will be with 365 days and not 180 what it currently shows
t0lkman is offline  
Old 10-03-2018, 02:47 PM
  #14  
Junior Member
 
Join Date: Apr 2010
Location: Honolulu
Posts: 38
Thanked 5 Times in 5 Posts
2018 C43amg,2012 CLS 550, 2004 Chevrolet SSR, 1934 Chevy street rod
2018 c43

Does anyone have the instructions to reset on a c43?
lou7777777 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: How to reset the Service Indicator


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:
You Rated this Thread: 5