Go Back  MBWorld.org Forums > Mercedes-Benz Coupes & Cabriolets > CLK-Class (W208)
BAS, ESP, ABS problem.....DIY repair >

BAS, ESP, ABS problem.....DIY repair

Notices
CLK-Class (W208) 1998-2002: CLK 200, CLK 230K, CLK 320, CLK 430 [Coupes & Cabriolets]

BAS, ESP, ABS problem.....DIY repair

 
Old 08-12-2006, 01:52 PM
  #26  
MBWorld Fanatic!
 
Join Date: Sep 2004
Location: Los Angeles, California
Posts: 1,178
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430
nope

Originally Posted by mattr2
I think my CLK has the same problem. Did the failure of this switch prevent the car from being moved from park?
CurYousGee is offline  
Old 08-13-2006, 01:44 AM
  #27  
Newbie
 
Join Date: Feb 2005
Posts: 22
Likes: 0
Received 0 Likes on 0 Posts
Actually....yes, problem solved

The brake lamp switch controls both the lights and the lever release so the car can be taken out of park when the brake is pressed. I was able to buy the part from the dealer and install it in about 10 minutes. This was a VERY helpful thread.

Thank you!
mattr2 is offline  
Old 09-29-2006, 03:28 AM
  #28  
Super Member
 
Join Date: Nov 2003
Location: TN
Posts: 527
Likes: 0
Received 1 Like on 1 Post
2002 c240
Hmmmmm. My brake lights work, shifts from park easily, but I believe I still need to replace mine because I have the yellow lights and the OBC warning. The lights were so bright at night I removed the bulb from the cluster......lol.

Guess I'll swing by MB tomorrow and pick up a switch.
The Jury is offline  
Old 10-02-2006, 05:39 PM
  #29  
Super Member
Thread Starter
 
Join Date: Aug 2003
Location: Los Angeles, CA
Posts: 626
Received 1 Like on 1 Post
'03 E55 (My Daily), '01 ML 320 (Wifey), Twin Turbo '69 Camaro (In Progess)
Failure of the switch actually causes a failure of your stability control as well as anti-lock brakes and brake assist system. While the light on the dash sucks to have come up, these other systems aren't functioning properly. That being said, the car should be driveable in that condition. After figuring out this repair for the stop lamp switch, a MB technician told me that they have started shimming the switch somehow to prevent the rather prnounced failure rate of these switches. I wonder how long before Mercedes realizes that a large number of their subsystem failures and thus repairs are a fault of cheap, inferior Bosch electrical sensors and switches (i.e. MAF, Stop Lamp, etc) !?!?
bbearden is offline  
Old 10-06-2006, 11:33 PM
  #30  
Junior Member
 
Join Date: Feb 2006
Location: IN
Posts: 61
Received 0 Likes on 0 Posts
2014 E550 Convertible
What an easy fix

After being lazy for far too long and seeing this post - I did it. The POS set me back $17 at the dealer and just a few minutes to replace - very easy. I can't begin to say how annoying those ESP/BAS, ABS, etc. lights and the beeping were. The fact that the cruise control also wouldn't work during an "episode" compounded it. It's back to normal now.

I did kind of enjoy driving the car with all of that stuff disabled (no silly flashing ! in the middle of the dash)!! I could come out of a sharp curve and leave rubber without having to hit the switch on the console...
software is offline  
Old 10-06-2006, 11:37 PM
  #31  
Junior Member
 
Join Date: Feb 2006
Location: IN
Posts: 61
Received 0 Likes on 0 Posts
2014 E550 Convertible
BTW - my old switch was cooked. It sounded like a baby rattle when I shook it. Obviously a quality item!
software is offline  
Old 11-01-2006, 03:17 AM
  #32  
Member
 
zdfun's Avatar
 
Join Date: Oct 2006
Location: Los Angeles
Posts: 134
Likes: 0
Received 0 Likes on 0 Posts
2005 CLK 500 Coupe


Thank you very much! It works!
zdfun is offline  
Old 11-01-2006, 01:32 PM
  #33  
Super Member
 
Join Date: Nov 2003
Location: TN
Posts: 527
Likes: 0
Received 1 Like on 1 Post
2002 c240
The Jury is offline  
Old 11-01-2006, 10:34 PM
  #34  
Newbie
 
Join Date: Oct 2006
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Thank You all!!! I just bought a 2002 CLK 430 and right after I arrived home and started checking out the car. I then started it to go for a ride and all those errors started displaying. I thought for sure I bought a lemon. I search for the issue and behold you had it posted. I purchase the switch and installed it in about 5 min ( so simple) Thank you all... Look forward to future correspondence.
RICLK430 is offline  
Old 11-02-2006, 12:51 AM
  #35  
Newbie
 
Join Date: Mar 2003
Location: Cookeville, TN
Posts: 22
Likes: 0
Received 0 Likes on 0 Posts
1999 CLK430
LOL at this switch man. Do these lights ever indicate anything other than "it's time to replace the $17 part!" It seems to be a self defeating safety issue if the problem is always a "switch" and not something more sinister with the brake system.

If the light comes on, does everyone who has replaced one just assume it's this switch or did you get your codes read first?
Bjorkin is offline  
Old 11-02-2006, 10:00 AM
  #36  
Super Member
Thread Starter
 
Join Date: Aug 2003
Location: Los Angeles, CA
Posts: 626
Received 1 Like on 1 Post
'03 E55 (My Daily), '01 ML 320 (Wifey), Twin Turbo '69 Camaro (In Progess)
More often than not, if its numerous lights coming on, its the switch and people just change out the part. However, with this new good intel, I'm just going to clean the part from now on. Why bother buying another cheap switch that will fail down the road when the old one can just be cleaned.
bbearden is offline  
Old 11-04-2006, 01:54 AM
  #37  
Super Member
 
Whodat's Avatar
 
Join Date: Apr 2006
Location: Somewhere in Maryland
Posts: 555
Likes: 0
Received 0 Likes on 0 Posts
2000 CLK 430 Cabriolet
Originally Posted by bbearden View Post
Took me 15 minutes for the job and another 10
to sip a cold beer afterwards. Cheers!
10 whole minutes to sip a cold one!? You're losing your touch! *LOL*
Whodat is offline  
Old 11-04-2006, 02:24 AM
  #38  
Super Member
Thread Starter
 
Join Date: Aug 2003
Location: Los Angeles, CA
Posts: 626
Received 1 Like on 1 Post
'03 E55 (My Daily), '01 ML 320 (Wifey), Twin Turbo '69 Camaro (In Progess)
LOL! Gettin' older I guess. Hell I'm just trying to keep the hair on my head as well. Just saw "Borat," hilarious! Def go check it out....
bbearden is offline  
Old 11-22-2006, 12:54 AM
  #39  
Newbie
 
Join Date: May 2005
Location: Toronto
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
2001 CLK 430, Audi A4
hi, what are the symptoms of this problem? my current issues are ABS/ESP/BAS changes(automatically) on the LCD display, ABS/ESP/BAS lights are constant on the left side of the console. car drives like normal.

issues i had previously, same display as above but the messages on the LCD does not change automatically (have to troggle between), same lights on left side of console are on, also CEL, tachometer not responsive, drives in limp mode, will not switch gears (i assume it was stuck in whichever gear at the time, usually first). was in the same dealer three times while various modules were ordered/replaced. forth time had it towed to another dealer and they blamed it on the fuse box. hasn't occurred since, now my current issues with ABS/BAS/ESP as outline above.

will this switch replacement fix my current problems?? and thank goodness for extended warranty... this was for a 01 w208 430
thx.
Waiby is offline  
Old 11-22-2006, 03:10 AM
  #40  
Member
 
zdfun's Avatar
 
Join Date: Oct 2006
Location: Los Angeles
Posts: 134
Likes: 0
Received 0 Likes on 0 Posts
2005 CLK 500 Coupe
I have this problem 4 days after I bought my CLK 320. It DID scare me. It usually turned on after I drove my car around 15-25 minutes The light was suddenly turn ON. I also noticed that my tail light (the brake light) was ON all the time even I didn't step on the brake.
zdfun is offline  
Old 12-11-2006, 10:33 PM
  #41  
Member
 
SeNia_CLK's Avatar
 
Join Date: Oct 2006
Location: Edmonton
Posts: 355
Likes: 0
Received 0 Likes on 0 Posts
2001 CLK 320
Originally Posted by bbearden View Post
Glad I could help you out! I don't get worried when I see that light flash these days, knowing how simple the fix is.
bbearden thanks a lot for the post man, I was a little concerned with this problem at first, going to deal with it right after my last exam on Thursday
SeNia_CLK is offline  
Old 12-11-2006, 10:48 PM
  #42  
Super Member
Thread Starter
 
Join Date: Aug 2003
Location: Los Angeles, CA
Posts: 626
Received 1 Like on 1 Post
'03 E55 (My Daily), '01 ML 320 (Wifey), Twin Turbo '69 Camaro (In Progess)
Glad to help you out. Best of luck on your finals!
bbearden is offline  
Old 12-16-2006, 05:40 PM
  #43  
Member
 
SeNia_CLK's Avatar
 
Join Date: Oct 2006
Location: Edmonton
Posts: 355
Likes: 0
Received 0 Likes on 0 Posts
2001 CLK 320
And now got a degree also! Now the plan is to switch CLK320 to a CLS63 AMG Coupe in a few years!

Last edited by SeNia_CLK; 12-16-2006 at 06:25 PM.
SeNia_CLK is offline  
Old 12-16-2006, 06:42 PM
  #44  
Member
 
Join Date: Nov 2006
Posts: 78
Likes: 0
Received 0 Likes on 0 Posts
clk430
My light came on after I disconnected the battery. I searched and found out that people 'reset' the light by turning the steering wheel all the way to the right and to the left, then back to straight. It actually worked. I got scared at first.

Last edited by NYCLK; 12-17-2006 at 09:30 AM.
NYCLK is offline  
Old 12-18-2006, 08:25 PM
  #45  
Member
 
SeNia_CLK's Avatar
 
Join Date: Oct 2006
Location: Edmonton
Posts: 355
Likes: 0
Received 0 Likes on 0 Posts
2001 CLK 320
Turns out its my camshaft sensor...another $180
SeNia_CLK is offline  
Old 04-29-2007, 01:28 AM
  #46  
Senior Member
 
Join Date: Jan 2007
Location: Lindenhurst, IL
Posts: 252
Likes: 0
Received 1 Like on 1 Post
2001 CLK55
I bought a stop lamp switch and turns out it was the wrong one. If anyone wants to buy it it works with a 99 clk430. $12.00 shipped. PM ME if interested. make sure yours looks like this, i don't believe it works on 2000-UP. Its Brand New Never installed.
AMGEEZY is offline  
Old 05-03-2007, 02:30 AM
  #47  
Newbie
 
Join Date: May 2007
Location: Las Vegas / Los Angeles
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2002 CL600, 2005 S500, 2002 M5, 2001 Range Rover HSE
SOS - Stuck in Park & Cranks when it wants to, ESP/BAS/Airmatic ERRORS...

I've got a a similar issue but with much more kinks...

Friday night the valet brought my 2002 s500 around to the front of the restaurant with no problems. They turned it off and when I was ready to leave, I hopped in, turned it over, nothing. The dash board lights up like a christmas tree giving me a Check Engine light, & ESP, BAS, Airmatic ERROR messages. I turned the automatic headlights off and tried it again, it started. I got it home, started it up the next day, no problem, ABS light on. Went to the grocery store, came out, wont start. And when I say "wont start" I mean won't crank or anything. Its like having your key in the II possition. I tried it a few times and nothing. So I left it there and walk 2 blocks home. I returned later to see if it just need some time to stop hating me and, it started! But wont come out of park.

I replaced the battery, it started, I turned the wheels lock to lock to erase the codes, & then I turned it off. I tried to start it again and nothing. No crank.

It cranks when it wants to and when it does, its stuck in park. Oh and one more thing...the A/C won't work. I noticed that the A/C display was fading on and off that first night on the way home from the restaurant. When the car decides to crank & turn over, the only thing that will get the A/C to do anything is if I hit the REST button. Isn't this only supposed to work when the cars off to push residual hot air off the engine during over heating? -My temp gauge reads normal btw.

SO....with ALL that being said....PLEASE HELP!! My car has been in the Ralph's parking lot for almost a week & no one, not even the dealer can tell me what to do!

Oh, no one will tow it for me because it wont come out of park...????

H.E.L.P.

THANK YOU!
ForrestBlackbur is offline  
Old 05-03-2007, 06:40 AM
  #48  
Member
 
NVDR's Avatar
 
Join Date: Sep 2004
Location: VIRginia
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
CLK430
my ABS, ESP and BAS lights came on after I released the parking brake, after a stop, ignition off and ignition on again it dissapeared. next time it comes back I will follow the write ups.
NVDR is offline  
Old 05-03-2007, 10:05 PM
  #49  
MBWorld Fanatic!
 
Holson's Avatar
 
Join Date: May 2003
Location: USA
Posts: 1,017
Received 34 Likes on 28 Posts
2018 G550
Encountered the same problem. The 1st time round the dealer replaced the brake switch... the 2nd time round, they replaced the brake booster

Thanks to Starmark, it cost me nothing.
Holson is offline  
Old 05-08-2007, 09:29 PM
  #50  
Newbie
 
Join Date: May 2007
Location: Texas
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
99 CLK 430
BAS ABS ESP Etc..... Quick Fix

I got these messages after a brisk takeoff and took the car to a European Shop and they said they just needed to clear the codes with their computer. Well that didn't work so they told me I prob had a bad ABS Sensor under the hood next to the BAS sensor.. They wanted obo $475.00
I read the threads obo the stop lamp switch and thanks to the Pics I decided to attempt to remove it to take a look. Really just to see if I could do it.... I disconnected the switch easily and cleaned the end and around it with a cloth, reinserted the switch and now my ESP button on the console works again and no error messages....just by cleaning it slightly!!!! Will check back in to see how long this works for..... 99 CLK 430 THANKS FOR THE PICS!!!!!!!!!!!!!!!!!!!

Last edited by AustinRoxy; 05-08-2007 at 10:51 PM.
AustinRoxy is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: BAS, ESP, ABS problem.....DIY repair


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: