PO141 Sensor Heater Circuit Malfunction Bank (1) Sensor (2) - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Coupes & Cabriolets > CLK-Class (W208)
PO141 Sensor Heater Circuit Malfunction Bank (1) Sensor (2) > PO141 Sensor Heater Circuit Malfunction Bank (1) Sensor (2)
Notices
CLK-Class (W208) 1998-2002: CLK 200, CLK 230K, CLK 320, CLK 430 [Coupes & Cabriolets]

PO141 Sensor Heater Circuit Malfunction Bank (1) Sensor (2)

Reply

 
 
Old 04-16-2012, 07:17 PM
  #1
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
PO141 Sensor Heater Circuit Malfunction Bank (1) Sensor (2)

Hey all,

I have a '00 CLK 430 and have had my Check Engine light on. It's been fluctuating on and off lately. I had my mechanic run a diagnostic and the error message was "PO141 Sensor Heater Circuit Malfunction Bank (1) Sensor (2)"

I'm wondering if this is something I can do myself, and what part(s) I would need. Any information would be extremely helpful.

Thanks!
Saif Akhtar is offline  
Reply With Quote
Old 04-16-2012, 07:36 PM
  #2
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Saif Akhtar View Post
Hey all,

I have a '00 CLK 430 and have had my Check Engine light on. It's been fluctuating on and off lately. I had my mechanic run a diagnostic and the error message was "PO141 Sensor Heater Circuit Malfunction Bank (1) Sensor (2)"

I'm wondering if this is something I can do myself, and what part(s) I would need. Any information would be extremely helpful.

Thanks!
Figured out that Bank (1) Sensor (2) means Passenger Side Rear sensor. Bosch Part Number 15092 (dealer charges $290; Amazon has it for $<90 - gotta love online shopping!)

I'm guessing I might be able to replace it myself. Any advice or DIY instructions would be appreciated!
Saif Akhtar is offline  
Reply With Quote
Old 04-16-2012, 09:57 PM
  #3
MBWorld Fanatic!
 
Join Date: May 2007
Location: Nebraska
Posts: 1,432
Thanks: 0
Thanked 0 Times in 0 Posts
99CLK320,
Pretty straight forward. unplug the old and turn it our with a wrench. reverse.
dlbehrns is offline  
Reply With Quote
Old 04-16-2012, 10:15 PM
  #4
Super Member
 
Join Date: Apr 2010
Location: springfield,mass
Posts: 665
Thanks: 0
Thanked 0 Times in 0 Posts
2001 clk 320
Did any other codes show.I know when mine showed that code.my egr valve code showed too.so I decided to tackle the cleanong of the egr valve and viola no more check engine light.
jbenz2001 is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dmitry_sorokin
Mercedes Tech Talk
10
07-30-2017 02:59 AM
rbengry
GL Class (X164)
8
07-12-2017 04:19 PM
lordofthering
M-Class (W164)
3
05-18-2017 11:07 AM
rawdvm
W211 AMG
8
06-15-2016 06:34 PM
alroumi
W211 AMG
1
12-29-2015 01:06 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:19 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: