Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
Airmatic Issue or No? Assistance needed >

Airmatic Issue or No? Assistance needed

Notices
E-Class (W212) 2010 - 2016: E 350, E 550

Airmatic Issue or No? Assistance needed

 
Old 10-03-2017, 08:16 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jun 2017
Posts: 8
Liked 0 Times in 0 Posts
W212 E550 2010
Question Airmatic Issue or No? Assistance needed

I have a w212 E550 2010 with Airmatic suspension. i bought used, and since i got it i hear a sound from the front suspension when am driving on a bump. The mechanic told me that it might be the mount of the strut defected.
FYI, i didn't though that it is the airmatic since the car's suspension is working fine, goes up and down, comfort and sport, according to the settings that i choose, and the car height doesn't get low overnight.
can anyone help what might be the problem, and what i might need to order for it (part number) or a picture or diagram of the front suspension.
btw, i also recently changed the 2 engine mount which were defected and thought that it will solve the problem, the car became smoother but problem not solved.
Thanks in advance
nahel souleiman is offline  
Old 10-03-2017, 09:58 AM
  #2  
MBWorld Fanatic!
 
KEY08's Avatar
 
Join Date: Oct 2005
Location: Chicagoland
Posts: 3,308
Liked 363 Times in 340 Posts
2014 E550 4Matic Designo Diamond White and loaded up
I would check the ball joints, as they are the source of suspension noise when they wear out.
KEY08 is offline  
The following users liked this post: KEY08
nahel souleiman (10-03-2017)
Old 10-03-2017, 10:26 AM
  #3  
MBWorld Fanatic!
 
belarus27's Avatar
 
Join Date: Jun 2013
Location: Sacramento , CA
Posts: 1,787
Liked 151 Times in 142 Posts
2010 e550 p2
More details would help

But sounds like one of the suspension parts is bad , check your sway bar links and ball joints like Key08 said.
Get underneath and inspect all of the components , u might see it right away.
belarus27 is offline  
The following users liked this post: belarus27
nahel souleiman (10-03-2017)
Old 10-03-2017, 10:49 AM
  #4  
Newbie
Thread Starter
 
Join Date: Jun 2017
Posts: 8
Liked 0 Times in 0 Posts
W212 E550 2010
i checked the ball joints and all the components, everything was right. i don't know how to exactly describe the sound, but for example, if i drive carefully on a bump i hear nothing, but if i drive a little bit faster on the same bump to let the front bounce up and down a little bit then i hear like if something is broken and not in place. but there is a difference when it is on sport mode compared to comfort mode, where on sport will make me really hear the sound , but on comfort i hear it much less or as if on comfort the stress is much less
nahel souleiman is offline  
Old 10-03-2017, 11:00 AM
  #5  
MBWorld Fanatic!
 
KEY08's Avatar
 
Join Date: Oct 2005
Location: Chicagoland
Posts: 3,308
Liked 363 Times in 340 Posts
2014 E550 4Matic Designo Diamond White and loaded up
Did you install a new transmission mount when you changed out the motor mounts?
KEY08 is offline  
Old 10-03-2017, 11:56 AM
  #6  
Newbie
Thread Starter
 
Join Date: Jun 2017
Posts: 8
Liked 0 Times in 0 Posts
W212 E550 2010
No, i didnt change it yet, am planning to, but is it possible that a transmission mount give such a sound
nahel souleiman is offline  
Old 10-04-2017, 05:46 PM
  #7  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,066
Liked 301 Times in 260 Posts
2011 E550 P2 4M Sedan
When I bought my 2011, I noticed a clunk/thump sound from the front when going over speed bumps at slow speed. Prior to the sale they sent the car to the dealer for evaluation and they apparently performed a system update that made the problem go away. IIRC the issue involved the bump stops and the clearances set in the system. Since this all happened pre-sale I don't have the details unfortunately. However, I did find this post in the bulletins thread that seemed to be related.
LI32.22-P-052062 – 212 thumping from area of the front axle when driving over speed humps when the suspension strut rebounds, the rebound buffer spring causes a metallic knocking noise. Dealer should flash Airmatic control unit.
Might want to check it out. It's been fine since for 3 years.
thefisch is offline  
Old 10-05-2017, 01:08 AM
  #8  
Newbie
Thread Starter
 
Join Date: Jun 2017
Posts: 8
Liked 0 Times in 0 Posts
W212 E550 2010
very interesting, thank you for the info, that's the exact sound that i get. Does anyone know what's the update or any details about it/ which tool to use..etc to inform my mechanic about it?

Last edited by nahel souleiman; 10-05-2017 at 01:24 AM.
nahel souleiman is offline  
Old 10-05-2017, 06:40 AM
  #9  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,066
Liked 301 Times in 260 Posts
2011 E550 P2 4M Sedan
Originally Posted by nahel souleiman View Post
very interesting, thank you for the info, that's the exact sound that i get. Does anyone know what's the update or any details about it/ which tool to use..etc to inform my mechanic about it?
Just give them the bulletin number in the post. If they don't know what to do with that, you may want to go somewhere else.
thefisch is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: