Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Some Help Please!!!!!

 
Old 09-27-2005, 12:19 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: mass
Posts: 47
Likes: 0
Received 0 Likes on 0 Posts
ml55 amg
Some Help Please!!!!!

battery died on me because i left ignition on. charged the battery and ml starts up fine. but, now my MCS does not come on. on/off switch does not work and its just off, nothing on the screeen at all. i was wondering if the MCS needs to be reset or something if the battery goes dead and if so how do i do this. or do i have to bring it to the dealer to fix. any help would be appreciated, thanks.
00amg is offline  
Old 09-27-2005, 11:54 AM
  #2  
Out Of Control!!
 
55fanatic's Avatar
 
Join Date: Dec 2004
Location: Boston, MA
Posts: 14,198
Received 5 Likes on 5 Posts
00 MB ML55, 91 Toyota Supra Turbo(sold), 06 E500(gone), 03 BMW M3
how are all your fuses?
55fanatic is offline  
Old 09-27-2005, 11:56 AM
  #3  
Out Of Control!!
 
Brunelleschi's Avatar
 
Join Date: Jul 2003
Location: Florida
Posts: 13,969
Likes: 0
Received 0 Likes on 0 Posts
In the market
I hate to ask, but have you read the manul? There are alot of reset procedures throughout the manual for various systems in the car. They are typically really simple procedures and they most always fix the problem. Good luck.
Brunelleschi is offline  
Old 09-27-2005, 07:22 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: mass
Posts: 47
Likes: 0
Received 0 Likes on 0 Posts
ml55 amg
fuses are fine. unfortunately i do not have the MCS manual to look at, it didnt come with the vehicle when i purchased it. however, i was able to do a search and learned to unhook the negative cable for a few min. to reset the MCS. then i called my dealer for my security code. now, i punched the code in and the screen says to wait. my question is, how long am i supposed to wait? nothing seems to happen except for the wait on the screeen. any ideas????????
00amg is offline  
Old 09-28-2005, 09:24 AM
  #5  
Almost a Member!
 
peid's Avatar
 
Join Date: Jul 2005
Location: South Dakota
Posts: 49
Likes: 0
Received 0 Likes on 0 Posts
2001 ML320
So you now have power to the MCS but can't get past the code? Once the correct code is entered and you push "OK" it is immediate activation of the system, no waiting involved.

If you now have power, pull fuse F10 & F21 I believe which are radio and interior light fuses and reinsert them after about 5 minutes. You should have to re-enter the code again.

If you don't have power yet, there is a 15A fuse behind the head unit which should be checked, you need a set of head unit removal keys to get to that one though. They are $10-$12 online or the dealer might do it for free for you.
peid is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Some Help Please!!!!!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: