Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

ML 320 with 113000 miles

 
Old 05-11-2006, 12:05 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2005
Posts: 21
Likes: 0
Received 0 Likes on 0 Posts
ML 320 with 113000 miles

Hi. I have an 2000 ML 320 with about 113000 miles on it, and it runs strong no problem at all, the only thing i needed to change was the crank shaft position sensor and a part of the computer, and that was because the mechanic messed up the computer when trying to fix the crank shaft sensor. I have noticed that every once in a while the car jerks a little when changing gears, this has been going on for some time now, probably sinc eabout 80,000 miles or so. I had one mechanic look at it and he said that there was nothing wrong. Is there something i should be weary of right away?

thanks

-shan
zeeyo987 is offline  
Old 05-11-2006, 07:53 AM
  #2  
Senior Member
 
azinn's Avatar
 
Join Date: May 2003
Location: In A Van Down By The River
Posts: 398
Likes: 0
Received 0 Likes on 0 Posts
2014 RX 350 F Sport, 2007 Scion tC, 2000 ML 430 Money Pit Finally Gone! Oh Happy Day!
Originally Posted by zeeyo987
Hi. I have an 2000 ML 320 with about 113000 miles on it, and it runs strong no problem at all, the only thing i needed to change was the crank shaft position sensor and a part of the computer, and that was because the mechanic messed up the computer when trying to fix the crank shaft sensor. I have noticed that every once in a while the car jerks a little when changing gears, this has been going on for some time now, probably sinc eabout 80,000 miles or so. I had one mechanic look at it and he said that there was nothing wrong. Is there something i should be weary of right away?

thanks

-shan
If you haven't already changed the transmission fluid & filter, it probably should be done. My 2 cents.
azinn is offline  
Old 05-11-2006, 08:21 AM
  #3  
Senior Member
 
cyeung65's Avatar
 
Join Date: May 2003
Location: Houston, TX
Posts: 291
Received 0 Likes on 0 Posts
Q & R
I have an 00 320 also, and I ran my last oil change over 9k miles per the VSS. I would get the valve lifters clacking on a cold start up. Its gone now with the new oil. Do you notice anything like that?
cyeung65 is offline  
Old 05-11-2006, 02:33 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Jun 2005
Posts: 21
Likes: 0
Received 0 Likes on 0 Posts
00 ml 320

hmm i never really noticed that, illmake sure to change the fluids though. do u guys think that its probably time to change the tranny though?
zeeyo987 is offline  
Old 05-11-2006, 03:41 PM
  #5  
Senior Member
 
azinn's Avatar
 
Join Date: May 2003
Location: In A Van Down By The River
Posts: 398
Likes: 0
Received 0 Likes on 0 Posts
2014 RX 350 F Sport, 2007 Scion tC, 2000 ML 430 Money Pit Finally Gone! Oh Happy Day!
Originally Posted by zeeyo987
do u guys think that its probably time to change the tranny though?
Read this http://www.mercedesshop.com/shopforu...ission+service and you can decide.
azinn is offline  
Old 05-18-2006, 03:26 PM
  #6  
Member
 
ml350's Avatar
 
Join Date: Dec 2004
Posts: 137
Likes: 0
Received 0 Likes on 0 Posts
2005 ML 350
does the 350 have the same trans as the 320. Or did mercedes put in a new trans on the 350 and 500.
ml350 is offline  
Old 05-18-2006, 03:52 PM
  #7  
Senior Member
 
Join Date: May 2005
Posts: 263
Likes: 0
Received 8 Likes on 8 Posts
W163 W164 R230
My trans blew up .. and I had to replace it just a few weeks ago! So I know a little about it! Here is the manufacture roadmap.


(MY 1998 - 1999)
http://4x4abc.com/ML320/ML_specsII_old.html

(MY2000-2005)
http://4x4abc.com/ML320/ML_specsII.html

The full DIY (loads of pics), checking fluid levels, etc,etc.... are on the P3 forum!. I took a picture of every step of the transmission removal & install.

I also posted the WIS & EPC for all transmission related info!.

www.pointedthree.com

PS: Someone had a problem in the UK with his ML270CDI transmission after I did mine. After reading my posts he went out and bought a trans+converter+ transcase from a wrecked MY2004 ML, then hired a car lift and followed my DIY replacement single handed !.

Last edited by pleubner; 05-18-2006 at 04:03 PM.
pleubner is offline  
Old 05-18-2006, 04:01 PM
  #8  
Member
 
ml350's Avatar
 
Join Date: Dec 2004
Posts: 137
Likes: 0
Received 0 Likes on 0 Posts
2005 ML 350
these two sites has info on 320 only,

it does not have any info on 350
ml350 is offline  
Old 05-18-2006, 04:05 PM
  #9  
Senior Member
 
Join Date: May 2005
Posts: 263
Likes: 0
Received 8 Likes on 8 Posts
W163 W164 R230
You mean 350 and 500 are missing right? .... because 230,320,430,ML55, 270CDI, 400CDI are listed!

The 500 has the same transmission as the ML55 and the 400CDI! Now to the 350 .... give me your VIN and I'll look it up! .... actually I posted all the Partno's on P3 of each model ....

.... ahhh silly me ... It's right at the beginning of my DIY .... You have a slightly different transmission than the ML500!.


NOTE: Since initially the 320 transmission was too weak (could not take the engine torque) , design changes were made, as well as pieces inside the transmission. Over the years as each transmission failure was analysed to the reason why it failed , modifications where made to improve it. .... So although the partno for a particular model might never change, the guts did! ....

In my case I have a 722.661 (ML270CDI). The new exchanged transmission has all the design changes incorporated. e.g parts that should not move and did breaking down now have holders, magnet in the pan, etc,etc....
Attached Thumbnails ML 320 with 113000 miles-transmission-types-models-my-.jpg  

Last edited by pleubner; 05-18-2006 at 04:26 PM.
pleubner is offline  
Old 05-18-2006, 04:13 PM
  #10  
Member
 
ml350's Avatar
 
Join Date: Dec 2004
Posts: 137
Likes: 0
Received 0 Likes on 0 Posts
2005 ML 350
he the vin,

4JGAB57E55A545752
ml350 is offline  
Old 05-18-2006, 04:30 PM
  #11  
Senior Member
 
Join Date: May 2005
Posts: 263
Likes: 0
Received 8 Likes on 8 Posts
W163 W164 R230
bump!.
pleubner is offline  
Old 05-18-2006, 04:48 PM
  #12  
Member
 
ml350's Avatar
 
Join Date: Dec 2004
Posts: 137
Likes: 0
Received 0 Likes on 0 Posts
2005 ML 350
so ml350 is on it own,

nobody else shares the same trans, with 350
ml350 is offline  
Old 05-18-2006, 04:52 PM
  #13  
Senior Member
 
Join Date: May 2005
Posts: 263
Likes: 0
Received 8 Likes on 8 Posts
W163 W164 R230
Now that's a hard question what other MB's have the 722.674 Transmission ?


PS: Remember they vary ever so slightly! Mainly in the ECU (Electronic Control Unit)

Last edited by pleubner; 05-18-2006 at 04:56 PM.
pleubner is offline  
Old 05-22-2006, 02:58 PM
  #14  
Member
 
Join Date: Mar 2006
Location: Dallas TX
Posts: 86
Likes: 0
Received 0 Likes on 0 Posts
W163 & 203
Ouui..... I m right behind u buddy....
Mine is 2000 ML430 running a bit over 113K now....
I had recently tune it and and changed the brake oil...
Car running even smoother now since I moved to dallas....
Pottie is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: ML 320 with 113000 miles


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: