Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

New owner needs help!

 
Old 05-20-2006, 09:51 AM
  #1  
Newbie
Thread Starter
 
Dungaman's Avatar
 
Join Date: May 2006
Location: York, England
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
ML 320
New owner needs help!

Hi all,

I recently purchased my '02 ml 320 and have found it to be great, however after a few miles i noticed a strange noise coming from the back of the central armrest. The noise, which is a loud humming with some rattling and a little vibration, is becoming quite annoying as i have used the switch to turn off all the cars air flow yet it seems to switch itself on and off whenever it wants and can last for 5 minutes. Sometimes it comes on randomly and there is air coming out the back air vents and other times its on but no air is flowing.

Can anyone tell me how to get rid of it or at least tell me what it does?

Also the ash tray comparment doesnt open when pushed, and can pop out randomly.... does it need fixing?

Thanks in advance.

Last edited by Dungaman; 05-20-2006 at 10:12 AM.
Dungaman is offline  
Old 05-20-2006, 11:33 PM
  #2  
Super Member
 
Join Date: Nov 2001
Posts: 862
Likes: 0
Received 0 Likes on 0 Posts
ML
Originally Posted by Dungaman
Hi all,

I recently purchased my '02 ml 320 and have found it to be great, however after a few miles i noticed a strange noise coming from the back of the central armrest. The noise, which is a loud humming with some rattling and a little vibration, is becoming quite annoying as i have used the switch to turn off all the cars air flow yet it seems to switch itself on and off whenever it wants and can last for 5 minutes. Sometimes it comes on randomly and there is air coming out the back air vents and other times its on but no air is flowing.

Can anyone tell me how to get rid of it or at least tell me what it does?

Also the ash tray comparment doesnt open when pushed, and can pop out randomly.... does it need fixing?

Thanks in advance.
Man, I wish I could recall all the details, but I remember a similar issue posted at another site and there were some interesting disgnoses. See the private message I just sent you.
Darkmann is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: New owner needs help!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: