Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Tele Aid Muted Display on Radio screen

 
Old 04-19-2011, 01:27 AM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2011
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2000 ML320
Exclamation Tele Aid Muted Display on Radio screen

I replaced the radio with a used one for my 2000 ML320 which equip with CD Changer only.
After I turn on power, it just switch to display Tele Aid Muted on screen even before asking for security code. No way to exit the screen.
Until I place at Reverse Gear, it display asking for security code, so I did, both radio and tape were working but CD Changer not detected. At all other gears, the screen switch back to Tele Aid Muted and radio not working then. No telephone and GPS system installed.
The radio I bought apparently look the same as the original. I bought The model RA4210, and I find there are only 7 pins at the ten pinouts. One missing at top right and two missing at bottom right.
The orginal model is RA4910 and having ten pins at the ten pinouts.
Is this the problem? any ideas please.
Took it to Dealer, they ask for $101 for diagnosis only. Tell nothing.
kwongkk is offline  
Old 04-19-2011, 04:39 PM
  #2  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
The 2000 ML uses a Non Fiber Optic MCS unit. Later years used a Fiber Optic link to control all external audio units like the CD changer in the rear, phone, Bose audio amp, Tel Aid etc.

All the MCS unit look much the same. The only two units that will work in the 2000 ML are as follows;

Mercedes part numbers--
163-820-04-86
163-820-21-86

I think they are all Manufacturer's part number RA4910 but different Mercedes part numbers.

Is your replacement MCS from a later year?

If it is the correct 2000 ML MCS unit it may have to be version coded by the dealer to match your vehicle.

Mike

Last edited by Mike's ML; 04-19-2011 at 04:45 PM.
Mike's ML is offline  
Old 04-19-2011, 05:58 PM
  #3  
Newbie
Thread Starter
 
Join Date: Apr 2011
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2000 ML320
Thanks Mike
The Model is A163 820 10 86 I bought.
RA4210 probably is a later model.
I installed it in a 1998 ML320, It did not have Tele Aid Muted problem, but CD player is not detected.
I plan to installed the CD Changer from that problem 2000 ML320 to it and see CD Changer detected or not.

Then I would compare the wiring connector of both cars, try to find which one is for Tele Aid system, or disconnected those extra wires connection to the year of 2000
Because I find out not all the pins are wired at the 1998.
Hope i works!
What do you think?

Kevin
kwongkk is offline  
Old 08-03-2013, 10:01 PM
  #4  
Newbie
 
Join Date: Aug 2013
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2000 ML55 AMG
I'm having the Tele Aid Muted issue as well. Has anyone gotten a fix for it? My battery died a few times when I left the car sitting for months without running it. I'm not sure if that has anything to do with this message, but I can't use the radio and really would like to. MB dealership wants $100 just to look at it, regardless if they find a solution or fix. would love some assistance
leisasd is offline  
Old 08-04-2013, 01:41 PM
  #5  
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Likes: 0
Received 0 Likes on 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
Originally Posted by kwongkk View Post
Thanks Mike
The Model is A163 820 10 86 I bought.
RA4210 probably is a later model.
I installed it in a 1998 ML320, It did not have Tele Aid Muted problem, but CD player is not detected.
I plan to installed the CD Changer from that problem 2000 ML320 to it and see CD Changer detected or not.

Then I would compare the wiring connector of both cars, try to find which one is for Tele Aid system, or disconnected those extra wires connection to the year of 2000
Because I find out not all the pins are wired at the 1998.
Hope i works!
What do you think?

Kevin
I don't have a listing for Model is A163 820 10 86 so I don't know if it is a Fiber Optic model or a non FO model.
A FO unit will not work in a 1998 - 2000 ML so my guess is that you have the wrong MCS unit for your year ML.

The only information I have is that only the two MCS part numbers I listed above will work in 1998 - 2000 ML's.
Mike

Last edited by Mike's ML; 08-04-2013 at 01:43 PM.
Mike's ML is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Tele Aid Muted Display on Radio screen


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: