Ml500 Stuck in park - MBWorld.org Forums

Notices
M-Class (W164) 2006-2011: ML280CDI, ML320CDI, ML420CDI, ML350, ML500, ML550

Ml500 Stuck in park

Old 01-04-2019, 03:53 AM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Ml500 Stuck in park

Stuck in park!
I have not driven my car in a few months, so I took it to fill up with gas and get it detailed, when I came home to park, I could not get it out of Park and into drive again. The battery warning light with “ take to service” warming was on.
It’s parked on a hill and seems to be in park, but it keeps telling me to put the car into neutral or park before you can start, so the engine will not turn over. I had a tow truck come in Edgemere Ford and took the pressure off the transmission and I was able to start it. But still would not go into gear.
I did find out that the charging wire for the exhilarate battery was disconnected, and the battery was completely dead. So I put it on a trickle charge and charged it up to 12 V. But still no luck, won’t go into gear. A little more research and I realize the brake lights were not coming on,. But when I turn on the ignition all the warning lights on the dashboard to come up. My feeling is that it might be the brake light switches.
Does anyone have any experience with this problem or any suggestions?. Thank you

Last edited by Jason E Gruver; 01-04-2019 at 04:02 AM.
Jason E Gruver is offline  
Old 01-04-2019, 09:17 AM
  #2  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
You cannot recharge a dead battery, it must be replaced with new. Then the codes in the Intelligent Servo Module must be read and cleared.

There is no brake light switch on 2003 to present MLs. The BLS is now incorporated into the Brake Booster.

As for no brake lights, remove everything in the spare tire area and look for water damage to the rear SAM which is caused by defective tail lamp seals installed at the assembly line.
Attached Files

Last edited by Maj. Dundee; 01-04-2019 at 09:19 AM.
Maj. Dundee is offline  
The Following User Says Thank You to Maj. Dundee For This Useful Post:
spkml320 (01-08-2019)
Old 01-12-2019, 03:49 AM
  #3  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
You cannot recharge a dead battery, it must be replaced with new. Then the codes in the Intelligent Servo Module must be read and cleared.

There is no brake light switch on 2003 to present MLs. The BLS is now incorporated into the Brake Booster.

As for no brake lights, remove everything in the spare tire area and look for water damage to the rear SAM which is caused by defective tail lamp seals installed at the assembly line.
Installed my new battery today, and I know the car early starts! But still will not shift into gear and the battery icon is no longer flashing. How do I clear the code?

Installed new battery today, at least the car starts up. Still does not go into gear, the person who commented on my thread said I have to clear the code, how do I do that?
Jason E Gruver is offline  
Old 01-12-2019, 04:03 AM
  #4  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
Did you have to jump the battery to start the truck over the long layover?

If so, then the auxiliary battery, along side the main battery must also be replaced. That battery is solely responsible for shifting from park to other gears.
Attached Files
File Type: pdf
R&I Battery Auxillary.PDF (104.0 KB, 5 views)
Maj. Dundee is offline  
Old 01-12-2019, 04:11 AM
  #5  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
Did you have to jump the battery to start the truck over the long layover?

If so, then the auxiliary battery, along side the main battery must also be replaced. That battery is solely responsible for shifting from park to other gears.
I replace the small auxiliary battery but not the main battery. The main battery is fairly new. But I do notice there is a bit of a lag when I go to start it. I will check the voltage to see what the voltages. I have not driven the car for about a year
Jason E Gruver is offline  
Old 01-12-2019, 04:26 AM
  #6  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
Did you have to jump the battery to start the truck over the long layover?

If so, then the auxiliary battery, along side the main battery must also be replaced. That battery is solely responsible for shifting from park to other gears.
Battery is 11.8 V, would that affect the shifting?
Jason E Gruver is offline  
Old 01-12-2019, 04:58 AM
  #7  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
Originally Posted by Jason E Gruver View Post

Battery is 11.8 V, would that affect the shifting?
What battery?

You never answered about jumping the battery.
Maj. Dundee is offline  
Old 01-12-2019, 05:01 AM
  #8  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
What battery?

You never answered about jumping the battery.
The main battery is reading 11.8, but the car still starts up. The aux battery is brand new
Jason E Gruver is offline  
Old 01-12-2019, 05:15 AM
  #9  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
Originally Posted by Jason E Gruver View Post

The main battery is reading 11.8, but the car still starts up. The aux battery is brand new
You are amazing, you still never answered the question. Why do I have to ask the same question three times?
Maj. Dundee is offline  
Old 01-12-2019, 05:17 AM
  #10  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
Did you have to jump the battery to start the truck over the long layover?

If so, then the auxiliary battery, along side the main battery must also be replaced. That battery is solely responsible for shifting from park to other gears.
Sorry, I am not 100% clear on your question. I did not have to jump the car if that was your question
Jason E Gruver is offline  
Old 01-12-2019, 05:21 AM
  #11  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
Originally Posted by Jason E Gruver View Post

Sorry, I am not 100% clear on your question. I did not have to jump the car if that was your question
Yes.
Maj. Dundee is offline  
Old 01-12-2019, 05:26 AM
  #12  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
If the main battery is reading 11.8v with the key out of the ign., then it is not the correct voltage. It should be 12.6-12.7v.
Maj. Dundee is offline  
Old 01-12-2019, 05:28 AM
  #13  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
Yes.
But if it was truly 11.8 V, would that be the reason why it would not shift into gear?
Jason E Gruver is offline  
Old 01-12-2019, 05:31 AM
  #14  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
Originally Posted by Jason E Gruver View Post

But if it was truly 11.8 V, would that be the reason why it would not shift into gear?
I would say yes because the auxiliary battery is charged directly off the main battery.
Maj. Dundee is offline  
Old 01-15-2019, 01:22 AM
  #15  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
Did you have to jump the battery to start the truck over the long layover?

If so, then the auxiliary battery, along side the main battery must also be replaced. That battery is solely responsible for shifting from park to other gears.
Battery was never completely dead, car always start up.
Negative wire from main battery to auxiliary battery had come off,Eux battery was 100%
drained
Purchased brand new aux battery, tested main battery and is fully charged. But still will not go into gear. Do I need to have the code to reset?
Jason E Gruver is offline  
Old 01-15-2019, 04:04 AM
  #16  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
Yes, all codes in all 25 modules must be read and erased. A cheap code reader will not do the trick.

Amazon Amazon

Last edited by Maj. Dundee; 01-15-2019 at 04:07 AM.
Maj. Dundee is offline  
Old 01-15-2019, 07:34 PM
  #17  
Newbie
Thread Starter
 
Join Date: Jan 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
2006 ML500
Originally Posted by Maj. Dundee View Post
Yes, all codes in all 25 modules must be read and erased. A cheap code reader will not do the trick.

https://www.amazon.com/Autel-MD802-M...autel+maxidiag
I had a mechanic come today and he said they were no error codes, so there is nothing to reset. Does that seem correct?
Jason E Gruver is offline  
Old 01-16-2019, 06:55 AM
  #18  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,662
Thanked 313 Times in 303 Posts
2002 ML 320 & 2006 ML500
Jason, think about it, you cannot move the shifter out of park and you believe that there isn't a code in any module? Who knows what your mech. used to check for codes.

You cannot own one of these vehicles without owning your own scanner. I suggested that you get the Autel, but of course it went by the waysides.
Maj. Dundee is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Ml500 Stuck in park


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: