Notices
M-Class (W166) 2012, Read about the upcoming M-Class

Trailer Lights Blinking

 
Old 02-03-2014, 09:11 PM
  #1  
Newbie
Thread Starter
 
MBduck's Avatar
 
Join Date: Nov 2013
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2014 ML350 BlueTec
Trailer Lights Blinking

We have a 2014 ML350 BlueTec with the towing option. We picked up our 2014 Lance travel trailer today. All went well except for one thing. The trailer lights all work great. But when the ML is turned off the trailer running lights (all LEDS) blink faintly. They are not bright when doing this. Very faint but blinking and the pace of the blinking seems to change. When I disconnect the electric connection between the trailer and the ML the blinking stops.

Any ideas?
MBduck is offline  
Old 02-04-2014, 12:02 AM
  #2  
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA
Posts: 5,279
Likes: 0
Received 17 Likes on 16 Posts
THE C350
I think I saw a thread about this a few weeks ago did you search at all? If not take a look
samaritrey is offline  
Old 02-04-2014, 06:13 AM
  #3  
MBWorld Fanatic!
 
DUTCH's Avatar
 
Join Date: Aug 2002
Location: Atlanta, GA USA
Posts: 1,298
Received 18 Likes on 15 Posts
2000 MB G500 NMLE, 2015 Audi Q7 3.0 TDI Prestige
Originally Posted by samaritrey View Post
I think I saw a thread about this a few weeks ago did you search at all? If not take a look
I just did a search with "trailer" as the key word. No luck in finding it.
DUTCH is offline  
Old 02-06-2014, 01:29 PM
  #4  
Junior Member
 
Join Date: Oct 2011
Posts: 53
Likes: 0
Received 0 Likes on 0 Posts
997 C4S; ML350
had the same problem with my 2013 ML350. I was just towing a U haul and don't do much towing so didn't think about it much
dk10438 is offline  
Old 07-20-2015, 11:15 AM
  #5  
Member
 
CBR Dude's Avatar
 
Join Date: Aug 2014
Posts: 198
Likes: 0
Received 4 Likes on 4 Posts
GL550
Just took mine in local Benz shop,they were as helpful as a hemroid! Claimed the trailer lights had to be the non-led! Took the trailer and Benz to the local trailer shop. They ordered the following from tow ready - 20141! They said the LED don't draw as much current as the old bulbs did and thus throw the electrics into a tail spin. Will post an update when the part comes in.
CBR Dude is offline  
Old 07-20-2015, 03:38 PM
  #6  
Newbie
Thread Starter
 
MBduck's Avatar
 
Join Date: Nov 2013
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2014 ML350 BlueTec
Excited to hear about the 2141 device. I tried a similar device made by Curt (C57003) but it did not solve the faint blinking. This looks much more compact. If your 2141 works that would be great! I'd need the 2142 which is 7 pin to 7 pin.

Thanks for posting!
MBduck is offline  
Old 07-20-2015, 04:12 PM
  #7  
Member
 
CBR Dude's Avatar
 
Join Date: Aug 2014
Posts: 198
Likes: 0
Received 4 Likes on 4 Posts
GL550
We had a 2012 VW Touareg That I used the same trailer with same 7 to 4 adapter and it worked fine. The VW had a whole host of stuff that happened when you plugged anything in to the socket.


The second I plugged the adapter in the Benz, the electrics went nuts. It does shut down the blind spot detection. I found that in the owners manual. That's OK as it would give it a false reading if it did work!


The trailer shop ordered the adapter that Curt says will work. It will be here in a few days. They said they never saw this before. They said they have Mercedes in here all the time.
CBR Dude is offline  
Old 07-20-2015, 05:57 PM
  #8  
Senior Member
 
Join Date: Aug 2011
Location: Canada
Posts: 355
Received 11 Likes on 5 Posts
2016 GLE 350d
I have two adapters that solve the problem. One I got from Mercedes and the other online and I think it was meant for a VW.

I can get you a part number if needed.
2012MLBlue is offline  
Old 07-20-2015, 06:09 PM
  #9  
Senior Member
 
gkgeiger's Avatar
 
Join Date: Mar 2015
Location: Ohio/Florida
Posts: 350
Received 10 Likes on 10 Posts
'10 C300, '15 ML250BT, '18 911 GTS Cab
Am I correct in understanding that all trailers with LED lights require this adapter. By the way, the 7pin to 7pin part number is 20142
gkgeiger is offline  
Old 07-20-2015, 08:57 PM
  #10  
Newbie
Thread Starter
 
MBduck's Avatar
 
Join Date: Nov 2013
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2014 ML350 BlueTec
Originally Posted by CBR Dude View Post
We had a 2012 VW Touareg That I used the same trailer with same 7 to 4 adapter and it worked fine. The VW had a whole host of stuff that happened when you plugged anything in to the socket.


The second I plugged the adapter in the Benz, the electrics went nuts. It does shut down the blind spot detection. I found that in the owners manual. That's OK as it would give it a false reading if it did work!


The trailer shop ordered the adapter that Curt says will work. It will be here in a few days. They said they never saw this before. They said they have Mercedes in here all the time.
We had the Curt 57003 and it did not solve the problem. I hope the reports indicate that the Tow Ready 2141 does work. Our MB dealer said the lights blinking on the trailer was a safety feature!
MBduck is offline  
Old 07-21-2015, 09:16 AM
  #11  
Member
 
CBR Dude's Avatar
 
Join Date: Aug 2014
Posts: 198
Likes: 0
Received 4 Likes on 4 Posts
GL550
I took the GL to my local Mercedes dealer. They acted like they had never seen the issue before. Recommended that I take the LED lights off the trailer. WTF would I do that for? These people are idiots from the word go in the first place. End of story! Sent me packing!


I called another dealer, they did not have the adapter but advised etrailer.com with help. He did know of the problem. He said all they sold were recycled ones they bought at one time but no longer carry them.


etrailer was of no help! Everything was canned responses back! I've had the same canned response before on other issues!


Took the trailer and the Benz to a local trailer shop. They had never seen the issue before and sell trailers to people with Mercedes, VW and Audi all the time with no issues and LED lights.


They ordered the adapter as they did not have it in stock. They said I would not be responsible for the cost if it did not work. They were just as curious about it as I was. No charge as well for the help!


We had a 2012 VW Touareg, using the same trailer and 7 to 4 adapter with no problems. Apparently at one time they had some issues too. A software update solved the problem. Hum...


The adapter I have has small LED lights built in test lights. Before I even hook up the trailer that's going nuts. I have two different styles of that 7-4 adapter and they both got nuts before the trailer is added to the picture. I suspect its the GL and not the LED lights on the trailer.


If it still does it after the adapter comes in I'm marching back over to Mercedes with a attitude and demand an answer and a fix! 100% total BS!


I've never seen such a crap in all my life.
CBR Dude is offline  
Old 07-21-2015, 11:04 PM
  #12  
MBWorld Fanatic!
 
Join Date: Nov 2012
Posts: 4,941
Likes: 0
Received 576 Likes on 449 Posts
A gaggle of MB's
Well... if you have a 5 or 4-pin trailer hook up w/LED trailer lights - yes - you have the wrong adapter.

For your GL-to-5/4-pin-LED you need Tow Ready 20141 - and so you know the 20141 has a resistor built-into the circuit that gives your GL the right "load" to recognize the circuit.

Others have mistaken adapter's that have LED tester lights - which have nothing to do with LED trailer lights - means those adapters would work on their MB.

Internet shopping - check shipping charges - but all-in-all you can score the correct 20141 for under $16..

A 20141 is not often stocked at local stores - might be - but rarer to find on the shelf.

Not all Mercedes dealers have towing experience - and not all trailer hitch guys have Mercedes experience - but from what you describe you have a $16 solution..
fabbrisd1 is offline  
The following users liked this post:
Etienne Lau (03-25-2018)
Old 07-22-2015, 09:08 AM
  #13  
Senior Member
 
gkgeiger's Avatar
 
Join Date: Mar 2015
Location: Ohio/Florida
Posts: 350
Received 10 Likes on 10 Posts
'10 C300, '15 ML250BT, '18 911 GTS Cab
Originally Posted by gkgeiger View Post
Am I correct in understanding that all trailers with LED lights require this adapter. By the way, the 7pin to 7pin part number is 20142
I didn't get an answer to my question but now I'm wondering if the tow vehicle has LED lights if that makes a difference with the trailer. I have a new trailer with LED's that I haven't towed yet. Soon I'll get a chance to actually try it but thought someone might have an answer.
gkgeiger is offline  
Old 07-22-2015, 10:33 AM
  #14  
Member
 
CBR Dude's Avatar
 
Join Date: Aug 2014
Posts: 198
Likes: 0
Received 4 Likes on 4 Posts
GL550
They have ordered the Tow Ready 20141 adapter. It's basically what I have except it has a built in resistor to handle the LED trailer lights. I've not got it yet to see if it's the cure all for the problem. As soon as I have the part I'll report back.


As far as I can tell it looks to be a hit and miss problem. The trailer worked on my GL450 fine, but not my GL550. Software, hardware issue, don't know? Mercedes was not helpful at all at least the servicing dealer! The selling dealer knew of the problem but did not have a solution!










It's a OEM factory hitch and harness so go figure. I've not cut into, spliced or have tampered with any of the electrics. The trailer shop that did the lights was also flustered. They sell LED trailers all the time so they said to Mercedes tow vehicles. I'm not so sure people that buy Mercedes suv's like to tow stuff. Same with Audi and Porsche!


I'll report back with what happens.
CBR Dude is offline  
Old 07-22-2015, 11:47 AM
  #15  
Senior Member
 
Join Date: Aug 2011
Location: Canada
Posts: 355
Received 11 Likes on 5 Posts
2016 GLE 350d
FYI it's not a new problem. I bought a new boat in 2008 and went to pick it up with my new at the time ML. Boat dealer hooked it up and nobody thought to check the signals until I was pulling out. Super dim brake lights and no signals. Trailer had all LED. After an hour of playing around with it we tried hooking up to an old trailer with non LED lights and it worked perfectly. Only solution that day was to replace the LED lights on the nice new trailer with some crappy but functional old lights. I was super pissed and it threw a damper on a great day picking up a shiny new boat. A week later had the adapter delivered and boat dealer reinstalled the LEDs and never had another issue.
2012MLBlue is offline  
Old 07-22-2015, 12:31 PM
  #16  
Senior Member
 
GregGebhardt's Avatar
 
Join Date: Mar 2014
Posts: 387
Likes: 0
Received 1 Like on 1 Post
2014 ML350 BlueTec
Originally Posted by gkgeiger View Post
I didn't get an answer to my question but now I'm wondering if the tow vehicle has LED lights if that makes a difference with the trailer. I have a new trailer with LED's that I haven't towed yet. Soon I'll get a chance to actually try it but thought someone might have an answer.
I pulled my Whaler with an all LED trailer and it blinked. Other than that the lights, signals, etc worked perfectly.
GregGebhardt is offline  
Old 07-22-2015, 11:58 PM
  #17  
MBWorld Fanatic!
 
Join Date: Nov 2012
Posts: 4,941
Likes: 0
Received 576 Likes on 449 Posts
A gaggle of MB's
So to boil it down - depending on the particular LED trailer light system - "some" LED trailer light systems will not be compatible as/is with your Mercedes - if you encounter this problem - the $16 fix is a Tow Ready 20141 or 20142 depending on the # pins required for your trailer hookup.

The Tow Ready 20141 or 20142 is "rarely" in stock at local retail trailer-supply/auto-parts stores - but easily obtained from internet sources.
fabbrisd1 is offline  
Old 09-23-2015, 09:51 AM
  #18  
Junior Member
 
marchgroupinc's Avatar
 
Join Date: Dec 2013
Location: SW Ontario
Posts: 38
Received 6 Likes on 3 Posts
ML350Blutec, C7 Corvette,
May be a little late but when I purchased my trailer the dealer CANAM Airstream in London Ontario warned me of this problem on Mercedes with LED trailers, before I left the dealership. Simple solution put a load on your running lights in the trailer like a small incandescent bulb hidden somewhere and the problem goes away. I installed a backup camera on the trailer powered by the running lights and that did the trick, problem solved.
marchgroupinc is offline  
Old 09-23-2015, 10:28 AM
  #19  
Member
 
CBR Dude's Avatar
 
Join Date: Aug 2014
Posts: 198
Likes: 0
Received 4 Likes on 4 Posts
GL550
The Tow Ready adapter cured the blinking lights but I get the bulb failure indicator on the dash. I may just have to live with that.

They ordered another one free of charge. I've not tested that one out.

The GL550 is the only vehicle that I own that's burping the trailers. Both trailers are LED.

The Benz is still under warranty. Mercedes has point blank said if you cut into the OEM wiring we will not honor any warranty that comes from the cutting of the wires.

The trailer shop claims it's never seen this before and that they sell all kinds of trailers to owners of German tow vehicles.

I'm afraid to place any load bearing resisters on the trailer side for fear my other two vehicles will burp the trailers. The tow shop does not want to be the guinea pig for the testing either for fear of melting something down.

My only other resort is to make an adapter that goes between the trailer and the Benz and use it only for that purpose and not on the other two tow vehicles.

The trailer worked great on my GL450. No issues what so ever!
CBR Dude is offline  
Old 09-23-2015, 01:40 PM
  #20  
Senior Member
 
gkgeiger's Avatar
 
Join Date: Mar 2015
Location: Ohio/Florida
Posts: 350
Received 10 Likes on 10 Posts
'10 C300, '15 ML250BT, '18 911 GTS Cab
I just did a test tow of my new trailer with LED lights and everything works as it should.
gkgeiger is offline  
Old 09-23-2015, 05:00 PM
  #21  
Member
 
CBR Dude's Avatar
 
Join Date: Aug 2014
Posts: 198
Likes: 0
Received 4 Likes on 4 Posts
GL550
gkgeiger,

Here's a good one for you.

Our building engineer has a new Vette that hes got a hitch on it to tow his bass boat. Nicely colored to match the boat!

He had a Ram 2500, but I'm guessing the inner child portion kicked in and he needed the Vette instead. It too matched the boat!

When he pulled up in that and I LMFAO! Wait for this now.... His wife said you can have the Vette but the truck has to go! The result was the Vette with the hitch on it.

Never seen one ever equipped that way! I have to wonder what the installer thought when he was doing the deed?

Good times!
CBR Dude is offline  
Old 09-23-2015, 09:30 PM
  #22  
Senior Member
 
gkgeiger's Avatar
 
Join Date: Mar 2015
Location: Ohio/Florida
Posts: 350
Received 10 Likes on 10 Posts
'10 C300, '15 ML250BT, '18 911 GTS Cab
Originally Posted by CBR Dude View Post
gkgeiger,

Here's a good one for you.

Our building engineer has a new Vette that hes got a hitch on it to tow his bass boat. Nicely colored to match the boat!

He had a Ram 2500, but I'm guessing the inner child portion kicked in and he needed the Vette instead. It too matched the boat!

When he pulled up in that and I LMFAO! Wait for this now.... His wife said you can have the Vette but the truck has to go! The result was the Vette with the hitch on it.

Never seen one ever equipped that way! I have to wonder what the installer thought when he was doing the deed?

Good times!
That is a good one. Fortunately I don't have to tow with mine.
gkgeiger is offline  
Old 09-26-2015, 07:58 AM
  #23  
MBWorld Fanatic!
 
DUTCH's Avatar
 
Join Date: Aug 2002
Location: Atlanta, GA USA
Posts: 1,298
Received 18 Likes on 15 Posts
2000 MB G500 NMLE, 2015 Audi Q7 3.0 TDI Prestige
This will fix the blinking LED trailer lights. In fact, I have one for sale; since the Q7 is compatible with the LED's in my trailer.

https://www.etrailer.com/Wiring/Tow-Ready/20142.html
DUTCH is offline  
Old 03-12-2018, 05:23 AM
  #24  
Newbie
 
Join Date: Mar 2018
Posts: 5
Received 0 Likes on 0 Posts
2017 Winnebago View
Trailer marker lights blinking

I have read all the posts and have tried the etrailer 7 pin to 7 adapter on my 2017 Winnebago View pulling 2017 trailer with led lights. It did not solve the problem. The marker lights on my new LED lighted trailer flash when all systems are off and key removed. The MB dealer here in Boise has had my Winnie and boat at their shop for almost a month and canít figure it out!! All trailer light functions work OK just this annoying blinking. No problem when hooked up to my 2017 Tacoma. Winnebago says itís an MB problem. Can someone get back to me with a possible solution?

Last edited by wmcfall; 03-24-2018 at 12:33 PM. Reason: New information
wmcfall is offline  
Old 03-12-2018, 08:20 AM
  #25  
Newbie
 
Join Date: Nov 2016
Location: Fernandina Beach, FL
Posts: 12
Likes: 0
Received 1 Like on 1 Post
2014 ML350 Bluetec
I too have a 2014 Bluetec and tow quite a bit. The trailer is a 2012 Ironhorse with LED lighting.
Using the wireless prodigy brake controller.
Have not had a problem and the lights function properly.
Interested to hear about your solution.
Good Luck!
nsully is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Trailer Lights Blinking


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: