Go Back  MBWorld.org Forums > Mercedes-Benz SLR & SL Roadsters > SL-Class (R129)
SL 500 Rollbar stuck in UP position, Soft top doesnt move, HELP!!!! >

SL 500 Rollbar stuck in UP position, Soft top doesnt move, HELP!!!!

Notices
SL-Class (R129) 1990-2002: SL 280, SL 300, SL 320, SL 500, SL 600, SL 60 AMG

SL 500 Rollbar stuck in UP position, Soft top doesnt move, HELP!!!!

 
Old 09-24-2007, 05:42 AM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2001 SL 500
Exclamation SL 500 Rollbar stuck in UP position, Soft top doesnt move, HELP!!!!

I have an '01 SL500, and the rollbar is stuck in the UP position, and the soft top wont move at all. No blown fuses what so ever. I can hear it clicking and can also hear the motor running. What other possible causes could there be as to why this top is not working. Could I possibly have lost all my hydraulic fluid? How do i check it? How would i go about refilling it if that is indeed the case? I need help. Any tips are greatly appreciated. Thanks in advance.
TrillGates is offline  
Old 09-24-2007, 11:06 AM
  #2  
MBWorld Fanatic!
 
Join Date: Mar 2005
Posts: 3,415
Likes: 0
Received 1 Like on 1 Post
some
Originally Posted by TrillGates View Post
I have an '01 SL500, and the rollbar is stuck in the UP position, and the soft top wont move at all. No blown fuses what so ever. I can hear it clicking and can also hear the motor running. What other possible causes could there be as to why this top is not working. Could I possibly have lost all my hydraulic fluid? How do i check it? How would i go about refilling it if that is indeed the case? I need help. Any tips are greatly appreciated. Thanks in advance.



ok do this

put the car in second posision (key) and then hold the Roll Bar button up for about 15-20 seconds, you should hear a "click" then you should be able to put it down.


hope this works
Mark
Bigdot is offline  
Old 09-24-2007, 12:37 PM
  #3  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2001 SL 500
Exclamation

Naa, that didnt work. I tried it with the key in the 2nd and 3rd positions. I tried the rollbar button as well as the Soft top button. Neither worked. I did hear the 'click' when i held the rollbar button for at least 20 or so seconds, but the rollbar was just as stiff and didnt give any. Im assuming that it has somehow filled the cylinders that pushes the rollbar up with hydraulic fluid, and its not being released. maybe some type of motor failure with the hydraulic dump. Anymore tips or tricks will be appreciated, but do u think this could be the case? If so, where could i locate the motor? Im totally out of ideas. Ive even disconnected the battery and let the car sort of reset itself so to speak. Is there any manual way to get the top down ?
TrillGates is offline  
Old 09-24-2007, 04:37 PM
  #4  
Member
 
Join Date: Feb 2005
Location: Los Angeles
Posts: 212
Likes: 0
Received 0 Likes on 0 Posts
96 SL500, 97 E420
Disconnecting the battery is a no-no. Do you have the owners manual? It says in there how to manually raise/lower the top. You may have a blown fuse, a bad top controller, etc. Your codes may need re-setting as well.
Look here

http://www.benzworld.org/forums/r129...er-system.html

and here

http://www.benzworld.org/forums/r129...ontroller.html
gqmagic is offline  
Old 09-25-2007, 01:04 PM
  #5  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2001 SL 500
I might just have found the culprit. I looked in the trunk under the spare tire, and BAMMMMM! There was NO hydraulic fluid left in the resovoir, it all must've leaked out somehow. so i think thats why its not working. im about to go get some, ill let u know how it went.
TrillGates is offline  
Old 09-25-2007, 02:23 PM
  #6  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2001 SL 500
The resovoir was bone dry, i added some hydro fluid and VOILA, I am now Top-less!!!!!!!!!!!!!!!!!
TrillGates is offline  
Old 09-25-2007, 11:54 PM
  #7  
Member
 
TheV12pwr's Avatar
 
Join Date: Dec 2004
Location: L.A.
Posts: 217
Likes: 0
Received 0 Likes on 0 Posts
SL000
Roll bar is electric,has nothing to do with hydraulic fluid level

Think people think!!!

Last edited by TheV12pwr; 09-26-2007 at 12:20 AM.
TheV12pwr is offline  
Old 09-26-2007, 02:24 PM
  #8  
MBWorld Fanatic!
 
Join Date: Jan 2006
Posts: 1,065
Received 130 Likes on 112 Posts
'03 SL500, '03 SL55, '00 S500, (5) R129s
The roll bar is hydraulic.
bobterry99 is offline  
Old 09-26-2007, 02:56 PM
  #9  
Member
 
TheV12pwr's Avatar
 
Join Date: Dec 2004
Location: L.A.
Posts: 217
Likes: 0
Received 0 Likes on 0 Posts
SL000
I stand corected!
What was I thinkin'
TheV12pwr is offline  
Old 09-26-2007, 07:04 PM
  #10  
Newbie
Thread Starter
 
Join Date: Sep 2007
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2001 SL 500
Exclamation

Ok guys, I have another issue with the top now. I had a few days of fun with the top going up and down. Now the top seems to be stuck in the down position. If I try to let the top up, it will go up half way, and then stop. Hydro fluid starts shooting out the drivers rear side where the top resides under the top cover. Maybe a broken line? Im not sure, but this thing is really getting on my nerves now. If I let it sit for a while, it seems like it goes up farther, but it just will not go all the way up. Is there another way to get the top back up? A manual way?
TrillGates is offline  
Old 09-27-2007, 01:24 AM
  #11  
Senior Member
 
Join Date: Nov 2004
Location: Bradenton, FL
Posts: 282
Likes: 0
Received 1 Like on 1 Post
'87 560SL Sold, '99 SL500 For Keeps
Originally Posted by TrillGates View Post
Ok guys, I have another issue with the top now. I had a few days of fun with the top going up and down. Now the top seems to be stuck in the down position. If I try to let the top up, it will go up half way, and then stop. Hydro fluid starts shooting out the drivers rear side where the top resides under the top cover. Maybe a broken line? Im not sure, but this thing is really getting on my nerves now. If I let it sit for a while, it seems like it goes up farther, but it just will not go all the way up. Is there another way to get the top back up? A manual way?
TrillGates,
The steps to manually put the top up/down are in the owners manual as previously suggested. You can download a copy for your if you don't have one at the site below. Keep in mind, you'll also need the 'special tool' that was provided in the tool kit that should have been with the car. If you don't have one, they are avaiable at the dealer for $12 or $13. You'll see what I mean specifically about this tool when you see the pictures that accompany the manual process in the owners manual.

http://www.benzworld.org/forums/r129...load-site.html

The leaking you describe reads more like a bad seal in the hydraulic cylinder, one of a dozen that it takes to get this top/roll bar up/down. If you use the other link that gqmagic provided, the instructions on how to get the bad cylinder out, have rebuilt (rebuilder's contact info provided), and reinstalled are in the string of posts at BenzWorld.

Bob
BJonesFL is offline  
Old 12-05-2014, 07:36 PM
  #12  
Newbie
 
Join Date: Jun 2012
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
1996 sl 600
1996 SL 600 roll bar stuck up.

Hello and thank you for reading this.
I let the car down off the jack while changing the right rear wheel. Had the suspension button on to disable the rollover response.Pow the roll bar popped up.Yes I've held the switch,checked the fuses, resevoir is full, pump isn't working to release lock mechanism.Is there another step other than battery disconnect done,Jumped pos neg,done,,,Whew!!!!!New tires and another monster arrives.It's raining for the winter and I'd like to go run that carpet!!
peter jones is offline  
Old 12-05-2014, 07:46 PM
  #13  
Newbie
 
Join Date: Jun 2012
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
1996 sl 600
1996 SL 600 roll bar stuck up.

Hello and thank you for reading this.
I let the car down off the jack while changing the right rear wheel. Had the suspension button on to disable the rollover response.Pow the roll bar popped up.Yes I've held the switch,checked the fuses, resevoir is full, pump isn't working to release lock mechanism.Is there another step other than battery disconnect done,Jumped pos neg,done,,,Whew!!!!!New tires and another monster arrives.It's raining for the winter and I'd like to go run that carpet!!
peter jones is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: SL 500 Rollbar stuck in UP position, Soft top doesnt move, HELP!!!!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: