Notices
SL-Class (R230) 2003 -- 2012: Discussion on the SL500, SL550, SL600

Radiator trouble

 
Old 04-17-2019, 02:33 AM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
SL500
Radiator trouble

Need some advice....need to flush the cooling system, ( oil got in the coolant, due failed oil cooler seals, I think, so replaced those, all went well). First I tried to remove the rad hose at the bottom of the rad, passenger side, no luck, doesn’t want to budge, then I started to open the petcock, and it broke, after opening just enough to start a slow leak.. I will attempt to drill out the remainder of the petcock tomorrow, and replace it. I would really prefer to get the lower rad hose off so I can drain large quantities quickly, the system is badly contaminated.
I brought this car back from Dubai, where it baked in the sun for 15 years. Any original plastic and rubber is extremely fragile.
Any thoughts greatly appreciated!
flymetom is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Radiator trouble


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: