Go Back  MBWorld.org Forums > Mercedes-Benz SLR & SL Roadsters > SL-Class (R230)
ABC strange behaviour/question >

ABC strange behaviour/question

Notices
SL-Class (R230) 2003 -- 2012: Discussion on the SL500, SL550, SL600

ABC strange behaviour/question

 
Old 05-13-2019, 06:50 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2016
Posts: 14
Likes: 0
Received 1 Like on 1 Post
2007 SL550, 2006 E350
ABC strange behaviour/question

Hello all,

A few years ago, I acquired 07 SL550 with 89K miles on it. Immediately, I replaced oil/filter, pulsation dampener, front&rear accumulators as a preventative maintenance.
Now I have 123K miles on it and feel that the car is imbalanced going over the bumps and while stopping. I checked the pressure on struts; both front have 77bars, rear left 75bar and rear right 65bar.
So, rear right strut shows low pressure and that difference in pressure might explain why the car feels imbalanced.
What could be the problem area: strut or pressure sensor on the valve block or the height sensor? I use XEntry for the diagnostics and service. I would appreciate if anyone had a suggestion or any other input. Thank you in advance, Vadim
vkovaler888 is offline  
Old 05-14-2019, 08:30 AM
  #2  
Super Member
 
Join Date: Jan 2006
Posts: 968
Received 118 Likes on 101 Posts
'03 SL500, '00 S500, (4) R129s
Originally Posted by vkovaler888 View Post
I checked the pressure on struts; both front have 77bars, rear left 75bar and rear right 65bar.
The lower pressure on the rear right suggests to me that this strut may be extended relative to the others. Whether or not the vehicle is level when on level ground would indicate to me troubleshooting steps.

Last edited by bobterry99; 05-14-2019 at 08:54 AM.
bobterry99 is offline  
Old 05-16-2019, 12:34 AM
  #3  
Senior Member
 
Join Date: May 2015
Location: North Cali
Posts: 341
Received 22 Likes on 21 Posts
2005 SL500
Maybe a ride height calibration would help?
Ghostty is offline  
Old 05-16-2019, 07:47 AM
  #4  
Super Member
 
Join Date: Jan 2006
Posts: 968
Received 118 Likes on 101 Posts
'03 SL500, '00 S500, (4) R129s
Originally Posted by Ghostty View Post
Maybe a ride height calibration would help?
That and/or a strut calibration, which I may recall doing on a friend's '09 car last fall.
bobterry99 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: ABC strange behaviour/question


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: