Notices
W210 AMG Discuss the W210 AMG's such as the E50, E55, and E60
Sponsored by:
Sponsored by:

Help! E55 has check engine light on

 
Old 02-11-2002, 02:45 PM
  #1  
Newbie
Thread Starter
 
Join Date: Jan 2002
Location: New York City
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
2001 E55 AMG
Unhappy Help! E55 has check engine light on

I was stopped at the light this weekend and suddenly the engine was rough idling... tach showed 600rpm down to 100rpm then back to 600rpm back and forth. Next morning the check engine light came on. I tried to call teleaid SOS and the technician told me it was probably bad grade fuel (?) and that I should just refuel again and in a couple days it will go away. I have always used premium grade fuel in this engine, 92 octane +. So I refueled up with mobile supreme and the car still rough idles, and STALLS when I'm at the light. However when I am cruising it is FINE, engine power feels normal and I did make a 250mi roundtrip without any problems. This only happens when I am at a STOP. Has anyone had this unfortunate thing happen and how did you resolve it?

Thanks for your comments!
AMGGuy is offline  
Old 02-11-2002, 05:58 PM
  #2  
Super Member
 
Join Date: Jan 2002
Location: New Jersey
Posts: 564
Likes: 0
Received 0 Likes on 0 Posts
2006 E500 4matic Wagon
Hey. I had the same problem with my 2000 E430 4Matic. I too thought it was maybe bad gasoline--NYC Metro area, must be a bad station somewhere you know. Still stalled, idled rough, etc. Dealer (Millennium, Bridgewater NJ) replaced Mass Airflow Sensor. Solved the problem. Covered by warranty. I know E430 is a different animal than an AMG, but I think dealer diagnostics would be a good bet for your beast...
BenzE is offline  
Old 02-11-2002, 06:21 PM
  #3  
Super Moderator
 
Vic55's Avatar
 
Join Date: Nov 2001
Location: THE Orange County, California
Posts: 11,771
Received 614 Likes on 419 Posts
2017 Audi R8 V10, 2016 AMG GTS, 2018 E63S Edition 1, 2018 Porsche GTS Cab, 2012 C63 BS
Its the Mass air flow sensor. Its the same crap that happened to my E55. I dont understand why this happens to so many Benzes but at least the warranty will cover it. It is still a pain in the a$$ to give up your car for a day to get it fixed.
Vic55 is offline  
Old 02-11-2002, 06:27 PM
  #4  
Out Of Control!
 
JamE55's Avatar
 
Join Date: Nov 2001
Location: CA, NV, CO
Posts: 21,000
Likes: 0
Received 0 Likes on 0 Posts
So is this a common problem to all or certain MB models??
JamE55 is offline  
Old 02-11-2002, 11:48 PM
  #5  
Almost a Member!
 
Join Date: Dec 2001
Location: NorCal
Posts: 25
Likes: 0
Received 0 Likes on 0 Posts
2000 E55
mas mass air sensor problemas

must be an E55 issue. mine went out 2 weeks ago; same symptoms as AMGGuy's. mine went out with a "chuff" under moderate throttle at about 4000rpm, then had the same rough idle and stall at idle. car has only 17k miles, and again, fixed same day by dealer under warranty.
silverstreak is offline  
Old 02-13-2002, 05:45 PM
  #6  
svc
Newbie
 
Join Date: Feb 2002
Location: Miami, FL and Rio de Janeiro
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Mercedes-Benz A190 (W168) and E220CDI (W210)
This bad rough idle issue do not belong only to E Class. I saw the same problem in the A and C Classes with petrol engines.
What could be the "connection" between that Air Mass Flow Sensor and the idle stabilizer? Hard to understand...

Sergio
svc is offline  
Old 02-17-2002, 12:26 PM
  #7  
Almost a Member!
 
Join Date: Nov 2001
Location: S VA
Posts: 60
Likes: 0
Received 0 Likes on 0 Posts
'01 E55 '99 ML430 '96 C4 Cab
Like Vic says, it's the mass air flow sensor. Had the same thing happen to me. It seems to be a common problem on E55's at least, maybe 430's and 320's as well.
rich
'01 E55
Rich is offline  
Old 02-25-2002, 08:47 AM
  #8  
Newbie
Thread Starter
 
Join Date: Jan 2002
Location: New York City
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
2001 E55 AMG
Thanks to all replies! I have an appointment on 3-14, I'll keep you guys posted
AMGGuy is offline  
Old 02-26-2002, 08:32 PM
  #9  
MBWorld Fanatic!
 
t-bone's Avatar
 
Join Date: Nov 2001
Location: Pasadena
Posts: 1,355
Likes: 0
Received 4 Likes on 4 Posts
2004 E55
I just got my car back today from having sercive done due to the "Check Engine" light on.

The cause? Mass Airflow Sensor

Good thing it came on now, because my warranty is going to be over in about 2000 miles.
t-bone is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Help! E55 has check engine light on


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: