Go Back  MBWorld.org Forums > Mercedes-Benz AMG Vehicles > E55 AMG, E63 AMG, E43AMG (W210, W211, W212,W213) > W211 AMG
Voltage Regulator Replacement DIY- Its usually not the alternator >

Voltage Regulator Replacement DIY- Its usually not the alternator

Notices
W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

Voltage Regulator Replacement DIY- Its usually not the alternator

 
Old 01-02-2014, 12:05 PM
  #101  
Junior Member
 
VICK3358's Avatar
 
Join Date: Dec 2013
Posts: 22
Likes: 0
Recieved 0 Likes on 0 Posts
'06 CLS 55 AMG, '04 LEXUS RX330, '96 3KGT VR4
Originally Posted by shardul View Post
by the hood release under the dash
Thanks again!
VICK3358 is offline  
Old 01-02-2014, 01:37 PM
  #102  
Senior Member
iTrader: (1)
 
Inspiredbenz's Avatar
 
Join Date: Nov 2012
Location: CORONA CA (SOCAL)
Posts: 379
Recieved 6 Likes on 5 Posts
SOLD W203..CURRENTLY DRIVING W211
So vick did you solve your issue?

If not check your volt. Reg. And yes if you suspect your hids they can be short circuiting
Inspiredbenz is offline  
Old 01-02-2014, 02:18 PM
  #103  
Junior Member
 
VICK3358's Avatar
 
Join Date: Dec 2013
Posts: 22
Likes: 0
Recieved 0 Likes on 0 Posts
'06 CLS 55 AMG, '04 LEXUS RX330, '96 3KGT VR4
Originally Posted by Inspiredbenz View Post
So vick did you solve your issue?

If not check your volt. Reg. And yes if you suspect your hids they can be short circuiting


I haven't got a chance to work on the car yet because I left it on my sister's house ;O( Plus I need to order the parts (VR, Aux Relay and CAS)
Tomorrow I'm going read the OBD II codes and confirm the CAS or any other one there.


I do have a few messages on my display:
"left/right head light, left license plate, SOS system) The lights are working Ok except the license plate, they blink and goes off. I saw a treat to fix them, but I'll try that after the main problems. I'll post the progress!
Thanks!
VICK3358 is offline  
Old 01-02-2014, 04:16 PM
  #104  
Senior Member
iTrader: (1)
 
Inspiredbenz's Avatar
 
Join Date: Nov 2012
Location: CORONA CA (SOCAL)
Posts: 379
Recieved 6 Likes on 5 Posts
SOLD W203..CURRENTLY DRIVING W211
Are the lic. plate lights aftermarket?

they may not be the right ones , I ordered sum white leds for lic. plate they did the same . They would work for a sec. and then flicker and not work again
Inspiredbenz is offline  
Old 01-04-2014, 06:30 PM
  #105  
Junior Member
 
VICK3358's Avatar
 
Join Date: Dec 2013
Posts: 22
Likes: 0
Recieved 0 Likes on 0 Posts
'06 CLS 55 AMG, '04 LEXUS RX330, '96 3KGT VR4
I replaced the CAS with an aftermarket from Autozone, MB didn't liked, trhrow me a P0355 Bad CAS, Put back the original and the Code is gone, However can still pass 3K revolutions on idle, so I still going to replace the CAS with a new original one. I check the aux batt and Is reading 12.65 car on or off? If that good?
VICK3358 is offline  
Old 01-12-2014, 01:30 PM
  #106  
Senior Member
 
Join Date: Oct 2011
Location: Southern Maryland USA
Posts: 413
Likes: 0
Recieved 3 Likes on 3 Posts
06 E55 AMG, 13 C63 AMG
I replaced the voltage regulator and my problem remains.

Voltage continues to drop. The alternator is getting super hot, like it is trying very hard to pump current somewhere, but it does not seem to be getting to the main system.

Anyone have any recommendations where to go from here?

G
Gadget is offline  
Old 01-12-2014, 01:37 PM
  #107  
Super Member
 
MAN55LE's Avatar
 
Join Date: Mar 2013
Location: America
Posts: 602
Likes: 0
Recieved 0 Likes on 0 Posts
04 E55 AMG
I normally only think it could be three or four things, voltage regulator, alternator itsel,f either of the batteries, and lastly a ground or electrical connection.....but in your case I think it's the alternator..... My local auto parts store has one remanufactured 168$ bucks and said it come with the voltage regulator, I just ordered that regulator should be here Monday.

Last edited by MAN55LE; 03-04-2014 at 12:35 AM.
MAN55LE is offline  
Old 01-12-2014, 02:32 PM
  #108  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
Originally Posted by MAN55LE View Post
I normally only think it could be three or four things, voltage regulator, alternator itsel,f either of the batteries, and lastly a ground or electrical connection.....but in your case I think it's the alternator..... My local auto parts store has one remanufactured 168$ bucks and said it come with the voltage regulator, I just ordered that regulator should be here Monday. I passed on the alternator and I'm just going to try the regulator first.
Man that's the bull**** from these cars and I can't take it, just now like not even 5 mins go i kicked my fender of my mint 05 E55 soo hard as ppl watched me. I just put in 2 days ago a used alternator that came out of a 06 e55 it had 81k miles I changed the voltage regulator JUST IN CASE. I installed new serpentine belt for better tension on the pulley of the alternator. I was at a red light and message went on "convention functions temporary unavailable" I got out the car and started to scream at my car "F*** you I hate you how many times i change parts for you HOW MANY TIMES DO YOU BREAK DOWN ON ME MY GF LEFT ME BECAUSE I CHOSE YOU OVER HER" light turned green ppl were honking and yelling. i than just blacked out and than I kicked my fender so hard it cracked the bracket of the head light assembly. I sticked my finger at everyone jumped into my car and floored it so hard 88mph on a 35 zone. Idc F*** these cars I give up.
E55AMG05 is offline  
Old 01-12-2014, 03:54 PM
  #109  
Super Member
 
MAN55LE's Avatar
 
Join Date: Mar 2013
Location: America
Posts: 602
Likes: 0
Recieved 0 Likes on 0 Posts
04 E55 AMG
Did you try replacing the batteries or testing the batteries and then after that disconnecting the battery for couple hours to see if it will reset....for somebody that was trying to save money (buying and returning battery chargers, buying used alternators)and this and that you sure caused yourself a lot of headache with kicking the fender that was just stupid do something else
Hey you got any pictures of that fender kick
MAN55LE is offline  
Old 01-12-2014, 07:24 PM
  #110  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
Originally Posted by MAN55LE View Post
Did you try replacing the batteries or testing the batteries and then after that disconnecting the battery for couple hours to see if it will reset....for somebody that was trying to save money (buying and returning battery chargers, buying used alternators)and this and that you sure caused yourself a lot of headache with kicking the fender that was just stupid do something else
Hey you got any pictures of that fender kick
Look man you don't know how much effort i put into saving money and keeping this car. Everything is OEM. It's the battery failure and yes I have the pics I just dnt know how to post pics on here a major pain in the *** as much as my car. Funny post faces but I don't smoke. 3 days ago i bought a battery charger from Walmart charged it for 12hrs and returned it next day. This can't be
E55AMG05 is offline  
Old 01-12-2014, 08:19 PM
  #111  
Junior Member
 
Join Date: Aug 2011
Location: Grand Rapids, MI
Posts: 67
Likes: 0
Recieved 0 Likes on 0 Posts
05 E55
Originally Posted by E55AMG05 View Post
Man that's the bull**** from these cars and I can't take it, just now like not even 5 mins go i kicked my fender of my mint 05 E55 soo hard as ppl watched me. I just put in 2 days ago a used alternator that came out of a 06 e55 it had 81k miles I changed the voltage regulator JUST IN CASE. I installed new serpentine belt for better tension on the pulley of the alternator. I was at a red light and message went on "convention functions temporary unavailable" I got out the car and started to scream at my car "F*** you I hate you how many times i change parts for you HOW MANY TIMES DO YOU BREAK DOWN ON ME MY GF LEFT ME BECAUSE I CHOSE YOU OVER HER" light turned green ppl were honking and yelling. i than just blacked out and than I kicked my fender so hard it cracked the bracket of the head light assembly. I sticked my finger at everyone jumped into my car and floored it so hard 88mph on a 35 zone. Idc F*** these cars I give up.
Time to go lease a Kia.
WoodyBang is offline  
Old 01-12-2014, 08:55 PM
  #112  
Member
 
Join Date: Oct 2012
Location: Santa Monica
Posts: 230
Likes: 0
Recieved 0 Likes on 0 Posts
2005 e55
[QUOTE=MAN55LE;5904679]I normally only think it could be three or four things, voltage regulator, alternator itsel,f either of the batteries, and lastly a ground or electrical connection.....but in your case I think it's the alternator..... My local auto parts store has one remanufactured 168$ bucks and said it come with the voltage regulator, I just ordered that regulator should be here Monday. I passed on the alternator and I'm just going to try the regulator first.[/QUOTE


Same thing just happened with mine. Changed Voltage regulator and still would not fully charge. Upon taking out the alternator I found a bunch of Melted plastic. I would replace alternator and be done with it
groove66 is offline  
Old 01-12-2014, 09:18 PM
  #113  
Junior Member
 
APBTdogman's Avatar
 
Join Date: Oct 2012
Posts: 64
Likes: 0
Recieved 0 Likes on 0 Posts
05 E55, Hawkeye WRX Wagon, Duramax Van, GT-Four Rally Car, LS1 Z-28, 1G CRX Rally Car
Had the burnt plastic smell on mine so i put a new alt in and prob solved. I also put a new vr in my old alt and tested it and it still was bad. Im pretty sure that if you just need a new vr you should not have the burnt smell. Burnt smell prob equals you need a new alt and should not waste time on a vr replacement.
APBTdogman is offline  
Old 01-12-2014, 09:32 PM
  #114  
Senior Member
 
Join Date: Oct 2011
Location: Southern Maryland USA
Posts: 413
Likes: 0
Recieved 3 Likes on 3 Posts
06 E55 AMG, 13 C63 AMG
If I replace the alternator, how does it come out?

Down out from underneath or through the front and up?

Seems like a very large unit and not much space to work with.

G
Gadget is offline  
Old 01-12-2014, 09:54 PM
  #115  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
Originally Posted by WoodyBang View Post
Time to go lease a Kia.
That's that bull****. Kia my ***
E55AMG05 is offline  
Old 01-12-2014, 09:57 PM
  #116  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
[QUOTE=groove66;5905100]
Originally Posted by MAN55LE View Post
I normally only think it could be three or four things, voltage regulator, alternator itsel,f either of the batteries, and lastly a ground or electrical connection.....but in your case I think it's the alternator..... My local auto parts store has one remanufactured 168$ bucks and said it come with the voltage regulator, I just ordered that regulator should be here Monday. I passed on the alternator and I'm just going to try the regulator first.[/QUOTE


Same thing just happened with mine. Changed Voltage regulator and still would not fully charge. Upon taking out the alternator I found a bunch of Melted plastic. I would replace alternator and be done with it
That's impossible it can't be the alternator. I purchased a 81K mile alternator and I'm going to add a new voltage regulator on top of it followed by a brand new serpentine belt for good alternator tension

$165 remanufactured alternator my ***. My alternator that I have is way better than yours. I payed $100 for the used 81K mile alternator and bought a OEM $60 Voltage Regulator. Total cost $160 for me. I'm not trying to be a d**k I'm just saying its not my alternator

Last edited by E55AMG05; 01-12-2014 at 10:01 PM.
E55AMG05 is offline  
Old 01-12-2014, 10:02 PM
  #117  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
Nvm
E55AMG05 is offline  
Old 01-12-2014, 10:13 PM
  #118  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
Originally Posted by Gadget View Post
If I replace the alternator, how does it come out?

Down out from underneath or through the front and up?

Seems like a very large unit and not much space to work with.

G
No it can't come out from the bottom. It comes out from the top. Make sure engine is cold make sure you disconnect the BLACK POSITIVE BATTERY TERMINAL You need to remove the fan shroud remove all the belts and remove the idler pulley the doubled one it's metal and plastic < be carful with the idler pulley I F*ucked mine up by not taking it out. Also remove bracket the plastic bracket underneath the pulley. Hope you have hose clamp pliers because you will need to remove 3 hose 2 small and one big. Coolant will leak dnt worry. Remove 2 bolts from the alternator take a crowbar and yank it. Disconnect the 2 wire connections on the alternator and pull it out. Installing it do it reverse. Hope this gives you a bit of a idea.
E55AMG05 is offline  
Old 01-12-2014, 11:18 PM
  #119  
Junior Member
 
APBTdogman's Avatar
 
Join Date: Oct 2012
Posts: 64
Likes: 0
Recieved 0 Likes on 0 Posts
05 E55, Hawkeye WRX Wagon, Duramax Van, GT-Four Rally Car, LS1 Z-28, 1G CRX Rally Car
When you remove the fan shroud dont forget the hidden t25 fastner at the bottom by the hose bracket. It is also a good idea to put a few layers of cardboard over the rad to keep it mint.
APBTdogman is offline  
Old 01-12-2014, 11:32 PM
  #120  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
Originally Posted by APBTdogman View Post
When you remove the fan shroud dont forget the hidden t25 fastner at the bottom by the hose bracket. It is also a good idea to put a few layers of cardboard over the rad to keep it mint.
The t25 bracket removal thing is not necessary. With all do respect I just explained exactly what needs to be done in order to remove and install the alternator and to bypass me you come up with cardboards and T25's. I DIDENT NEED TO USE THE T25's AND SURE DIDENT NEED ANY CARDBOARDS!!!! the way I explained it, is the exact way HOW IT SHOULD GO!!!!
E55AMG05 is offline  
Old 01-13-2014, 12:30 AM
  #121  
Junior Member
 
APBTdogman's Avatar
 
Join Date: Oct 2012
Posts: 64
Likes: 0
Recieved 0 Likes on 0 Posts
05 E55, Hawkeye WRX Wagon, Duramax Van, GT-Four Rally Car, LS1 Z-28, 1G CRX Rally Car
Originally Posted by E55AMG05 View Post
The t25 bracket removal thing is not necessary. With all do respect I just explained exactly what needs to be done in order to remove and install the alternator and to bypass me you come up with cardboards and T25's. I DIDENT NEED TO USE THE T25's AND SURE DIDENT NEED ANY CARDBOARDS!!!! the way I explained it, is the exact way HOW IT SHOULD GO!!!!

Lol are you ok over there? This is a forum not an automotive lecturing class, we are all free to add to the discussion. Have a cold pepsi or somethin jeez.
APBTdogman is offline  
Old 01-13-2014, 01:22 AM
  #122  
Member
 
Join Date: May 2011
Location: NY
Posts: 160
Likes: 0
Recieved 0 Likes on 0 Posts
2005 E55 AMG
Originally Posted by APBTdogman View Post
Lol are you ok over there? This is a forum not an automotive lecturing class, we are all free to add to the discussion. Have a cold pepsi or somethin jeez.
Your right sorry about that the whole ALTERNATOR issue that I am having with my car is seriously making me nuts.. Anyways I have respect for everyone in THIS SECTION of this forum because you all are 55K owners followed by me.
E55AMG05 is offline  
Old 01-13-2014, 05:33 AM
  #123  
Newbie
 
santillan_m's Avatar
 
Join Date: Dec 2013
Location: ventura, ca
Posts: 9
Likes: 0
Recieved 0 Likes on 0 Posts
05 e55 amg , 00 civic Si em1, 2k12 camaro ls
Originally Posted by E55AMG05 View Post
Your right sorry about that the whole ALTERNATOR issue that I am having with my car is seriously making me nuts.. Anyways I have respect for everyone in THIS SECTION of this forum because you all are 55K owners followed by me.


Wowwwww hahaha ^^^^ I know how you guys feel I've spend alot of damn time reading forums on this issue that I am having on my e55 the same crap and yessss I've myself been getting 😡😤 so irritated about it my fiancÚ is pissed cause my dd e55 is down againnnn and she has to give me rides and wake up early to take me to work .!! my car has been down for 2 weeks now it left me stranded had it towed to my house I replaced my batteries too I replaced my VR and my CPS and it didn't start it will crank but not start so I finally got it to start replaced a fuse on the engine bay.. I drove it around a couple blocks i was so happy and then after 20 min it shut down on me againnnnnn!!!!!!! Ggrrrrr and the red battery/alternator came back again !!! And now I'm back to being Carless for another week !!!!! And btw I did had this smell of burnt in the beginning so nowwww I'm gonna have to change my alternator which is not cheap i read ??? But now I'm curious about the aux battery sensor can that be it too ????
santillan_m is offline  
Old 01-13-2014, 08:50 AM
  #124  
Junior Member
 
VICK3358's Avatar
 
Join Date: Dec 2013
Posts: 22
Likes: 0
Recieved 0 Likes on 0 Posts
'06 CLS 55 AMG, '04 LEXUS RX330, '96 3KGT VR4
Originally Posted by santillan_m View Post
Wowwwww hahaha ^^^^ I know how you guys feel I've spend alot of damn time reading forums on this issue that I am having on my e55 the same crap and yessss I've myself been getting ���� so irritated about it my fiancÚ is pissed cause my dd e55 is down againnnn and she has to give me rides and wake up early to take me to work .!! my car has been down for 2 weeks now it left me stranded had it towed to my house I replaced my batteries too I replaced my VR and my CPS and it didn't start it will crank but not start so I finally got it to start replaced a fuse on the engine bay.. I drove it around a couple blocks i was so happy and then after 20 min it shut down on me againnnnnn!!!!!!! Ggrrrrr and the red battery/alternator came back again !!! And now I'm back to being Carless for another week !!!!! And btw I did had this smell of burnt in the beginning so nowwww I'm gonna have to change my alternator which is not cheap i read ??? But now I'm curious about the aux battery sensor can that be it too ????
OMG an MB alternator epidemy!!!

I had it, I installed a rebuild one from Autozone. Works ok for a few days and went down. I got another one under warranty and everything have been working Ok now for a week. Anyhow I'm going to replace the VR and CPS just to be safe.
VICK3358 is offline  
Old 01-13-2014, 11:16 AM
  #125  
Junior Member
 
APBTdogman's Avatar
 
Join Date: Oct 2012
Posts: 64
Likes: 0
Recieved 0 Likes on 0 Posts
05 E55, Hawkeye WRX Wagon, Duramax Van, GT-Four Rally Car, LS1 Z-28, 1G CRX Rally Car
I should have mentioned that if you remove the t25s and pop the hard lines out of the shroud then there is no need to disconnect water lines. The advantage to doing it this way is that you dont need to worry about air getting into the coolant system or antifreeze droppin on the floor .
APBTdogman is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 2 votes, 5.00 average.

Quick Reply: Voltage Regulator Replacement DIY- Its usually not the alternator


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: