Go Back  MBWorld.org Forums > Mercedes-Benz AMG Vehicles > E55 AMG, E63 AMG, E43AMG (W210, W211, W212,W213) > W211 AMG
Weird Braking Problem, Dash lit up / error messages and lack of brakes. Advice needed >

Weird Braking Problem, Dash lit up / error messages and lack of brakes. Advice needed

Notices
W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

Weird Braking Problem, Dash lit up / error messages and lack of brakes. Advice needed

 
Old 12-08-2012, 10:54 AM
  #1  
MBWorld Fanatic!
Thread Starter
 
jpohl402's Avatar
 
Join Date: Dec 2007
Location: PHX/PIE/OMA ---> Yes, all three
Posts: 2,050
Likes: 0
Received 1 Like on 1 Post
E55 then E63, now back to an E55
Weird Braking Problem, Dash lit up / error messages and lack of brakes. Advice needed

Tooling down the road like normal, then a very strange occurrence of events.
Have fairly new (def good enough) brake pads, rotors, etc.

1. E-brake light in clock display lit up (red, "brake")
2. In tach, ABS light (orange) lit up
3. In instrument cluster, displayed message "ESP malfunction"
4. That almost immediately changed to large red background message with stop sign, saying "STOP. Reduced braking power. Depress brake pedal firmly."
5. Engine RPMs jumped up to 4000 and stayed constant there - I was not on gas!
6. Heard a loud whirring sound from engine bay, kind of like a pump or tank or something? I'm really not exactly sure. Not the radiator fan though.
7. Had very little brakes, went almost to floor and very spongy feeling.

Slowly pulled into turning lane off highway, brakes were terrible. Steady red "STOP - Reduced braking power" message in cluster.

Turned off car, cluster then changed to "STOP. Brake Failure! Start Engine"

Ignored it, waited 2-3 minutes, restarted - and almost the strangest thing of all, nothing seems to be wrong now. Runs and drives fine..... Any ideas ? Thanks
jpohl402 is offline  
Old 12-08-2012, 01:22 PM
  #2  
MBWorld Fanatic!
 
FASN8N's Avatar
 
Join Date: Feb 2005
Location: Atlanta
Posts: 1,728
Likes: 0
Received 0 Likes on 0 Posts
CTSV/6sp Grocery Getter
Battery, alternator, or voltage regulator likely on the way out...
FASN8N is offline  
Old 12-22-2012, 09:26 PM
  #3  
Newbie
 
Join Date: Dec 2012
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
2005 SL500
Originally Posted by jpohl402 View Post
Tooling down the road like normal, then a very strange occurrence of events.
Have fairly new (def good enough) brake pads, rotors, etc.

1. E-brake light in clock display lit up (red, "brake")
2. In tach, ABS light (orange) lit up
3. In instrument cluster, displayed message "ESP malfunction"
4. That almost immediately changed to large red background message with stop sign, saying "STOP. Reduced braking power. Depress brake pedal firmly."
5. Engine RPMs jumped up to 4000 and stayed constant there - I was not on gas!
6. Heard a loud whirring sound from engine bay, kind of like a pump or tank or something? I'm really not exactly sure. Not the radiator fan though.
7. Had very little brakes, went almost to floor and very spongy feeling.

Slowly pulled into turning lane off highway, brakes were terrible. Steady red "STOP - Reduced braking power" message in cluster.

Turned off car, cluster then changed to "STOP. Brake Failure! Start Engine"

Ignored it, waited 2-3 minutes, restarted - and almost the strangest thing of all, nothing seems to be wrong now. Runs and drives fine..... Any ideas ? Thanks
Hi Did you ever get a response about this event? I just changed my rotors and pads. Did a spiffy job I thought. But, when I started the car up, I got the exact same message as you but mine isn't going out!
stevevmaloney is offline  
Old 12-27-2012, 07:45 PM
  #4  
MBWorld Fanatic!
Thread Starter
 
jpohl402's Avatar
 
Join Date: Dec 2007
Location: PHX/PIE/OMA ---> Yes, all three
Posts: 2,050
Likes: 0
Received 1 Like on 1 Post
E55 then E63, now back to an E55
Steve,
No I did not...
I haven't been driving the car much, but when I do, it hasn't done the error message. I never got it looked at yet....
jpohl402 is offline  
Old 12-27-2012, 07:47 PM
  #5  
MBWorld Fanatic!
 
Join Date: Sep 2009
Location: NOMAD
Posts: 7,425
Received 23 Likes on 20 Posts
CLS550 4Matic
Maybe brake sensors are faulty...try that instead of changing everything out.

I forgot to change my sensors on my E and I got this error
djrabbi is offline  
Old 12-27-2012, 08:33 PM
  #6  
MBWorld Fanatic!
 
Join Date: Oct 2012
Location: Canada
Posts: 1,242
Received 5 Likes on 5 Posts
2004 E55 AMG
Originally Posted by jpohl402 View Post
Steve,
No I did not...
I haven't been driving the car much, but when I do, it hasn't done the error message. I never got it looked at yet....
The problem is .....

I was at the dealership to get a full check up of my car and asked the foreman that is the hydraulic pump noise means it's near it failure

"he goes , the car is 2004 and it's normal for it to make a little noise, if the pump fails , you will get the errors that you just described above ^^ press hard and all "

but I am not sure about the rpm problem.
viren.89 is offline  
Old 12-27-2012, 09:40 PM
  #7  
MBWorld Fanatic!
 
moosejaw's Avatar
 
Join Date: Nov 2005
Posts: 5,692
Likes: 0
Received 4 Likes on 2 Posts
none
SBC brake system failure possibly?
The SBC pump is covered by a 10 year warranty on the 03-04s.
Another reason to upgrade/shop around for 05-06
https://mbworld.org/forums/e-class-w...nit-aware.html
moosejaw is offline  
Old 01-21-2013, 01:55 AM
  #8  
Newbie
 
Join Date: Jan 2013
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
cls 500
Originally Posted by stevevmaloney View Post
Hi Did you ever get a response about this event? I just changed my rotors and pads. Did a spiffy job I thought. But, when I started the car up, I got the exact same message as you but mine isn't going out!
I'm having the same problem. I changed my brakes today and now all of a sudden I'm getting this code of Reducing brake power and depress the brake pedal fully. Like mentioned I thought I did a great job as I have multiple cars that I work on. I think I'll try and change the sensor as I did not have a new one on hand. Hopefully that saves me a trip to the MB dealership.
cls dragon is offline  
Old 05-19-2013, 10:16 AM
  #9  
Newbie
 
Join Date: May 2013
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
sl500
very similar problem with my sl500
sweet_caribbean is offline  
Old 05-19-2013, 11:19 AM
  #10  
MBWorld Fanatic!
 
Toadster's Avatar
 
Join Date: Dec 2011
Location: Folsom, CA
Posts: 4,051
Received 19 Likes on 18 Posts
2005 E55 AMG
how's your AUX battery? maybe needs replacing?

only $67 online 14-BS battery

Last edited by Toadster; 05-19-2013 at 11:24 AM.
Toadster is offline  
Old 05-24-2013, 02:18 PM
  #11  
Newbie
 
Join Date: May 2013
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
sl500
The starter battery needs to be replaced.. The rear battery is fine. I'll check the battery and let you know if it makes a difference.
sweet_caribbean is offline  
Old 06-24-2018, 04:34 PM
  #12  
Newbie
 
Join Date: Jun 2018
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
2006 e500 4matic
2006 Mercedes e500 4matic - get the reduced braking power message while driving on the road - car loses power and takes longer distance to stop - I pull over, stop and restart and regular braking power works - also get the depress brake fully message - how do you fix this problem?
ced915 is offline  
Old 11-19-2018, 09:21 AM
  #13  
Newbie
 
Join Date: Sep 2018
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
2005 SL65 AMG
Did you ever get an answer here. I got the same warnings you described this morning on my sl65. What was the problem?
Cultured is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Weird Braking Problem, Dash lit up / error messages and lack of brakes. Advice needed


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: