Notices
W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

Check Engine Light Turned on Under WOT

 
Old 03-06-2017, 11:49 AM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2015
Location: Joliet, IL
Posts: 11
Received 0 Likes on 0 Posts
E63 AMG
Check Engine Light Turned on Under WOT

Over the weekend I was out in the country ripping it a few times. But on one long run, my CEL turned on. This morning on my way to my buddies shop the CEL turned off. I still had by friend run a scan of the car and P2093 was the only code in the record. I did look up the definition on here, and this is all that came up, does anyone know have this code come up before and If so what was the issue? My car is running fine now, it is as though nothing happened. The only things done to the car are a Renntech intake and a Renntech Tune.

P2093 (B) self-adaptation L Cyl bank for enrich at partial load above limit.

My Car is a 2008 E63 FYI

Last edited by AutobahnE63; 03-06-2017 at 02:16 PM.
AutobahnE63 is offline  
Old 03-06-2017, 04:52 PM
  #2  
Super Member
 
Join Date: Sep 2016
Posts: 655
Received 37 Likes on 35 Posts
E55 amg
Could be the gas pedal sensor or map senor ,,.DOes it idle all loppy?
oneslow55 is offline  
Old 03-06-2017, 06:23 PM
  #3  
Newbie
Thread Starter
 
Join Date: Oct 2015
Location: Joliet, IL
Posts: 11
Received 0 Likes on 0 Posts
E63 AMG
Originally Posted by oneslow55 View Post
Could be the gas pedal sensor or map senor ,,.DOes it idle all loppy?
It idles fine no issues there
AutobahnE63 is offline  
Old 03-06-2017, 06:56 PM
  #4  
Super Member
 
Join Date: Sep 2016
Posts: 655
Received 37 Likes on 35 Posts
E55 amg
Originally Posted by AutobahnE63 View Post
It idles fine no issues there
Must be the gas pedal sensor ..Goes into limp mode ?
oneslow55 is offline  
The following users liked this post:
AutobahnE63 (03-07-2017)
Old 03-07-2017, 11:27 AM
  #5  
Newbie
Thread Starter
 
Join Date: Oct 2015
Location: Joliet, IL
Posts: 11
Received 0 Likes on 0 Posts
E63 AMG
It did reduce power, it didn't feel like the limp modes I have experienced in other cars. It was just reduced power so it felt like it had 300hp.
AutobahnE63 is offline  
Old 03-07-2017, 09:55 PM
  #6  
MBWorld Fanatic!
 
Rocman8's Avatar
 
Join Date: Nov 2014
Posts: 1,139
Received 67 Likes on 63 Posts
2006 E55, 2005 C55, 2005 E320 Estate Sport, 2015 ML350
Sounds like a vacuum leak to me or even an air mass meter. Vacuum leaks on 156 engines are very common. This won't be a guessing fix here. Find someone that knows this engine to properly diagnose it.
Rocman8 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Check Engine Light Turned on Under WOT


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: