Notices
W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

Run away fan problem .

 
Old 02-16-2019, 06:17 PM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Likes: 0
Liked 0 Times in 0 Posts
c300
Run away fan problem .

My fan on my 2008 c300 is running in high speed mode all the time any ideas?
mike2366 is offline  
Old 02-16-2019, 07:13 PM
  #2  
Senior Member
 
Join Date: Feb 2014
Location: FRISCO TEXAS
Posts: 335
Liked 5 Times in 5 Posts
2006 E55
wrong forum for that model
actech is offline  
Old 02-16-2019, 07:13 PM
  #3  
tw2
MBWorld Fanatic!
 
tw2's Avatar
 
Join Date: Aug 2011
Location: New Zealand
Posts: 2,801
Liked 142 Times in 125 Posts
2005 E55 AMG, 1991 MR2
Some cars have a separate temperature sensor which may be unplugged or has failed. Otherwise scan with STAR to get any cooling related codes. Or post in the w204 C-class forum and you might get more help.
tw2 is offline  
Old 02-16-2019, 07:49 PM
  #4  
MBWorld Fanatic!
 
Join Date: Dec 2008
Posts: 2,115
Liked 17 Times in 13 Posts
shrimp boat
Originally Posted by mike2366 View Post
My fan on my 2008 c300 is running in high speed mode all the time any ideas?
wrong forum, but I bet you your fan plug is soaking wet. Unplug and dry it and see if that helps
Forrest Gump 9 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Run away fan problem .


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: