Go Back   MBWorld.org Forums > Mercedes-Benz Coupes & Cabriolets > C-Class Coupe (C204)
Sign in using an external account
Register Forgot Password?


Welcome to MBWorld.org!
Welcome to MBWorld,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 01-05-2012, 06:59 AM   #1
Junior Member
 
Join Date: Oct 2011
Posts: 60
Drives: C250 Coupe
Red face How to turn on Internet in COMAND?

Hi Everyone,
I'm able to go into engineering mode and I saw "Internet" under SW Settings. My question is how to turn the internet on and bring out the "globe" in the main screen?

Can COMAND access internet using my iPhone (via bluetooth)?

Thanks in advance!
Mike
To remove this ad, register today or login if you already are registered!

mikengo is offline   Reply With Quote
Old 01-05-2012, 07:28 AM   #2
Member
 
Join Date: Jan 2012
Location: Sydney, Australia
Posts: 95
Drives: C250 CDI coupe, Obsidian Black, Vision Pack, Drive Assist Plus pack, Comfort Pack, Rev Camera
jamesdatramp
Hi Mike

Yep you can enable the Internet interface however you need a phone with the DUN Bluetooth access profile.

iPhone won't do it neither will some androids however blackberry and Samsung do.

Good luck.

James
jkyriakou is offline   Reply With Quote
Old 01-05-2012, 07:51 AM   #3
Junior Member
 
Join Date: Oct 2011
Posts: 60
Drives: C250 Coupe
Quote:
Originally Posted by jkyriakou View Post
Hi Mike

Yep you can enable the Internet interface however you need a phone with the DUN Bluetooth access profile.

iPhone won't do it neither will some androids however blackberry and Samsung do.

Good luck.

James
Hi James. Thank you for the quick response. Does that mean that if it is a supported phone, the globe will appear? The globe is not visible while pairing with my iPhone.
mikengo is offline   Reply With Quote
Old 01-05-2012, 11:48 AM   #4
Senior Member
 
johnny--2k's Avatar
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 319
Drives: 2009 C63
more details please!!! What is the "globe" and how do you get into engineering mode? I would love to have internet in the car!
__________________
09 C63 | Eurocharged V5 Tune | Charcoal Delete | Matte Gunmetal Metallic Wrap
johnny--2k is offline   Reply With Quote
Old 01-05-2012, 03:47 PM   #5
Member
 
Jav_A's Avatar
 
Join Date: Oct 2011
Location: ON
Posts: 76
Drives: 2012 C250 coupe
Jav_A
Access engineering menu by holding down the red 'end call' button + pound # + 1 together for a few seconds.
Careful what you play around with in here though.
Jav_A is offline   Reply With Quote
Old 01-05-2012, 04:03 PM   #6
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,101
Drives: 2012 C250 Coupe
jctevere
I don't know what your talking about appearing on the home screen. But after you have enabled internet, you go over to the globe symbol on the top right of the comand screen, how you would access sirius weather. But now, instead of sirius weather being the only square, you can add favorites and input a "www." address to browse the web.

As said above though, you need a bluetooth phone that supports DUN to do this, iPhones don't, VERY few androids do, and only a handful of blackberry's support this. However, even the phones that do support it, the internet speed is PAINFULLY slow. I am going to try to find out if there is a work around to hookkup to wifi or somehting...
__________________
jctevere is offline   Reply With Quote
Old 01-05-2012, 04:35 PM   #7
Senior Member
 
johnny--2k's Avatar
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 319
Drives: 2009 C63
Edit: Found it.
__________________
09 C63 | Eurocharged V5 Tune | Charcoal Delete | Matte Gunmetal Metallic Wrap

Last edited by johnny--2k; 01-05-2012 at 05:53 PM.
johnny--2k is offline   Reply With Quote
Old 01-05-2012, 07:49 PM   #8
Member
 
Join Date: Jan 2012
Location: Sydney, Australia
Posts: 95
Drives: C250 CDI coupe, Obsidian Black, Vision Pack, Drive Assist Plus pack, Comfort Pack, Rev Camera
jamesdatramp
Internet speed is dependent on your network speed. In saying that DUn is usually slower because of how it's routed. The MB apps however, weather, Facebook should work fine. (don't know why you need Facebook in your car but you could then technically "check in")

My rep has advised (and I have confirmed independently) that MB will be adding PAN support third quarter 2012.

Will most likely require a stealer upgrade but iPhone should then work.

James
jkyriakou is offline   Reply With Quote
Old 01-05-2012, 08:24 PM   #9
Junior Member
 
Join Date: Apr 2011
Posts: 55
Drives: 2011 C350
just so everyone know iphone or android can download an app called pdanet to enable DUN Bluetooth tethering
mugennosora is offline   Reply With Quote
Old 01-05-2012, 10:59 PM   #10
Senior Member
 
johnny--2k's Avatar
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 319
Drives: 2009 C63
What i want to know is if there is a way to enable the lines in the backup camera like the new ML's have. I tried using the same camera mode as my moms ML, but when in reverse, it doesn't pull up anything, just stays on whatever screen you are in (ie audio, phone, nav, etc...) so that's a no go from what I can tell.
__________________
09 C63 | Eurocharged V5 Tune | Charcoal Delete | Matte Gunmetal Metallic Wrap
johnny--2k is offline   Reply With Quote
Old 01-05-2012, 11:24 PM   #11
Member
 
Join Date: May 2005
Location: Pasadena, CA
Posts: 248
Drives: '12 C204 C250, '05 SLK350 (sold)
Send a message via AIM to slktyperice
Quote:
Originally Posted by mugennosora View Post
just so everyone know iphone or android can download an app called pdanet to enable DUN Bluetooth tethering
Can anyone confirm that pdanet will enable the MB internet? I got into the engineering menu but couldn't do anything.
slktyperice is offline   Reply With Quote
Old 01-06-2012, 12:04 AM   #12
Junior Member
 
Join Date: Apr 2011
Posts: 55
Drives: 2011 C350
they removed the line option on the new C because our camera is NOT centered...after many people complain those line are gone...

Quote:
Originally Posted by johnny--2k View Post
What i want to know is if there is a way to enable the lines in the backup camera like the new ML's have. I tried using the same camera mode as my moms ML, but when in reverse, it doesn't pull up anything, just stays on whatever screen you are in (ie audio, phone, nav, etc...) so that's a no go from what I can tell.
mugennosora is offline   Reply With Quote
Old 01-06-2012, 12:04 AM   #13
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,101
Drives: 2012 C250 Coupe
jctevere
Quote:
Originally Posted by jkyriakou View Post
Internet speed is dependent on your network speed. In saying that DUn is usually slower because of how it's routed. The MB apps however, weather, Facebook should work fine. (don't know why you need Facebook in your car but you could then technically "check in")

My rep has advised (and I have confirmed independently) that MB will be adding PAN support third quarter 2012.

Will most likely require a stealer upgrade but iPhone should then work.

James
Internet speed is not the speed cap for this setup. The issue with bluetooth DUN dial-up networking is that it does not have a very good throughput. Most tests show that PDANet tops out around 50KB/s (faster than edge, but only half as fast as even the worst 3G. So essentially - it is slow.

It would be great if PAN support is added. Comand updates are usually free under warranty (it is maps updates that cost money).

PDANet is a good solution for Androids. But kinda buggy/problematic. The BEST solution for iPhones is to get iBluever, which is specifically made for bluetooth DUN connection. However, you must jailbreak your phone. There is a demo version so that you can ensure it will work for our uses, but it costs money on the Cydia market.

Here is the link for more information:
http://www.if0rce.com/en/ibluever/

Its interesting that you say Mercedes is planning PAN support for third quarter, I will check with my sources at MBUSA to confirm this...

EDIT: Acutally, I think that iBluever only allows your iPad/iPod/iPhone to connect to an existing Bluetooth DUN connection (meaning recieve internet, not send). I am unsure if PDANet will allow you to share iPhone internet via bluetooth DUN.

I *think* that mac laptops support bluetooth DUN internet sharing. So perhaps if you tether your iPhone to your laptop, then have your laptop share to the comand system via bluetooth DUN, it should work - but is far from an ideal setup.
__________________

Last edited by jctevere; 01-06-2012 at 12:14 AM.
jctevere is offline   Reply With Quote
Old 01-06-2012, 12:59 AM   #14
Member
 
Join Date: Jan 2012
Location: Sydney, Australia
Posts: 95
Drives: C250 CDI coupe, Obsidian Black, Vision Pack, Drive Assist Plus pack, Comfort Pack, Rev Camera
jamesdatramp
jct

Please check with MBUSA and let us know. My sources mentioned that September 2012 is the likely release. Also expecting the "natural" speech for nav about that time for Oz. US should already have that language pack. (it basically means you dont have to spell every address to the nav)

In any case a quick google search also confirmed some of those details (ie telematics news website)

Thanks again

JK
jkyriakou is offline   Reply With Quote
Old 01-06-2012, 09:22 AM   #15
Junior Member
 
Join Date: Oct 2011
Posts: 60
Drives: C250 Coupe
OK. I got it. The engineering mode was a little tricky. I didn't notice the extra settings until I move downwards the menu (console **** nudge down) and there was like 10 pages of settings in the SW Settings and HW settings.

Anyway, I manage to bring out the globe (internet) and DVD Video. (See attached picture). I was not able to browse as it gave me an error "phone not support for data transfer" - or something like that. I guess need to use a phone that supports DUN (Dial Up Networking). Will let everyone know my test result when I get to borrow an E51 phone later.

As for the DVD, I manage to play a DVD disc but it has an error displayed on the screen. (See attached picture). Audio for Scene 1,2,3,4,5... was available. Only thing is picture is missing. Does anyone know for this NTG 4.5, do I need to install extra module in order to play the video on the screen?

Oh BTW, please note that every setting you change, you need to reboot the car!
Attached Thumbnails
How to turn on Internet in COMAND?-dvd-video-menu.jpg   How to turn on Internet in COMAND?-dvd-play.jpg  
mikengo is offline   Reply With Quote
Old 01-06-2012, 09:30 AM   #16
Junior Member
 
Join Date: Apr 2011
Posts: 55
Drives: 2011 C350
Quote:
Originally Posted by mikengo View Post
OK. I got it. The engineering mode was a little tricky. I didn't notice the extra settings until I move downwards the menu (console **** nudge down) and there was like 10 pages of settings in the SW Settings and HW settings.

Anyway, I manage to bring out the globe (internet) and DVD Video. (See attached picture). I was not able to browse as it gave me an error "phone not support for data transfer" - or something like that. I guess need to use a phone that supports DUN (Dial Up Networking). Will let everyone know my test result when I get to borrow an E51 phone later.

As for the DVD, I manage to play a DVD disc but it has an error displayed on the screen. (See attached picture). Audio for Scene 1,2,3,4,5... was available. Only thing is picture is missing. Does anyone know for this NTG 4.5, do I need to install extra module in order to play the video on the screen?

Oh BTW, please note that every setting you change, you need to reboot the car!

on my other cars, to watch dvd your car must be in Park, but not sure about this one.
mugennosora is offline   Reply With Quote
Old 01-06-2012, 11:14 AM   #17
Member
 
Jav_A's Avatar
 
Join Date: Oct 2011
Location: ON
Posts: 76
Drives: 2012 C250 coupe
Jav_A
Any c coupe owner in Canada able to bring out the globe icon? I haven't been able to do it
Jav_A is offline   Reply With Quote
Old 01-06-2012, 02:07 PM   #18
MBWorld Fanatic!
 
jctevere's Avatar
 
Join Date: Sep 2009
Location: Dix Hills, New York
Posts: 2,101
Drives: 2012 C250 Coupe
jctevere
As far as video, is the right region code set for the DVD's you use, also, what about PAL/NTSC, etc?

If they are, then perhaps you didn't have the parking brake on. Not only do cars require you to be in park, but most also require you to have the parking brake set (that third little foot pedal on the left). So give that a try and see what happens.
__________________
jctevere is offline   Reply With Quote
Old 01-08-2012, 02:46 PM   #19
Senior Member
 
johnny--2k's Avatar
 
Join Date: Jan 2003
Location: Dallas, TX
Posts: 319
Drives: 2009 C63
what are the settings for Sprint using PdaNet? I still get no connection with bluetooth dun enabled.
__________________
09 C63 | Eurocharged V5 Tune | Charcoal Delete | Matte Gunmetal Metallic Wrap
johnny--2k is offline   Reply With Quote
Old 01-08-2012, 10:30 PM   #20
Junior Member
 
Join Date: Oct 2011
Posts: 60
Drives: C250 Coupe
I did a "end call+#+*" to get back remaining 5 retries for DVD settings and perform some HU Parameter settings. As a result, the MEDIA INTERFACE was missing after reboot. I tried changing back to previous settings but it doesn't work. Still missing MEDIA INTERDACE. I can't connect my iPod now. Anyone has any idea?
mikengo is offline   Reply With Quote
Old 01-09-2012, 03:23 AM   #21
Member
 
Join Date: Jan 2012
Location: Sydney, Australia
Posts: 95
Drives: C250 CDI coupe, Obsidian Black, Vision Pack, Drive Assist Plus pack, Comfort Pack, Rev Camera
jamesdatramp
Yeah. You prob factory reset with that code.

You need to go back through the config menu (not he settings) and tell it that the hdd is installed and media interface is installed.
jkyriakou is offline   Reply With Quote
Old 01-09-2012, 09:10 AM   #22
Junior Member
 
Join Date: Oct 2011
Posts: 60
Drives: C250 Coupe
Quote:
Originally Posted by mikengo View Post
I did a "end call+#+*" to get back remaining 5 retries for DVD settings and perform some HU Parameter settings. As a result, the MEDIA INTERFACE was missing after reboot. I tried changing back to previous settings but it doesn't work. Still missing MEDIA INTERDACE. I can't connect my iPod now. Anyone has any idea?
Ok, I'm back on track. Found the culprit. Reset doesn't work.

My hands were itchy to set the TGW Parameters. If you come across missing MEDIA INTERFACE, make sure your UCI is set to installed. Picture will be posted soon
Attached Thumbnails
How to turn on Internet in COMAND?-photo-1.jpg   How to turn on Internet in COMAND?-photo-2.jpg   How to turn on Internet in COMAND?-photo-3.jpg  

Last edited by mikengo; 01-11-2012 at 02:25 AM. Reason: Pictures added
mikengo is offline   Reply With Quote
Old 03-08-2012, 11:29 AM   #23
Junior Member
 
woofwoofz's Avatar
 
Join Date: Mar 2009
Posts: 55
Drives: 2009 C300 4Matic Sport...2012 C350 4Matic
Quote:
Originally Posted by Jav_A View Post
Any c coupe owner in Canada able to bring out the globe icon? I haven't been able to do it
Jav_A, did you ever get a reply back? I am looking for the Globe icon too on the top left of the COMAND screen. It would nice to enable that.

DW
__________________
DW
woofwoofz is offline   Reply With Quote
Old 03-08-2012, 11:51 AM   #24
Member
 
Jav_A's Avatar
 
Join Date: Oct 2011
Location: ON
Posts: 76
Drives: 2012 C250 coupe
Jav_A
Nope..i asked the dealership and they told me some bs about not having the Sirius package. i dont buy that, but i havnt bothered with this since most ppl haven't been able to connect to the internet even after getting the globe.
Jav_A is offline   Reply With Quote
Old 08-03-2012, 02:57 AM   #25
MBWorld Fanatic!
 
Join Date: Nov 2011
Posts: 1,369
Drives: 2012 C63 Sedan Black with CF interior
so sorry to bump this im just really curious, where do i activate internet? I did mb services and browser but nothing came up on my globe menu
natman316 is offline   Reply With Quote
Old 08-03-2012, 02:57 AM
 
 
 
Reply

Tags
2012, 45, c250, comand, dun, enable, engineer, engineering, internet, mbusa, menu, mercedes, ntg, sluggish, system, turn



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off




All times are GMT -4. The time now is 05:48 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
Everyone's Personal Details