Notices
190E (W201) 1982-1993: 190E 2.3, 190E 2.6, 190E 2.3-16, 190E 2.5-16, 190 D 2.2, 190 D 2.5, 190 D 2.5 TURBO, 190E 2.5-16 Evolution I, 190E 2.5-16 Evolution II

Dead Car

 
Old 10-02-2005, 01:04 PM
  #1  
Newbie
Thread Starter
 
Join Date: Aug 2005
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Dead Car

I don't know if i'm in the right forum, but i have a 260E 1989 and i was driving one day and the car just died, i let it sit for a two days and still dead, i have no idea what it might be, does anyone have any idea what it might be, please i need help. any help will be greatly appreciated
hitop12 is offline  
Old 10-02-2005, 01:34 PM
  #2  
MTI
MBWorld Fanatic!
 
Join Date: Dec 2002
Location: Scottsdale, Arizonai
Posts: 2,719
Likes: 0
Received 0 Likes on 0 Posts
'85 190E 2.3-16 '99 C280 '11 GLK350
As "Miracle Max" might say . . ."there's a difference between mostly dead and completely dead."

1) What were the symptoms when it "died".

2) What are the symptoms now, when you try to start.

3) What diagnostic efforts have you made so far?

4) Mileage, date of most recent service, color of interior and what kind of music were you listening to when it expired.
MTI is offline  
Old 10-02-2005, 10:44 PM
  #3  
Newbie
Thread Starter
 
Join Date: Aug 2005
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
dead car

it just died on me driving at 30 mph and didn't crank over, it just cranks and thats it, nothing else...i think it might be a relay for the starter ir it just might be the starter. i don't know
hitop12 is offline  
Old 10-03-2005, 02:37 AM
  #4  
Senior Member
 
vas2vas's Avatar
 
Join Date: Mar 2003
Location: LI, New York
Posts: 298
Likes: 0
Received 0 Likes on 0 Posts
87 190E 2.6/1995 M3
Originally Posted by hitop12
it just died on me driving at 30 mph and didn't crank over, it just cranks and thats it, nothing else...i think it might be a relay for the starter ir it just might be the starter. i don't know
if it cranks is not the starter... if it just suddenly died, withought any previous symptoms (missfire, loss of power etc) then check fuel pump...
vas2vas is offline  
Old 10-05-2005, 10:19 AM
  #5  
Newbie
Thread Starter
 
Join Date: Aug 2005
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
dead car

i will thanks
hitop12 is offline  
Old 10-08-2005, 07:15 PM
  #6  
MBWorld Fanatic!
 
Join Date: Apr 2005
Location: Long Beach, Ca
Posts: 2,842
Likes: 0
Received 0 Likes on 0 Posts
lots of cars
PLEASE GO TO THE W124 FOR MORE INFO. It's your fuel pump relay that is bad. Turn on the ignition and see if you hear a noise from the rear right passanger tire. If you don't your fuel pumps are bad. Also move around the fuel pump relay and see if the car starts or make a noise. It's the one next to the one that says KLIMA
YNVDIZW124 is offline  
Old 10-11-2005, 02:17 AM
  #7  
Newbie
Thread Starter
 
Join Date: Aug 2005
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
dead car

thanks man
hitop12 is offline  
Old 11-04-2005, 10:12 PM
  #8  
Newbie
 
Join Date: Oct 2005
Location: Menlo Park, California
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
I drive a 1991 190e 2.3 and I also own a 2001 ML320
To give you better idea I need more info, but checking for fuel would be a start, you can also check for spark after doing those two check back and let know what happens. Check rotor and cap also.
PERUNICA is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Dead Car


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: