Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Instrument Cluster Display >

Instrument Cluster Display

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Instrument Cluster Display

 
Old 02-19-2008, 07:36 PM
  #1  
Member
Thread Starter
 
tmehanna's Avatar
 
Join Date: Jul 2007
Posts: 106
Likes: 0
Received 0 Likes on 0 Posts
Instrument Cluster Display

Is there anyway to make it stick to whatever mode it was on before you switch ignition off? Mine switches back from Audio to Trip. Very annoying.
tmehanna is offline  
Old 02-19-2008, 07:38 PM
  #2  
Super Member
 
PoaMike's Avatar
 
Join Date: Oct 2007
Posts: 552
Likes: 0
Received 0 Likes on 0 Posts
C300 (W204) w/ MM, P1, & 18"amg's
Um... I forgot but just to let you know yes there is a way. Someone else should know.
PoaMike is offline  
Old 02-19-2008, 08:04 PM
  #3  
MBWorld Fanatic!
 
tanktube67's Avatar
 
Join Date: Nov 2007
Location: SFV CA
Posts: 4,434
Likes: 0
Received 5 Likes on 5 Posts
2008 Black Out C350 Saks Edition / 87 VW GTI
Originally Posted by tmehanna View Post
Is there anyway to make it stick to whatever mode it was on before you switch ignition off? Mine switches back from Audio to Trip. Very annoying.
I wish, but I don't think so
tanktube67 is offline  
Old 02-19-2008, 08:33 PM
  #4  
Member
 
Kieffer's Avatar
 
Join Date: Sep 2007
Location: Colorado
Posts: 201
Likes: 0
Received 0 Likes on 0 Posts
2008 C350 Sport, 2007 ML320 CDI
I hope there is. Our ML bring up the display that was up when the vehicle was shut off (only a couple of displays are shut out - like water temp). I, too, would love to figure this out. I wonder if it's a dealer setting...
Kieffer is offline  
Old 02-19-2008, 08:38 PM
  #5  
Senior Member
 
syrAMG's Avatar
 
Join Date: Jan 2008
Location: New York City
Posts: 420
Likes: 0
Received 0 Likes on 0 Posts
W212 2011 E-350 4Matic
If you turn off your ignition at whatever your display was, it will appear at the same display at startup. at least that's how my car is
syrAMG is offline  
Old 02-20-2008, 12:20 AM
  #6  
Member
Thread Starter
 
tmehanna's Avatar
 
Join Date: Jul 2007
Posts: 106
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by syrAMG View Post
If you turn off your ignition at whatever your display was, it will appear at the same display at startup. at least that's how my car is
May be it's always on Trip when you switch off?
tmehanna is offline  
Old 02-20-2008, 12:30 AM
  #7  
Member
 
Join Date: Dec 2007
Location: Athens Greece
Posts: 121
Likes: 0
Received 0 Likes on 0 Posts
C200 AMG W204
Originally Posted by tmehanna View Post
May be it's always on Trip when you switch off?
that was a good one
CE EXO is offline  
Old 02-20-2008, 12:59 AM
  #8  
MBWorld Fanatic!
 
Savage c-300's Avatar
 
Join Date: Nov 2007
Location: Irvine, CA
Posts: 1,009
Received 1 Like on 1 Post
C300 Sport, MM, P1
Originally Posted by tmehanna View Post
May be it's always on Trip when you switch off?
good call....
Savage c-300 is offline  
Old 02-20-2008, 01:10 AM
  #9  
Member
 
JohnGjolaj1's Avatar
 
Join Date: Nov 2007
Location: NY
Posts: 137
Likes: 0
Received 0 Likes on 0 Posts
88 560sl, 08 c350
whats the big deal? just push the button 3 times to the right and theres your audio. how hard is that?
JohnGjolaj1 is offline  
Old 02-20-2008, 08:26 AM
  #10  
MBWorld Fanatic!
 
tanktube67's Avatar
 
Join Date: Nov 2007
Location: SFV CA
Posts: 4,434
Likes: 0
Received 5 Likes on 5 Posts
2008 Black Out C350 Saks Edition / 87 VW GTI
Originally Posted by tmehanna View Post
May be it's always on Trip when you switch off?
tanktube67 is offline  
Old 02-20-2008, 10:15 AM
  #11  
MBWorld Fanatic!
 
Join Date: Jul 2007
Location: San Antonio
Posts: 1,104
Likes: 0
Received 0 Likes on 0 Posts
2008 C350
Originally Posted by tmehanna View Post
May be it's always on Trip when you switch off?
MBTex is offline  
Old 02-20-2008, 02:07 PM
  #12  
Super Member
 
delirium's Avatar
 
Join Date: Jul 2007
Location: Orange County, Ca
Posts: 634
Received 3 Likes on 3 Posts
C350
regardless of what mine is on when i turn the car off, it always starts on the trip.
delirium is offline  
Old 02-20-2008, 03:15 PM
  #13  
Senior Member
 
misterng's Avatar
 
Join Date: Jun 2007
Location: Bay Area
Posts: 253
Likes: 0
Received 0 Likes on 0 Posts
2008 W204
Originally Posted by tmehanna View Post
May be it's always on Trip when you switch off?
misterng is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Instrument Cluster Display


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: