Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
About Faulty message 'check tail n brake lamp' >

About Faulty message 'check tail n brake lamp'

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

About Faulty message 'check tail n brake lamp'

 
Old 04-16-2010, 02:04 PM
  #1  
Member
Thread Starter
 
Join Date: Oct 2008
Location: La Habra, CA (OC)
Posts: 174
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport LOADED
About Faulty message 'check tail n brake lamp'

I don't know why but my car throws me faulty error sign.
It says 'check left tail and brake lamp' even thogh there is nothing wrong with left lamp.
How do I get rid of that message? I get it everytime I turn on the ignition.
Is this fuse issue?
I have no idea, do you have any idea?
wanchu83 is offline  
Old 04-16-2010, 03:22 PM
  #2  
Super Member
 
Join Date: Mar 2009
Location: Calgary, AB
Posts: 567
Likes: 0
Received 0 Likes on 0 Posts
2012 C63 AMG
Did you change any bulbs in the back? Something has to be burnt out, the error sign only comes up when it doesn't register any resistance from a bulb.
Illusive is offline  
Old 04-16-2010, 06:25 PM
  #3  
Junior Member
 
Join Date: Dec 2007
Location: Toronto, Ontario
Posts: 63
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport 6-spd
I also get that message periodically, and there is nothing wrong with any of my rear bulbs. To get rid of the message, simply press the "OK" button on the steering wheel.
earlybird is offline  
Old 04-17-2010, 04:09 AM
  #4  
Junior Member
 
Join Date: Jun 2003
Posts: 24
Likes: 0
Received 0 Likes on 0 Posts
C300
I used to get that message, if you have p2 with the LED tail lights you actually have an LED burnt out, just take it to the dealer and have them replace the bulb and you are good to go. I never got the message again.
nikemykee is offline  
Old 04-17-2010, 05:24 PM
  #5  
Member
 
Join Date: Feb 2003
Location: Toronto
Posts: 238
Received 8 Likes on 8 Posts
2009 e class 2012 ml350
check the plug thats connected to both your tail lights.
I`ve seen a few that got melted.


Originally Posted by wanchu83 View Post
I don't know why but my car throws me faulty error sign.
It says 'check left tail and brake lamp' even thogh there is nothing wrong with left lamp.
How do I get rid of that message? I get it everytime I turn on the ignition.
Is this fuse issue?
I have no idea, do you have any idea?
f4i 954 is offline  
Old 04-18-2010, 01:20 PM
  #6  
Senior Member
 
Join Date: Sep 2009
Location: Chicagoland
Posts: 361
Likes: 0
Received 1 Like on 1 Post
2008 ML350 4matic
Sounds goofy, but check the left side bulb that has the "rear fog light" element in it. Could be just that bulb and you cant see it due to not illuminating that one specifically when you check them out...
Benzo 003 is offline  
Old 04-18-2010, 03:14 PM
  #7  
Member
Thread Starter
 
Join Date: Oct 2008
Location: La Habra, CA (OC)
Posts: 174
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport LOADED
I do have led tail light, it might be just one or two led bulb burned.I will take it to the dealer next week to see If I can fix this.
wanchu83 is offline  
Old 11-12-2010, 03:09 PM
  #8  
Junior Member
 
Join Date: Dec 2007
Location: Toronto, Ontario
Posts: 63
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport 6-spd
I recently started getting the "check tail and brake lamp" message on a regular basis.......almost daily. So, I removed the housing that holds the bulbs and noticed that the tail/brake lamps were flickering when the engine was running.

I took the car to the dealership, and they mentioned that it is a known problem that the wiring harness is faulty in some vehicles. I now have an appointment to bring in the car to get the rear wiring harness replaced. The job should should take about 1/2 day.
earlybird is offline  
Old 11-12-2010, 03:37 PM
  #9  
MBWorld Fanatic!
 
hitokiri89's Avatar
 
Join Date: Aug 2010
Location: New York
Posts: 1,018
Likes: 0
Received 0 Likes on 0 Posts
2010 c350
Put your rear fig lights on ut might be burned out .
hitokiri89 is offline  
Old 11-12-2010, 03:40 PM
  #10  
RLE
MBWorld Fanatic!
 
RLE's Avatar
 
Join Date: Feb 2004
Location: SEATTLE WASHINGTON USA
Posts: 3,986
Likes: 0
Received 0 Likes on 0 Posts
'08 C300 Lux Barolo Red Beige Leather P2 MM 18" wheels '84 944
Bulb out functions

Originally Posted by Benzo 003 View Post
Sounds goofy, but check the left side bulb that has the "rear fog light" element in it. Could be just that bulb and you cant see it due to not illuminating that one specifically when you check them out...
Is goofy. The left upper taillight filament and fog filament are one and the same. The taillight operates at a reduced voltage except when the rear fog is selected and then is at battery voltage, thus fully bright.
RLE is offline  
Old 11-12-2010, 03:47 PM
  #11  
RLE
MBWorld Fanatic!
 
RLE's Avatar
 
Join Date: Feb 2004
Location: SEATTLE WASHINGTON USA
Posts: 3,986
Likes: 0
Received 0 Likes on 0 Posts
'08 C300 Lux Barolo Red Beige Leather P2 MM 18" wheels '84 944
LEDs if out...

Originally Posted by nikemykee View Post
I used to get that message, if you have p2 with the LED tail lights you actually have an LED burnt out, just take it to the dealer and have them replace the bulb and you are good to go. I never got the message again.
You are saying that just one LED out (out of seventeen) will turn on the lamp out warning?

LED's are not replaceable one by one so the entire lamp assembly must be replaced.
RLE is offline  
Old 11-12-2010, 06:05 PM
  #12  
Senior Member
 
Join Date: Feb 2008
Location: Toronto
Posts: 300
Received 2 Likes on 2 Posts
2008 c300
Originally Posted by wanchu83 View Post
I don't know why but my car throws me faulty error sign.
It says 'check left tail and brake lamp' even thogh there is nothing wrong with left lamp.
How do I get rid of that message? I get it everytime I turn on the ignition.
Is this fuse issue?
I have no idea, do you have any idea?

Check the right tail lamps. When I got that message (both side in a month) it was the opposite lamp that was out. Guess it depends upon how you view "left and right"
keith100 is offline  
Old 11-12-2010, 06:08 PM
  #13  
Junior Member
 
Join Date: Dec 2007
Location: Toronto, Ontario
Posts: 63
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport 6-spd
Originally Posted by hitokiri89 View Post
Put your rear fig lights on ut might be burned out .
There is no rear fog light on the right side of the car. (the warning message reads "check right tail and brake lamp").

The dealership has the problem under control and it will be fixed soon.

Anyway, thanks for your input.
earlybird is offline  
Old 11-28-2010, 05:32 PM
  #14  
Junior Member
 
Join Date: Dec 2007
Location: Toronto, Ontario
Posts: 63
Likes: 0
Received 0 Likes on 0 Posts
C300 Sport 6-spd
Just an update..... The tail lights warning message has now been resolved.

The dealer replaced the wiring harness for the rear tail lamps, and the L/S tail lamp bulb holder.
earlybird is offline  
Old 02-15-2011, 06:08 PM
  #15  
Senior Member
 
itcrashed's Avatar
 
Join Date: Oct 2005
Location: East Bay, CA
Posts: 387
Likes: 0
Received 0 Likes on 0 Posts
MB w204 C300 Sport, Audi B7 A4 2.0TQ, Porsche Cayman 981
I know this is an older thread, but I just wanted to share that I had the same exact problem on my right rear tail light harness.

I get a warning that my right rear tail light bulb is out - but it really isn't.
When I went to inspect the bulbs, I noticed the electrical harness was melted into the light bulb panel.

Spoke to my SA and he said that he's seen quite a few 2008s with P2 that exhibited this problem.

They replaced everything under warranty...but I wonder if the problem will creep up again over time. Seems like a poorly designed harness or poorly designed LED control board.
itcrashed is offline  
Old 06-02-2011, 12:34 AM
  #16  
Member
 
Join Date: May 2011
Location: Jersey
Posts: 134
Likes: 0
Received 1 Like on 1 Post
2008 C300 w204
Dammit just happened to me, looks like I'll be takin a trip to the dealer! Smh.......she's only a few weeks old (to me)
Dark Kent is offline  
Old 06-02-2011, 06:56 AM
  #17  
MBWorld Fanatic!
 
AkaSigFreak's Avatar
 
Join Date: Dec 2007
Location: Orlando, Florida
Posts: 3,058
Received 40 Likes on 36 Posts
E350 Sport/ML350RWD
It happened to me about two weeks ago. The SA said he was replacing bulbs and it would take a few minutes. When I came back- three employees were standing at my trunk. They "fixed it", but I don't think they replaced a harness. Since I'm getting close to warranty end, maybe I should take it back.
AkaSigFreak is offline  
Old 07-09-2011, 07:54 PM
  #18  
Junior Member
 
Join Date: May 2008
Location: Alexandria, VA
Posts: 47
Received 2 Likes on 2 Posts
'17 C300 Sport, P2, Pano, Black; '17 Jetta GLI White
Damn. I'm out of warranty and just got this message too. All my lights are lit as well. Wonder what this will set me back
purefunk is offline  
Old 07-09-2011, 09:27 PM
  #19  
Member
 
Join Date: May 2011
Location: Jersey
Posts: 134
Likes: 0
Received 1 Like on 1 Post
2008 C300 w204
My lights were lit as well. I just got mine fixed they told me it was the circuit board. I'm not aware of the price bcuz luckily I'm still under warranty until november
Dark Kent is offline  
Old 07-10-2011, 03:16 AM
  #20  
Junior Member
 
Join Date: May 2009
Location: Chester Springs, PA, USA
Posts: 71
Likes: 0
Received 0 Likes on 0 Posts
Mercedes Benz C300 Sport 4Matic
Thank God, with less than 200 miles left on my car, I got two brake light bulbs replaced without costing me a dime.
redfox302 is offline  
Old 07-10-2011, 02:53 PM
  #21  
Member
 
Join Date: Feb 2011
Posts: 85
Received 0 Likes on 0 Posts
2015 Mase Ghibli SQ4. 2013 Range Rover Supercharged
i got the same message b4. i checked n NOTHING wrong w the lamps. few days later, I checked again n the break lamp on the RIGHT side was dead.... but error say "on LEFT"???
Anh1 is offline  
Old 07-10-2011, 03:09 PM
  #22  
Member
 
Join Date: Sep 2009
Posts: 132
Likes: 0
Received 0 Likes on 0 Posts
2006 C230 6spd > C300 4Matic
I just had this happen to me, according to my mechanic. The car alerts you before the bulb actually goes out. The lights worked fine but when we pulled them out the bottoms looked burnt out. It's just an alert to let you know to change em, they don't necessarily have to be out.
IllusionX is offline  
Old 11-10-2011, 01:05 PM
  #23  
MBWorld Fanatic!
 
604 C63's Avatar
 
Join Date: Aug 2011
Posts: 2,738
Received 354 Likes on 247 Posts
2012 P31 Sedan w/LSD
Predictive warning lights that sense when failure will occur soon?

That guy has a case of "gonnahidemylackofknowlegewithbull****-itis". Although.....if its true.....MB just got a big leg up in the hotly contested tail light bulb sales race and all that costly R&D is about to pay off.

Same damn problem here.
604 C63 is offline  
Old 11-10-2011, 01:28 PM
  #24  
Super Member
 
Join Date: Mar 2011
Location: NNJ
Posts: 957
Likes: 0
Received 0 Likes on 0 Posts
'11 C350 '13 F150 lariat
as posted its not pre-emptive, its actually the cars system sensing resistance in the circuit that is not within the programmed range. I too had the problem on my 08 and it was the actual wiring harness at the bulb socket that was starting to melt. Its a know problem at every dealership. If your getting the message u can best beleive that one of your bulbs or harnesses or sockets is burnt, melted, or starting to go out
jimmythegreek is offline  
Old 11-10-2011, 02:27 PM
  #25  
MBWorld Fanatic!
 
Petje's Avatar
 
Join Date: Apr 2008
Location: The Netherlands - ROTTERDAM
Posts: 1,123
Likes: 0
Received 2 Likes on 2 Posts
W205 C400
Had the same with my 08 W204, also my Socket was melted. Well known problem!!
Petje is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: About Faulty message 'check tail n brake lamp'


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: