Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Installing RearView Camera on 2012 C Class >

Installing RearView Camera on 2012 C Class

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Installing RearView Camera on 2012 C Class

 
Old 06-09-2015, 04:48 PM
  #101  
Newbie
 
Join Date: Jun 2015
Posts: 14
Likes: 0
Liked 0 Times in 0 Posts
Mercedes C-Class W204 Restyle
But where is number 71 fuse?

Originally Posted by chrisdean View Post
Fuse 71 is in the rear fuse box by the right hand wheel arch in the trunk.
Look - this is how it looks like (of course i know where the fuse box situated, but thank you anyway)




But where is this 71 located?
dv1977 is offline  
Old 06-09-2015, 08:36 PM
  #102  
Member
 
Join Date: Jun 2013
Location: San Antonio, TX
Posts: 229
Likes: 0
Liked 3 Times in 3 Posts
2012 C250 Sport Sedan
Originally Posted by dv1977 View Post
Look - this is how it looks like (of course i know where the fuse box situated, but thank you anyway)

But where is this 71 located?
At the risk of sounding like a smart a** it is labeled "71". I just went out and looked to verify that it's labeled. I would've taken a picture but it's covered with tape since the latch doesn't close because the add a fuse is too big and I don't want to mess with it.

Here's a picture of my add a fuse during install for reference. Hope it helps.
lemonstand is offline  
Old 06-10-2015, 04:16 AM
  #103  
Newbie
 
Join Date: Jun 2015
Posts: 14
Likes: 0
Liked 0 Times in 0 Posts
Mercedes C-Class W204 Restyle
Originally Posted by lemonstand View Post
At the risk of sounding like a smart a** it is labeled "71". I just went out and looked to verify that it's labeled. I would've taken a picture but it's covered with tape since the latch doesn't close because the add a fuse is too big and I don't want to mess with it.

Here's a picture of my add a fuse during install for reference. Hope it helps.
Ooopps! Smartass detected! Just kidding! :-)
Thank you, that was completely my mistake - I've just realized it has some marks on the fuse box!
Also I want to ask you again: do you know something about parking lines? How can I activate them?
And, by the way - after reading an incredible amount of information I've understood: I have to connect +12 AC to #71 fuse and also connect the activating wire to reverse light lamp - because I checked and that won't work separately from each other - only when both wires are connected the cam starts to picture!
Am I wright?
dv1977 is offline  
Old 06-10-2015, 10:43 AM
  #104  
Member
 
Join Date: Apr 2014
Posts: 177
Likes: 0
Liked 2 Times in 2 Posts
W205 C200 AMG Line Premium
Originally Posted by dv1977 View Post
Ooopps! Smartass detected! Just kidding! :-)
Thank you, that was completely my mistake - I've just realized it has some marks on the fuse box!
Also I want to ask you again: do you know something about parking lines? How can I activate them?
And, by the way - after reading an incredible amount of information I've understood: I have to connect +12 AC to #71 fuse and also connect the activating wire to reverse light lamp - because I checked and that won't work separately from each other - only when both wires are connected the cam starts to picture!
Am I wright?
Don't go near the reversing light. The camera is first activated in the engineering menu and finally in the basic user settings menu on the head unit.
chrisdean is offline  
Old 06-10-2015, 02:20 PM
  #105  
Newbie
 
Join Date: Jun 2015
Posts: 14
Likes: 0
Liked 0 Times in 0 Posts
Mercedes C-Class W204 Restyle
Originally Posted by chrisdean View Post
Don't go near the reversing light. The camera is first activated in the engineering menu and finally in the basic user settings menu on the head unit.
Thanks, I know it. It sounds like a spelling - "don't, don't you go near reverse light, this place is cursed"!
But thanks anyway!
dv1977 is offline  
Old 08-04-2015, 01:32 PM
  #106  
Junior Member
 
Join Date: Jul 2015
Posts: 22
Likes: 0
Liked 0 Times in 0 Posts
my11 c250 cdi avantgarde
2011 c250 cdi avantgarde w204


once all the cabling is done, will the camera have these reference lines or will it have only the view and no grids or references ?

Installing RearView Camera on 2012 C Class-2011-mercedes-ml350-3.jpg

edit: just found out gridlines are switched on and off via the engineering mode menu...

Last edited by andreb; 08-04-2015 at 01:57 PM.
andreb is offline  
Old 08-05-2015, 01:23 AM
  #107  
Junior Member
 
Join Date: Jul 2015
Posts: 22
Likes: 0
Liked 0 Times in 0 Posts
my11 c250 cdi avantgarde
has anyone successfully installed diy? and do you require the multimedia module around $400

w204 2011 c250 wagon

http://www.emeraldintegrations.com/m...ra-system.html
andreb is offline  
Old 09-28-2015, 11:16 AM
  #108  
Newbie
 
Join Date: Oct 2014
Location: Dallas TX
Posts: 10
Likes: 0
Liked 0 Times in 0 Posts
2016 S550, 2014 C250
Been going though this DIY and there is a bunch of good info. I have a 2014 C250 with the Nav in the glovebox (Becker unit). Does that mean I don't have COMAND? Is there any way to do a camera retrofit if I don't have that? It does have bluetooth phone/audio with the control dial on the console.
ReturnZero is offline  
Old 09-29-2015, 10:39 AM
  #109  
Super Member
 
Join Date: Aug 2011
Location: Philly area
Posts: 838
Likes: 0
Liked 25 Times in 24 Posts
350 GLK, C280
DV1977, to answer your question about using the reverse light power, you need to understand that all the lights in the car are operated off the computer. There are no relays or power switches as in old vehicles. The computer pulses signals in a manner that it can tell if the lamp is blown and can actually be switching the ground side depending on which lamp. For example, you cannot go into the overhead lamp in the interior to get power for a radar detector or windshield camera. You must pull power from a DC supply such as a cigar lighter or directly from the fuse box. Trying to pull power from a light source will not only not work correctly, it can also damage the output SCR's in the computer.
The MOST optical connection loop tells the NAV screen when the car is in reverse and to turn on the reverse camera input, so rear view cameras don't need to be connected to anything but switched power, ground and video. If the camera has an extra lead to switch on for use in older vehicles, that lead should be connected to the same place as the power lead.
bop11 is offline  
Old 01-12-2016, 02:50 AM
  #110  
Newbie
 
Join Date: Jan 2016
Posts: 2
Likes: 0
Liked 0 Times in 0 Posts
C204, W204
Hello,

first of all thank you for such good guidance for installing the rear view camera.
I just have some additional question regarding the pinning of the camera.
Iím using an original MB rear view camera and it has 4 Pins.

Pin1 : Shielded cable --> Video Signal

Pin2 : White cable --> Activation line ?

Pin3 : Black cable --> Ground

Pin4 : Red cable --> Power Supply

As I understood the power supply and the activation line ( Pin4 + Pin2 ) should be connected to +12V via the Fuse 71 in the fuse box.

Is this correct ?

But in this case the camera would be always be powered on and only when entering the reverse gear the HMI will switch to the rear view camera display and show the camera picture.

Or is there some other possibility ?

Thank you for your help.

BR,
Novi
botswana23 is offline  
Old 01-12-2016, 08:46 AM
  #111  
Member
 
Join Date: Jun 2013
Location: San Antonio, TX
Posts: 229
Likes: 0
Liked 3 Times in 3 Posts
2012 C250 Sport Sedan
Originally Posted by botswana23 View Post
Hello,

first of all thank you for such good guidance for installing the rear view camera.
I just have some additional question regarding the pinning of the camera.
Iím using an original MB rear view camera and it has 4 Pins.

Pin1 : Shielded cable --> Video Signal

Pin2 : White cable --> Activation line ?

Pin3 : Black cable --> Ground

Pin4 : Red cable --> Power Supply

As I understood the power supply and the activation line ( Pin4 + Pin2 ) should be connected to +12V via the Fuse 71 in the fuse box.

Is this correct ?

But in this case the camera would be always be powered on and only when entering the reverse gear the HMI will switch to the rear view camera display and show the camera picture.

Or is there some other possibility ?

Thank you for your help.

BR,
Novi
I cannot speak to how the factory camera should be installed but from a general DIY installation the power does come from fuse #71. And yes the camera will be "on" all the time but it's a non issue since it doesn't consume allot of power. I've had my camera in my car going on 2 years with this set up.


Oh and don't tap into the reverse light for power. They're too many issues with flickering screens when you do this. Good luck.
lemonstand is offline  
Old 01-12-2016, 08:52 AM
  #112  
Newbie
 
Join Date: Jan 2016
Posts: 2
Likes: 0
Liked 0 Times in 0 Posts
C204, W204
Ok thanks.

I will try and report later if I could make it running

BR,
Novi
botswana23 is offline  
Old 02-28-2016, 06:47 AM
  #113  
Newbie
 
Join Date: Feb 2016
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
2013 C300 4Matic
Great posts in here and very informative.

Can someone please tell me how to thread the Video Cable from the back to the front.

Thank again, and appreciate any input.
Clive Shum is offline  
Old 02-28-2016, 07:10 AM
  #114  
Member
 
yacoub.alyacoub's Avatar
 
Join Date: Aug 2013
Location: Qatar/ non US
Posts: 78
Liked 0 Times in 0 Posts
2012 C200 CGI AMG Sport,2011 SLK 200 Komprs R171 2000 Toyota Land Cruiser GXR, 2007 Jeep Wrangler JK
Originally Posted by Clive Shum View Post
Great posts in here and very informative.

Can someone please tell me how to thread the Video Cable from the back to the front.

Thank again, and appreciate any input.
I Used the Orignal OEM retro fit for the reverse camera

and the cable wend from the module "installed in the rear seat wo the SAM module in the right side of the trunk, then under the rear seats on the left side under the door sills of the driver and the rear left, the under the lower panel below the steering wheel and then to the command from behind.

I Will also try to copy and upload the installation manual for it it was almost straight forward work took me about 5 hours including the front headlights as I was doing it all together the only problem I'm facing currently that everything is perfect it just didn't work.

I have to send it to the dealer to add the code "218" using VeDoc.

I checked it using the star diagnosis everything is fine except this code is needed for the cm to work and the dealer is telling me it's a 5 hours job and it will cost around $550 which is too expensive in my point of view for just adding a code to the car
yacoub.alyacoub is offline  
Old 02-28-2016, 07:11 AM
  #115  
Member
 
yacoub.alyacoub's Avatar
 
Join Date: Aug 2013
Location: Qatar/ non US
Posts: 78
Liked 0 Times in 0 Posts
2012 C200 CGI AMG Sport,2011 SLK 200 Komprs R171 2000 Toyota Land Cruiser GXR, 2007 Jeep Wrangler JK
https://www.commandonline.co.uk/W204...amera-kit.html

this was the kit I bought from command online
yacoub.alyacoub is offline  
Old 04-07-2017, 11:56 AM
  #116  
Newbie
 
Join Date: Apr 2017
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
MB C200 - 2012
Thumbs up MB C200-2012 Rear cam Instaled

Hi all,
I just instal my rear cam on MB C200-2012, head Panel NTG4.5.
Thanks all of you for very helpful guides - it WORKS.
Hi dv1977 just plug to the LEFT green conecction and it works.
Attached Thumbnails Installing RearView Camera on 2012 C Class-20170407_114426.jpg  
Biso is offline  
Old 12-26-2018, 08:04 PM
  #117  
Newbie
 
Join Date: Dec 2018
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
2011 C-350
Hello guys, I have a 2011 C-350 coupe and seens it is the same as 2012. I bougth a rear view camera as the picture at eBay. I just install the camera and the conector to main unit into green conector (see picture) the problem is that I canít see any image in the main screen. Can you help me if i need an interface? Adapter? Or fuse?





Raulnoriegape is offline  
Old 01-06-2019, 09:24 PM
  #118  
Senior Member
 
TheRulesLawyer's Avatar
 
Join Date: Mar 2014
Posts: 378
Liked 2 Times in 1 Post
C350
Did you set the camera on in the engineering menu? If so I'd intercept the video feed where its still composite connection (RCA) and feed it to a TV or something just to verify the camera is producing a signal as installed.
TheRulesLawyer is offline  
Old 01-19-2019, 07:12 PM
  #119  
Junior Member
 
IloveC300's Avatar
 
Join Date: Jan 2014
Location: Seattle, WA
Posts: 43
Likes: 0
Liked 0 Times in 0 Posts
2012 C300 4Matic
The camera i bought has a small red wire coming out from RCA (yellow) connector which goes into the fakra cable. Do i have to connect this red wire to the power for the camera to work? this is at the end where it connects to fakra to COMAND. There is already red and black wire at the end where it connects to camera and i have connected those to fuse 71 and ground. I have connected everything but the video doesnt come so not sure if this red wire needs to be connected to power source. any help would be appreciated.
thanks
IloveC300 is offline  
Old 01-19-2019, 07:16 PM
  #120  
Junior Member
 
IloveC300's Avatar
 
Join Date: Jan 2014
Location: Seattle, WA
Posts: 43
Likes: 0
Liked 0 Times in 0 Posts
2012 C300 4Matic
I'm unable to upload the picture.

Last edited by IloveC300; 01-19-2019 at 07:27 PM. Reason: attaching pciture
IloveC300 is offline  
Old 01-19-2019, 10:30 PM
  #121  
Senior Member
 
TheRulesLawyer's Avatar
 
Join Date: Mar 2014
Posts: 378
Liked 2 Times in 1 Post
C350
I'm not sure what wire you are talking about, but it does need power. I have mine hooked into the panel by make brake lights on the right side. Test it with a tv or something to verify you're sending a signal.
TheRulesLawyer is offline  
Old 02-21-2019, 12:17 PM
  #122  
Newbie
 
Join Date: Feb 2019
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
w212
help needed, I know this is for c class, but I cant find similar post for e class.
I have e class w212 2011 tried to retrofit RR camera and on my head unit I have only one double green fakra connector 1 slot free, but everyone one else seems like having double and another one just above for reveverse camera.
My question is can I use that free fakra and connect camera to it? Will it work then I put my car into Reverse?

Sorry for my bad English, this is not my primary language.
edma is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Installing RearView Camera on 2012 C Class


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: