Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Rear light issues

 
Old 03-19-2015, 12:34 PM
  #1  
Member
Thread Starter
 
Join Date: Oct 2008
Location: London, U.K.
Posts: 222
Received 1 Like on 1 Post
MB C220 Sport W204, 18" AMGs, Grey lthr, xenons, p'ktronic, HKardon, Comand nav.
Rear light issues

I have a 2009 model W204 Sport with OEM LED rear turn signals / with the remainder of the taillamps being conventional. The offside (US nearside) one has been acting strangely in the last few days. The red taillamps are very dim on that side compared with the other and the lower red lights are barely visible. Occasionally I get error messages telling me the turn signals on that side are out yet they still operate. What they do do is flash alternately with one of the top red taillamps! Also have been getting other random error messages on "reverse lamps out", "taillamp out" but nothing steady or predictable. The lights also seem to flicker. Is this an earth problem or the dreaded meltdown that so many seem to have had? Can't see any evidence of this with mine. Or is it a SAM problem or lamp cluster issue? Comments welcome. Thanks.

Last edited by NewtwoMB; 03-19-2015 at 12:35 PM. Reason: Change to text
NewtwoMB is offline  
Old 03-19-2015, 01:28 PM
  #2  
Doa
Super Member
 
Join Date: Apr 2013
Location: Belgium
Posts: 814
Received 17 Likes on 16 Posts
W205
my guess is the mass cable that melted
Doa is offline  
Old 03-20-2015, 11:15 AM
  #3  
Member
Thread Starter
 
Join Date: Oct 2008
Location: London, U.K.
Posts: 222
Received 1 Like on 1 Post
MB C220 Sport W204, 18" AMGs, Grey lthr, xenons, p'ktronic, HKardon, Comand nav.
Rear light issues

Thanks DOA, but how do I confirm that? I cannot see any evidence of melted or damaged wiring. Would it be near the tail lamp area or somewhere else.

Thanks in advance.
NewtwoMB is offline  
Old 03-20-2015, 11:24 AM
  #4  
Doa
Super Member
 
Join Date: Apr 2013
Location: Belgium
Posts: 814
Received 17 Likes on 16 Posts
W205
normally the black connector should have some damage where the mass pin/cable is but i've known some cars where the mass cable melted at the mass side and not in the black connector
Doa is offline  
Old 03-20-2015, 11:33 AM
  #5  
Member
Thread Starter
 
Join Date: Oct 2008
Location: London, U.K.
Posts: 222
Received 1 Like on 1 Post
MB C220 Sport W204, 18" AMGs, Grey lthr, xenons, p'ktronic, HKardon, Comand nav.
Thumbs up

OK, I think I get your meaning. You're referring to the black connector that's clipped into the rear lamp cluster, yes?
NewtwoMB is offline  
Old 03-20-2015, 04:14 PM
  #6  
Newbie
 
Join Date: Dec 2014
Location: Watford uk
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
c class
I had the same problem up until last week. The drivers side rear light was dim. If you leave the car running and check the light, you should hear a faint electrical buzzing from the actually black connector. It's the brown earth wire! It's under amp'd. It's a 5 amp wire with 10+ running through it. The black connector should be slightly or totally melted. I repaired mine myself and I have little mechanical knowledge. Took roughly an hour. Need any help give me a shout
Togie30440 is offline  
Old 03-20-2015, 05:08 PM
  #7  
Senior Member
 
vipsa's Avatar
 
Join Date: Jan 2013
Location: Berkley, MI
Posts: 344
Likes: 0
Received 1 Like on 1 Post
'09 C350
There's a recall for that issue in the US. I would guess there would be one in the UK as well.
I had mine done last month.
vipsa is offline  
Old 03-20-2015, 09:19 PM
  #8  
Junior Member
 
Join Date: Apr 2007
Posts: 21
Likes: 0
Received 1 Like on 1 Post
2008 c300 6-speed
yea..i just got the recall letter for the issue a couple months ago ( in the US ). I noticed the same tail lights issue and I went ahead and fixed it before the recall letter was delivered. If you have the issue, you will see the tail light connector showing burn marks. I fixed it by tapping the connector wire directly to the other side on the tail lamp. I don't know if they dealership will still grant me the recall. I will try to have it replaced next time I bring in my car for the service.
gary_youngster is offline  
Old 03-22-2015, 07:53 AM
  #9  
Member
Thread Starter
 
Join Date: Oct 2008
Location: London, U.K.
Posts: 222
Received 1 Like on 1 Post
MB C220 Sport W204, 18" AMGs, Grey lthr, xenons, p'ktronic, HKardon, Comand nav.
No evidence of burn marks on connector or anywhere nearby. and no recall notice on the issue - I asked the local dealer who services my car once per year. Had the car from new - no issues till now.
NewtwoMB is offline  
Old 03-31-2015, 08:21 AM
  #10  
Member
Thread Starter
 
Join Date: Oct 2008
Location: London, U.K.
Posts: 222
Received 1 Like on 1 Post
MB C220 Sport W204, 18" AMGs, Grey lthr, xenons, p'ktronic, HKardon, Comand nav.
Rear light issues - fixed!

Took it to the dealer for diagnosis on their computer. Fortunately not a SAM issue. Parts replaced were:

Bulb socket panel right rear light unit MA 204 820 16 00
Electrical plug for above MA 211 545 03 28
Contact pins 081585 (7) for socket panel MA 013 545 16 26
Repair electrical cable line

Low cost parts but labour costs are a PITA .

All works fine now so very happy.
NewtwoMB is offline  
Old 03-31-2015, 10:58 AM
  #11  
Senior Member
 
vipsa's Avatar
 
Join Date: Jan 2013
Location: Berkley, MI
Posts: 344
Likes: 0
Received 1 Like on 1 Post
'09 C350
I'm very surprised that there was not a recall for that exact issue in EU. It does indeed seem to be only in North America.http://www.mbca.org/forum/2014-04-30...aillight-issue
Maybe give a call to MB EU and see if they would maybe reimburse you at least partially.
Just curious, where was your car made?
vipsa is offline  
Old 03-31-2015, 12:06 PM
  #12  
Member
Thread Starter
 
Join Date: Oct 2008
Location: London, U.K.
Posts: 222
Received 1 Like on 1 Post
MB C220 Sport W204, 18" AMGs, Grey lthr, xenons, p'ktronic, HKardon, Comand nav.
There is no warranty recall for this issue according to Mercedes-Benz (UK) Ltd and also, according to the dealer, none from Germany, they checked through the whole system for me (fortunately have a good relationship with dealer who've looked after it from day 1).

The car was built in Germany, Bremen I think.

Last edited by NewtwoMB; 03-31-2015 at 12:09 PM.
NewtwoMB is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Rear light issues


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: