Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Have you guys ever seen this??? >

Have you guys ever seen this???

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Have you guys ever seen this???

 
Old 09-14-2015, 10:28 AM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
Exclamation Have you guys ever seen this???

Ok, there are some problem on my car, but I don't know much about cars.
Have any one of you seen this problem?
The abs, esp, engine light, srs were all on in one time! I couldn't even drive!
After start it for serval times, all the other light were off but the engine light was still on. I have no idea what's going on. It has no problems when I drove it everyday; however, if I stop driving it for even just one day, problems come out.
Guys please help me out, :/
Thank you so much.
Attached Thumbnails Have you guys ever seen this???-image.jpg  
chorkiu is offline  
Old 09-14-2015, 10:37 AM
  #2  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
The SRS
Attached Thumbnails Have you guys ever seen this???-image.jpg  
chorkiu is offline  
Old 09-14-2015, 10:38 AM
  #3  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
Sorry guys I'm using my iPad can't upload pics in one time
Attached Thumbnails Have you guys ever seen this???-image.jpg  
chorkiu is offline  
Old 09-14-2015, 10:40 AM
  #4  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
The cruise
Attached Thumbnails Have you guys ever seen this???-image.jpg  
chorkiu is offline  
Old 09-14-2015, 10:41 AM
  #5  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
The abs light
Attached Thumbnails Have you guys ever seen this???-image.jpg  
chorkiu is offline  
Old 09-14-2015, 10:42 AM
  #6  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
Ok last pic. My babe is teasing me
Attached Thumbnails Have you guys ever seen this???-image.jpg  
chorkiu is offline  
Old 09-14-2015, 11:39 AM
  #7  
MBWorld Fanatic!
 
xXHotelCrazyXx's Avatar
 
Join Date: Jan 2011
Location: five oh two
Posts: 1,882
Received 3 Likes on 3 Posts
2008 W204 Sport
Not sure if its the same on the Merc, but its the same on other cars. Check the brake fluid level, if thats good, check your brake pads.
xXHotelCrazyXx is offline  
Old 09-14-2015, 08:40 PM
  #8  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
Originally Posted by xXHotelCrazyXx View Post
Not sure if its the same on the Merc, but its the same on other cars. Check the brake fluid level, if thats good, check your brake pads.
Is this the brake's problem? It has under 20k miles on it.
chorkiu is offline  
Old 09-14-2015, 09:20 PM
  #9  
MBWorld Fanatic!
 
xXHotelCrazyXx's Avatar
 
Join Date: Jan 2011
Location: five oh two
Posts: 1,882
Received 3 Likes on 3 Posts
2008 W204 Sport
Not sure.
xXHotelCrazyXx is offline  
Old 09-15-2015, 06:40 AM
  #10  
Super Member
 
xEryx's Avatar
 
Join Date: Mar 2015
Location: Berks County, PA
Posts: 841
Received 47 Likes on 44 Posts
2012 C300 4Matic Sport
I had this same problem for the last few weeks on the '12, the car would sometimes not turn on and I would need to jump it. The battery is only supposed to last around 4 years apparently, so I had the battery replaced yesterday. The reason for the SRS malfunction is that the system is getting low voltage values from the battery based on what the tech got in his STAR. $220 for new battery and labor, not covered by warranty.
xEryx is offline  
Old 09-15-2015, 03:45 PM
  #11  
Member
 
Join Date: Mar 2010
Posts: 211
Likes: 0
Received 7 Likes on 7 Posts
2011 C300 Luxury
Originally Posted by xEryx View Post
I had this same problem for the last few weeks on the '12, the car would sometimes not turn on and I would need to jump it. The battery is only supposed to last around 4 years apparently, so I had the battery replaced yesterday. The reason for the SRS malfunction is that the system is getting low voltage values from the battery based on what the tech got in his STAR. $220 for new battery and labor, not covered by warranty.
Battery should be covered under warranty. My battery was dead and needed a jump. Called roadside assist and MB sent a tech out, tested battery and installed new one for me under warranty.
95Sinned420 is offline  
Old 09-15-2015, 08:44 PM
  #12  
Newbie
 
Join Date: Jul 2015
Location: Enfield,CT
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
w204 C300
I had this same issue just got my car back from the dealer turned out I had a bad fuse box. Some kind of short I'm guessing.
Cclass860 is offline  
Old 09-16-2015, 10:02 AM
  #13  
Newbie
Thread Starter
 
Join Date: Sep 2015
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
2012 C250
So, I dropped my car off to the dealer yesterday. I'll get it back Thursday and I'll tell you guys what the problem is with my car.
chorkiu is offline  
Old 09-23-2015, 02:37 PM
  #14  
Member
 
Join Date: Jun 2014
Location: Los Angeles, CA
Posts: 207
Likes: 0
Received 0 Likes on 0 Posts
2008 E63 AMG
Originally Posted by chorkiu View Post
So, I dropped my car off to the dealer yesterday. I'll get it back Thursday and I'll tell you guys what the problem is with my car.
Happened to my w211 E63. We thought it was battery, so we changed, but problem persisted. I have a voltage regulator on my car and when it drops below 10V, it locks ABS. So we changed alternator and prob solved.
Vanquish59 is offline  
Old 09-24-2015, 04:26 PM
  #15  
Senior Member
 
Andriy242's Avatar
 
Join Date: Feb 2014
Location: Edmonton
Posts: 312
Likes: 0
Received 13 Likes on 13 Posts
14' E63S
Get into the engineering menu on your COmmand and check the voltage. THen you can see if it's the battery or not.
Andriy242 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Have you guys ever seen this???


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: