Notices
C63 AMG (W204)
Sponsored by:
Sponsored by:

Shudder on acceleration.

 
Old 03-09-2012, 02:26 PM
  #1  
Member
Thread Starter
 
shauni's Avatar
 
Join Date: Aug 2011
Location: Johannesburg
Posts: 105
Likes: 0
Received 0 Likes on 0 Posts
2012 C63 AMG
Shudder on acceleration.

Hi everyone, when accelerating at a medium speed I experience a slight shudder when depressing the throttle, has anyone else experienced this? On a 2012 C63
shauni is offline  
Old 03-09-2012, 02:40 PM
  #2  
MBWorld Fanatic!
 
dodger63's Avatar
 
Join Date: Oct 2008
Location: Northport N.Y.
Posts: 3,309
Likes: 0
Received 0 Likes on 0 Posts
2013 f250 6.7 diesel
Originally Posted by shauni View Post
Hi everyone, when accelerating at a medium speed I experience a slight shudder when depressing the throttle, has anyone else experienced this? On a 2012 C63
It's the sound barrier,
dodger63 is offline  
Old 03-09-2012, 02:45 PM
  #3  
MBWorld Fanatic!
 
Join Date: Jan 2009
Posts: 4,551
Received 31 Likes on 26 Posts
C63 AMG
Do you mean a hesitation?

Stock ?

Could be O2 sensors
Merc63 is offline  
Old 03-09-2012, 03:03 PM
  #4  
MBWorld Fanatic!
 
BAD430BENZ's Avatar
 
Join Date: Jan 2009
Posts: 2,077
Likes: 0
Received 1 Like on 1 Post
360 Modena TT
Originally Posted by dodger63 View Post
It's the sound barrier,
....he didn't say at WOT with headers and catless mids
BAD430BENZ is offline  
Old 03-09-2012, 03:04 PM
  #5  
MBWorld Fanatic!
 
dodger63's Avatar
 
Join Date: Oct 2008
Location: Northport N.Y.
Posts: 3,309
Likes: 0
Received 0 Likes on 0 Posts
2013 f250 6.7 diesel
Originally Posted by BAD430BENZ View Post
....he didn't say at WOT with headers and catless mids
Opps your right my bad
dodger63 is offline  
Old 03-09-2012, 03:42 PM
  #6  
MBWorld Fanatic!
 
CoolBDPhenom03's Avatar
 
Join Date: Mar 2012
Location: Walnut Creek, CA
Posts: 4,026
Likes: 0
Received 3 Likes on 2 Posts
Vivid Racing '09 C63 AMG
Originally Posted by dodger63 View Post
It's the sound barrier,
That comment is so win
CoolBDPhenom03 is offline  
Old 03-09-2012, 04:32 PM
  #7  
Super Member
 
alrasheed1991's Avatar
 
Join Date: Oct 2009
Location: Kingdom Of Saudi Arabia
Posts: 632
Likes: 0
Received 0 Likes on 0 Posts
2011 C63AMG P31
Originally Posted by dodger63 View Post
It's the sound barrier,
alrasheed1991 is offline  
Old 03-09-2012, 04:34 PM
  #8  
MBWorld Fanatic!
 
Sincity's Avatar
 
Join Date: Feb 2003
Location: Vegas and Vancouver, BC
Posts: 5,945
Received 6 Likes on 6 Posts
.
Issue with MCT?
Sincity is offline  
Old 03-10-2012, 06:47 AM
  #9  
Member
Thread Starter
 
shauni's Avatar
 
Join Date: Aug 2011
Location: Johannesburg
Posts: 105
Likes: 0
Received 0 Likes on 0 Posts
2012 C63 AMG
Yes the car is stock! I phoned the workshop and they just told me its how the new MCT is..
shauni is offline  
Old 03-10-2012, 07:14 AM
  #10  
MBWorld Fanatic!
 
gthal's Avatar
 
Join Date: Sep 2011
Posts: 1,294
Likes: 0
Received 1 Like on 1 Post
2012 C63 coupe
Originally Posted by shauni View Post
Yes the car is stock! I phoned the workshop and they just told me its how the new MCT is..
Not true... I have zero issues in acceleration. They are making excuses because they don't know what it is.
gthal is offline  
Old 03-10-2012, 10:15 AM
  #11  
MBWorld Fanatic!
 
AMGC60-3's Avatar
 
Join Date: Aug 2008
Location: N.Jersey and New York, stationed in Germany
Posts: 1,291
Likes: 0
Received 0 Likes on 0 Posts
W164 ML500,SMART For two,1994 C280(5speed manual) 1999 C230k station wagon
Originally Posted by dodger63 View Post
It's the sound barrier,
I thought it was from entering "warp speed"?
AMGC60-3 is offline  
Old 03-10-2012, 10:19 AM
  #12  
Member
Thread Starter
 
shauni's Avatar
 
Join Date: Aug 2011
Location: Johannesburg
Posts: 105
Likes: 0
Received 0 Likes on 0 Posts
2012 C63 AMG
Originally Posted by gthal View Post
Not true... I have zero issues in acceleration. They are making excuses because they don't know what it is.
Yeah that's what I thought, that's why I'm asking here, I think I'll try another workshop and take it in?!
shauni is offline  
Old 03-10-2012, 01:42 PM
  #13  
MBWorld Fanatic!
 
Join Date: Jan 2009
Posts: 4,551
Received 31 Likes on 26 Posts
C63 AMG
Take it to the dealer, u got warranty.
Merc63 is offline  
Old 04-15-2012, 02:20 PM
  #14  
Junior Member
 
Join Date: Jan 2010
Location: Naples, FL
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
2007 E 63
I just took delivery of my 12 a week ago. I'm experiencing the same thing, especially on light acceleration between 1500-2500 rpms. It's really beginning to tick me off, and I can't stand the thought of hearing the stealer tell me "it's normal". Please let me know if you learn anything. It almost feels like a MAF sensor or something.

Savnole97 is offline  
Old 04-15-2012, 03:30 PM
  #15  
Senior Member
 
Join Date: Oct 2011
Location: washington, DC
Posts: 476
Likes: 0
Received 1 Like on 1 Post
2013 Fiat Abarth
Originally Posted by dodger63 View Post
It's the sound barrier,
genius
c63edition1 is offline  
Old 04-15-2012, 03:36 PM
  #16  
Banned
 
Join Date: Feb 2012
Location: Los Angeles
Posts: 2,838
Received 66 Likes on 55 Posts
'16 C63-S
Originally Posted by Savnole97 View Post
I just took delivery of my 12 a week ago. I'm experiencing the same thing, especially on light acceleration between 1500-2500 rpms. It's really beginning to tick me off, and I can't stand the thought of hearing the stealer tell me "it's normal". Please let me know if you learn anything. It almost feels like a MAF sensor or something.

Off Topic : I'm sorry dude, but your wheels are really bad. It's so ghetto imo
Guilty is offline  
Old 04-15-2012, 03:45 PM
  #17  
Junior Member
 
Join Date: Jan 2010
Location: Naples, FL
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
2007 E 63
hmm..ADV-1 wheels ghetto...interesting
Savnole97 is offline  
Old 04-15-2012, 03:55 PM
  #18  
Banned
 
Join Date: Feb 2012
Location: Los Angeles
Posts: 2,838
Received 66 Likes on 55 Posts
'16 C63-S
Originally Posted by Savnole97 View Post
hmm..ADV-1 wheels ghetto...interesting
I don't care about the brand, I'm not expert in wheels, even if you paid $1M for it, they just look gross. Not for a C63. Maybe for a GM.
Guilty is offline  
Old 04-15-2012, 04:01 PM
  #19  
Junior Member
 
Join Date: Jan 2010
Location: Naples, FL
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
2007 E 63
Grammer either, obviously.
Savnole97 is offline  
Old 04-15-2012, 04:26 PM
  #20  
Super Member
 
_timothy's Avatar
 
Join Date: Mar 2012
Posts: 851
Likes: 0
Received 0 Likes on 0 Posts
c63
Originally Posted by Savnole97 View Post
Grammer either, obviously.
nor speeeeling

i like them!
_timothy is offline  
Old 04-15-2012, 04:36 PM
  #21  
MBWorld Fanatic!
 
VaclavSV's Avatar
 
Join Date: Jun 2011
Posts: 1,911
Likes: 0
Received 1 Like on 1 Post
2012 C63 AMG Black Series
Originally Posted by Savnole97 View Post
hmm..ADV-1 wheels ghetto...interesting
They aren't bad at all! There have been way worse on this forum! I like the 10 spoke trakfunction more but these are great!

I don't know what you mean by shudder... I haven't felt anything. The only things with my 2012 is that when Im stopped and put it into S or S+ the car jerks, and when Im driving in S+ the car will keep the revs quite high after I have stopped accelerating. I usually just grab the paddle and it shifts up right away. If I don't grab the paddle it take about 5 or 6 seconds for the car to 'decide' to shift.
VaclavSV is offline  
Old 04-15-2012, 04:50 PM
  #22  
Banned
 
Join Date: Feb 2012
Location: Los Angeles
Posts: 2,838
Received 66 Likes on 55 Posts
'16 C63-S
Originally Posted by Savnole97 View Post
Grammer either, obviously.
I'm foreign.
Guilty is offline  
Old 04-15-2012, 09:23 PM
  #23  
Junior Member
 
Join Date: Jan 2010
Location: Naples, FL
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
2007 E 63
Originally Posted by VaclavSV View Post
They aren't bad at all! There have been way worse on this forum! I like the 10 spoke trakfunction more but these are great!

I don't know what you mean by shudder... I haven't felt anything. The only things with my 2012 is that when Im stopped and put it into S or S+ the car jerks, and when Im driving in S+ the car will keep the revs quite high after I have stopped accelerating. I usually just grab the paddle and it shifts up right away. If I don't grab the paddle it take about 5 or 6 seconds for the car to 'decide' to shift.
Thanks, I almost got the 10 spokes actually. In the end I thought the spokes were a bit thin for the car, but it was a tough choice. I thought the 8's looked a bit more aggressive for the car.
Anyway, it's not so much a shudder, but more of a slight stumble/hesiation maybe. I use M mode most of the time anyway and it's much less noticeable.
Anybody have a tune on a P31 '12 that saw improvement on this?

thanks,
Savnole97 is offline  
Old 04-15-2012, 09:41 PM
  #24  
Senior Member
 
Join Date: Jan 2009
Posts: 262
Likes: 0
Received 0 Likes on 0 Posts
C204, W209, W164
Originally Posted by AMGC60-3 View Post
I thought it was from entering "warp speed"?
Definitely not.. he stated his car is stock... so no flux capacitor..
Infamouz is offline  
Old 04-15-2012, 10:36 PM
  #25  
Super Member
 
Join Date: Jan 2012
Location: Sydney
Posts: 505
Likes: 0
Received 17 Likes on 13 Posts
2015 E400 Coupe
i have a 2012 and have no such shudder. Mind you in our city "medium speed" is like 35 kmh. lmao
Harold1898 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Shudder on acceleration.


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: