Notices
CLK-Class (W208) 1998-2002: CLK 200, CLK 230K, CLK 320, CLK 430 [Coupes & Cabriolets]

clk 430 won,t start

 
Old 07-04-2008, 08:39 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2007
Location: Ontario,Canada
Posts: 36
Likes: 0
Received 0 Likes on 0 Posts
99 CLK 430, 84 v8 rx7, 97 gtp grand prix
Smile clk 430 won,t start

Just trying to see if I,m right but my car over the last couple weeks has been getting harder and harder to start when hot but perfectly good when cold then today it took several tries to start when hot I,m thinking crank position sensor any input appreciated thanks in advance
Thunderdome66 is offline  
Old 07-05-2008, 11:45 AM
  #2  
Member
 
Join Date: Jan 2007
Location: Anaheim Hills, CA
Posts: 112
Likes: 0
Received 0 Likes on 0 Posts
CLK430, SC430, RX330
Originally Posted by Thunderdome66 View Post
Just trying to see if I,m right but my car over the last couple weeks has been getting harder and harder to start when hot but perfectly good when cold then today it took several tries to start when hot I,m thinking crank position sensor any input appreciated thanks in advance

Maybe the CPS, but also have you tried adding distilled water into your battery?

https://mbworld.org/forums/clk-class-w208/250488-anyone-here-add-water-battery-regularly.html
ratha67 is offline  
Old 07-05-2008, 11:50 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Jun 2007
Location: Ontario,Canada
Posts: 36
Likes: 0
Received 0 Likes on 0 Posts
99 CLK 430, 84 v8 rx7, 97 gtp grand prix
the battery seems fine the engine spins no problem just doesn,t fire after a few cycles it fires right up?
Thunderdome66 is offline  
Old 07-05-2008, 12:42 PM
  #4  
Senior Member
 
Join Date: May 2007
Posts: 285
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by ratha67 View Post
Maybe the CPS, but also have you tried adding distilled water into your battery?

https://mbworld.org/forums/showthread.php?t=250488
My GF's ML430 just had the CPS replaced. When it got really hot out she would stall at the traffic light and it would just crank until you let it rest for 3-5 minutes. It was random but always with the AC on and a hot day.

We first replaced her battery b/c there was no water in it at all but in less than 72 hours she stalled again. I searched the forums and saw the CPS issue with the 430 engine. We got it to the dealer and they sourced the code right to the CPS. When the CPs is out the engine dosen't know what to do. It can;t set up a spark pattern to get it going.

Total: $450 parts and labor, no more stalling
ApproachingZero is offline  
Old 07-05-2008, 04:05 PM
  #5  
Senior Member
 
JYOO's Avatar
 
Join Date: Jun 2006
Location: Los Angeles (SPOOKTOWN to c exact)
Posts: 337
Likes: 0
Received 0 Likes on 0 Posts
CLK but loves my Fords
I payed 220 to have the CPS repaired that included the towing. 450 sounds outrageous.
JYOO is offline  
Old 07-05-2008, 08:45 PM
  #6  
Senior Member
 
Join Date: May 2007
Posts: 285
Likes: 0
Received 0 Likes on 0 Posts
[QUOTE=JYOO;2921373]I payed 220 to have the CPS repaired that included the towing. 450 sounds outrageous.[/QUOTE

It was only $400 for the CPS change. My GF got an oil change too. I forgot about that one

Where the hell do you live? Did you get it done at the dealer?

I think the CPS alone was $200.
ApproachingZero is offline  
Old 07-05-2008, 09:11 PM
  #7  
Senior Member
 
JYOO's Avatar
 
Join Date: Jun 2006
Location: Los Angeles (SPOOKTOWN to c exact)
Posts: 337
Likes: 0
Received 0 Likes on 0 Posts
CLK but loves my Fords
I live in LA, no i got it done at a Mercedes specialists shop.
JYOO is offline  
Old 07-06-2008, 12:08 AM
  #8  
Senior Member
 
Join Date: May 2007
Posts: 285
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by JYOO View Post
I live in LA, no i got it done at a Mercedes specialists shop.
That's diffrent then.

Out here we have only 1 or 2 good shops that can work on Benzs without throwing parts at them. Those places charge about the same as the dealer b/c they know they can get away with it.
ApproachingZero is offline  
Old 07-18-2008, 11:25 PM
  #9  
Junior Member
Thread Starter
 
Join Date: Jun 2007
Location: Ontario,Canada
Posts: 36
Likes: 0
Received 0 Likes on 0 Posts
99 CLK 430, 84 v8 rx7, 97 gtp grand prix
Cool

turns out it was the cps sensor bought from dealer 185 in Canada 1 week now no more problems
Thunderdome66 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: clk 430 won,t start


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: