Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
Cruise control lights flashing. Why? Can't find answer. >

Cruise control lights flashing. Why? Can't find answer.

Notices
E-Class (W211) 2003-2009

Cruise control lights flashing. Why? Can't find answer.

 
Old 10-22-2010, 02:13 PM
  #1  
MBWorld Fanatic!
Thread Starter
 
BagMan's Avatar
 
Join Date: Jan 2010
Location: SWFL
Posts: 1,057
Thanked 16 Times in 12 Posts
E55, E320 CDI , CLA250, Jag XJ Supersport
Cruise control lights flashing. Why? Can't find answer.

Sometimes I see the my cruise control lights (you know, that segmented ring around the speedo that goes on with cruise control) flashing and then go out.

Can anyone tell me what that means?

Today I caught it flashing briefly and the cruise control wasn't even on.

I checked the manual and did a search but could not find the answer.

Car does not have distronic.
BagMan is offline  
Old 10-22-2010, 02:18 PM
  #2  
Member
 
Join Date: Nov 2009
Location: Vancouver, Canada
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
E320 CDI
Did you switch off your ESP?
crazypotato is offline  
Old 10-22-2010, 02:46 PM
  #3  
MBWorld Fanatic!
Thread Starter
 
BagMan's Avatar
 
Join Date: Jan 2010
Location: SWFL
Posts: 1,057
Thanked 16 Times in 12 Posts
E55, E320 CDI , CLA250, Jag XJ Supersport
Originally Posted by crazypotato View Post
Did you switch off your ESP?
nope
BagMan is offline  
Old 10-25-2010, 11:07 PM
  #4  
MBWorld Fanatic!
 
Join Date: Sep 2009
Location: NOMAD
Posts: 7,348
Thanked 18 Times in 17 Posts
CLS550 4Matic
Have you disconnected your battery lately?!?! Happened to me and started to work a couple days later
djrabbi is offline  
Old 10-26-2010, 11:25 AM
  #5  
MBWorld Fanatic!
Thread Starter
 
BagMan's Avatar
 
Join Date: Jan 2010
Location: SWFL
Posts: 1,057
Thanked 16 Times in 12 Posts
E55, E320 CDI , CLA250, Jag XJ Supersport
Originally Posted by djrabbi View Post
Have you disconnected your battery lately?!?! Happened to me and started to work a couple days later
Nope. The funny thing is everything works fine. Once in a while the ring in the speedometer just flashes for a couple of seconds.
BagMan is offline  
Old 10-26-2010, 11:49 AM
  #6  
MBWorld Fanatic!
 
KEY08's Avatar
 
Join Date: Oct 2005
Location: Chicagoland
Posts: 3,220
Thanked 340 Times in 318 Posts
2014 E550 4Matic Designo Diamond White and loaded up
Just a Halloween Gremlin.

It'll go away as quickly as it showed up, I'm sure.
KEY08 is offline  
Old 06-12-2011, 11:58 AM
  #7  
Newbie
 
Join Date: Dec 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes CLS
Do you have any news on this one? I'm having the same problem in w219

Last edited by Ram Tibu; 06-12-2011 at 12:14 PM.
Ram Tibu is offline  
Old 06-13-2011, 01:24 PM
  #8  
MBWorld Fanatic!
Thread Starter
 
BagMan's Avatar
 
Join Date: Jan 2010
Location: SWFL
Posts: 1,057
Thanked 16 Times in 12 Posts
E55, E320 CDI , CLA250, Jag XJ Supersport
Sorry. Nothing new to report. I see a flash once in a while, but everything works like it's supposed to.
BagMan is offline  
Old 06-13-2011, 03:10 PM
  #9  
Newbie
 
Join Date: Dec 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes CLS
Thanks. Samething here. I just see a flash one in a while but all works fine. I will keep my eyes open and share.
Ram Tibu is offline  
Old 06-13-2011, 08:53 PM
  #10  
Member
 
Join Date: Sep 2010
Posts: 134
Thanks: 0
Thanked 0 Times in 0 Posts
2006 E320 CDI 235 hp 420 ft tq
On mine the segmented ring will be there and then not all with the cruise on.
With the cruise working fine.
I have changed from the speedo to the mpg after start and total time mpg and everything still works , just not the ring.
I was just thinking it was just not able to keep up with what I wanted.
2slowcdi is offline  
Old 06-08-2014, 09:37 AM
  #11  
Newbie
 
Join Date: Aug 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2007 CLS550
My W219 is has been doing this for a few years now. Has anyone figured out how to fix this? My cruise control functions as it should but the flashing ring is annoying. I have figured out that if I turn on the cruise control, after a (random) amount of time the ring will go away, flashing or solid (solid as it should be). Is there any way to turn the ring indicator off? Any help or advise appreciated.
MrSteed is offline  
Old 07-05-2014, 12:06 AM
  #12  
Newbie
 
Join Date: Jul 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
W211 E280 2007 Avantgarde Black
Same here

The segmented ring keeps flashing and sometimes may just disappear. Np issues with the actual cruise control. The segment also flashes once in a while even when cruise is not activated. Any one with a solid explanation or remedy?
akifssa is offline  
Old 09-25-2014, 10:02 PM
  #13  
Junior Member
 
Join Date: Apr 2010
Location: Honolulu
Posts: 38
Thanked 5 Times in 5 Posts
2018 C43amg,2012 CLS 550, 2004 Chevrolet SSR, 1934 Chevy street rod
cruise ring light flashing

My 2007 clk, w209, cruise light ring in dash flashes about once every 5 minutes. Looks like no one has the answer.
lou7777777 is offline  
Old 09-30-2014, 09:00 AM
  #14  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,696
Thanked 573 Times in 556 Posts
1999 E300TD
The overall CC system is very different depending upon MY/model however what I believe to be constant are the imputes the ECU requires to maintain a speed without the pedal control---they are throttle control BAS and ESP modules----and here we go again which one is causing the flashing----the car has to be quick tested to locate the stored and or current faults----all other supposition is just that----so live with it or spend some money to find out why or just throwing parts at the car!!
Plutoe is offline  
Old 11-11-2014, 10:31 PM
  #15  
Newbie
 
Join Date: Aug 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2007 CLS550
Happy to report this problem in my 2007 CLS550 went away on its own. The ring no longer flashes, however it no longer comes on when I turn on the cruise control as its supposed to. Cruise control functions properly otherwise. I suspect that the flashing of the circle is the start of that cruise control indicator starting to fail. Glad its finally off!
MrSteed is offline  
Old 01-31-2015, 11:01 PM
  #16  
Newbie
 
Join Date: Jan 2014
Location: Friendswood, Texas
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2006 E350
Same Problem

I have the same problem on my 2006 E350... circle of lights will randomly flash... no performance change, just a sporadic blink of that row of lights. Have my car in the shop to fix the gas leak now that the warranty has been extended, and had them look at it. Typically, they said to replace the entire instrument cluster. I think not... it doesn't bother me that much.
dwbster is offline  
Old 04-30-2015, 08:33 AM
  #17  
Junior Member
 
Join Date: Jun 2010
Location: Dallas, TX
Posts: 20
Thanks: 0
Thanked 2 Times in 1 Post
1996 S500 Sedan, 2007 CLK350 Cabriolet
My 2007 CLK350 209 also does this. Seems to be at shift points or maybe ESP related moments, but all functions well, and I can't find a pattern. If anyone finds out a possible reason, (even a category of issue!) please post and let us know! "gremlins" isn't a very helpful answer!
drrobertjfrank is offline  
Old 10-24-2016, 05:29 PM
  #18  
Newbie
 
Join Date: Oct 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2006 E500
Have 2006 E500. Same problem. Have the random flash of the cruise control digital light ring cluster just below the Odometer numerals for one second or less. It is not always the same. Sometimes it is a full ring 0-160 mph and sometimes it is only a section, the 0-20 mph section, 40-80 mph, 20-140 mph,....you get the idea. It is not related to speed, shift pattern, acceleration, braking, turning or anything else that I can tell. These lights normally illuminate the section of the ring when setting the cruise to the speed being set as well as giving a numeric display of the speed. So, now the cruise control does work, but there is no indicator light that lets you know it is set. This happened after a service to the steering module which was replaced because the turn signal indicator light on the dash for turning left would illuminate and flash as if turning left when turning on the signal for a right hand turn. Car was brought back to diagnose the random flash, which was verified by mechanic, but no answer or repair was forthcoming. Then one day I went to activate the cruise and realized that was where the problem seemed to be from. Took car in , didn't get solved and got long winded explanation about the cluster and a lot of work and time ........ Spoke with service manager regarding this and he thinks it is a software compatibility issue. That sometimes new modules have some new programs and don't allow for complete exchange of information and recommends car be brought back in and evaluated No charge. Will post results once that is done.

Last edited by drjoeyb; 10-24-2016 at 05:31 PM.
drjoeyb is offline  
Old 05-23-2017, 09:04 PM
  #19  
MBWorld Fanatic!
 
Jon2007E63P30's Avatar
 
Join Date: Oct 2007
Location: San Jose, CA
Posts: 1,717
Thanks: 0
Thanked 8 Times in 4 Posts
2007 E63 w/P30 and Eurotech CF Diffuser
I just got this after changing rear tires with front tires that are near end of life (actually life support). It was suggested in another thread that the blinking may be a result of excessive tire diameter difference. I change the fronts this weekend and will let you all know.
Jon2007E63P30 is offline  
Old 11-27-2017, 04:12 AM
  #20  
Newbie
 
Join Date: Nov 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2007 E350
2007 E350 same flashing issue

I have this happening in my car at random intervals of about 30 seconds to 5 minutes. Different portions of the cruise light ring will light up for a split second. Sometimes multiple non-connected sections light up at once. This happens even when the ignition key is in the accessory position and the engine is not on. Like others have noted, there is no other effect and I suspect that it is a software fault.
Tim Ash is offline  
Old 11-28-2017, 11:24 AM
  #21  
Junior Member
 
Join Date: Jan 2017
Posts: 56
Thanked 12 Times in 5 Posts
2006 E55 AMG
Originally Posted by Tim Ash View Post
I have this happening in my car at random intervals of about 30 seconds to 5 minutes. Different portions of the cruise light ring will light up for a split second. Sometimes multiple non-connected sections light up at once. This happens even when the ignition key is in the accessory position and the engine is not on. Like others have noted, there is no other effect and I suspect that it is a software fault.
This is exactly what mine does. Last night, I had this new behavior from it. Untz, untz, untz:

87geeinn is offline  
Old 01-20-2018, 07:03 PM
  #22  
Junior Member
 
Join Date: Jun 2008
Location: Annapolis Maryland
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
1999 SLK Sport & 2003 E500 Sport
I have a 2003 E500.....I have one key that the "cruise ring" is off until I turn on the cruise control (works as it should)
And another key that the cruise ring comes on as soon as I start the car...then when I turn the cruise on the ring goes out. Took it to the Benz dealer...could not figure it out.
Assuming it is a programming issue.....car/cruise works fine with both keys.
rdp3430 is offline  
Old 01-21-2018, 01:28 AM
  #23  
MBWorld Fanatic!
 
konigstiger's Avatar
 
Join Date: Jul 2003
Location: North Scottsdale, AZ
Posts: 9,990
Thanked 1,018 Times in 871 Posts
'71 Pinto
Not certain how this would apply to two key condition mentioned, and complete failure would trigger ESP warning but "could" be intermittent problem with steering angle sensor.
Attached Files
File Type: pdf
CLS SAS.pdf (97.8 KB, 64 views)
File Type: pdf
Steering angle.pdf (54.9 KB, 68 views)
konigstiger is offline  
Old 03-07-2018, 02:18 PM
  #24  
Newbie
 
Join Date: Mar 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
CLS550
My 2007 CLS550 does the same thing. Cruise works great. Sometimes the ring is steady and correct with the cruise on, sometimes it is flashing with the cruise on (which is annoying). There are intermittent flashes of the cruise control light ring when the cruise is not engaged; these are very quick and if I'm not looking at the dash when it happens I probably don't notice many of them. Sure wish someone could figure this out or at least report back if Mercedes was able to fix it.

Seems to occur across multiple models.
bjwmercedes is offline  
Old 04-21-2018, 12:01 AM
  #25  
Junior Member
 
Muckman83's Avatar
 
Join Date: Mar 2018
Posts: 26
Thanked 0 Times in 0 Posts
Audi TTRS
Any more info on this ? My CLK63 is doing the same thing
when even I activate curse control the ring will constantly flash
also my tires at the rear are worn, could this be the problem?
Muckman83 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Cruise control lights flashing. Why? Can't find answer.


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: