KEYLESS GO wire broken - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
KEYLESS GO wire broken >

KEYLESS GO wire broken

Notices
E-Class (W211) 2003-2009

KEYLESS GO wire broken

 
Old 11-25-2011, 11:43 PM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2011
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
N/A
KEYLESS GO broken wire DIY

W211 2004 E500
Keyless Go not staring with button
No error messages un dashboard
Was thinking shifting knob is bad,but find out is BROKEN WIRE!
There is step by step instructions how fixit

I take pictures when i put together everything
And then REVERSED them
Click on images to enlarge them





if you want to take everything apart do next



connect wires back,start the car shift in N or D and take out ashtray holder.
Shift back in P and maybe disconnect rear battery.



lift up console
remove those plastic things and lift that wire to right side of shifter
now you can put console on passenger side floor




raise up shifter slowly and take off that ring







Now the HARDEST part
those two wires are really short and hard to clean and solder
DONT HOLD HEAT FOR TO LONG you can melt isolation



Thats how it look when i solder and put tape on.
Let the wire go on right side on shifter

Good luck and sorry about my english.


Please let me know which site i can use to post bigger pictures for free.

Last edited by Huligan; 11-26-2011 at 01:17 AM.
Huligan is offline  
The Following User Says Thank You to Huligan For This Useful Post:
rafi1430 (02-07-2017)
Old 11-26-2011, 12:02 PM
  #2  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
Terrific writeup....thanks. Clicking on a pic brings it up full size btw.
starbrite is offline  
Old 10-05-2012, 06:08 PM
  #3  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
Glad I bookmarked this post, because it looks like I may have this same broken wire, based on my KG symptoms. The op may only have 2 posts , but this one is a winner. Thankfully, all the pics are still up.

Edit: sure enough, my wire is toast.

Edit#2: The only thing the op didn't mention is that 2 black screws, holding the side panels in place, require a T-10 Torx driver and the silver screws holding the console, are T-27.

I was able to remove the ashtray holder without having to shift the gear out of park.

The plastic tabs on the shifter housing were difficult to break loose. Screwdriver didn't do it. I had to use a wider and flatter blade and hit it with a small hammer to break loose on both sides. When removing the shifter assembly from the tranny connecting rod, stuff a towel into the hole so the grommet and/or the snap ring don't fall into the hole and then to the ground. I had to retrieve both of them a couple of times. Oh, and I did disconnect the battery after everything was apart.

Lastly, to solder the wires, they were too short on the shifter side to do any twisting so I "tinned" all 4 ends and then just held them in an overlap position to re melt the solder on each connection. Use a very thin iron tip. I used a Weller soldering station PTL tip.(Click here)

Other than that, it went smoothly, no other surprises.

Last edited by starbrite; 05-30-2014 at 12:40 PM. Reason: added info
starbrite is offline  
Old 05-17-2013, 04:15 AM
  #4  
Newbie
 
Join Date: Aug 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
W211 55AMG / r170 32AMG
Thank you

Thanks for your thread.
But picture too small. Could you letme see bigger pictures please?
suphinx is offline  
Old 05-17-2013, 10:57 AM
  #5  
Out Of Control!!
 
Join Date: Feb 2011
Location: Tampa
Posts: 11,544
Thanked 566 Times in 549 Posts
1999 E300TD
Nice job!!!
Plutoe is offline  
Old 05-19-2013, 01:54 PM
  #6  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
Originally Posted by suphinx View Post
Thanks for your thread.
But picture too small. Could you let me see bigger pictures please?
Just double click on any photo and it will come up full size.

Last edited by starbrite; 01-19-2014 at 03:01 PM.
starbrite is offline  
Old 01-11-2014, 02:27 AM
  #7  
Senior Member
 
Join Date: Jul 2006
Location: Santa Clara, CA
Posts: 432
Thanks: 0
Thanked 0 Times in 0 Posts
2005 E55 AMG, 2010 KTM 990 Adventure R
Outstanding writeup! This thread is a gem, you just saved me $1153.95
mrweelr is offline  
Old 01-12-2014, 06:30 PM
  #8  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
Have you found the broken wire ? And, if so, what were your keyless go problems/symptoms

Edit: thanks for the pm's

Last edited by starbrite; 01-15-2014 at 06:39 PM.
starbrite is offline  
Old 04-07-2014, 01:37 AM
  #9  
Newbie
 
benzthere320's Avatar
 
Join Date: Apr 2014
Location: Houston
Posts: 10
Thanked 0 Times in 0 Posts
2004 E320 USA, TITANITE RED - METALLIC
Excellent..
benzthere320 is offline  
Old 04-25-2014, 05:36 AM
  #10  
Junior Member
 
Join Date: Apr 2004
Location: Europe
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
E420CDI 2008, GLK220CDI 2009
Fantastic post thanks It will help lot of members
cc260E is offline  
Old 07-06-2014, 01:21 AM
  #11  
Junior Member
 
Join Date: Jan 2008
Posts: 71
Thanks: 0
Thanked 1 Time in 1 Post
2003 E55
Thanks for this. Just did this repair today and it seems to be working. Man those wires are thin, soldering them was a real pain in the *** and i was sure i didn't do a good job but it seems to be working.
twowheelmarc is offline  
Old 08-07-2014, 11:26 PM
  #12  
MBWorld Fanatic!
 
bbirdwell's Avatar
 
Join Date: Jan 2014
Location: Republic of Texas
Posts: 1,807
Thanked 380 Times in 309 Posts
'99 and '05 E55 AMG
Instead of soldering, consider using "electrical lever nuts" available in 2-conductor to 5-conductor and work with 28 gauge to 12 gauge wire:


Wago 222-412 LEVER-NUTS 2 Conductor Compact Connectors 50 PK - - Amazon.com Wago 222-412 LEVER-NUTS 2 Conductor Compact Connectors 50 PK - - Amazon.com
bbirdwell is online now  
Old 08-08-2014, 05:39 PM
  #13  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
Nope, won't work. The wires aren't long enough for all to connect from the same side like that. They barely overlap ~1/4 in as it is.

Also, keep in mind that the wire moves with the shifter and the connector may get hung up. Good thought though.

Last edited by starbrite; 08-09-2014 at 06:26 PM.
starbrite is offline  
Old 11-03-2014, 09:38 AM
  #14  
Newbie
 
Join Date: Nov 2014
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
2004 E55 AMG
Fantastic post Huligan. I just had my armrest disassembled today because I face the exact same problem. But when I got to the shifter assy I became unsure, and backed out of it.
But now when I have read your post, I will check this tomorrow....
Great pic's

Best regards, Michael
Turbomic is offline  
Old 11-12-2015, 10:37 AM
  #15  
Newbie
 
Join Date: Nov 2015
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
E320 W211 2003
hello... does anybody have the manual configuration of they keyless go for a E320 2003? doors not working...thanks...
ivanulloalazo is offline  
Old 12-31-2015, 06:44 PM
  #16  
DPG
Newbie
 
Join Date: Nov 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2004 E55
Is there a place that these pictures are posted larger? They don't expand to full screen anymore.
DPG is offline  
Old 12-31-2015, 07:25 PM
  #17  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
No, but I have most of them from the original post, and will try to post them over the weekend.
starbrite is offline  
Old 12-31-2015, 07:35 PM
  #18  
DPG
Newbie
 
Join Date: Nov 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2004 E55
Originally Posted by starbrite View Post
No, but I have most of them from the original post, and will try to post them over the weekend.
Awesome! Thank you so much!
DPG is offline  
Old 01-03-2016, 03:10 PM
  #19  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
Ok. here they are.....all that I have, however, I think there's only a few missing: (start with the last pic in the second post)

Left clicking on a photo will start the slide show. If you want to view a photo even larger (before the slide show), right click on it and then select "Open link in new tab" or in "new window'. Either one works both in IE and Firefox.
Attached Thumbnails KEYLESS GO wire broken-img_0091.jpg   KEYLESS GO wire broken-img_0092.jpg   KEYLESS GO wire broken-img_0093.jpg   KEYLESS GO wire broken-img_0094.jpg   KEYLESS GO wire broken-img_0095.jpg  

KEYLESS GO wire broken-img_0096.jpg   KEYLESS GO wire broken-img_0098.jpg   KEYLESS GO wire broken-img_0100.jpg   KEYLESS GO wire broken-img_0102.jpg   KEYLESS GO wire broken-img_0103.jpg  


Last edited by starbrite; 01-03-2016 at 03:28 PM.
starbrite is offline  
Old 01-03-2016, 03:11 PM
  #20  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
The rest.... (these are not in order)
Attached Thumbnails KEYLESS GO wire broken-img_0106.jpg   KEYLESS GO wire broken-img_0109.jpg   KEYLESS GO wire broken-img_0110.jpg   KEYLESS GO wire broken-img_0112.jpg   KEYLESS GO wire broken-img_0113.jpg  

KEYLESS GO wire broken-img_0114.jpg  
starbrite is offline  
Old 01-10-2016, 12:46 PM
  #21  
DPG
Newbie
 
Join Date: Nov 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2004 E55
Thanks sir!
DPG is offline  
Old 01-10-2016, 05:06 PM
  #22  
DPG
Newbie
 
Join Date: Nov 2015
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2004 E55
Just fixed mine, works perfect now!
DPG is offline  
Old 05-16-2016, 09:32 PM
  #23  
Super Member
 
infantry's Avatar
 
Join Date: Feb 2010
Location: Glendale, AZ
Posts: 831
Thanks: 0
Thanked 0 Times in 0 Posts
07 E63. 07 STi limited #606/800
So what other symptoms did you guys have? I'm going to check my wire out this week, but I'm having no messages about key in the dash. Push to start doesn't work. And all the doors unlock and lock barely work. Rare time it may work.
infantry is offline  
Old 05-17-2016, 05:35 PM
  #24  
MBWorld Fanatic!
 
starbrite's Avatar
 
Join Date: Jul 2006
Location: Long Island, NY
Posts: 1,780
Thanked 5 Times in 4 Posts
2004 E320
Note that the op states "No error messages un dashboard "

Push to start is independent of the doors and trunk. Most likely your wire is broken.
starbrite is offline  
Old 10-11-2016, 12:42 PM
  #25  
Senior Member
 
SuperChargerE55's Avatar
 
Join Date: Sep 2011
Location: Sweden
Posts: 361
Thanked 6 Times in 6 Posts
E55 AMG V8 Kompressor 2004 E 55 AMG Type: 5,439 cc (5.439 L; 331.9 cu in) Supercharged V8 Powe
Only if no error message

Originally Posted by Huligan View Post
W211 2004 E500
Keyless Go not staring with button
No error messages un dashboard
Was thinking shifting knob is bad,but find out is BROKEN WIRE!
There is step by step instructions how fixit

I take pictures when i put together everything
And then REVERSED them
Click on images to enlarge them








if you want to take everything apart do next



connect wires back,start the car shift in N or D and take out ashtray holder.
Shift back in P and maybe disconnect rear battery.





lift up console
remove those plastic things and lift that wire to right side of shifter
now you can put console on passenger side floor





raise up shifter slowly and take off that ring












Now the HARDEST part
those two wires are really short and hard to clean and solder
DONT HOLD HEAT FOR TO LONG you can melt isolation



Thats how it look when i solder and put tape on.
Let the wire go on right side on shifter

Good luck and sorry about my english.


Please let me know which site i can use to post bigger pictures for free.
Let me say perfect DIY much appreciated.
Just quickly quistion never find why mine isn't working had other more important stuff to fix first but time came it is not working but getting the error on display "Key Not Reconized"
Did I just get the wrong key NONE keyless or any other ideas anything.
Also cross checked all doors none will unlock keyless..

Betting key need new one and need recode ?
SuperChargerE55 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: KEYLESS GO wire broken


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: