Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W211)
Urgent Help - E350 07 >

Urgent Help - E350 07

Notices
E-Class (W211) 2003-2009

Urgent Help - E350 07

 
Old 12-30-2014, 06:45 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Urgent Help - E350 07

I need some help mechanics are closed for xmas/new years. Basically started the car put it into reserve and car just goes spastic when put into gear major shake and noise from the rear? When i put it in D again same thing only time it doesn't shake or make a huge nose is in park or neutral?

What is this?
silentmerc is offline  
Old 12-30-2014, 07:21 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Car shakes/noise and feels like something is about to fall apart? on the dashboard it came up not activated or something like and went away
silentmerc is offline  
Old 12-31-2014, 11:39 AM
  #3  
Junior Member
 
Join Date: Nov 2014
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
BMW M roadster
Originally Posted by silentmerc View Post
Car shakes/noise and feels like something is about to fall apart? on the dashboard it came up not activated or something like and went away
Could it be the rubber flex joint on the prop shaft going bad?
emilnat is offline  
Old 01-01-2015, 10:48 PM
  #4  
MBWorld Fanatic!
 
vettdvr's Avatar
 
Join Date: Mar 2006
Location: Louisiana
Posts: 3,254
Likes: 0
Received 4 Likes on 4 Posts
03 E500 and Corvette
Motor mounts. If you drive it does it smooth out. If so you probably can drive it. I did when mine failed at 80,000 miles.
vettdvr is offline  
Old 01-07-2015, 07:16 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Originally Posted by vettdvr View Post
Motor mounts. If you drive it does it smooth out. If so you probably can drive it. I did when mine failed at 80,000 miles.
What happens is

- Start car - normal
- Once you move into gear in that process the whole car shakes/vibrates then lands into gear, in neutral/park it goes into gear fine without any shaking or vibrating.


So once you have it in 'D' and driving the car stays in same gear? just drives on one gear kind of....
silentmerc is offline  
Old 01-07-2015, 07:18 AM
  #6  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Error message came on the dashboard but didn't have time to read the message as i was busy seeing what was happening and message went away and never came back, but the car is still the same.

My mechanic is back from holidays on the 19th...anyone know if this is a serious problem?
silentmerc is offline  
Old 01-07-2015, 10:35 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
When i drive it is smooth driving but stuck in one gear and going sluggish but no clunk what so ever....i then put it into gears manually and going from 1 2 3 4 gears car feels the same speed doesn't feel like its changing gears?

Last edited by silentmerc; 01-07-2015 at 10:40 PM.
silentmerc is offline  
Old 01-08-2015, 09:43 AM
  #8  
MBWorld Fanatic!
 
vettdvr's Avatar
 
Join Date: Mar 2006
Location: Louisiana
Posts: 3,254
Likes: 0
Received 4 Likes on 4 Posts
03 E500 and Corvette
Does the tac show changes in rpm after you change gears while holding cruise speed?
vettdvr is offline  
Old 01-09-2015, 01:53 AM
  #9  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Originally Posted by vettdvr View Post
Does the tac show changes in rpm after you change gears while holding cruise speed?
Nope, when i drive it in auto the taco moves but it is stuck in one gear no matter how much you accelerate its stuck and doesn't pick up speed. I even tried changing gears manually on the dash it is showing as changing gears but the revs stay on one gear, revs don't go up or down during gear change.

Kind of like froze in one gear and going sluggish in one pace. Any idea?
silentmerc is offline  
Old 01-09-2015, 01:55 AM
  #10  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Probably gearbox is dead right? cars only done 110000 km, if it's done a gearbox at this km what a disaster of a car Mercedes is.
silentmerc is offline  
Old 01-11-2015, 08:25 AM
  #11  
MBWorld Fanatic!
 
vettdvr's Avatar
 
Join Date: Mar 2006
Location: Louisiana
Posts: 3,254
Likes: 0
Received 4 Likes on 4 Posts
03 E500 and Corvette
Originally Posted by silentmerc View Post
Probably gearbox is dead right? cars only done 110000 km, if it's done a gearbox at this km what a disaster of a car Mercedes is.

You are probably right on both counts.
vettdvr is offline  
Old 01-12-2015, 03:40 PM
  #12  
Newbie
 
dhuddleson's Avatar
 
Join Date: Aug 2014
Location: Manotick, Ontario
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
2003 E320 sedan
These are electronically controlled transmissions, and the "limp home" feature will try to protect against disastrous failure, so I very much doubt you have a massive expense like a complete transmission. You need to have a competent mechanic with correct diagnostic equipment (Mercedes capable) to fully diagnose. This could be as simple as incorrect (low) fluid level, a stuck solenoid or perhaps the Electrical Conductor Plate. Still could be a few hundred dollars to fix, but compare to thousands for a transmission.

Get a proper diagnosis on it!
dhuddleson is offline  
Old 01-19-2015, 02:32 AM
  #13  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Originally Posted by dhuddleson View Post
These are electronically controlled transmissions, and the "limp home" feature will try to protect against disastrous failure, so I very much doubt you have a massive expense like a complete transmission. You need to have a competent mechanic with correct diagnostic equipment (Mercedes capable) to fully diagnose. This could be as simple as incorrect (low) fluid level, a stuck solenoid or perhaps the Electrical Conductor Plate. Still could be a few hundred dollars to fix, but compare to thousands for a transmission.

Get a proper diagnosis on it!

It's at the workshop now, the mechanic said car is in limp mode and he won't know what is wrong until diagnostics. He said these cars have the transmission computer or whatever it is inside the actual gearbox and when the oil heats up it causes these problems.

I will probably know what the exact problem is tommorow.. he said anywhere between couple hundred dollars to $2000
silentmerc is offline  
Old 01-19-2015, 11:50 AM
  #14  
Newbie
 
Join Date: Jan 2015
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
944
Originally Posted by silentmerc View Post
I need some help mechanics are closed for xmas/new years. Basically started the car put it into reserve and car just goes spastic when put into gear major shake and noise from the rear? When i put it in D again same thing only time it doesn't shake or make a huge nose is in park or neutral?

What is this?
G'Day..
Sorry for your issues but glad your mech has returned to duty.
When you bought your car in July '14:
1. What was the trans fluid maintenance history from the previous owner?
2. What was the current mileage at that time? (now having about 66,000 miles (110,000kms)
3. And to clarify, is it a 2006 (as your 07/2014 post indicated) or a 2007 E350 ?
Wishing good news for ya..
Cheers, mikey

Last edited by VirginiaF1; 01-19-2015 at 11:52 AM.
VirginiaF1 is offline  
Old 01-24-2015, 05:37 AM
  #15  
Junior Member
Thread Starter
 
Join Date: Jul 2014
Posts: 19
Likes: 0
Received 0 Likes on 0 Posts
E350
Ok so i have an update. Spoken briefly with the mechanic and he mentioned a few things wrong with it.

stuck solenoid or perhaps the Electrical Conductor Plate <--- this is what is causing the problem along with other things which will be explained once i go to him.

It was time for a major service which i will be doing brake fluids,coolant,oil change,spark plugs,air con filter? or whatever it is, exhaust clip or support bracket is broken so will be fixing it. A few other things are getting changed which i forgot when he mentioned it will know when i go to collect the car.

Total cost $2k

Car is dec 06, registered march 07.
silentmerc is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Urgent Help - E350 07


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: