Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
Bluetooth Music Streaming? >

Bluetooth Music Streaming?

Notices
E-Class (W212) 2010 - 2016: E 350, E 550

Bluetooth Music Streaming?

 
Old 04-28-2014, 05:04 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Bluetooth Music Streaming?

I've been searching DIY to enable Bluetooth audio streaming thru navi engineer mode. I can't find anything that shows u how to step by step..
beemerfreak is offline  
Old 04-28-2014, 05:13 PM
  #2  
Super Member
 
mikemargolis's Avatar
 
Join Date: Feb 2011
Posts: 503
Received 13 Likes on 13 Posts
'11 E350BTC P2 Leather
more info needed

what year car, what kind of phone, etc...

On my 2011, I just connect my phone via bluetooth and start the music on the phone, via pandora, itunes, whatever, and set the Audio to bluetooth, and it plays automatically.
mikemargolis is offline  
Old 04-28-2014, 05:26 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
2010 e350, iPhone
beemerfreak is offline  
Old 04-28-2014, 09:16 PM
  #4  
Member
 
Join Date: Feb 2012
Location: Denver
Posts: 193
Received 2 Likes on 2 Posts
2014 CLS550 4Matic; 2010 E550, 2007 SL550
iPhones don't play well. Bluetooth Audio won't come play, contacts won't sync, etc etc.
My old iPhone wouldn't talk to three Mercs.

My Android plays through Bluetooth audio, contacts sync, etc. Perfect, seamless, easy. iPhone, no.
PilotAlan is offline  
Old 04-28-2014, 09:22 PM
  #5  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,082
Received 312 Likes on 271 Posts
2011 E550 P2 4M Sedan
look for the e class hacks thread. There are steps there. some folks have reported issues with having the reconnect their iphones using external authorizations after the hack though. Good luck!
thefisch is offline  
Old 04-28-2014, 10:35 PM
  #6  
Senior Member
 
Join Date: Aug 2008
Location: British Columbia
Posts: 436
Likes: 0
Received 0 Likes on 0 Posts
2011 E350 4 Matic
I have a 2011 and tried the hack found in the "secret menu" and was able to get an android working but in order to get the iphone 5 going i had to get the command updated.

the update add aux volume boost, climate control display on the screen.
2nice4me is offline  
Old 04-28-2014, 11:31 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by 2nice4me View Post
I have a 2011 and tried the hack found in the "secret menu" and was able to get an android working but in order to get the iphone 5 going i had to get the command updated.

the update add aux volume boost, climate control display on the screen.
How do I do it exactly?
beemerfreak is offline  
Old 04-28-2014, 11:45 PM
  #8  
Newbie
 
ttsagris's Avatar
 
Join Date: Mar 2014
Location: Northwest Indiana
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
E350, Z-06, 330xi, Highlander
My 2010 CPO had bluetooth audio enabled when I bought it. It's true that it does work, but not consistently and it's a bit glitchy (at least with an iphone5). It worked fine for a while, then I would have to re-pair the phone and command every so often. Now, it's every time I power off the car and restart. Every time. I'm going to turn it off and see if the problem is fixed. I'm betting the 2010's need a software update for full compatibility. When I find the hack I'll let you know.
ttsagris is offline  
Old 04-29-2014, 12:37 AM
  #9  
Senior Member
 
Join Date: Aug 2008
Location: British Columbia
Posts: 436
Likes: 0
Received 0 Likes on 0 Posts
2011 E350 4 Matic
here are some steps from a previous posts and should do the trick. But otherwise search for the engineering menu.

https://mbworld.org/forums/3862307-post8.html

"Originally Posted by jinx420hat View Post
Alright guys I'll do my best at this... (BT=Bluetooth)

-End Call + # + 1: opens Engineering Mode

- HU Settings

- HU Parameter
(the following are the settings I put them in)
(1) BT contact plate: Not Installed
(2) LCT: Installed
(3) BT audio: On
(4) Audio Aux: Off (greyed out: not an option)
(5) Video Aux: Off
(6) Navi: installed
(7) BT: on

-back buttonx2

-pull command wheel down

- system reset

- reset - yes

- go to audio, then go to the audio tab again to bring up the drop down menu of audio options, select BT audio and activating audio device comes up, then the audio streaming screen"

Last edited by 2nice4me; 04-29-2014 at 12:46 AM.
2nice4me is offline  
Old 04-29-2014, 01:31 AM
  #10  
Junior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by 2nice4me View Post
here are some steps from a previous posts and should do the trick. But otherwise search for the engineering menu.

https://mbworld.org/forums/3862307-post8.html

"Originally Posted by jinx420hat View Post
Alright guys I'll do my best at this... (BT=Bluetooth)

-End Call + # + 1: opens Engineering Mode

- HU Settings

- HU Parameter
(the following are the settings I put them in)
(1) BT contact plate: Not Installed
(2) LCT: Installed
(3) BT audio: On
(4) Audio Aux: Off (greyed out: not an option)
(5) Video Aux: Off
(6) Navi: installed
(7) BT: on

-back buttonx2

-pull command wheel down

- system reset

- reset - yes

- go to audio, then go to the audio tab again to bring up the drop down menu of audio options, select BT audio and activating audio device comes up, then the audio streaming screen"
Now that is what I was looking for thanks a million!!!!
Now I need to go outside and try it out!!
beemerfreak is offline  
Old 04-29-2014, 02:08 AM
  #11  
Junior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
I'm stuck at this part.. It won't pair with my iPhone 5..

beemerfreak is offline  
Old 04-29-2014, 02:46 AM
  #12  
Senior Member
 
Join Date: Aug 2008
Location: British Columbia
Posts: 436
Likes: 0
Received 0 Likes on 0 Posts
2011 E350 4 Matic
That's exactly what was my my car, you try an android and it probably will work. Regardless show that to the dealership and they will do the update.
2nice4me is offline  
Old 04-29-2014, 10:37 AM
  #13  
Senior Member
 
Join Date: May 2013
Location: Boston
Posts: 325
Likes: 0
Received 0 Likes on 0 Posts
2010 E550
I have a 2010, and the dealer update did the trick.
stale-bread is offline  
Old 04-29-2014, 10:55 AM
  #14  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,082
Received 312 Likes on 271 Posts
2011 E550 P2 4M Sedan
Originally Posted by 2nice4me View Post
i had to get the command updated.
Originally Posted by stale-bread View Post
I have a 2010, and the dealer update did the trick.
Would either of you mind explaining how you got the dealer to provide this update? Others have posted that dealers told them there is no way to update comand. Was a specific fix applied to help with BT? AFAIK, there is no way to check the software version in comand so how would someone know if an update was applied other than the issue is no longer present?
thefisch is offline  
Old 04-29-2014, 11:43 AM
  #15  
Senior Member
 
Join Date: May 2013
Location: Boston
Posts: 325
Likes: 0
Received 0 Likes on 0 Posts
2010 E550
This is how I got the dealer to do the upgrade. I had a scheduled service update, so they were going to be working on the car anyways. I told them I'm in sales and my clients are constantly complaining about my Bluetooth connectivity in my new MB. I said this is very important to get this working correctly because my BMW 650 I traded in had zero issues with my phone. The SA stated that they probably know what needs to be done to fix this for you. When I picked it up, the software was updated and Bluetooth audio streaming worked flawlessly.
stale-bread is offline  
Old 04-29-2014, 11:47 AM
  #16  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,082
Received 312 Likes on 271 Posts
2011 E550 P2 4M Sedan
good advice. I assume it was covered under warranty. If not, let us know if there was any charge.
thefisch is offline  
Old 04-30-2014, 12:13 AM
  #17  
Senior Member
 
Join Date: Aug 2008
Location: British Columbia
Posts: 436
Likes: 0
Received 0 Likes on 0 Posts
2011 E350 4 Matic
Originally Posted by thefisch View Post
good advice. I assume it was covered under warranty. If not, let us know if there was any charge.
Yeah mine was under warranty. I just made the adjustment as described above and then complained that the iphone 5 didn't work but android did.

I made sure to call out the fact that the android worked because i was concerned that the dealer may state that this car was not spec'd to have BT streaming.
2nice4me is offline  
Old 04-30-2014, 01:54 AM
  #18  
Junior Member
Thread Starter
 
Join Date: Jan 2007
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
So after trying to get it to work all last night.. Today I successfully got my brothers android note 2 to work with it.. As far as my iPhone 5 no luck.. Now I have to come up with a excuse for the dealer to update the command..
beemerfreak is offline  
Old 04-30-2014, 09:26 AM
  #19  
Senior Member
 
Join Date: May 2013
Location: Boston
Posts: 325
Likes: 0
Received 0 Likes on 0 Posts
2010 E550
Originally Posted by beemerfreak View Post
So after trying to get it to work all last night.. Today I successfully got my brothers android note 2 to work with it.. As far as my iPhone 5 no luck.. Now I have to come up with a excuse for the dealer to update the command..
I gave you one earlier in this thread. Im sure they will upgrade you as long as you are under warranty or have your car serviced by them regularly.
stale-bread is offline  
Old 04-30-2014, 10:08 AM
  #20  
MBWorld Fanatic!
 
Arrie's Avatar
 
Join Date: Oct 2010
Posts: 2,872
Received 85 Likes on 75 Posts
2010 E550
Originally Posted by beemerfreak View Post
So after trying to get it to work all last night.. Today I successfully got my brothers android note 2 to work with it.. As far as my iPhone 5 no luck.. Now I have to come up with a excuse for the dealer to update the command..
Your navigation does not work correctly. If you drive with navi on and want to select a stopover point you should be able to use the MAP tab at the bottom left to see the point on the map before you actually select it as a stopover point. Handy feature when looking for a gas station to see location on the map as you don't want to select something that is too far from your route.

This MAP tab does not work before the update, i.e. the Comand SW update fixes this. It just happens to fix the BT audio too.
Arrie is offline  
Old 05-02-2014, 11:31 PM
  #21  
MBWorld Fanatic!
 
Dema's Avatar
 
Join Date: Jul 2002
Location: California
Posts: 2,677
Likes: 0
Received 2 Likes on 2 Posts
i535
Search the forum for a solution. It was some thread something E class hack where was blue tooth streaming enabling procedure described well. Indeed it works flawlessly for Android phones, but requires some action for every iPhone connection. Later W212 has blue tooth streaming as not hidden feature, although I can't tell difference.
Dema is offline  
Old 05-11-2014, 07:36 AM
  #22  
Newbie
 
Join Date: May 2014
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
2009 ML350
I have a 2009 ML 350, I am not able to do the music streaming. I can only connect bluetooth to the phone portion voice calls only. Please advise
gk768w is offline  
Old 05-11-2014, 06:41 PM
  #23  
Member
 
Join Date: Mar 2014
Location: Sugar Land, TX
Posts: 125
Likes: 0
Received 0 Likes on 0 Posts
2011 E550
I guess I should consider myself lucky. When I got my 2011 E550 the sales rep said it didn't have streaming audio until 2012 so I would have to connect it in the glove compartment that is a bad place to put the connector.

I have an iPhone 5 and after getting the car saw a menu option for Bluetooth and paired my phone and it worked perfectly.

I don't see why this is so much an issue for Mercedes when other cars have had this working fine.
SLpat is offline  
Old 05-11-2014, 10:58 PM
  #24  
Super Member
 
dfordham's Avatar
 
Join Date: Apr 2007
Location: New Mexico
Posts: 561
Likes: 0
Received 1 Like on 1 Post
2014 E350, 2012 SL550
Originally Posted by SLpat View Post
When I got my 2011 E550 the sales rep said it didn't have streaming audio until 2012 so I would have to connect it in the glove compartment that is a bad place to put the connector.
Your salesman was FOS. 2011's had bluetooth streaming. I know, I had one.

Regards,
Don
dfordham is offline  
Old 05-12-2014, 07:39 PM
  #25  
MBWorld Fanatic!
 
thefisch's Avatar
 
Join Date: Mar 2014
Location: West Central Florida
Posts: 3,082
Received 312 Likes on 271 Posts
2011 E550 P2 4M Sedan
Originally Posted by dfordham View Post
Your salesman was FOS. 2011's had bluetooth streaming. I know, I had one.

Regards,
Don
Most are FOS. I wish they would replace salespeople with robots that just hand you the keys for the test drive and pull up specs, brochure, etc. when you need it (like you can do at home). Then I wouldn't mind going to the dealerships as much.
thefisch is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Bluetooth Music Streaming?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: