Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
E550 Airmatic HELP !!!!! >

E550 Airmatic HELP !!!!!

Notices
E-Class (W212) 2010 - 2016: E 350, E 550

E550 Airmatic HELP !!!!!

 
Old 09-18-2018, 12:53 PM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
E550 Airmatic HELP !!!!!

Help I started having issues with the air suspension going down overnight just in the rear of the car then the whole car then it became random front , back , whole car and then sometimes not at all then it it was just one side . So after a few days of that it got where it would not level out at all so I first replaced the valve that distributes air to each wheel then the compressor now I have replaced both rear air bags still the car will not air up the compressor runs 3 cycles and throws the code that says implausable value and then 2 others for the front level sensors are out of range you can keep clearing the code and the rear will air up but the front will not move does anyone have a clue what the heck is going on I am ready to get rid of this car it is driving me crazy . I have been a auto mechanic all my life until a few years ago when I had to have back surgery I have never not been able to figure something out Any help or suggestions would be a big help.
Tmaxxman is offline  
Old 09-18-2018, 02:52 PM
  #2  
MBWorld Fanatic!
 
belarus27's Avatar
 
Join Date: Jun 2013
Location: Sacramento , CA
Posts: 1,802
Received 154 Likes on 145 Posts
2010 e550 p2
Interesting to see what can it be.

im guessing you checked all of the leveling sensors and links if they are in place and working?
belarus27 is offline  
Old 09-18-2018, 03:27 PM
  #3  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
Yes I checked the leveling sensors . This has been a nightmare that I wish I could wake up from.
Tmaxxman is offline  
Old 09-18-2018, 03:43 PM
  #4  
MBWorld Fanatic!
 
KEY08's Avatar
 
Join Date: Oct 2005
Location: Chicagoland
Posts: 3,453
Received 392 Likes on 362 Posts
2014 E550 4Matic Designo Diamond White and loaded up
#1 sorry about your back problems. I know how much that must be frustrating. These Airmatic issues can appear from all types of places. Bad front strut(s), bad rear air spring(s), Bad or improper sensor function, leak in any part of the lines, bad distribution unit, corroded line at compressor, and on. You have spent a lot of money throwing parts in there and unfortunately owners on this board with Airmatic issues have basically all approached the problem in a similar fashion of trial and error. It may be time to take it to a dealer and maybe get it diagnosed and repaired. You won't get hit with a big part cost as you have replaced a lot already (unless the front struts are bad).
Have you checked the rear shocks for leaks? I'm not talking about the air springs. The shocks do help to provide support as well as ride comfort. Like any shock you can see leaks or check their rebound. How many miles are on your car?
I have had 2 Airmatic equipped cars and although I have only had minor faults I get it that they can be a real pain sometimes.
KEY08 is offline  
Old 09-18-2018, 04:38 PM
  #5  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
The shocks show no signs of leaking and my closet dealer is 200 miles away and as low as the car is setting there is no way to get it there you would tear the car to pieces loading it on a trailer or a rollback.
Tmaxxman is offline  
Old 09-19-2018, 07:50 PM
  #6  
MBWorld Fanatic!
 
Arrie's Avatar
 
Join Date: Oct 2010
Posts: 2,872
Received 85 Likes on 75 Posts
2010 E550
If you have a leak in a spring it will leak and let the car down the same way every day. It will not suddenly get random and not go down. I guess you already proved this to yourself by changing the rear air springs and it did not fix anything.

You say you checked the level sensors. How? How do you know they are reading correctly?

If the level sensors are fine and you have replased each air spring control valve and the compressor the thing left is the control module for the AirMatic system. I don’t know where it is but troubleshooting logic says it is the only thing left as the possible problem.
Arrie is offline  
Old 09-19-2018, 11:12 PM
  #7  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
I have a scanner that shows there readings a long with the other related sensors . It has driven me crazy there are only so many components the control module is next to the reserve tank
Tmaxxman is offline  
Old 09-20-2018, 10:02 AM
  #8  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
Here are the codes it shows C156784, C156984, C155664, and this is a new one C155A1F yesterday is the first time this one has showed up.
Tmaxxman is offline  
Old 09-20-2018, 12:27 PM
  #9  
Out Of Control!!
 
konigstiger's Avatar
 
Join Date: Jul 2003
Location: North Scottsdale, AZ
Posts: 10,383
Received 1,164 Likes on 980 Posts
'71 Pinto
Given all you’ve done at this point you have nothing to lose by following suggested remedies in attached bulletins, checking front prefuse box and checking for moisture.
Attached Files
File Type: pdf
AIRmatic, function.pdf (20.2 KB, 63 views)
File Type: pdf
LI32.22-P-057569_Ver_2.pdf (41.5 KB, 43 views)
File Type: pdf
LI32.22-P-048597_Ver_10.pdf (44.0 KB, 34 views)
File Type: pdf
F prefuse.pdf (31.9 KB, 66 views)
konigstiger is offline  
The following 2 users liked this post by konigstiger:
Ferris_E550 (09-27-2018), Tmaxxman (09-20-2018)
Old 09-25-2018, 04:40 PM
  #10  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
come on someone any ideas at all
Tmaxxman is offline  
Old 09-25-2018, 07:22 PM
  #11  
Senior Member
 
mercy-me's Avatar
 
Join Date: Apr 2012
Location: Just north of Detroit,Michigan
Posts: 415
Received 74 Likes on 60 Posts
2003 SL500, 2012 E350 4Matic P2
Sorry for your frustration. I went through a lot with my W220 Airmatic system. It seems like you have a leak somewhere but the randomness of your drooping is a puzzle. You said you replace the main valve distribution block and the pump itself. Were these parts brand new? I rebuilt my pump only to have the case itself develop a leak which forced me to purchased a new one. Your pump is timing out after 3 cycles which suggests either it is not putting out enough volume or you have a leak great enough for the pump to overcome. I don't know what kind of scanner you have but you need an SDS interrogation to run tests and isolate the failed component.

My recommendation is to read through the other forums and search for Airmatic issues since the system is pretty much the same across all the various models that use it. I came across this thread which tells you how to lock the system in the up position.
Don't give up yet!

Bob
mercy-me is offline  
The following 2 users liked this post by mercy-me:
KEY08 (09-26-2018), Tmaxxman (09-26-2018)
Old 09-25-2018, 07:30 PM
  #12  
MBWorld Fanatic!
 
Arrie's Avatar
 
Join Date: Oct 2010
Posts: 2,872
Received 85 Likes on 75 Posts
2010 E550
Originally Posted by Tmaxxman View Post
come on someone any ideas at all
After all responses you say “come on someone any ideas at all”

????

Where the heck do you come from?
Arrie is offline  
Old 09-26-2018, 09:50 AM
  #13  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
Yes all the parts are new
Tmaxxman is offline  
Old 09-26-2018, 09:51 AM
  #14  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
Because none of the ideas have helped that's where I come from . Just trying to get more ideas going
Tmaxxman is offline  
Old 09-26-2018, 10:03 AM
  #15  
MBWorld Fanatic!
 
KEY08's Avatar
 
Join Date: Oct 2005
Location: Chicagoland
Posts: 3,453
Received 392 Likes on 362 Posts
2014 E550 4Matic Designo Diamond White and loaded up
Flat bed the 200 miles or fly in an MB tech. You have limited options beyond what has already been posted. I think this issue may have now beat you.
KEY08 is offline  
Old 09-26-2018, 10:28 AM
  #16  
MBWorld Fanatic!
 
belarus27's Avatar
 
Join Date: Jun 2013
Location: Sacramento , CA
Posts: 1,802
Received 154 Likes on 145 Posts
2010 e550 p2
Originally Posted by Arrie View Post


After all responses you say “come on someone any ideas at all”

????

Where the heck do you come from?
thats what i thought too , but when you desperately in need of help......i guess it is what it is lol
belarus27 is offline  
Old 10-01-2018, 09:04 AM
  #17  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
Well had some success over the weekend got the car to air all the air springs but now it rides very rough there is no give at all, any ideas ? the right side is setting a little higher than the left . Is there a way to reset the control module for the airmatic suspension?
Tmaxxman is offline  
Old 10-01-2018, 03:39 PM
  #18  
MBWorld Fanatic!
 
belarus27's Avatar
 
Join Date: Jun 2013
Location: Sacramento , CA
Posts: 1,802
Received 154 Likes on 145 Posts
2010 e550 p2
Originally Posted by Tmaxxman View Post
Well had some success over the weekend got the car to air all the air springs but now it rides very rough there is no give at all, any ideas ? the right side is setting a little higher than the left . Is there a way to reset the control module for the airmatic suspension?
only if you got a star system... in it you can actually manually adjust the height how you like it and/or reset it. I wish i took a picture while indy shop was doing that for me.
Reading about the problem i got a question , did you change any control arms , or bushings , anything suspension related?

or you just need to get it recalibrated.
belarus27 is offline  
Old 10-01-2018, 07:36 PM
  #19  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
No have not replaced any of that stuff just need it reset
Tmaxxman is offline  
Old 10-04-2018, 11:16 AM
  #20  
Junior Member
Thread Starter
 
Join Date: May 2018
Posts: 18
Received 0 Likes on 0 Posts
2010 E550
Well guys I have given up I am taking the car to a shop . Thanks you to everyone that gave advise but I am today sending off my 3rd payment since not being able to drive the car so it is time to try something different I will post the results when the car is fixed.
Tmaxxman is offline  
Old 11-04-2018, 08:11 PM
  #21  
Newbie
 
Join Date: Sep 2016
Posts: 8
Likes: 0
Received 1 Like on 1 Post
300sd,,300d sold, s320,,& S550
Cool

HI, Tmaxxman,,did you get the car fix,if so what was it ? Reading the posts,to me it sounds like a bad left-front strut !!!
newtoforum2016 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: E550 Airmatic HELP !!!!!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: