Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W213)
Mercedes Me Connect - General User Questions and Tips Thread >

Mercedes Me Connect - General User Questions and Tips Thread

Notices
E-Class (W213) 2016 -

Mercedes Me Connect - General User Questions and Tips Thread

 
Old 12-31-2018, 02:49 PM
  #51  
Newbie
 
Join Date: Nov 2017
Posts: 9
Thanked 1 Time in 1 Post
GLE550e & E534A Cabriolet & SL500 & E320 Sedan & 300SL
I just purchased a 2019 E43A4 Cabriolet and the Mercedes Me Connect app on my iPhone 6 does not work. I've had it one week now and still the app will not work. I am not driving the car and only have 24 miles on it. The dealer reps are very nice and are trying to help --- they say that Mercedes is working on this issue. I have also been told that someone from Mercedes will be contacting me and no one has contacted me. I am wondering if I purchased a "lemon" and should return the car ?
mgardner23665 is offline  
Old 12-31-2018, 03:11 PM
  #52  
Member
 
Join Date: Oct 2018
Location: UK
Posts: 137
Thanked 10 Times in 10 Posts
E Class Estate S213
Originally Posted by mgardner23665 View Post
I just purchased a 2019 E43A4 Cabriolet and the Mercedes Me Connect app on my iPhone 6 does not work. I've had it one week now and still the app will not work. I am not driving the car and only have 24 miles on it. The dealer reps are very nice and are trying to help --- they say that Mercedes is working on this issue. I have also been told that someone from Mercedes will be contacting me and no one has contacted me. I am wondering if I purchased a "lemon" and should return the car ?
i had exactly the same problem and when Mercedes Me got in touch they said I needed to drive for at least an hour or so to enable the server to sync with the car.

When I did that it worked and now is connected all the time and is a great app.

Go do 60-70 miles and see what happens.
JDPEClassUK is offline  
The Following User Says Thank You to JDPEClassUK For This Useful Post:
mgardner23665 (12-31-2018)
Old 12-31-2018, 03:26 PM
  #53  
Newbie
 
Join Date: Nov 2017
Posts: 9
Thanked 1 Time in 1 Post
GLE550e & E534A Cabriolet & SL500 & E320 Sedan & 300SL
Thanks very much for the advice. I'll try driving the car a few more miles. I was just hesitant in case I needed to take the car back ..... On another note, my daughter picked up her new GLC yesterday and the app worked instantly at the dealer.

Happy New Year !
mgardner23665 is offline  
Old 12-31-2018, 03:57 PM
  #54  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,291
Thanked 265 Times in 220 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mgardner23665 View Post
I just purchased a 2019 E43A4 Cabriolet and the Mercedes Me Connect app on my iPhone 6 does not work. I've had it one week now and still the app will not work. I am not driving the car and only have 24 miles on it. The dealer reps are very nice and are trying to help --- they say that Mercedes is working on this issue. I have also been told that someone from Mercedes will be contacting me and no one has contacted me. I am wondering if I purchased a "lemon" and should return the car ?
Your car is NOT a lemon. For some of us, the Mercedes Me Connect process was less than immediate. It took nearly 3 weeks for mine to finally connect. I did have to create a ticket with MBUSA and they were very responsive and had to elevate to some special programming team, operated out of some little city in Germany, but they finally got me connected and all is good with Me Connect now. You definitely do need to take an extended drive for the car to connect with the Satellite, which then connects with the servers all held in Germany.
rbrylaw is offline  
The Following User Says Thank You to rbrylaw For This Useful Post:
mgardner23665 (12-31-2018)
Old 12-31-2018, 04:26 PM
  #55  
Newbie
 
Join Date: Nov 2017
Posts: 9
Thanked 1 Time in 1 Post
GLE550e & E534A Cabriolet & SL500 & E320 Sedan & 300SL
Thank you very much for your insight ... I will take your's and other's advice and take a long ride tomorrow. Personally on another issue of which I do not know if it has been brought up on a forum such as this before --- I'm afraid to contact Mercedes directly as I "got in trouble" with a Mercedes dealer over a 2015 ML350 that we purchased that was in the shop for over a month shortly after we purchased it with issues that they could not correct ..... apparently the dealers get reprimanded by Mercedes if a customer contacts them in New Jersey directly ? Just guessing and don't know for sure sure what happens, but the dealer did hear from Mercedes after my direct contact for help .... Mercedes bought back the 2015 ML and we traded it for a GLE 550e that we really like and enjoy.
mgardner23665 is offline  
Old 12-31-2018, 05:24 PM
  #56  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,291
Thanked 265 Times in 220 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mgardner23665 View Post
Thank you very much for your insight ... I will take your's and other's advice and take a long ride tomorrow. Personally on another issue of which I do not know if it has been brought up on a forum such as this before --- I'm afraid to contact Mercedes directly as I "got in trouble" with a Mercedes dealer over a 2015 ML350 that we purchased that was in the shop for over a month shortly after we purchased it with issues that they could not correct ..... apparently the dealers get reprimanded by Mercedes if a customer contacts them in New Jersey directly ? Just guessing and don't know for sure sure what happens, but the dealer did hear from Mercedes after my direct contact for help .... Mercedes bought back the 2015 ML and we traded it for a GLE 550e that we really like and enjoy.
That's absurd. You should contact MB directly if you ever feel your dealer can't solve something to your satisfaction. In the case of Me Connect, the dealers really can't do anything. There is a Me Connect team at MB headquarters specifically for Me Connect. Call them for help with this. They're the ones with the direct link to the team in Germany.
rbrylaw is offline  
Old 12-31-2018, 05:45 PM
  #57  
Member
 
Join Date: Oct 2018
Location: UK
Posts: 137
Thanked 10 Times in 10 Posts
E Class Estate S213
Originally Posted by rbrylaw View Post
That's absurd. You should contact MB directly if you ever feel your dealer can't solve something to your satisfaction. In the case of Me Connect, the dealers really can't do anything. There is a Me Connect team at MB headquarters specifically for Me Connect. Call them for help with this. They're the ones with the direct link to the team in Germany.
Agreed. The team at Mervedes Me are pretty responsive and donít have anything to do with your dealer and they are the developers of the app.
JDPEClassUK is offline  
Old 12-31-2018, 06:07 PM
  #58  
Senior Member
 
Join Date: May 2018
Location: Long Island, NY
Posts: 407
Thanked 43 Times in 38 Posts
2019 E 450, 2016 E350 4matic (retired), 2018 Ford Edge Sport, 2008 Porsche Boxster
My experience:

Picked up car on Thursday, December 27, 2019. ME Connect up and running on my iPhone by Saturday, December 29 and 100% operational, including tutorial videos, by Sunday, December 30.

No complaints!
JTK44 is offline  
Old 01-04-2019, 05:54 PM
  #59  
Newbie
 
Join Date: Nov 2017
Posts: 9
Thanked 1 Time in 1 Post
GLE550e & E534A Cabriolet & SL500 & E320 Sedan & 300SL
Thanks again .... I'm envious of most of you whose app works !!! I contacted Mercedes directly on January 2 in the AM and I was told that the issue of the app not working has been "escalated" and that I would hear back from them within 24 hours .... I'm patiently waiting and it is now Friday January 4 .... a sales rep told me that I purchased a great car and that I should enjoy it even if the app does not work ?
mgardner23665 is offline  
Old 01-04-2019, 08:34 PM
  #60  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,291
Thanked 265 Times in 220 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mgardner23665 View Post
Thanks again .... I'm envious of most of you whose app works !!! I contacted Mercedes directly on January 2 in the AM and I was told that the issue of the app not working has been "escalated" and that I would hear back from them within 24 hours .... I'm patiently waiting and it is now Friday January 4 .... a sales rep told me that I purchased a great car and that I should enjoy it even if the app does not work ?
Oh. They clearly didn't tell you that's 24 hours in some little German city time? I was told multiple times I'd hear in 24 hours. Only their 24 hours isn't US time. What I did was make myself a daily NUISANCE until they finally got it working for me. Call them daily. Get a case number and memorize it. They will get this resolved. They have for many of us. It's just not quite as fast as we might hope for.
rbrylaw is offline  
Old 01-04-2019, 08:59 PM
  #61  
Newbie
 
Join Date: Dec 2018
Location: Colorado
Posts: 6
Thanked 1 Time in 1 Post
2019 E450 Wagon
I too am having the same experience with Mercedes Me on my new 2019 E450 wagon. Initially there were issues getting the vehicle connected to the app, but that was resolved after being escalated to Germany. Now the remote start feature is not functional and has been escalated as well. I have been told that this is a known issue and a fix is in the works with no ETA on an update.
MountainFisher is offline  
Old 01-04-2019, 09:05 PM
  #62  
Newbie
 
Join Date: Nov 2017
Posts: 9
Thanked 1 Time in 1 Post
GLE550e & E534A Cabriolet & SL500 & E320 Sedan & 300SL
Thanks for the reassurance that it is not only my new car --- however, I do not remember if I mentioned that my daughter picked up her 2019 GLC this past Sunday and the app worked instantly at the dealer. This just added to my disappointment and frustration with Mercedes.
mgardner23665 is offline  
Old 01-04-2019, 09:35 PM
  #63  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,291
Thanked 265 Times in 220 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by mgardner23665 View Post
Thanks for the reassurance that it is not only my new car --- however, I do not remember if I mentioned that my daughter picked up her 2019 GLC this past Sunday and the app worked instantly at the dealer. This just added to my disappointment and frustration with Mercedes.
Yet again, no one explained that the app works like roulette wheel. The ball lands in the right slot instantly for some. And as you've now learned, the ball not so instantly for others. Sorry you're one of the others. But you're in good company and there is light at the end of the tunnel. There really is.
rbrylaw is offline  
Old 01-05-2019, 11:48 AM
  #64  
Newbie
 
Join Date: Dec 2018
Location: Colorado
Posts: 6
Thanked 1 Time in 1 Post
2019 E450 Wagon
mgardner- there is hope. I just randomly tried the app this am and it worked. I did not receive any communication from MB that the fix had been applied, so I guess the roulette ball finally landed on my number.
MountainFisher is offline  
Old 01-06-2019, 03:46 AM
  #65  
MBWorld Fanatic!
 
2012 merc amg's Avatar
 
Join Date: Jul 2013
Location: Venice Florida
Posts: 2,531
Thanked 137 Times in 123 Posts
2019 E450 Cabriolet and 2019 E450 Wagon.
Originally Posted by rbrylaw View Post
This is the second thread I've started for Mercedes Me Connect. For 2019, Mercedes opened a new App for the 2019 cars. Some of us had significant issues getting activated to Mercedes servers (myself included). We'll leave that thread open for new people who purchase a 2019 and can't get connected.

This thread will be a general user questions and tips thread. Topics like how to do you get a message that you forgot to lock your car to appear, or how do you send an address to your car, would be the types of questions that would serve this thread best.
Strange the app does not work for either of my cars anymore for remote lock and unlock and remote start ?
2012 merc amg is online now  
Old 01-06-2019, 05:20 AM
  #66  
Super Member
 
guhvies's Avatar
 
Join Date: Feb 2006
Location: Bromley, UK
Posts: 759
Thanked 73 Times in 69 Posts
2017 C43 AMG Saloon
Originally Posted by 2012 merc amg View Post


Strange the app does not work for either of my cars anymore for remote lock and unlock and remote start ?
Oh oh, looks like you've entered the MB Twilight Zone (c)(tm)...
guhvies is offline  
Old 01-06-2019, 06:13 AM
  #67  
Senior Member
 
Join Date: Jan 2015
Posts: 341
Thanks: 0
Thanked 17 Times in 16 Posts
C class s205 250 bluetec executive line 4matic
I find the mercedes me app is inaccessible quite reguarly so i also have a shortcut to the mercedes me portal on my phone and usually that is available even if the app is not. It looks a lot different but you can still do all the things you can via the app.
just occasionally both are down at the same time.....not sure why mercedes is having such a difficult time with the technology.
parkwood is offline  
Old 01-06-2019, 08:58 AM
  #68  
Senior Member
 
nycebo's Avatar
 
Join Date: Nov 2014
Location: New York, NY
Posts: 443
Thanked 31 Times in 25 Posts
Mercedes Benz e450 Wagon / Porsche 911 Cabriolet
Does your car have good signal?
nycebo is offline  
Old 01-06-2019, 10:01 AM
  #69  
Senior Member
 
Join Date: Jan 2015
Posts: 341
Thanks: 0
Thanked 17 Times in 16 Posts
C class s205 250 bluetec executive line 4matic
I live in rural france so 3g/4g is a bit patchy with a few "white zones" around. However it is rare for the in car internet hotspot to fall over or not to connect and rarer still for the sos system not to connect. So in general i would say i have a good connection with mercedes central control for want of a better description.
However when using the app on home wi fi mercedes me connect is not always accessible it just says try again. I normally find the portal gives me access but occasionally this will also not connect. I have assumed it is access into mercedes servers by my phone or rarely pc that is the issue rather than the car not connecting. Next time i will check if i can the status of the car connection.
parkwood is offline  
Old 01-08-2019, 09:02 PM
  #70  
MBWorld Fanatic!
 
2012 merc amg's Avatar
 
Join Date: Jul 2013
Location: Venice Florida
Posts: 2,531
Thanked 137 Times in 123 Posts
2019 E450 Cabriolet and 2019 E450 Wagon.
I logged out and back in on the computer to the portal, now the app works with my Convertible E450 but still not my Wagon, I give up, lol.
2012 merc amg is online now  
Old 01-08-2019, 09:04 PM
  #71  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,291
Thanked 265 Times in 220 Posts
2019 E450 4Matic & 2018 E400 4Matic
After all this time has it still never worked with the Wagon?
rbrylaw is offline  
Old 01-08-2019, 10:05 PM
  #72  
MBWorld Fanatic!
 
2012 merc amg's Avatar
 
Join Date: Jul 2013
Location: Venice Florida
Posts: 2,531
Thanked 137 Times in 123 Posts
2019 E450 Cabriolet and 2019 E450 Wagon.
It did work but doesnít anymore for some reason. If I didnít have the convertible Iíd think maybe it was the system but nope gotta be something weird with the wagon. It does do things with the wagon like tell me the doors are closed. Tire pressure etc. it Just wonít lock/unlock or start that car.
2012 merc amg is online now  
Old 01-08-2019, 10:32 PM
  #73  
Senior Member
 
nycebo's Avatar
 
Join Date: Nov 2014
Location: New York, NY
Posts: 443
Thanked 31 Times in 25 Posts
Mercedes Benz e450 Wagon / Porsche 911 Cabriolet
Does it work from the web portal?
nycebo is offline  
Old 01-09-2019, 12:39 AM
  #74  
MBWorld Fanatic!
 
2012 merc amg's Avatar
 
Join Date: Jul 2013
Location: Venice Florida
Posts: 2,531
Thanked 137 Times in 123 Posts
2019 E450 Cabriolet and 2019 E450 Wagon.
Does the same thing on the Portal, the progress gauge just keeps spinning around when I try to lock or unlock or remote start. It all works fine on my Cabriolet with either the Portal or my iPhone. I'm not going to worry about it at this point, I've wasted enough time on it.
2012 merc amg is online now  
Old 01-18-2019, 10:37 PM
  #75  
MBWorld Fanatic!
Thread Starter
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,291
Thanked 265 Times in 220 Posts
2019 E450 4Matic & 2018 E400 4Matic
Since last night, I haven't been able to open or use the Me Connect app. Mercedes Me works fine for the E400, but the Me Connect app, just spins and spins. Are any of you not able to get the app to do anything?
rbrylaw is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Mercedes Me Connect - General User Questions and Tips Thread


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: