Go Back  MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > GL Class (X164)
Bought a 2010 GL 550 and here are my problems >

Bought a 2010 GL 550 and here are my problems

Notices
GL Class (X164) 2007-2012: GL320CDI, GL420CDI, GL450, GL550

Bought a 2010 GL 550 and here are my problems

 
Old 09-24-2018, 04:50 PM
  #1  
Member
Thread Starter
 
Join Date: Sep 2018
Posts: 96
Received 0 Likes on 0 Posts
2010 GL 550 + 2010 GLK 350
Exclamation Bought a 2010 GL 550 and here are my problems

Hi folks,
I got a used 2010 GL 550 (125000km, 77000 miles) couple of weeks ago and so far I was quite happy with the car with the exceptions of the problems below:
1) Start is very slow, its like the car is not a huge fan of cranking. I thought it was related to the battery and have it replaced but the problem continues. I took it to a mechanic and read through this forum and he says it might be the crank sensor and I think (from this forum), it is the cable harness that is feeding the starter from the battery that needs to be replaced. This is bothering me a lot as winter is coming and I'm in Canada.
2) AC is sometimes working, sometimes not. When it works, it cools fine, so I don't think it needs new gas but has some other problem. In winter thats ok but I hate it.
3) Rear hatch is really slooooooooow, I think (from what I read here) it needs oil change
4) The car is super uncomfortable. I don't think my suspension is dead because I can raise the car with Airmatic, play with suspension settings and they all seem to work, but still the car is very stiff and not as comfortable as I would expect. I think 21 inch (295/40/R21 tires on them) wheels have something to do with it. Any ideas?
5) Some seats are squeaky and I hate it!
6) Consumes a hell of gas, I can do 15 (16l/100km) mpg with premium gas. On highway only, I could do 20.5 mpg (11.5 lt/100km) and in city (with very little idling) it becomes 13 mpg (18 l/100km). I bought the car cheapish and I'm kind of OK with it. I just wish it consumed a bit less.
7) Bluetooth does not have streaming and it stutters after 5 minutes of talking on the phone and I hate it. I may even replace the stereo because of this.
8) Usability of Comand really sucks. It takes minutes to enter an address. ****ty system and super complicated and confusing.
9) Lights when in short beams, don't go far away. (High beams are perfect though)

I love the car overall, I am just debating whether I should do a total overhaul and try to use it for 3 years or just let it go when I have the chance. It was in a great condition when I bought it but these were the small issues that I've overlooked.
Your suggestions along with item numbers are extremely appreciated. I just don't know where to begin and what to do. My biggest concern is the crank/start issue as I will be screwed if it doesn't start one morning and I can not go to work. I am asking you all about of these problems because I'm kind of falling in love with the car. Its like being in a very problematic and love-filled relationship
ignorant is offline  
Old 09-24-2018, 05:33 PM
  #2  
MBWorld Fanatic!
 
Join Date: Nov 2017
Location: Bethesda, MD
Posts: 1,211
Received 131 Likes on 124 Posts
2010 Mercedes GL450; 2000 Mercedes ML55 AMG; 2016 VW GLI SEL Stick!!!
Originally Posted by ignorant View Post
Hi folks,
I got a used 2010 GL 550 (125000km, 77000 miles) couple of weeks ago and so far I was quite happy with the car with the exceptions of the problems below:
1) Start is very slow, its like the car is not a huge fan of cranking. I thought it was related to the battery and have it replaced but the problem continues. I took it to a mechanic and read through this forum and he says it might be the crank sensor and I think (from this forum), it is the cable harness that is feeding the starter from the battery that needs to be replaced. This is bothering me a lot as winter is coming and I'm in Canada.
2) AC is sometimes working, sometimes not. When it works, it cools fine, so I don't think it needs new gas but has some other problem. In winter thats ok but I hate it.
3) Rear hatch is really slooooooooow, I think (from what I read here) it needs oil change
4) The car is super uncomfortable. I don't think my suspension is dead because I can raise the car with Airmatic, play with suspension settings and they all seem to work, but still the car is very stiff and not as comfortable as I would expect. I think 21 inch (295/40/R21 tires on them) wheels have something to do with it. Any ideas?
5) Some seats are squeaky and I hate it!
6) Consumes a hell of gas, I can do 15 (16l/100km) mpg with premium gas. On highway only, I could do 20.5 mpg (11.5 lt/100km) and in city (with very little idling) it becomes 13 mpg (18 l/100km). I bought the car cheapish and I'm kind of OK with it. I just wish it consumed a bit less.
7) Bluetooth does not have streaming and it stutters after 5 minutes of talking on the phone and I hate it. I may even replace the stereo because of this.
8) Usability of Comand really sucks. It takes minutes to enter an address. ****ty system and super complicated and confusing.
9) Lights when in short beams, don't go far away. (High beams are perfect though)

I love the car overall, I am just debating whether I should do a total overhaul and try to use it for 3 years or just let it go when I have the chance. It was in a great condition when I bought it but these were the small issues that I've overlooked.
Your suggestions along with item numbers are extremely appreciated. I just don't know where to begin and what to do. My biggest concern is the crank/start issue as I will be screwed if it doesn't start one morning and I can not go to work. I am asking you all about of these problems because I'm kind of falling in love with the car. Its like being in a very problematic and love-filled relationship

these cars require lots of love. And are usually neglected from their previous owners so they often need some overdue maintenance.


1. You are right. Or your mechanic. Crank sensor or harness. Or maybe even starter.

2. I had this. It can be fixed sometimes with a regassing and evacuation, or a new blower which is expensive.

4. If possible check if your struts have been replaced before. They might be leaking. Otherwise I highly think the level sensors/rods are seized. Lube then up and make sure they move freely and then reset the airmatic height. One on each corner. I had this, the cause was the level sensors being seized in the rear. Ended up being replaced.

5. Lube joints. Especially rear seats.

6. Normal. Donít complain. You have a 5,5 liter. I get the same from a 4.6 😢

7. Don't replace the command system. It's arduous but it works. Use coolstream carpro for Bluetooth streaming with audio names. I have th is and it connects with the iPod pin and allows you to play music from your iPhone using Spotify etc to the command system and shows track and artist names most of th r time. Works great! $75

8. Read through the command manual and it might demystify some things. Other things are just hard to get too. I would buy a car mount and use waze.

9. You have a 550. So yours came standard with the lighting package. Yours is as old as mine and I also have th lighting package. Mine are original and they're very blue compared to my 2016 gli which are white. I think the bkubs are old and necessitate replacement. I would change the bulbs and then reports back. Try the Philips xtremevision. I think I will buy those soon.

Best of luck. Ask questions and a lot of them and do please report back on any issues, solutions and other hhjngs that come up. They help a lot of people in the future and keep the dialogue going.

Also don't take the flack or naysayers too personally. Some people have very short tempers on here.

Cheers!

kombifan is offline  
The following users liked this post:
ignorant (09-24-2018)
Old 09-24-2018, 10:03 PM
  #3  
Member
Thread Starter
 
Join Date: Sep 2018
Posts: 96
Received 0 Likes on 0 Posts
2010 GL 550 + 2010 GLK 350
Dear @kombifan, huge thanks for your honest and sincere answer! Will surely listen to your advice.
First and easiest step will be to order coolstream carpro. Saw some other ones that are around 30 bucks at Amazon, worth a try, dont you think?
ignorant is offline  
Old 09-24-2018, 10:15 PM
  #4  
MBWorld Fanatic!
 
Join Date: Nov 2017
Location: Bethesda, MD
Posts: 1,211
Received 131 Likes on 124 Posts
2010 Mercedes GL450; 2000 Mercedes ML55 AMG; 2016 VW GLI SEL Stick!!!
Originally Posted by ignorant View Post
Dear @kombifan, huge thanks for your honest and sincere answer! Will surely listen to your advice.
First and easiest step will be to order coolstream carpro. Saw some other ones that are around 30 bucks at Amazon, worth a try, dont you think?

Be careful. There are two versions. The carpro I mentioned and the coolstream duo.

The carpro is this one and you do need the special mercedes version. CoolStream Bluetooth Adapter 2011 Earlier Mercedes iPod iPhone 30 Pin Cable CarPro https://www.amazon.com/dp/B017RW3DLG/ref=cm_sw_r_cp_api_fMzQBbG122518
It let's you use the iPod pin to play music and showethe music tracks.

The other one is the coolstream duo which uses the iPod pin to charge and then the aux jack to play the music.the duo is also $30 and I fear that what you are seeing is just an aux jack input.

I had that one too but ended up hanging to the carpro because it just worked 10x better for me. I hated not being able to use the car steering wheel and command button for the duo and hbe carpro let me have all functionality I expected from a Bluetooth system as it should have come from the factory. The carpro works just as if it was connected via an iPod.
kombifan is offline  
Old 09-25-2018, 10:04 AM
  #5  
EWT
Member
 
Join Date: Jan 2007
Posts: 205
Received 5 Likes on 5 Posts
08 GL550, 95 Supra TT
Originally Posted by ignorant View Post
Hi folks,
I got a used 2010 GL 550 (125000km, 77000 miles) couple of weeks ago and so far I was quite happy with the car with the exceptions of the problems below:
1) Start is very slow, its like the car is not a huge fan of cranking. I thought it was related to the battery and have it replaced but the problem continues. I took it to a mechanic and read through this forum and he says it might be the crank sensor and I think (from this forum), it is the cable harness that is feeding the starter from the battery that needs to be replaced. This is bothering me a lot as winter is coming and I'm in Canada.
2) AC is sometimes working, sometimes not. When it works, it cools fine, so I don't think it needs new gas but has some other problem. In winter thats ok but I hate it.
3) Rear hatch is really slooooooooow, I think (from what I read here) it needs oil change
4) The car is super uncomfortable. I don't think my suspension is dead because I can raise the car with Airmatic, play with suspension settings and they all seem to work, but still the car is very stiff and not as comfortable as I would expect. I think 21 inch (295/40/R21 tires on them) wheels have something to do with it. Any ideas?
5) Some seats are squeaky and I hate it!
6) Consumes a hell of gas, I can do 15 (16l/100km) mpg with premium gas. On highway only, I could do 20.5 mpg (11.5 lt/100km) and in city (with very little idling) it becomes 13 mpg (18 l/100km). I bought the car cheapish and I'm kind of OK with it. I just wish it consumed a bit less.
7) Bluetooth does not have streaming and it stutters after 5 minutes of talking on the phone and I hate it. I may even replace the stereo because of this.
8) Usability of Comand really sucks. It takes minutes to enter an address. ****ty system and super complicated and confusing.
9) Lights when in short beams, don't go far away. (High beams are perfect though)

I love the car overall, I am just debating whether I should do a total overhaul and try to use it for 3 years or just let it go when I have the chance. It was in a great condition when I bought it but these were the small issues that I've overlooked.
Your suggestions along with item numbers are extremely appreciated. I just don't know where to begin and what to do. My biggest concern is the crank/start issue as I will be screwed if it doesn't start one morning and I can not go to work. I am asking you all about of these problems because I'm kind of falling in love with the car. Its like being in a very problematic and love-filled relationship
I have an 08 GL550 and I've had several of the same issues. My A/C started acting up after my compressor failed (and was replaced by the dealer). It seems to almost always occur when the vehicle is really hot and the A/C goes to Max A/C. I took it back in, the dealer flashed the HVAC controller with some kind of update and evacuated and refilled the system. The system worked better, but still turns off at times on hot days. I've found that manually turning the fan speed down a couple of notches and not allowing it to go to Max A/C usually keeps the A/C from cycling off.

I fixed the lack of bluetooth streaming by attaching a bluetooth adapter to the aux cable:
Amazon Amazon
They also make them for Apple 30 pin connectors if yours is equipped with that.. It isn't as convenient as a stereo that does it automatically, but it works. I've been giving some though to using something like an AVID head unit too though since the OEM system is so bad. I haven't used the Command system for years - it was bad when it was new and awful now.

My headlights were pretty bad too. The bowls behind the bulbs deteriorate and don't do a very good job of providing light output. It requires removing the headlights from the car and opening them up, but I fixed mine by replacing the factory projectors with EVOX-R bi-xenon projectors, which are dramatically better the 9 year old OEM projectors they replaced. I did a write-up with some pictures at: https://mbworld.org/forums/gl-class-...erience-2.html

The ride shouldn't be stiff unless the vehicle is in sport mode. It is pretty cushy in normal and especially in the comfort setting where it is downright floaty. The only time I've had ride issues is when a strut has failed and the car won't rise to a normal ride height. Does one corner or end of the car drop overnight? If you plan to keep it for a few years, Arnott is the the go-to for replacement air suspension parts. The parts fail regularly and they are great at honoring their lifetime warranty.

We have 186K on ours and will keep it until something major fails at this point. It is still a great family hauler and doesn't look like a 10 year old SUV with that many miles - the exterior and interior have held up amazingly well.
EWT is offline  
Old 12-29-2018, 08:10 PM
  #6  
Newbie
 
Join Date: Dec 2018
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
GL 450 X164 2008
Hi
What means "regassing and evacuation"?
michelfloride is offline  
Old 12-29-2018, 09:01 PM
  #7  
MBWorld Fanatic!
 
Join Date: Nov 2017
Location: Bethesda, MD
Posts: 1,211
Received 131 Likes on 124 Posts
2010 Mercedes GL450; 2000 Mercedes ML55 AMG; 2016 VW GLI SEL Stick!!!
It means removing the r134a refrigerant safely and completely and then refilling with the correct amount.
kombifan is offline  
Old 12-31-2018, 02:59 PM
  #8  
Junior Member
 
Join Date: Dec 2018
Posts: 43
Received 7 Likes on 7 Posts
GL 550
Originally Posted by ignorant View Post
Dear @kombifan, huge thanks for your honest and sincere answer! Will surely listen to your advice.
First and easiest step will be to order coolstream carpro. Saw some other ones that are around 30 bucks at Amazon, worth a try, dont you think?

If I were you, I would go with the 9" AVIN Android Oreo head unit....super easy to install (no wires to cut) and totally upgrades this vehicle to the current century!!! Huge big touch screen system that looks factory The cost is more than if you do an add on streaming device, but you can do so much more with it. If you plan to keep the vehicle for 3 years plus, its definitely worth it. Shoot, I can stream SlingTV when I am stuck in bumper to bumber traffic so its nice to hear the news or listen to Sportscenter, etc during rush hour.........keeps the road rage to a minimum......LOL.

As for the head lights, totally agree....I would replace the D1S bulbs to start. I replaced mine and they seem to work much better. I skimped though and didnt get the OSRAM Xenarc bulbs, so I think I am going to get them or as kombifan mentioned the Philips.

For your suspension issue....did you notice a difference in when you switched from Sport, Auto, and Comfort mode on your suspension settings? Didn't like any of the changes? I also know the big wide 21" wheels do play some part in the ride feel as well.

Anyway...good luck with your rig...sure you'll get it where you want it once you've had time time with it.

Last edited by Iceytys; 12-31-2018 at 03:09 PM.
Iceytys is offline  
Old 01-01-2019, 09:10 PM
  #9  
MBWorld Fanatic!
 
Join Date: Nov 2017
Location: Bethesda, MD
Posts: 1,211
Received 131 Likes on 124 Posts
2010 Mercedes GL450; 2000 Mercedes ML55 AMG; 2016 VW GLI SEL Stick!!!
Originally Posted by EWT View Post
I have an 08 GL550 and I've had several of the same issues. My A/C started acting up after my compressor failed (and was replaced by the dealer). It seems to almost always occur when the vehicle is really hot and the A/C goes to Max A/C. I took it back in, the dealer flashed the HVAC controller with some kind of update and evacuated and refilled the system. The system worked better, but still turns off at times on hot days. I've found that manually turning the fan speed down a couple of notches and not allowing it to go to Max A/C usually keeps the A/C from cycling off.

I fixed the lack of bluetooth streaming by attaching a bluetooth adapter to the aux cable: https://www.amazon.com/Mpow-Bluetoot...s=a2dp+adapter They also make them for Apple 30 pin connectors if yours is equipped with that.. It isn't as convenient as a stereo that does it automatically, but it works. I've been giving some though to using something like an AVID head unit too though since the OEM system is so bad. I haven't used the Command system for years - it was bad when it was new and awful now.

My headlights were pretty bad too. The bowls behind the bulbs deteriorate and don't do a very good job of providing light output. It requires removing the headlights from the car and opening them up, but I fixed mine by replacing the factory projectors with EVOX-R bi-xenon projectors, which are dramatically better the 9 year old OEM projectors they replaced. I did a write-up with some pictures at: https://mbworld.org/forums/gl-class-...erience-2.html

The ride shouldn't be stiff unless the vehicle is in sport mode. It is pretty cushy in normal and especially in the comfort setting where it is downright floaty. The only time I've had ride issues is when a strut has failed and the car won't rise to a normal ride height. Does one corner or end of the car drop overnight? If you plan to keep it for a few years, Arnott is the the go-to for replacement air suspension parts. The parts fail regularly and they are great at honoring their lifetime warranty.

We have 186K on ours and will keep it until something major fails at this point. It is still a great family hauler and doesn't look like a 10 year old SUV with that many miles - the exterior and interior have held up amazingly well.
have you thought about replacing the drier?
kombifan is offline  
Old 01-02-2019, 10:49 AM
  #10  
Super Member
 
Join Date: Jun 2010
Location: San Diego, CA, USA
Posts: 634
Received 60 Likes on 52 Posts
2007 GL450
May I suggest next time don't use the forums to dump your laundry list of issues. You end up with an overwhelming number of overlapping threads.

The issue with the starter is discussed elsewhere at length. I am not familiar with the alternative problems, namely the wiring harness and the crank sensor, but it seems like the starter itself is a major contributor - and it is a wear item, unlike the other causes. Check whether the motor is slower to crank when warm; this seems like a symptom of wear. 77k miles seems low for starter failure, but it simply is a matter of revolutions turned - which raises questions about those idiotic start-stop systems, if you think about it.
eric_in_sd is offline  
Old 01-02-2019, 12:49 PM
  #11  
Member
Thread Starter
 
Join Date: Sep 2018
Posts: 96
Received 0 Likes on 0 Posts
2010 GL 550 + 2010 GLK 350
Originally Posted by eric_in_sd View Post
May I suggest next time don't use the forums to dump your laundry list of issues. You end up with an overwhelming number of overlapping threads.

The issue with the starter is discussed elsewhere at length. I am not familiar with the alternative problems, namely the wiring harness and the crank sensor, but it seems like the starter itself is a major contributor - and it is a wear item, unlike the other causes. Check whether the motor is slower to crank when warm; this seems like a symptom of wear. 77k miles seems low for starter failure, but it simply is a matter of revolutions turned - which raises questions about those idiotic start-stop systems, if you think about it.
Eric, you are correct. I shouldn't have done that but a bit scared once I got the car.
Now everything is slowly working out huge thanks to the members of this forum.

About my starter, it may actually be the starter itself as you've mentioned.
I'll try to have it checked by someone professional, but unfortunately I'm living in a very small city which doesn't have any MB indy.

Would OBD scanners help?
ignorant is offline  
Old 01-02-2019, 03:06 PM
  #12  
Super Member
 
Join Date: Jun 2010
Location: San Diego, CA, USA
Posts: 634
Received 60 Likes on 52 Posts
2007 GL450
Originally Posted by ignorant View Post
Eric, you are correct. I shouldn't have done that but a bit scared once I got the car.
Now everything is slowly working out huge thanks to the members of this forum.
Yeah, there's a bunch of great supportive guys here. Shout out to all, and wishing you a healthy and prosperous New Year.
Try not to panic. I've felt it many times and it's not healthy.

Originally Posted by ignorant View Post
About my starter, it may actually be the starter itself as you've mentioned.
I'll try to have it checked by someone professional, but unfortunately I'm living in a very small city which doesn't have any MB indy.
Would OBD scanners help?
You emphatically should own a good scan tool. Mercedes Medic does a decent write-up on them. I like the MB-II. STAR is big and confusing, but people say it's the ultimate. You can do simple OBD with a $7bux bluetooth adapter.
None will help with the starter problem, unfortunately.
The GL550 is a beeyatch to change the starter on, or so I am told. If I was you I'd bite the bullet and do it. You'll get cascading problems, like killing the battery, if you keep a marginal starter in there.
eric_in_sd is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Bought a 2010 GL 550 and here are my problems


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: