Notices
M-Class (W166) 2012, Read about the upcoming M-Class

Smell when starting AC

 
Old 07-03-2012, 08:31 PM
  #26  
Super Member
 
iankayem's Avatar
 
Join Date: Jul 2010
Location: Australia
Posts: 623
Thanks: 0
Thanked 1 Time in 1 Post
GLE500e 2017, ML350 BlueTec 2012(sold), A200 2013, ML350CDI 2009(sold), Aston Martin DB7 2003
Surely people have heard of legionare's disease.
iankayem is offline  
Old 07-03-2012, 10:04 PM
  #27  
Senior Member
 
Join Date: Oct 2011
Posts: 357
Thanks: 0
Thanked 0 Times in 0 Posts
2012 ML 350 BlueTec
Originally Posted by iankayem View Post
Surely people have heard of legionare's disease.
Funny you mention that. I worked at the Bellevue after the outbreak. There is a ghost on the 12 floor that all the employees have encountered.
katiesdad7 is offline  
Old 07-05-2012, 10:49 AM
  #28  
Super Member
 
Join Date: Mar 2012
Location: East part of Texas
Posts: 567
Thanked 17 Times in 15 Posts
2017 CLS550
Here is something a person posted at another forum as to where the air conditioning condensation is going: "OK fwiw here's one svc dept answer - there are body panels underneath the drain for the A/C (noise reduction, aerodynamic, that sort of thing) - the condensate drains onto the inner surface of the panels and is evaporated by airflow when the vehicle is in motion - only prolonged sitting and large amount of drainage would result in piddling like a Harley on the ground. Works for me. No fancy recycling of condensate or anything like that. Case closed for me".
shortspark is online now  
Old 07-05-2012, 02:22 PM
  #29  
Member
 
Join Date: May 2012
Location: Gresham, OR
Posts: 157
Thanked 1 Time in 1 Post
2013 ML 350
It seems to me that the smell is generated from within the system itself. If the water is indeed draining onto a panel or where ever, then one would think there should be no smell. If I were going to Star Fest it would be interesting to take a mason jar filled with the air conditioning aroma and put in on the table where the M-B big wigs sit and explain to them that this is what their $50K + cars smell like.
frtdog is offline  
Old 07-08-2012, 05:09 AM
  #30  
Junior Member
 
Join Date: Mar 2012
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
W204
I've the same experience on my c class. Do you use the auto function of the AC? Also, always let fresh air in while the AC is on.

What you can do now is to clean the AC and replace a new filter.
paupauchu88 is offline  
Old 07-08-2012, 07:07 AM
  #31  
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
2012 ML350
Originally Posted by paupauchu88 View Post
I've the same experience on my c class. Do you use the auto function of the AC? Also, always let fresh air in while the AC is on.

What you can do now is to clean the AC and replace a new filter.
I always use the auto function . How do you let fresh air in always? I never use the button for circulating air inside only.
Thanks
GA350 is offline  
Old 07-10-2012, 05:09 PM
  #32  
Junior Member
Thread Starter
 
Join Date: Mar 2012
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
2012 ML350
Finally got a chance to go to the service center. They accepted the smell was real and changed the cabin filters and dual filter ( something that nature ). Initially wanted me to pay indicating that it's a maintainance issue and not covered warranty, but I showed my extreme unhappiness on this remark as the car is hardly 3000 miles old. Then they agree to do it free of cost to me. It saved $200 from my expenses.
So far no smell, but will watch.
I was told the super condenser which gets the drainage needs drying on and off, and they recommend me keeping the car few hours out in sun once in a while. They also told me that they have noticed this in those cars parked in garages( mine is 100% times). Wearied ...
GA350 is offline  
Old 07-12-2012, 10:05 AM
  #33  
Junior Member
 
Join Date: Mar 2012
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
W204
Originally Posted by GA350 View Post
I always use the auto function . How do you let fresh air in always? I never use the button for circulating air inside only.
Thanks
Auto function can allow fresh air in. That's fine.

I do the AC cleaning and replace the air-filter and the smell is gone. But it comes back around 20000km
paupauchu88 is offline  
Old 07-14-2012, 06:47 PM
  #34  
Newbie
 
Join Date: Apr 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
2008 C300 Sport
For real!! Lol
KgdmCitzn is offline  
Old 09-12-2012, 04:15 PM
  #35  
Newbie
 
Join Date: Sep 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2012 ML 350 BlueTec
ML 350 Bluetec Smell

Iím having the same problem since the day I drove off the lot. Itís been in the shop three times and I still have the same horrible smell. Itís beyond ridiculous I am going to hire an attorney to get out of this lemon. No water drips out while the AC is on I think it is collecting somewhere and its creating mold. Someone needs to bring this to light I'm getting sick head aches everyday now. I have never had this problem with any other car I've owned Mercedes-Benz for 20 years and this has never happened before.

Originally Posted by GA350 View Post
I have noticed a very bad or mushy smell when I start my car with A/C off( after I have shut the car for sometime and the AC was running when i shut the car).
This gets better in 10-15 seconds after I turn the AC on. The smell is a very strong smell of moisture with stangnant air....
Does anyone have the same experience?
I am worried as it might be a problem with my cabin air filter.
My car is only 3000miles on it.
Thanks
Tahoeoz is offline  
Old 09-13-2012, 11:15 PM
  #36  
MBWorld Fanatic!
 
Join Date: Jul 2003
Location: Lake Oswego, OR
Posts: 3,317
Thanked 101 Times in 81 Posts
2020 GLE 450 (on order); 2012 ML350; 2015 M4 Coupe
AC smell

This occurred on my W164 after a few years, not yet on my W166. The problem is moisture on the coils growing things. If possible, try to turn off the AC a few minutes before turning off the car to dry the coils out. I must say, this has not been an issue on my two BMW M3s or other cars, so not sure what is different.
GregW / Oregon is offline  
Old 09-14-2012, 12:53 PM
  #37  
JAM
Senior Member
 
Join Date: Jun 2003
Location: US-Philadelphia
Posts: 260
Thanks: 0
Thanked 0 Times in 0 Posts
SL600
Have had this on MANY MB products including my 07 S550 and 12 ML. Issue is always the condensor needs to be cleaned out. Have NEVER had this issue on any car other than MB product. No excuse for it in my mind. My 2001 Range Rover has never had to have the condensor core cleaned and has no odor to the AC whatsoever.
JAM is offline  
Old 06-23-2013, 11:14 PM
  #38  
Newbie
 
Join Date: Jun 2013
Location: GTA, Canada
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2013 ML350 BT, 2016 C450
I'm getting the same smell at start up.
Get this really foul smell at start up that lasts for about 15 seconds.

We have had this vehicle for 9 months.
This started once the weather started warming up in May.
The other issue is that this odour seems to have permeated into the vehicle and whenever we get into the vehicle there is a trace of this foul odour in the car.

I've been to the dealer twice for this issue. The problem I have is that both times we haven't been able to reproduce the smell.

They have sprayed whatever they use into the AC system and there's still no improvement.
To make matters worse, the dealer is claiming this is not a warranty issue and has charged me for this "service".

This is our second ML. First was a 2009 which never had this issue.
I have never had a previous or current vehicle with this issue.

It's bad enough that unless this gets resolved I will be trading in this vehicle soon, which is not something I would want to do. I think its a great vehicle otherwise.
Rinial is offline  
Old 06-23-2013, 11:55 PM
  #39  
MBWorld Fanatic!
 
Join Date: Jul 2003
Location: Lake Oswego, OR
Posts: 3,317
Thanked 101 Times in 81 Posts
2020 GLE 450 (on order); 2012 ML350; 2015 M4 Coupe
Originally Posted by Rinial View Post
I'm getting the same smell at start up.
Get this really foul smell at start up that lasts for about 15 seconds.

We have had this vehicle for 9 months.
This started once the weather started warming up in May.
The other issue is that this odour seems to have permeated into the vehicle and whenever we get into the vehicle there is a trace of this foul odour in the car.

I've been to the dealer twice for this issue. The problem I have is that both times we haven't been able to reproduce the smell.

They have sprayed whatever they use into the AC system and there's still no improvement.
To make matters worse, the dealer is claiming this is not a warranty issue and has charged me for this "service".

This is our second ML. First was a 2009 which never had this issue.
I have never had a previous or current vehicle with this issue.

It's bad enough that unless this gets resolved I will be trading in this vehicle soon, which is not something I would want to do. I think its a great vehicle otherwise.
You've got growies on the condenser coils. I've had it happen on other vehicles, but not this one yet. Ask if there is a more complete cleaning process that can be done. Helps to turn off the AC a few minutes before you turn off the car when you can.

Last edited by GregW / Oregon; 06-25-2013 at 11:09 PM.
GregW / Oregon is offline  
Old 06-24-2013, 03:05 PM
  #40  
Member
 
Join Date: May 2012
Location: Gresham, OR
Posts: 157
Thanked 1 Time in 1 Post
2013 ML 350
This is the annual stinky air conditioning caused by, as Greg said, crap on the condenser coils. Unfortunately, at least for me, it only happened at start up after the vehicle sat for several hours so unless the vehicle was left at the dealer the problem could not be duplicated. So I took a large mason jar and filled it with air from the conditioner right after start up. Took the jar to the dealer, opened it up, and there was no longer any doubt about the smell. Now this was on my old '06 and it really hasn't been hot enough long enough here yet to see if the problem exists with my '13. Good luck with yours. I remember the maintenance guy said to spray a Lysol type product into the air intake with the air conditioning on but I don't know the merit of that as I sold my '06 before I tried it. Again, good luck.

PS, Go to the Mercedes web site and sign into 'Owners On-Line". I have asked them a few questions in the past and they always got back to me. Perhaps they can give you some new info on the problem.

Last edited by frtdog; 06-24-2013 at 03:13 PM.
frtdog is offline  
Old 06-24-2013, 05:16 PM
  #41  
Member
 
Join Date: Oct 2012
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
S550, SRX, ML550
Originally Posted by frtdog View Post
Just curious, do any of you have or know someone who has an S-Class and if so does the A/C smell?
I owned a S550 for a couple of years - there was a very slight smell at startup, but hardly noticeable.

My new ML550 however (with 4000 miles on the clock) smells somewhat like musty vinegar for about 30 seconds at startup, MUCH worse than the S ever was.

I live in Colorado, it's a pretty dry climate without much humidity most days, so I don't believe atmospheric humidity levels or mold is part of the problem. Also, I only get the smell after I've been driving the car recently and then parked for a little while. For example, while I've not noticed it when starting up in my garage (typically 70-80F), once it's been parked at a shopping center in the sun for an hour (90F day) it smells really terrible - so bad I have to open the window to let fresh air in.

2c

Last edited by Thimee; 06-24-2013 at 05:29 PM.
Thimee is offline  
Old 06-26-2013, 01:16 PM
  #42  
Member
 
Join Date: Dec 2010
Location: Charlotte, NC
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
'15 GL350 Bluetec
I've experienced this issue with many of my M-B's in the past, and also with the '12 ML. Dealer addressed citing Bulletin LI83.00-P-051588. They replaced the cabin filter, no charge, no discussion. Problem has not recurred.
twodivers is offline  
Old 09-12-2013, 01:08 AM
  #43  
Newbie
 
Join Date: Sep 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2011 B200
Talking SMELLY AC in my B200

I had a really bad problem with musty moldy smell and the car only has 20,000 km on it stored indoors. It was getting really bad. It was hard to be in the car with AC on or off.

I read this thread about leaving the AC on automatic. The B200 does not have automatic so I tried leaving the AC on all the time and adjusting the temperature when I needed it warmer or cooler and I never turned the AC all the way to the coldest setting.

I drove the car this way for a few days and the smell seems to be gone! Today I even turned the AC off and it was still odor free.
GregKnobloch is offline  
Old 09-12-2013, 02:00 AM
  #44  
Member
 
Join Date: May 2012
Location: Gresham, OR
Posts: 157
Thanked 1 Time in 1 Post
2013 ML 350
My '01 ML did not stink, my '06 did, my '13 does not. Go figure!
frtdog is offline  
Old 09-12-2013, 09:25 AM
  #45  
Senior Member
 
Cyber GS's Avatar
 
Join Date: Mar 2011
Location: NYC / LI
Posts: 431
Thanks: 0
Thanked 0 Times in 0 Posts
2013 CTS-V, 2017 Audi Q7 / Past MB's: 2011 ML350 & 2012 ML350
My 2012 ML also has the ac odor when the ac compressor is off. When the compressor is on there is no foul odor.

While previous cars I have owned, including the 2011 ML had an ac smell it was no where near as bad / foul smelling as the odor is in the 2012.

I'm going to give Greg's suggestion a try.

Last edited by Cyber GS; 09-12-2013 at 09:30 AM.
Cyber GS is offline  
Old 09-16-2013, 01:45 PM
  #46  
Junior Member
 
Join Date: Apr 2012
Location: North Cyprus
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
2012 ml-250
I am also having the same smelly socks issue. This is a shame to have such a thing and hearing my 14 years old son's complaints, humiliating my car. This smell is more than ever with the car's eco start and stop feature, as it increases when you turn off the compressor. Even worse, we smell this smell every day for hours and what if it is harmful or worse causes cancer!!!
Pitazorro is offline  
Old 10-28-2013, 03:26 PM
  #47  
Junior Member
 
bobhbenz's Avatar
 
Join Date: Sep 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
c-300
I'm also have smelly socks at start up for about 30 seconds, going to the dealer now and will leave it with them until fixed.
bobhbenz is offline  
Old 10-28-2013, 06:33 PM
  #48  
Senior Member
 
Join Date: Mar 2010
Location: USA
Posts: 363
Thanked 2 Times in 2 Posts
E550C
I recently had a dealer claim this isn't a warranty covered issue. This is pretty disturbing to hear as it appears to be a pretty common problem. I had hoped they'd do the right thing and fix my issue.

Has anyone had this issue and complained of it within warranty? If so, please PM me. We need to look into our alternatives here. Thanks
nauticalx is offline  
Old 10-28-2013, 09:50 PM
  #49  
Member
 
Join Date: Dec 2007
Location: Orange County, CA
Posts: 222
Thanks: 0
Thanked 0 Times in 0 Posts
'16 Jaguar F-Type R,'13 ML63
I had this taken care of a couple weeks ago under warranty. Car is only 9 mths old and 6000 miles on it. Service advisor said this is a common issue he has seen and MB recently changed the service interval on the cabin filters from every 20k miles down to 10k. Dealer changed both filters and disinfected the system for free.

I had this problem on a Lexus a few years back. The problem was with the charcoal cabin filter. Lexus eventually changed the part from a charcoal filter to a woven hepa filter due all the problems they were having. I suspect that the same thing is happening here.
another_geek is offline  
Old 11-17-2013, 02:11 AM
  #50  
Senior Member
 
MBenz777's Avatar
 
Join Date: Nov 2013
Location: Laguna Hills, CA
Posts: 313
Thanked 15 Times in 12 Posts
2013 ML 350 BlueTec
I had this problem with a Lexus RX 400h and now my 2013 ML 350 Bluetec looks like is going to start a little bit of smell at ony 1,400 miles.

I know I have a very sensitive sense of smell, but the smell is there, even though is not so strong at this moment and others are not bothered by it...yet.
MBenz777 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Smell when starting AC


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: