Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > S-Class (W220)
Stuck in limp mode need help. >

Stuck in limp mode need help.

Notices
S-Class (W220) 1999-2006: S 320 CDI, S 320, S430, S 500, S 600

Stuck in limp mode need help.

 
Old 04-22-2017, 01:11 AM
  #1  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Stuck in limp mode need help.

So for my 22nd birthday I decided to ditch my ls400 and buy a big daddy pimpin 2002 S500 , it only has 131k and yet it's in limp mode (2nd gear) , I recently had my fuel pump go out and let the car sit for 9 days until I replaced the fuel pump. Next after all that she now doesn't display any gears on the dash and she's now giving me a p0600 Serial link code as well as the previous mass airflow code I negated to fix. So I've spoken to my dad and we replaced the 13 pin connector which did nothing by the way and I'm still confused on where to go next with the car please help.
AMGV8D is offline  
Old 04-22-2017, 04:34 AM
  #2  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
Check the tcu in the engine compartment and look for signs of fluid entry
tusabes is online now  
Old 04-23-2017, 04:03 PM
  #3  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Originally Posted by tusabes View Post
Check the tcu in the engine compartment and look for signs of fluid entry
ok so I pulled it out and it's dripping I'm guessing oldddd transmission fluid , can I dry it and use it if it's automatically time for a new one?
AMGV8D is offline  
Old 04-23-2017, 10:14 PM
  #4  
MBWorld Fanatic!
 
bbirdwell's Avatar
 
Join Date: Jan 2014
Location: Republic of Texas
Posts: 1,940
Received 421 Likes on 343 Posts
'99 and '05 E55 AMG
Clean it with electronic circuit board/contact cleaner. Multiple posts on this. Search. You're not the first to experience this.

Here's one example:
http://www.benzworld.org/forums/w210...ml#post4582348

Last edited by bbirdwell; 04-23-2017 at 10:18 PM.
bbirdwell is offline  
Old 04-23-2017, 10:28 PM
  #5  
Senior Member
 
Join Date: Oct 2015
Posts: 324
Received 22 Likes on 21 Posts
E420
You can pull the circuit board out of the casing by using a flat head screw driver. Make sure it is circuit board cleaner because certain contact cleaners eat away at plastics.
E42AMG??? is offline  
The following users liked this post:
AMGV8D (05-15-2017)
Old 04-24-2017, 01:29 AM
  #6  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
You also need to change the electrical connector plug that's responsible for the fluid leak otherwise you'll have the problem again

Stuck in limp mode need help.-a14e5203-622a-4e5e-9281-466b511fa18c.png
tusabes is online now  
The following users liked this post:
AMGV8D (05-15-2017)
Old 04-24-2017, 02:41 AM
  #7  
Senior Member
 
Join Date: Oct 2015
Posts: 324
Received 22 Likes on 21 Posts
E420
They replaced that already, that is the "13 pin connector" that was mentioned in the first post.
E42AMG??? is offline  
The following users liked this post:
AMGV8D (05-15-2017)
Old 05-05-2017, 09:52 PM
  #8  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Ok so I've been looking to buy another TCM , will a C class TCM with matching numbers work for my S class?
AMGV8D is offline  
Old 05-06-2017, 01:51 PM
  #9  
MBWorld Fanatic!
 
Join Date: Dec 2012
Location: Acworth, GA (N of Atlanta)
Posts: 1,420
Received 92 Likes on 87 Posts
2003 S430
Cleaning usually works, is cheap and easy to do...
wallyp is offline  
The following users liked this post:
AMGV8D (05-15-2017)
Old 05-08-2017, 07:07 PM
  #10  
Junior Member
 
Join Date: Feb 2017
Location: Wisconsin
Posts: 63
Received 3 Likes on 3 Posts
2004 S600
limp mode

my 2004 s600 got water in same area by dealer...went into limp mode...they blew it out with air and all workee good!
Icarus747 is offline  
Old 05-11-2017, 04:03 PM
  #11  
Senior Member
 
Join Date: Dec 2014
Location: CALIFORNIA, UNITED STATES
Posts: 447
Received 2 Likes on 2 Posts
2003 S430, 2014 E350
You need to find what transmission you have. Most likely a 5 speed 722.6xxx one. So you will need a TCU for that transmission. Theres no 7 speeds in 2002 right?
cybertronicify is offline  
The following users liked this post:
AMGV8D (05-15-2017)
Old 05-15-2017, 01:29 AM
  #12  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Okay so I bought a new TCM and put it in , My dashboard now finally shows the Gear indicator, yet it now shifts into reverse after 10 seconds , and and it's stuck in 3 or 4th gear now with a P0730 "incorrect gear ratio" , is it time for a new tranny or is it something I can just yank out the bottom of the tranny and fix?

Last edited by AMGV8D; 05-15-2017 at 01:42 AM. Reason: Spell check
AMGV8D is offline  
Old 05-15-2017, 01:40 AM
  #13  
Senior Member
 
Join Date: Dec 2014
Location: CALIFORNIA, UNITED STATES
Posts: 447
Received 2 Likes on 2 Posts
2003 S430, 2014 E350
Oh the dash doesn't show gear indicator? Your shifter module must be bad. Because there is no position sensor in the transmission that reports to the instru cluster. Only the shifter module does. Mines went bad a few months ago, limp mode, sometimes it works and shifts to 5th, then stays in 5th.
cybertronicify is offline  
Old 05-15-2017, 01:44 AM
  #14  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Dash is fine and the shifter module works for about 10 seconds until the car is supposed to shift
AMGV8D is offline  
Old 05-15-2017, 01:48 AM
  #15  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
There's nothing wrong with your tranny , it is an electrical problem . You probably still have damaged parts besides the fluid filled tcm . Did you clean the wiring thoroughly and Completely ? If not there is still fluid in the wiring now damaging your new tcm

did your car ever run correctly when you bought it , or did you buy it with problems ?
tusabes is online now  
The following users liked this post:
AMGV8D (05-15-2017)
Old 05-15-2017, 01:51 AM
  #16  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Didn't clean the connectors to the TCM because they looked dry and it had no problems at all until I the fuel pump went out and the car Sat for 9 days
AMGV8D is offline  
Old 05-15-2017, 10:57 PM
  #17  
MBWorld Fanatic!
 
Join Date: Jan 2008
Posts: 5,066
Likes: 0
Received 179 Likes on 174 Posts
Mercedes
The way fluid gets into the tcm is that it wicks its way up the wiring so if you had fluid make its way to the tcm then there was still lots of fluid still contaminating it

please answer my question whether this car ever ran correctly prior to sitting for 9 days or did you buy it with problems ? Lots of people buy a Mercedes cheap with problems only to find out the problems costs thousands to fix
tusabes is online now  
Old 05-15-2017, 11:20 PM
  #18  
Senior Member
 
Join Date: Oct 2015
Posts: 324
Received 22 Likes on 21 Posts
E420
You have the wrong Tcu it's set up for a different gear ratio.
E42AMG??? is offline  
Old 06-14-2017, 02:40 PM
  #19  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Car ran perfect when I got it , now it's just stuck in third and I've cleaned wiring now I'm just wondering do I just send it too Mercedes or I can fix it myself
AMGV8D is offline  
Old 06-14-2017, 02:41 PM
  #20  
Newbie
Thread Starter
 
Join Date: Apr 2017
Posts: 10
Received 0 Likes on 0 Posts
2002 S500
Do I need to send it to get re programmed ?
AMGV8D is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Stuck in limp mode need help.


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: