Dreaded 5508 AirMatic Fault Code - MBWorld.org Forums

Notices
W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

Dreaded 5508 AirMatic Fault Code

 
Old 12-07-2015, 04:04 PM
  #1  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
Dreaded 5508 AirMatic Fault Code

Hey guys, hoping you guys can assist.

Got the dreaded 5508 AirMatic malfunction code a while back. Let the car sit for about 2 weeks before I touched it. Car would hold its height as long as I kept it parked.

Cleared error 5508, code came back
Replaced compressor with new unit, cleared code, then code came back
Body still as same height now 4 weeks later

Buddy recommended that I replace relay and cut the compressor line so it has a fresh end at the fitting. I replaced relay with brand new hella relay, and checked line. Car still returning error 5508, and I've never seen the compressor power on since error first appeared with either the original or new compressor/relay combo. Buddy was able to power the compressor directly to confirm it works. He also checked the original relay and it was working fine. Car after this last time I removed compressor air line is now sitting on its control arms on the driver side.

Thoughts? Do I need a STAR computer to appropriately address reset and initialization of AirMatic? Been about a month and a half and me very sad.

Last edited by hachiroku; 12-07-2015 at 04:08 PM.
hachiroku is offline  
Old 12-07-2015, 04:37 PM
  #2  
MBWorld Fanatic!
 
Max.H's Avatar
 
Join Date: Nov 2007
Location: San Diego
Posts: 3,653
Thanked 28 Times in 27 Posts
E55
Jeez that sucks man. Sorry to hear, hopefully you can get it sorted out quick.

What happens when you start the car, does it raise up to normal height? Can you raise and lower the car?
Max.H is offline  
Old 12-07-2015, 07:23 PM
  #3  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
i've not heard the compressor turn on like ever. lol

all fuses are good, relays are good, compressor is good.
hachiroku is offline  
Old 12-08-2015, 06:41 PM
  #4  
MBWorld Fanatic!
 
2000UZJ's Avatar
 
Join Date: Jul 2014
Location: Earth, USA, Atlanta, GA
Posts: 1,302
Thanked 21 Times in 20 Posts
458 Speciale, 911 Turbo, Q5 TDI, E55
I never hear my compressor either. I just get confused when my car starts to go up and down at the stoplight. It still throws me off every time I see the nose rise up
2000UZJ is offline  
Old 12-09-2015, 03:53 PM
  #5  
MBWorld Fanatic!
 
Rocman8's Avatar
 
Join Date: Nov 2014
Posts: 1,134
Thanked 67 Times in 63 Posts
2006 E55, 2005 C55, 2005 E320 Estate Sport, 2015 ML350
Are you checking the correct fuse and relay?
Rocman8 is offline  
Old 12-09-2015, 04:49 PM
  #6  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
i checked the 40 amp big fuse and relay at the far back of engine bay fuse box. the standalone relay connected to standalone connector/harness. also checked fuse box on drivers side dash. lists 2-3 fuses for AirMatic.
hachiroku is offline  
Old 12-09-2015, 05:25 PM
  #7  
MBWorld Fanatic!
 
Rocman8's Avatar
 
Join Date: Nov 2014
Posts: 1,134
Thanked 67 Times in 63 Posts
2006 E55, 2005 C55, 2005 E320 Estate Sport, 2015 ML350
The airmatic pump 40a fuse is located in the front prefuse block F32 fuse number 74. This is under the passenger front floor area. Pull carpet back and remove the 3 10mm plastic nuts and there you have it.
Rocman8 is offline  
Old 12-09-2015, 05:41 PM
  #8  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
thanks for the info...i'll look there!
hachiroku is offline  
Old 12-09-2015, 10:27 PM
  #9  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
nope... and now I can't get the fuse box back into its holder. ughhhhDreaded 5508 AirMatic Fault Code-img_20151209_182021_zpsbpst6ps3.jpg
hachiroku is offline  
Old 12-09-2015, 10:37 PM
  #10  
MBWorld Fanatic!
 
Rocman8's Avatar
 
Join Date: Nov 2014
Posts: 1,134
Thanked 67 Times in 63 Posts
2006 E55, 2005 C55, 2005 E320 Estate Sport, 2015 ML350
Pull the actual fuse out of the holder. Sometimes the connection actually burns so it looks ok from the top but underneath it could be burnt.
Rocman8 is offline  
Old 12-09-2015, 10:40 PM
  #11  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
which one is it
hachiroku is offline  
Old 12-09-2015, 10:42 PM
  #12  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
.

Last edited by hachiroku; 12-09-2015 at 10:47 PM.
hachiroku is offline  
Old 12-09-2015, 10:45 PM
  #13  
MBWorld Fanatic!
 
Rocman8's Avatar
 
Join Date: Nov 2014
Posts: 1,134
Thanked 67 Times in 63 Posts
2006 E55, 2005 C55, 2005 E320 Estate Sport, 2015 ML350
Number 74. I cant remember exact location.
Rocman8 is offline  
Old 12-09-2015, 10:57 PM
  #14  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
finally found a property diagram.

Dreaded 5508 AirMatic Fault Code-screenshot_20151209-185403_zpsyjf5b4pv.pngDreaded 5508 AirMatic Fault Code-screenshot_20151209-185422_zps7id6b7ct.png
hachiroku is offline  
Old 12-09-2015, 11:02 PM
  #15  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
pulled fuse out according to diagram. no issues.
hachiroku is offline  
Old 12-09-2015, 11:18 PM
  #16  
MBWorld Fanatic!
 
Rocman8's Avatar
 
Join Date: Nov 2014
Posts: 1,134
Thanked 67 Times in 63 Posts
2006 E55, 2005 C55, 2005 E320 Estate Sport, 2015 ML350
Hmmm. Only other thing that I can think of is a bad relay even though it's new. Other than this it's gonna take some deeper in person diagnosing by someone familiar with the system.
Rocman8 is offline  
Old 12-10-2015, 03:11 AM
  #17  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
ok thanks for the help.
hachiroku is offline  
Old 02-09-2019, 11:22 PM
  #18  
Newbie
 
charlesb2003's Avatar
 
Join Date: Oct 2018
Posts: 12
Thanked 0 Times in 0 Posts
2005 E320
Sorry to bump an old thread but I just got this code as well. Both front struts are new, and car has been riding fine for a couple months but every day I would get a "visit workshop" message on the dash but I just ignored it, until the other day I went to take a drive and I got the red STOP Vehicle Too Low! message and noticed the front end slammed, more on the passenger side but both sides very low. Rear looks fine.

I have heard my compressor kick on occasionally but it doesn't seem to be able to affect the height. I don't hear air leaking anywhere. Could it be the valve body? I'm thinking about changing that but I don't like throwing parts at a problem. Is there anything else I should check first?
charlesb2003 is offline  
Old 02-10-2019, 10:05 AM
  #19  
Senior Member
 
Join Date: Jan 2015
Posts: 297
Thanked 12 Times in 11 Posts
07 E63, 17 Pilot
Originally Posted by charlesb2003 View Post
Sorry to bump an old thread but I just got this code as well. Both front struts are new, and car has been riding fine for a couple months but every day I would get a "visit workshop" message on the dash but I just ignored it, until the other day I went to take a drive and I got the red STOP Vehicle Too Low! message and noticed the front end slammed, more on the passenger side but both sides very low. Rear looks fine.

I have heard my compressor kick on occasionally but it doesn't seem to be able to affect the height. I don't hear air leaking anywhere. Could it be the valve body? I'm thinking about changing that but I don't like throwing parts at a problem. Is there anything else I should check first?
This sounds like your passenger's front air strut is leaking and needs replacement.
cfmistry is offline  
Old 02-11-2019, 04:27 PM
  #20  
MBWorld Fanatic!
Thread Starter
 
Join Date: Sep 2014
Location: San Diego, Ca
Posts: 1,535
Thanked 126 Times in 108 Posts
2007 Mercedes E63 AMG Pano, 2002 Audi A4 1.8t
were these rebuilt or new units? the fronts i believe are on separate air lines if you've lost that much air while driving it definitely sounds like your airbag has ruptured. when my drivers side front ruptured i heard a large hissing....and believe i heard my compressor kick on to fight the air loss...after a few minutes i did see the stop vehicle too low. only my front drivers side was dipped, the passenger side was level.

most if not all rebuilt airmatic struts use higher quality bellows which generally come with a lifetime warranty.
hachiroku is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Dreaded 5508 AirMatic Fault Code


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: