Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
DIY: Rear-View Camera under $200 >

DIY: Rear-View Camera under $200

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

DIY: Rear-View Camera under $200

 
Old 06-28-2010, 10:44 AM
  #76  
MBWorld Fanatic!
 
I am Jeff's Avatar
 
Join Date: Oct 2009
Location: eNyCe
Posts: 2,280
Recieved 56 Likes on 47 Posts
Steel Grey Metallic C63!!
Originally Posted by absolutleo View Post
how are you all snaking the rca cable from rear to front? is taking the interior trim/carpeting apart required?
Yes, you have to take apart the trunk to wire the camera. Also taking trim molding off the door sills and underneath the glove box to wire to the headunit.
I am Jeff is offline  
Old 06-28-2010, 10:45 AM
  #77  
MBWorld Fanatic!
 
I am Jeff's Avatar
 
Join Date: Oct 2009
Location: eNyCe
Posts: 2,280
Recieved 56 Likes on 47 Posts
Steel Grey Metallic C63!!
Originally Posted by joshg1001 View Post
which one is the better one?
If you haven't bought one yet, then getting the CMOS-200 makes more sense because it is newer. Otherwise, if you already have one installed, you don't have to worry too much about upgrading because you can't really see too much of a difference.
I am Jeff is offline  
Old 06-28-2010, 11:47 AM
  #78  
Super Member
 
Join Date: Apr 2010
Posts: 771
Likes: 0
Recieved 6 Likes on 5 Posts
2017 C43
Man I am having a hell of a time finding a fakra cable.. i went to radio shack, Fry's (think costco of electronics) , best buy and a shucks.. and had every single sales person look at my like I was crazy... guess I'll have to suck it up and just order one off ebay and wait for it. Good to see the CMOS-200 will work fine!
blue00r6 is offline  
Old 06-28-2010, 01:16 PM
  #79  
MBWorld Fanatic!
 
joshg1001's Avatar
 
Join Date: Jun 2008
Location: San Francisco, CA
Posts: 1,890
Likes: 0
Recieved 38 Likes on 34 Posts
2017 E300
oh poo, I have the older one...in a box not installed.
joshg1001 is offline  
Old 06-28-2010, 01:33 PM
  #80  
MBWorld Fanatic!
 
Ron Jr's Avatar
 
Join Date: May 2008
Location: Long Island, New York
Posts: 2,824
Likes: 0
Recieved 0 Likes on 0 Posts
2013 C300 Sport Black Darth V3.0
Originally Posted by blue00r6 View Post
Man I am having a hell of a time finding a fakra cable.. i went to radio shack, Fry's (think costco of electronics) , best buy and a shucks.. and had every single sales person look at my like I was crazy... guess I'll have to suck it up and just order one off ebay and wait for it. Good to see the CMOS-200 will work fine!
Best Buy and ask for a 2008 VW antenna adaptor, cut the Motorola off and solder an RCA on. Easy as pie.
Ron Jr is offline  
Old 06-28-2010, 02:14 PM
  #81  
MBWorld Fanatic!
 
I am Jeff's Avatar
 
Join Date: Oct 2009
Location: eNyCe
Posts: 2,280
Recieved 56 Likes on 47 Posts
Steel Grey Metallic C63!!
Originally Posted by Ron Jr View Post
Best Buy and ask for a 2008 VW antenna adaptor, cut the Motorola off and solder an RCA on. Easy as pie.
Ron, bestbuy stopped carrying them. I searched from brooklyn to baltimore and they all said they stopped carrying them.
I am Jeff is offline  
Old 06-28-2010, 02:52 PM
  #82  
MBWorld Fanatic!
 
Krytech's Avatar
 
Join Date: Nov 2007
Location: Phoenix, AZ
Posts: 1,423
Likes: 0
Recieved 0 Likes on 0 Posts
2014 Ghibli S Q4 & 2008 C350
Originally Posted by blue00r6 View Post
Man I am having a hell of a time finding a fakra cable.. i went to radio shack, Fry's (think costco of electronics) , best buy and a shucks.. and had every single sales person look at my like I was crazy... guess I'll have to suck it up and just order one off ebay and wait for it. Good to see the CMOS-200 will work fine!
Just order one from Mid City Engineering. They ship quick, got mine a couple days after I ordered it. It's worry-free. It'll work and you'll be happy.
Krytech is offline  
Old 06-28-2010, 03:15 PM
  #83  
Senior Member
Thread Starter
 
Join Date: Jan 2008
Location: Vancouver, BC
Posts: 366
Likes: 0
Recieved 25 Likes on 19 Posts
08 C300
Originally Posted by blue00r6 View Post
Man I am having a hell of a time finding a fakra cable.. i went to radio shack, Fry's (think costco of electronics) , best buy and a shucks.. and had every single sales person look at my like I was crazy... guess I'll have to suck it up and just order one off ebay and wait for it. Good to see the CMOS-200 will work fine!
http://cgi.ebay.com/Radioa-Extension...item3a53d33a84

just get this.
white46 is online now  
Old 06-28-2010, 03:59 PM
  #84  
Junior Member
 
Join Date: Aug 2009
Location: Germany
Posts: 52
Likes: 0
Recieved 0 Likes on 0 Posts
C 180 K
Originally Posted by white46 View Post
I did get that but the RCA plug does not quite fit...

L
lingnoi is offline  
Old 06-28-2010, 04:07 PM
  #85  
Super Member
 
Join Date: Apr 2010
Posts: 771
Likes: 0
Recieved 6 Likes on 5 Posts
2017 C43
Originally Posted by white46 View Post
Yeah this is what i was planning on but i didnt feel like waiting for 3 weeks for it to arrive from china..
blue00r6 is offline  
Old 06-28-2010, 04:10 PM
  #86  
MBWorld Fanatic!
 
I am Jeff's Avatar
 
Join Date: Oct 2009
Location: eNyCe
Posts: 2,280
Recieved 56 Likes on 47 Posts
Steel Grey Metallic C63!!
I got the mid city engineering one and it fit perfectly. I don't have to worry about the cable falling out the back of the HU.
I am Jeff is offline  
Old 06-28-2010, 10:14 PM
  #87  
Member
 
Join Date: Jul 2009
Location: washington, d.c.
Posts: 77
Likes: 0
Recieved 0 Likes on 0 Posts
c300
Originally Posted by I am Jeff View Post
Yes, you have to take apart the trunk to wire the camera. Also taking trim molding off the door sills and underneath the glove box to wire to the headunit.
i understand the taking the trim off the trunk and underneath the glove box part... but not the door sills. is there a DIY on the door sills? or anyone have some pictures of what/how to take it apart? thx
absolutleo is offline  
Old 06-28-2010, 10:30 PM
  #88  
MBWorld Fanatic!
 
I am Jeff's Avatar
 
Join Date: Oct 2009
Location: eNyCe
Posts: 2,280
Recieved 56 Likes on 47 Posts
Steel Grey Metallic C63!!
Originally Posted by absolutleo View Post
i understand the taking the trim off the trunk and underneath the glove box part... but not the door sills. is there a DIY on the door sills? or anyone have some pictures of what/how to take it apart? thx

Believe it or not, just pull on it or use a wedge to pop it out with some strength. It'll pop out. The sills are teh easiest part.
I am Jeff is offline  
Old 08-01-2010, 07:11 PM
  #89  
Newbie
 
Join Date: Aug 2010
Posts: 4
Likes: 0
Recieved 0 Likes on 0 Posts
C300
That's a great thread, does this work on any 2009 or 2008 C300 models as long as you have the LCD (I'm a newbie ?
followgreg is offline  
Old 08-01-2010, 08:23 PM
  #90  
Super Member
 
Join Date: Apr 2009
Location: NY
Posts: 588
Likes: 0
Recieved 0 Likes on 0 Posts
08 c350
yes ^^ as long as u have the MM package.
kevinwithdabenz is offline  
Old 08-08-2010, 03:57 AM
  #91  
Newbie
 
Join Date: Jul 2010
Posts: 5
Likes: 0
Recieved 0 Likes on 0 Posts
C300
I got my VIM & Reverse Camera Kit from Mid City. VIM installed and works great, now for the Reverse Camera

Kenwood CMOS-200 Power Wiring Question:

1) You know how you have 2 power sources Needles. A) Reverse Light B) Accessory Power.

After i run everything to the back, where do i run the Accessory Power to? Instruction says to run the power to the Engine Key, but it seems that most people are running the power from somewhere else? Where do i run the power to because it has to be a NON CONSTANT Power Source.

Any help or info would be much appreciated.

Thanks..
ss4fusion is offline  
Old 08-08-2010, 01:05 PM
  #92  
Member
 
Join Date: Jun 2010
Location: Toronto
Posts: 81
Recieved 0 Likes on 0 Posts
2010 C300 4Matic
Originally Posted by lingnoi View Post
I did get that but the RCA plug does not quite fit...

L
If Im not mistaken right cable is fakra A to RCA (Female).
jon3sh is offline  
Old 08-08-2010, 01:15 PM
  #93  
Newbie
 
Join Date: Jul 2009
Posts: 7
Likes: 0
Recieved 0 Likes on 0 Posts
2008 W204 C-300 Sport
Have had my backup camera installed for a few months now, but have a pesky "check rear right light" error message. Camera works great, but has anyone had a similar problem, or know how to fix this?
gausda is offline  
Old 08-08-2010, 02:21 PM
  #94  
Member
 
cbcharlie's Avatar
 
Join Date: Oct 2008
Location: Bay Shore, NY
Posts: 186
Likes: 0
Recieved 0 Likes on 0 Posts
2009 C300 4Matic Sport P2/MM/Steel Gray
the fakra to rca cables you see on ebay are NOT the right ones (I bought one, trust me). If you don't wanna solder, just pay the money to midcity, just make sure they get your address right, they left out a digit in my house number, and it ended up all the way on the other side of town, luckily the guy it got delivered to called the number on the package and it got to me
cbcharlie is offline  
Old 08-08-2010, 03:24 PM
  #95  
Newbie
 
Join Date: Jul 2010
Posts: 5
Likes: 0
Recieved 0 Likes on 0 Posts
C300
I got my VIM & Reverse Camera Kit from Mid City. VIM installed and works great, now for the Reverse Camera

Kenwood CMOS-200 Power Wiring Question:

1) You know how you have 2 power sources Needles. A) Reverse Light B) Accessory Power.

After i run everything to the back, where do i run the Accessory Power to? Instruction says to run the power to the Engine Key, but it seems that most people are running the power from somewhere else? Where do i run the power to because it has to be a NON CONSTANT Power Source.

Any help or info would be much appreciated.

Thanks..
ss4fusion is offline  
Old 08-13-2010, 01:32 PM
  #96  
MBWorld Fanatic!
 
I am Jeff's Avatar
 
Join Date: Oct 2009
Location: eNyCe
Posts: 2,280
Recieved 56 Likes on 47 Posts
Steel Grey Metallic C63!!
Originally Posted by ss4fusion View Post
I got my VIM & Reverse Camera Kit from Mid City. VIM installed and works great, now for the Reverse Camera

Kenwood CMOS-200 Power Wiring Question:

1) You know how you have 2 power sources Needles. A) Reverse Light B) Accessory Power.

After i run everything to the back, where do i run the Accessory Power to? Instruction says to run the power to the Engine Key, but it seems that most people are running the power from somewhere else? Where do i run the power to because it has to be a NON CONSTANT Power Source.

Any help or info would be much appreciated.

Thanks..

Just run it to the reverse brake lamp. Power only goes to it when you engage reverse.
I am Jeff is offline  
Old 09-01-2010, 09:34 PM
  #97  
Senior Member
 
Join Date: Oct 2008
Posts: 397
Likes: 0
Recieved 0 Likes on 0 Posts
2010 C300
is there any way to install a backup camera on a w204 without the MM package? i do have the NAV+4 option though, if that makes any difference.
victort is offline  
Old 09-02-2010, 08:00 PM
  #98  
Member
 
Join Date: Nov 2008
Posts: 181
Likes: 0
Recieved 0 Likes on 0 Posts
w204 amg
Originally Posted by ss4fusion View Post
I got my VIM & Reverse Camera Kit from Mid City. VIM installed and works great, now for the Reverse Camera

Kenwood CMOS-200 Power Wiring Question:

1) You know how you have 2 power sources Needles. A) Reverse Light B) Accessory Power.

After i run everything to the back, where do i run the Accessory Power to? Instruction says to run the power to the Engine Key, but it seems that most people are running the power from somewhere else? Where do i run the power to because it has to be a NON CONSTANT Power Source.

Any help or info would be much appreciated.

Thanks..
wait for fotos of this camera in your car!
miloc204 is offline  
Old 09-03-2010, 02:06 AM
  #99  
MBWorld Fanatic!
 
Savage c-300's Avatar
 
Join Date: Nov 2007
Location: Irvine, CA
Posts: 1,009
Recieved 1 Like on 1 Post
C300 Sport, MM, P1
Installing mine this weekend. I ordered the cable from ebay even though everyone says its not the right cable since I figured I would just solder it but what they sent me seems like it's a male RCA that looks like a mini RCA female. Hard to explain but I'll post pictures later.
Savage c-300 is offline  
Old 09-07-2010, 01:36 PM
  #100  
Member
 
Join Date: Nov 2008
Posts: 181
Likes: 0
Recieved 0 Likes on 0 Posts
w204 amg
Originally Posted by Savage c-300 View Post
Installing mine this weekend. I ordered the cable from ebay even though everyone says its not the right cable since I figured I would just solder it but what they sent me seems like it's a male RCA that looks like a mini RCA female. Hard to explain but I'll post pictures later.

post pictyres of the camera installation i m ready to install kenwood cmos 200!
miloc204 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: DIY: Rear-View Camera under $200


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: