Fuses Location and diagram????? - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Fuses Location and diagram????? >

Fuses Location and diagram?????

Notices
C-Class (W204) 2008-Present: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Fuses Location and diagram?????

Old 11-30-2009, 09:55 PM
  #1  
Member
Thread Starter
 
Join Date: Dec 2008
Location: PR
Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
C350 2008
Fuses Location and diagram?????

Yesterday, when I tried to replaced the front signal lights with LED's, a fuse was blow out (I assume because not power), for my surpraise not fuse legend is available, how it is possible? In a MB, The owner manual show only the block fuses location, not each individual fuse. HELP !!!!
SuperDavid is offline  
Old 11-30-2009, 10:18 PM
  #2  
Senior Member
 
Join Date: Aug 2008
Location: British Columbia
Posts: 436
Thanks: 0
Thanked 0 Times in 0 Posts
2011 E350 4 Matic
Originally Posted by SuperDavid View Post
Yesterday, when I tried to replaced the front signal lights with LED's, a fuse was blow out (I assume because not power), for my surpraise not fuse legend is available, how it is possible? In a MB, The owner manual show only the block fuses location, not each individual fuse. HELP !!!!
Check your spare tire, where the tools are, it should have a sheet with locations.
2nice4me is offline  
Old 11-30-2009, 11:33 PM
  #3  
MBWorld Fanatic!
 
acr2001's Avatar
 
Join Date: Nov 2007
Location: NYC
Posts: 2,078
Thanks: 0
Thanked 1 Time in 1 Post
2012 C300 4Matic
Originally Posted by SuperDavid View Post
Yesterday, when I tried to replaced the front signal lights with LED's, a fuse was blow out (I assume because not power), for my surpraise not fuse legend is available, how it is possible? In a MB, The owner manual show only the block fuses location, not each individual fuse. HELP !!!!
Your post is hard to understand. If you are looking for a fuse for the turn signal you won't find one as the ECU breaks the circuit (no fuse).
acr2001 is offline  
Old 12-01-2009, 12:32 AM
  #4  
MBWorld Fanatic!
 
raymond g-'s Avatar
 
Join Date: Jan 2004
Location: Seattle WA
Posts: 5,431
Thanked 80 Times in 78 Posts
99 E320
the fuse maps should be located within the fuse compartments, stuck to the
lid(s): fuse compartment on left end of dash (must have door open to access),
engine compartment (driver's side I believe), and very possible in the trunk
as well (less sure, depending on model)
raymond g- is offline  
Old 12-01-2009, 08:46 AM
  #5  
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 19,902
Thanked 78 Times in 65 Posts
late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Frequently on a printed sheet for all locations in the rear fuse box.
Glyn M Ruck is offline  
Old 12-01-2009, 08:59 AM
  #6  
Member
Thread Starter
 
Join Date: Dec 2008
Location: PR
Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
C350 2008
Originally Posted by raymond g- View Post
the fuse maps should be located within the fuse compartments, stuck to the
lid(s): fuse compartment on left end of dash (must have door open to access),
engine compartment (driver's side I believe), and very possible in the trunk
as well (less sure, depending on model)

The problem is not fuse map in the fuse compartments, either engine or trunk compartment, can you verify if you have same issue, my car is C350 2008.

The problem is only in my car? or maybe is all the 2008 has same problem, because I saw another W204 with missing fuse map.
SuperDavid is offline  
Old 12-01-2009, 03:55 PM
  #7  
MBWorld Fanatic!
 
acr2001's Avatar
 
Join Date: Nov 2007
Location: NYC
Posts: 2,078
Thanks: 0
Thanked 1 Time in 1 Post
2012 C300 4Matic
Originally Posted by SuperDavid View Post
The problem is not fuse map in the fuse compartments, either engine or trunk compartment, can you verify if you have same issue, my car is C350 2008.

The problem is only in my car? or maybe is all the 2008 has same problem, because I saw another W204 with missing fuse map.
Check your interior fuse box on the left side of the dash against the drivers door!!
acr2001 is offline  
Old 12-01-2009, 05:25 PM
  #8  
MBWorld Fanatic!
 
raymond g-'s Avatar
 
Join Date: Jan 2004
Location: Seattle WA
Posts: 5,431
Thanked 80 Times in 78 Posts
99 E320
Originally Posted by SuperDavid View Post
The problem is not fuse map in the fuse compartments, either engine or trunk compartment, can you verify if you have same issue, my car is C350 2008.

The problem is only in my car? or maybe is all the 2008 has same problem, because I saw another W204 with missing fuse map.

the owner's manual identifies that the map(s) is located in these places.
if your car does not have them, it has been removed by someone, or,
a huge conspiracy by MB to deprive you of this important item.
raymond g- is offline  
Old 12-02-2009, 01:59 AM
  #9  
RLE
MBWorld Fanatic!
 
RLE's Avatar
 
Join Date: Feb 2004
Location: SEATTLE WASHINGTON USA
Posts: 3,986
Thanks: 0
Thanked 0 Times in 0 Posts
'08 C300 Lux Barolo Red Beige Leather P2 MM 18" wheels '84 944
FOOZES

Originally Posted by SuperDavid View Post
The problem is not fuse map in the fuse compartments, either engine or trunk compartment, can you verify if you have same issue, my car is C350 2008.

The problem is only in my car? or maybe is all the 2008 has same problem, because I saw another W204 with missing fuse map.
Lot of bad info posted.

There are two fuse panels. Under the hood at the left rear, a lift off black cover. In the trunk on the right side behind the door.

There is no fuse box at either end of the dash in US models because the items those fuses serve are not US equipment. Whether cars sold in Puerto Rico are configured the same is unknown to me.

The fuse layout is a folded sheet of paper stored with the tools on top of the spare wheel in the trunk, not in either fuse panel location.

According to my fuse sheet, the turn signals are served by fuse 13 which is in the front fuse panel.

Last edited by RLE; 12-02-2009 at 02:07 AM. Reason: Clarification
RLE is offline  
Old 12-02-2009, 02:31 AM
  #10  
Member
 
fattysnax's Avatar
 
Join Date: Jun 2009
Location: NJ/PA
Posts: 86
Thanks: 0
Thanked 0 Times in 0 Posts
'09 C300 Sport 4Matic Arctic White
I had the same problem this weekend when changing out my passenger-side low beam bulb. Thought it was a blown fuse but it was the computer not sending any power to the light. The bulb was fine.

This may sound elementary but after swapping bulbs, try turning the car off completely and take the key out, then turn it back on. Do this each time you plug/unplug a new bulb. Hope this helps!
fattysnax is offline  
Old 12-02-2009, 09:22 AM
  #11  
Member
Thread Starter
 
Join Date: Dec 2008
Location: PR
Posts: 110
Thanks: 0
Thanked 0 Times in 0 Posts
C350 2008
Originally Posted by RLE View Post
Lot of bad info posted.

There are two fuse panels. Under the hood at the left rear, a lift off black cover. In the trunk on the right side behind the door.

There is no fuse box at either end of the dash in US models because the items those fuses serve are not US equipment. Whether cars sold in Puerto Rico are configured the same is unknown to me.

The fuse layout is a folded sheet of paper stored with the tools on top of the spare wheel in the trunk, not in either fuse panel location.

According to my fuse sheet, the turn signals are served by fuse 13 which is in the front fuse panel.
Thanks for the information, yes all the cars in PR are same US model, I found the fuse layout in the spare wheel, WOW !!! many people has same problem to find the fuse layout and fuse panel locations, in the owner manual show the 3 locations are only 2 for US model that you mention before, however the W203 has 3 locations.

Again this case was only to replace a bulb, but in the future can be more critical thanks again.
SuperDavid is offline  
Old 07-31-2014, 03:53 PM
  #12  
Newbie
 
Join Date: Jul 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
C300 Sport Automatic
I was having the same issues (no fuse layout for any panel and drivers side headlamp that wouldnt light even after replacing). I tried what fattysnax posted above and it worked for me. With the car off, turned lights to off position, turned the car on, turned the lights to the ON position and they worked. Tried auto and DRL and they worked too.

"This may sound elementary but after swapping bulbs, try turning the car off completely and take the key out, then turn it back on. Do this each time you plug/unplug a new bulb. Hope this helps!"
mwn9592 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Fuses Location and diagram?????


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: