Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Bad steering lock and ignition module $1900!!! >

Bad steering lock and ignition module $1900!!!

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Bad steering lock and ignition module $1900!!!

 
Old 07-26-2013, 05:10 PM
  #51  
Newbie
 
Join Date: May 2013
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
w204

Last edited by prom1975; 07-27-2013 at 03:35 AM.
prom1975 is offline  
Old 07-26-2013, 11:58 PM
  #52  
Member
 
Join Date: Jun 2004
Location: New Jersey
Posts: 227
Likes: 0
Liked 0 Times in 0 Posts
2009 C300 Sport 4Matic
Originally Posted by prom1975 View Post
any chance your site have an english translation ?
nismosr is offline  
Old 07-27-2013, 03:36 AM
  #53  
Newbie
 
Join Date: May 2013
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
w204
Originally Posted by nismosr View Post
any chance your site have an english translation ?
You can use a google translator =-)
prom1975 is offline  
Old 07-29-2013, 10:36 AM
  #54  
MBWorld Fanatic!
 
Join Date: Sep 2007
Location: Southeast
Posts: 1,484
Likes: 0
Liked 0 Times in 0 Posts
2008 C300 Sport, RWD, US
Originally Posted by JimPap View Post
Thanks for posting.

My 2008 C300 will intermittently not want to start.

What I've done is removed the key fob, then reinsert it. You can hear something that sounds like a sliding part move when it works right and when it doesn't work, you don't hear the sliding noise. Can't help but wonder if this is something that I could take apart but then again, I'd rather not tear it up.

In any event, it sounds like it's on it's way out and I'll be calling mbusa when it finally gives up the ghost.
It finally gave up the ghost last week. The only way I could get it to crank this morning was to have my wife pray for it to start. Don't laugh, it started after I tried a half dozen times including banging the tilting steering wheel thing a few times.

Anyway, this time my discussion with the service writer that I've gotten to know with my other repairs was that I wanted MBUSA to pay for this one. That it's an obvious defect that many others had and I'm prepared to organize a class action suit. He mentioned that this same problem happens on a lot of cars including the E series and one other series.
JimPap is offline  
Old 07-29-2013, 11:26 AM
  #55  
MBWorld Fanatic!
 
vic viper's Avatar
 
Join Date: Mar 2009
Location: Sweden
Posts: 3,101
Liked 201 Times in 131 Posts
S213
Its not that common, and we havnt replaced any W212 EZS modules or steering locks.

For the record, W212 with ISM 7G tronic doesnt have a steering lock at all.
vic viper is online now  
Old 08-01-2013, 08:07 AM
  #56  
MBWorld Fanatic!
 
Join Date: Sep 2007
Location: Southeast
Posts: 1,484
Likes: 0
Liked 0 Times in 0 Posts
2008 C300 Sport, RWD, US
vic viper

What all is involved in replacing the module?
How long does it take?
Is it a DIY project?

Too late for me as my car's in the shop waiting for parts but for others.
JimPap is offline  
Old 08-22-2013, 06:38 AM
  #57  
Newbie
 
Join Date: Aug 2013
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
c 220
i have a 2008 w204 c220 and have the same problem of a faulty steering lock. took it to the mb dealership and have ben told that the same needs to be replaced. it seems to be a worldwide issue on mb and the same needs to be seriously looked in to by merc
kulbir gill
india
KulbirGill is offline  
Old 02-17-2014, 09:24 PM
  #58  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
I have a 2009 C220CDI W204 had the same problem about two weeks ago car wouldn't start hasn't happen since fingers crossed.

I spoke to the dealer and he mentioned it could be the key or ignition switch

So I priced a brand new ignition switch just over $2.000
silkynitro is offline  
Old 02-18-2014, 02:28 AM
  #59  
Newbie
 
Wally Wombat's Avatar
 
Join Date: Feb 2014
Location: Victoria
Posts: 3
Likes: 0
Liked 0 Times in 0 Posts
C220 CDI 2009
Originally Posted by silkynitro View Post
I have a 2009 C220CDI W204 had the same problem about two weeks ago car wouldn't start hasn't happen since fingers crossed.

I spoke to the dealer and he mentioned it could be the key or ignition switch

So I priced a brand new ignition switch just over $2.000
May I give you a piece of sound advice ... sell the C220 CDI and go and buy a Subaru Forester (not Diesel either ) or a Hyundai Elantra.

That Black Beast is jinxed.
Wally Wombat is offline  
Old 02-18-2014, 06:40 AM
  #60  
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 19,903
Liked 91 Times in 75 Posts
late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Remember to make them diagnose whether it is the ESL or the EIS. Most damn dealers just replace both which is not necessary & relieves you of your hard earned cash.

https://mbworld.org/forums/c-class-w...?highlight=EIS
Glyn M Ruck is offline  
Old 02-18-2014, 12:07 PM
  #61  
Super Member
 
caligreenzzz's Avatar
 
Join Date: Jun 2011
Posts: 682
Likes: 0
Liked 1 Time in 1 Post
W204
Originally Posted by silkynitro View Post
I have a 2009 C220CDI W204 had the same problem about two weeks ago car wouldn't start hasn't happen since fingers crossed.

That's how I felt, but once it happens, it's a done deal....give it a month and I bet ur car won't start......
caligreenzzz is offline  
Old 02-18-2014, 12:24 PM
  #62  
MBWorld Fanatic!
 
Join Date: Jun 2011
Location: vancouver bc
Posts: 1,258
Likes: 0
Liked 14 Times in 13 Posts
'14 ML350 4matic,'13 GLK350 4matic,'09 C300 4matic,'07 B200 turbo,'07 Honda Odyssey, '07 Mini Cooper
I have a 09 and the ignition switch was replaced almost a year ago. Is the old part been replaced with a new version or just the same thing?
shotgun_banjo is offline  
Old 02-18-2014, 06:07 PM
  #63  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
Originally Posted by Wally Wombat View Post
May I give you a piece of sound advice ... sell the C220 CDI and go and buy a Subaru Forester (not Diesel either ) or a Hyundai Elantra.

That Black Beast is jinxed.
Thanks for the advice matey, I'm looking at a New Honda CR-V I'm finding it a little hard getting in and out of this so called luxury car.


Cheers

Last edited by silkynitro; 02-18-2014 at 06:47 PM.
silkynitro is offline  
Old 02-18-2014, 06:16 PM
  #64  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
Originally Posted by caligreenzzz View Post
That's how I felt, but once it happens, it's a done deal....give it a month and I bet ur car won't start......
What was the problem with yours, was it the ignition switch??

Thanks, you have just jinxed me, I've just had the same problem, had to put the key in an out a few times before it would start.

I may have to take it to the dealer sooner than later.

Last edited by silkynitro; 02-18-2014 at 08:14 PM.
silkynitro is offline  
Old 02-18-2014, 06:23 PM
  #65  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
Originally Posted by shotgun_banjo View Post
I have a 09 and the ignition switch was replaced almost a year ago. Is the old part been replaced with a new version or just the same thing?
Haven't changed it, not sure what the problem is, I'm due for a service in about a month or so, i'll get it checked out then, that's if it last till then, fingers crossed.

cheers
silkynitro is offline  
Old 02-18-2014, 06:28 PM
  #66  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
Originally Posted by Glyn M Ruck View Post
Remember to make them diagnose whether it is the ESL or the EIS. Most damn dealers just replace both which is not necessary & relieves you of your hard earned cash.

https://mbworld.org/forums/c-class-w...?highlight=EIS
Thanks, will do, either way i'll be putting my hand in the pocket once again
silkynitro is offline  
Old 02-18-2014, 09:19 PM
  #67  
MBWorld Fanatic!
 
Carsy's Avatar
 
Join Date: Mar 2008
Location: 1 hours drive north of Sydney Australia
Posts: 3,714
Liked 41 Times in 40 Posts
2007 W204 220CDI Classic Sedan
Has anyone know of a 2007 having these problems ?.

There seem to be more 2008 & 2009's.

Silky, Hopefully yours was a one off glitch. Sometimes mine will not start but always because I have not ticked all the logic boxes.
Carsy is offline  
Old 02-18-2014, 09:53 PM
  #68  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
Originally Posted by Carsy View Post
Has anyone know of a 2007 having these problems ?.

There seem to be more 2008 & 2009's.

Silky, Hopefully yours was a one off glitch. Sometimes mine will not start but always because I have not ticked all the logic boxes.
I wish it was, it's happened about 3-4 times in the last couple of months.

I checked with the dealer, he thinks it maybe either the key?? or the ignition switch, he said the C Class

(not sure if he meant all or just 2009 model) has had a few problems with the switch.

I said well in that case, it should be replaced under MB good will and he said yes it should be.

However MB customer service said we will look at helping out with the cost certainly won't be replaced for nothing. it's wear & tear
Never had one go in any of my other cars
silkynitro is offline  
Old 02-18-2014, 10:15 PM
  #69  
MBWorld Fanatic!
 
Carsy's Avatar
 
Join Date: Mar 2008
Location: 1 hours drive north of Sydney Australia
Posts: 3,714
Liked 41 Times in 40 Posts
2007 W204 220CDI Classic Sedan
Have you tried your other key?
Carsy is offline  
Old 02-18-2014, 10:45 PM
  #70  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
Originally Posted by Carsy View Post
Have you tried your other key?
No I haven't, I'll change from today and see what happens thanks.

I've been meaning to ask what brand of tyres are you running,

I have Goodyear Assurance on the car when bought, and they seem very noisy all most due for a new set.

I'm going to put Michelin Primacy 3 st on if I don't get the sh...ts and trade on another car

Cheers

Last edited by silkynitro; 02-18-2014 at 10:47 PM.
silkynitro is offline  
Old 02-19-2014, 01:42 AM
  #71  
MBWorld Fanatic!
 
Carsy's Avatar
 
Join Date: Mar 2008
Location: 1 hours drive north of Sydney Australia
Posts: 3,714
Liked 41 Times in 40 Posts
2007 W204 220CDI Classic Sedan
My OEMs where Bridgestone Turanzas & each & every tyre failed in the same way with deep cracking on the outer tread when about 20 % left.

I replaced them with Michelin Primacy HP as suggested by Glyn as the South African farmers use them on their rough roads. They seem to be tough & are not cupping as yet.

One was damaged by a sharp pothole . Primacy HP were no longer available to me here in tubeless, only in run flat, so I went for his other recommendation the Michelin XM2 . So far so good , a tough tyre for my conditions but too early to give a recommendation as I have only done about 6000 km. Their price from Jax was quite reasonable @$182 each.

Glyn did say the SA farmers were also fitting Primacy 3 so they must be tough enough.

Good luck with the other key.

JC
Carsy is offline  
Old 02-23-2014, 06:27 AM
  #72  
Newbie
 
Wally Wombat's Avatar
 
Join Date: Feb 2014
Location: Victoria
Posts: 3
Likes: 0
Liked 0 Times in 0 Posts
C220 CDI 2009
Originally Posted by silkynitro View Post
I wish it was, it's happened about 3-4 times in the last couple of months.

I checked with the dealer, he thinks it maybe either the key?? or the ignition switch, he said the C Class

(not sure if he meant all or just 2009 model) has had a few problems with the switch.

I said well in that case, it should be replaced under MB good will and he said yes it should be.

However MB customer service said we will look at helping out with the cost certainly won't be replaced for nothing. it's wear & tear
Never had one go in any of my other cars
Have you tried the other key as suggested silkynitro?
Wally Wombat is offline  
Old 02-23-2014, 07:42 AM
  #73  
Senior Member
 
W204white2010's Avatar
 
Join Date: Aug 2010
Location: So Cal
Posts: 277
Likes: 0
Liked 0 Times in 0 Posts
W204
Originally Posted by silkynitro View Post
However MB customer service said we will look at helping out with the cost certainly won't be replaced for nothing. it's wear & tear
Never had one go in any of my other cars
I'm in the same boat as you. My service advisor here in southern California said the same exact BS. "it's wear & tear"
W204white2010 is offline  
Old 02-23-2014, 10:18 PM
  #74  
Member
 
Join Date: Mar 2012
Location: Brisbane Australia
Posts: 115
Likes: 0
Liked 0 Times in 0 Posts
C220CDI 2009
Originally Posted by Wally Wombat View Post
Have you tried the other key as suggested silkynitro?
Yes have been using the other key since my last post at this stage touch wood it's working fine.

I ask the local dealer if he wouldn't mind bringing out the C200CDi 2011 model (Price $39.485.00) that he has in-stock, looking at trading up to one that is still in warranty that's if the change over figure is there a bouts, and hopefully I'll get a better run out of this one.

If not, I'll keep this one for a little longer since I've had a fair few parts replaced already and don't really expect to much more to go wrong that will cost me a heap of $$$$$$$$$$$$

Cheers
silkynitro is offline  
Old 02-23-2014, 10:37 PM
  #75  
Super Member
 
Join Date: Jul 2006
Location: queensland australia
Posts: 635
Liked 2 Times in 2 Posts
2009 C 63
Originally Posted by silkynitro View Post
Yes have been using the other key since my last post at this stage touch wood it's working fine.

I ask the local dealer if he wouldn't mind bringing out the C200CDi 2011 model (Price $39.485.00) that he has in-stock, looking at trading up to one that is still in warranty that's if the change over figure is there a bouts, and hopefully I'll get a better run out of this one.

If not, I'll keep this one for a little longer since I've had a fair few parts replaced already and don't really expect to much more to go wrong that will cost me a heap of $$$$$$$$$$$$

Cheers
about 6 months ago i had my eis replaced under MB used car warranty cost just over $2000 i was told who is your local MB dealer.
aussie e55 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Bad steering lock and ignition module $1900!!!


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: