Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
2008 C300 won't start >

2008 C300 won't start

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI
Old 06-15-2015, 02:47 PM
How-Tos on this Topic
Last edit by: IB Advertising
See related guides and technical advice from our community experts:

Browse all: Engine Diagnostics
Print Wikipost

2008 C300 won't start

 
Old 09-13-2016, 05:23 PM
  #301  
Super Member
 
Join Date: Aug 2016
Location: Regina SK
Posts: 517
Liked 42 Times in 39 Posts
2008 C-230 4Matic Sport
Originally Posted by EPineda View Post
It looks like we have the same problem with my car or perhaps similar in nature. I parked the car the other night and will not start the following morning.

Upon inserting the key to the ignition, the car will crank but will not start. I got these all these messages on the dash: Front SRS Malfunction - Service Required, Left SRS Malfunction - Service Required, SRS Malfunction - Service Required, Cruise Control Inoperable, ABS and ESP Inoperative, Tire Pressure Monitor Inoperative, Cruise Control Inoperative.

Additionally, I have the interior lights out, Radio, GPS, etc. that didn't work, One particular problem I noticed, the OBDII diagnostic port has NO power (I tried 3 different units and all of them didn't work) before my mechanic tested it for power. Of course, there was none (see next paragraph)!

I decided to consult a good neighborhood mechanic I know and we tried all kinds of checks on different fuses - make sense since a lot of stuff don't have any power at all. ALL the fuses we checked (engine compartment and trunk) where found to be good. One particular part we tested is the 'Pre-Power Fuse Box' (PN 2045403550) next to the battery. It seemed one (1) terminal on this fuse box does not have power where there should be. According to my mechanic, power is distributed to the other fuse boxes (engine compartment, trunk and dashboard) from this part and then to multiple components and systems (but not on all systems are on the same terminal). The Starter is connected to its own terminal so when you try to start the car, the engine is cranking. The other terminal is fine (that explains power to door locks, etc.)

Also, according to my mechanic, under this 'Pre-Power Fuse Box' there are also built-in fuses (that are not supposed to be replaceable). In effect, MB wants you and me to replace the whole 'Pre-Power Fuse Box' assembly whenever it is bad.


Our tests on this part is continuing, so stay tune. This could be the answer to a lot of question where the engine would crank but will not start. I suggest you do your own testing on this part if you are experiencing the same issues as my car.


If anyone on this board has an internal circuit diagram on this 'Pre-Power Fuse Box', kindly please post it, as well as instructions on how to take it out and install the new one.


Good luck!!

I got a "Cruise Control Not Operable" message today while I was driving for no reason. Everything works OK. I can hear the steering lock engaging ect ect. I went inside for about an hour, came out started the car fine and now the message is gone.

Last edited by Colin G; 09-13-2016 at 06:10 PM.
Colin G is offline  
Old 09-13-2016, 06:08 PM
  #302  
Super Member
 
Join Date: Aug 2016
Location: Regina SK
Posts: 517
Liked 42 Times in 39 Posts
2008 C-230 4Matic Sport
Originally Posted by IGB View Post

Mine is a Canadian car and my VIN is not recognized on that site.
Colin G is offline  
Old 11-22-2016, 10:03 AM
  #303  
Newbie
 
Join Date: Jun 2011
Posts: 7
Likes: 0
Liked 0 Times in 0 Posts
C230 K 2004
Hi, i am a repair shop owner, i specialize in european cars and had a customer bring his car on towing. Guess what, the steering locked is screwwed.
We had the column removed and figured we can't take the ESL out without destroying it.
I thought that we coud replace the little motor in the ESL but as i've read, we can't remove it without destroying it.
I am now looking at an emulator to delete this crap outta that car. It will also be the most simple fix that i can perform.
Not to mention that the nearest MB dealer is at 500 km. So i HAVE to find a solution.
I sent a message to Charles.soori because he is in Ontario, near me(Quebec) so he could sell or rent me the tools needed to solve the problem.
Waiting for any of you to reply if you can help me, sell me one of those emulator.

Max
Supercab is offline  
Old 11-22-2016, 10:18 AM
  #304  
Junior Member
 
Join Date: Mar 2013
Location: Ontario, Canada
Posts: 61
Liked 4 Times in 4 Posts
2008 C300
Email sent
​​​​​​​
Originally Posted by Supercab View Post
Hi, i am a repair shop owner, i specialize in european cars and had a customer bring his car on towing. Guess what, the steering locked is screwwed.
We had the column removed and figured we can't take the ESL out without destroying it.
I thought that we coud replace the little motor in the ESL but as i've read, we can't remove it without destroying it.
I am now looking at an emulator to delete this crap outta that car. It will also be the most simple fix that i can perform.
Not to mention that the nearest MB dealer is at 500 km. So i HAVE to find a solution.
I sent a message to Charles.soori because he is in Ontario, near me(Quebec) so he could sell or rent me the tools needed to solve the problem.
Waiting for any of you to reply if you can help me, sell me one of those emulator.

Max
charles.soori is offline  
Old 11-28-2016, 05:19 PM
  #305  
Newbie
 
Join Date: Mar 2012
Posts: 6
Liked 0 Times in 0 Posts
W304 C350 2010
Mine went, too. 73K miles. 2010 C350.

Dealer charged $1700 to fix it. Ugh.
sancarlosscott is offline  
Old 11-28-2016, 07:10 PM
  #306  
Junior Member
 
Join Date: Mar 2013
Location: Ontario, Canada
Posts: 61
Liked 4 Times in 4 Posts
2008 C300
That's expensive. With that amount I can fix 3 cars.
Originally Posted by sancarlosscott View Post
Dealer charged $1700 to fix it. Ugh.
charles.soori is offline  
The following users liked this post: charles.soori
sancarlosscott (11-28-2016)
Old 03-31-2017, 11:22 AM
  #307  
Newbie
 
Join Date: Mar 2017
Posts: 1
Likes: 0
Liked 1 Time in 1 Post
Range Rover Sport SC
Thumbs up

Originally Posted by Will Faris View Post
My 2008 C350 wouldn't start. I got the familiar signs of EIS/ESL issues in this thread. After a few days of talking to a friend that's a MB tech and reading the forums I thought id try the basics like getting a new key fob battery and moving the steering wheel. No luck there. In desperation I stuck my finger in the fob socket and the tip of my finger was all black. Got some rubbing alcohol on a qtip and thoroughly cleaned the socket out. Inserted the fob afterwards and I immediately hear the steering column unlock and the car started. It's been two weeks now of daily driving and no more issues. Praying that a dirty socket was all that it was.
I would like to thank Will Faris for the smartest, simplest and definitely the cheapest solution to the "2008 c300 won't start" problem. I'm sure there are a few possible causes and some expensive to fix, but I wonder how many unlucky c300 owners outside of warranty had to stump-up ~$1000 when all they needed was a Q-tip and some rubbing alcohol.

My son now drives our 2008 C300 4-matic and yesterday he found it would not start when trying to get to school. I took a look at it later in the day and first thing I checked was obviously the battery. I did notice the lack of whirring noise when turning the key, but there was no clicking noise either. battery was good however. Obviously something else afoot so I googled and came across this thread.

We had exactly the same symptoms as described by earlier posts in this thread (int. lights work, radio works, windows don’t work, battery good; engine won't start blah, blah…) I then read Will Faris' suggestion and it kind of made sense. Nine year old car; son that never cleans it...huh, is it that simple? Still, I was a little surprised someone dismissed the idea so readily and even went to great lengths in describing why it was such a stupid idea. Given that it was such a stupid idea, I decided to try it.

I stuck the Q-tip in the key chamber, gave it a whirl and sure enough, there was plenty of black "stuff" that came out. I suspect, with 1000s of times the key has gone in and out of the chamber it has worn away the plastic material, leaving fine dust to accumulate over time.

When someone suggests a solution that sounds too simple to be true, they may well be on to something—especially when someone else dismisses the idea with such condescending contempt.

I'm so glad I read this thread and tried such a stupid idea before putting the car in the hands of a car mechanic.
TheMoke is offline  
The following users liked this post: TheMoke
MBLadydriver (11-12-2017)
Old 03-31-2017, 03:41 PM
  #308  
Member
 
Demvang's Avatar
 
Join Date: Jun 2015
Posts: 140
Liked 10 Times in 10 Posts
2011 C300 4Matic Sport
Can't imagine that dirty key socket would cause problems ... thanks for the tip.
Demvang is offline  
Old 04-02-2017, 04:11 PM
  #309  
Newbie
 
Join Date: Apr 2017
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
2008 C230 4-Matic
2008 C230 4-matic

Originally Posted by Ron Jr View Post
I am so glad I got rid of my 2008.
My car won't start...checked battery Andy it is fine...reading thru these messages opened my eyes about reported similar issues.

Word of advise. don't buy Mercedes. Their perception is these we better cars but owning two three of MB in last ten years only had problems and spend money to maintain these cars.

Time to switch other manufacturer!
Dooncomputer is offline  
Old 04-17-2017, 01:13 PM
  #310  
Newbie
 
Join Date: Apr 2017
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
C300 SPORT
I've been reading this thread because I have just experienced this issue. I have an 2008 C300 with right under 100k miles. Went out to start my car Sunday and nothing. Just wondering if there were any updates within the last year. Having my car towed to the dealership later today. Trying to brace myself for what they are going to say.
AHARRIS831 is offline  
Old 04-17-2017, 01:22 PM
  #311  
Junior Member
 
Join Date: Mar 2013
Location: Ontario, Canada
Posts: 61
Liked 4 Times in 4 Posts
2008 C300
Originally Posted by AHARRIS831 View Post
I've been reading this thread because I have just experienced this issue. I have an 2008 C300 with right under 100k miles. Went out to start my car Sunday and nothing. Just wondering if there were any updates within the last year. Having my car towed to the dealership later today. Trying to brace myself for what they are going to say.
if you can remove your esl, eis and send them to me I can fix it, for way cheaper. Dealer will tell you close to 1500+$
if you need a emulator programed all I need is your eis and working key
charles.soori is offline  
Old 08-28-2017, 04:16 PM
  #312  
Newbie
 
Join Date: Aug 2017
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
C300
Hope this helps.. or, may be good steps to try for other similar issues

Hi,

I'm not a mechanic nor claim to be Benz expert.. so just a suggestion if it helps in anyway.

I had issue 2-3 years ago starting my 2008 C300 after car battery replacement (from AutoZone). Somehow, I got it started few times, but at one point it did not start and I had to call in AAA. I initially thought it was battery related issue, but the AAA tech use to work for Benz Services got my car started in 10 seconds. He told me the car was in "Security Lockdown". He recommended following steps in order. (Note: Try Procedure 2 only if first one doesn't work.)


To unlock the security -

Procedure 1:

(1) Unlock the car,
(2) Turn the key all the way without starting the car
(3) Let the mirrors open up and everything to reset (~ 10 seconds) -- Should do this every time!
(4) Start the car


Procedure 2:

If above doesn't work, here's a keyless entry option on the key:

(1) Press Unlock
(2) Lock
(3) Unlock
(4) Lock
(5) Lock
(6) Unlock
(7) Follow Procedure 1 steps above


I was told the Procedure 1 should be best practice for every day use as well!


Same issue happened to me 3 weeks ago after my car was sitting in driveway for 3 weeks. I searched internet for couple days trying to recall these steps, but could not find it anywhere! Luckily, I had documented above step and emailed it to myself.

Please spread this steps in other posts as I've read about similar symptoms I had reported. Again, it may not solve the ESI or other issues, but this is 10 second steps that may save lot of money and headache for people so please do pass it around.

Thanks
hmp32 is offline  
Old 10-04-2017, 06:20 PM
  #313  
Newbie
 
Join Date: Oct 2017
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
2008 C300
Inter

Originally Posted by c3nthusiast View Post
You key sensor and steering wheel lock sensor may be bad. $800-1600 depending on what's wrong.
Not convinced.
What if this is intermittent? Happens to my 2008 C300 maybe 3 times a week.

Key battery was replaced. No change. Occasionally it won't start for a while.

Sometimes, I leave the key in, and it will beep, signaling that the car is ready to start up. This happens when I'm dialing AAA
George Darwin is offline  
Old 03-15-2018, 05:39 PM
  #314  
Newbie
 
Join Date: Mar 2018
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
C300 4matic
QTIP Option?

Originally Posted by TheMoke View Post
I would like to thank Will Faris for the smartest, simplest and definitely the cheapest solution to the "2008 c300 won't start" problem. I'm sure there are a few possible causes and some expensive to fix, but I wonder how many unlucky c300 owners outside of warranty had to stump-up ~$1000 when all they needed was a Q-tip and some rubbing alcohol.

My son now drives our 2008 C300 4-matic and yesterday he found it would not start when trying to get to school. I took a look at it later in the day and first thing I checked was obviously the battery. I did notice the lack of whirring noise when turning the key, but there was no clicking noise either. battery was good however. Obviously something else afoot so I googled and came across this thread.

We had exactly the same symptoms as described by earlier posts in this thread (int. lights work, radio works, windows don’t work, battery good; engine won't start blah, blah…) I then read Will Faris' suggestion and it kind of made sense. Nine year old car; son that never cleans it...huh, is it that simple? Still, I was a little surprised someone dismissed the idea so readily and even went to great lengths in describing why it was such a stupid idea. Given that it was such a stupid idea, I decided to try it.

I stuck the Q-tip in the key chamber, gave it a whirl and sure enough, there was plenty of black "stuff" that came out. I suspect, with 1000s of times the key has gone in and out of the chamber it has worn away the plastic material, leaving fine dust to accumulate over time.

When someone suggests a solution that sounds too simple to be true, they may well be on to something—especially when someone else dismisses the idea with such condescending contempt.

I'm so glad I read this thread and tried such a stupid idea before putting the car in the hands of a car mechanic.

I've got a C300 4matic with under 100K miles on it and seem to be yet another victim of this same problem...The car is with my go-to mechanic now, who just called to say that he can't fix the problem, that it's an issue with the key and/or EIS, and it needs to be brought to the dealer to be fixed... After reading through all posts - was curious to know if anyone else had tried and had luck with the q-tip / rubbing alcohol method? Or had any luck fighting MB on this recurring issue?
FLA_MB is offline  
Old 03-15-2018, 07:43 PM
  #315  
Super Member
 
Join Date: Nov 2016
Posts: 531
Liked 89 Times in 82 Posts
2008 C300 Sport
Originally Posted by FLA_MB View Post
I've got a C300 4matic with under 100K miles on it and seem to be yet another victim of this same problem...The car is with my go-to mechanic now, who just called to say that he can't fix the problem, that it's an issue with the key and/or EIS, and it needs to be brought to the dealer to be fixed... After reading through all posts - was curious to know if anyone else had tried and had luck with the q-tip / rubbing alcohol method? Or had any luck fighting MB on this recurring issue?


https://www.ebay.ca/itm/MERCEDES-W20...tak6vA&vxp=mtr

Again, get the emulators, they are half the cost and you will never have to worry about it failing again, the only down side is if the car gets stolen, your insurance might have an issue with the steering lock not being there but they dont need to know that. If someone can steal your car without your key, lock or no lock it wont matter anyways.
ltwargssf is offline  
Old 01-29-2019, 02:51 AM
  #316  
Junior Member
 
huotalicusC200K's Avatar
 
Join Date: May 2014
Location: MELBOURNE VICTORIA AUSTRALIA
Posts: 70
Likes: 0
Liked 1 Time in 1 Post
w2010 w204 c300 amg sports package
ITS MOST LIKELY THE ESL
W204S ALL MODELS UP TO 2014 HAVE THIS ISSUE
ITS THE NOTOR IN THE ESL THAT FAILS OVERTIME NOT THE NEC CHIP
HOWEVER IF YOU ATTEMPT TO REMOVE THE ESL IN THE LOCK POSITION BY GRINDING OFF THE LOCKING BOLT ON TOP OF THE ESL..AND THEN YOU OPEN THE ESL, YOU WILL DEFINITELY FRY THE CHIP
SO ITS IMPORTANT TO TRY AND GET THE ESL IN THE UNLOCKED POSITION THEN DISCONNECT THE BATTERY WITH YOUR KEY IN THE IGNITION ...THAT WAY IT WONT LOCK ON YOU AGAIN
YOU CAN TRY BY TAPPING ON THE STEERING COLUMN WITH A HAMMER AND THAT CAN SOMETIMES SHOCK THE ESL TO SPIN ONE MORE ROTATION I DID THIS AND IT WORKED AND SO HAVE OTHER PEOPLE , JUST BE AWARE ITS BY CHANCE
CUZ IF YOU PULL THE KEY OUT IT WILL LOCK AGAIN STRAIGHT AWAY
IF UR SKILL LEVEL IS DESCENT AND U MANAGE TO GET THE ESL TO UNLOCK, DISCONNECT THE BATTERY AND YOU CAN REMOVE THE ESL YOURSELF WITH SOME TIME AND EFFORT, ITS A DESCENT JOB, AND IF YOUR NOT COMFORTABLE WITH OPENING THE ESL THEN
REMOVING IT AND GETTING SOMEONE TO OPEN IT AND FIX IT WILL STILL SAVE YOU ON THE LABOUR COSTS, WHICH IS NORMALLY AROUND 1000
ESL BYPASS IS ACTUALLY A GOOD IDEA THEN YOU NEVER HAVE TO WORRY ABOUT IT AGAIN AND IT IS HALF THE PRICE ..IT WILL JUST NEED TO BE CODED TO YOUR CAR...MOST LOCAL AUTOMOTIVE KEY SPECIALISTS CAN DO THIS

YOU CAN BUY ESP BYPASSES FOR AROUND 50 TO 100 OFF EBAY AND THEN GET IT CODED TO YOUR CAR ....THAT WAY YOU DONT EVEN HAVE TO REMOVE THE OLD ESL, OR YOU CAN EVEN BUY A BYPASS THAT LOOKS JUST LIKE YOUR ESL AND THAT WILL THEN BE FITTED TO YOUR CAR SO THAT YOU NEVER HAVE TO WORRY ABOUT THE ESL LOCKING YOUR STEERING WHEEL, ITS A GOOD INVENTION THATS FOR SURE
AND THEY WERE INVENTED CUZ W204S HAVE THE MOST UNRELIABLE ESL MODULES...ALL BECUZ OF THAT MOTOR INSIDE THE MODULE

huotalicusC200K is offline  
Old 04-15-2019, 02:10 PM
  #317  
Newbie
 
Join Date: Apr 2019
Location: Phoenix, AZ
Posts: 8
Likes: 0
Liked 1 Time in 1 Post
C 250
Has anyone reported this issue with FL models? I have a 2013 C250 with 41,000 miles and I have the intermittent "won't start" issue. I have just been turning it off, take the key out, reinsert and it'll start. Sometimes it's taken two tries but usually one does the trick. Not really happy about ponying up $1,000+ to resolve this.
PHXBenz is offline  
Old 04-16-2019, 10:44 AM
  #318  
Super Member
 
Join Date: Sep 2015
Location: Milwaukee, WI USA
Posts: 697
Likes: 0
Liked 72 Times in 69 Posts
2012 C300 4Matic
Originally Posted by PHXBenz View Post
Has anyone reported this issue with FL models? I have a 2013 C250 with 41,000 miles and I have the intermittent "won't start" issue. I have just been turning it off, take the key out, reinsert and it'll start. Sometimes it's taken two tries but usually one does the trick. Not really happy about ponying up $1,000+ to resolve this.
I don't know that I remember anyone on here with a face lift model that has had a confirmed issue with that. Doesn't seem to be an issue with the face lift models, at least not yet.
Alfadude is offline  
Old 04-16-2019, 07:10 PM
  #319  
Newbie
 
Join Date: Apr 2019
Location: Phoenix, AZ
Posts: 8
Likes: 0
Liked 1 Time in 1 Post
C 250
Originally Posted by Alfadude View Post
I don't know that I remember anyone on here with a face lift model that has had a confirmed issue with that. Doesn't seem to be an issue with the face lift models, at least not yet.
Thank you, Alfadude! I’ll keep you all posted if it gets worse. It’s been fine the last couple of days.
PHXBenz is offline  
Old 04-18-2019, 06:49 PM
  #320  
Member
 
Join Date: Aug 2016
Location: Seattle
Posts: 83
Liked 2 Times in 2 Posts
2004.5 C230 Kompressor Sport
Happend to me the other week. 2009 c300 83kmiles dealer charged $1350 and within 1 day it was fixed. Damn steering lock
dboyrusky is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: 2008 C300 won't start


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: