Whining noise around 40mph - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Whining noise around 40mph >

Whining noise around 40mph

Notices
C-Class (W204) 2008-Present: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Whining noise around 40mph

Old 01-09-2019, 03:11 PM
  #1  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
Whining noise around 40mph

I have a 2010 c300 4matic with about 90,000 miles on it. Iíve noticed that when ever I am coasting from 55 down to around 40 miles an hour there is a whining noise but as soon as it gets below 40 mph and it goes away, The car shift fine in runs great no other issues. Any ideas what this might be.
ethanr24 is offline  
Old 01-09-2019, 06:09 PM
  #2  
MBWorld Fanatic!
 
Adi-Benz's Avatar
 
Join Date: Apr 2016
Location: Milwaukee, WI
Posts: 3,034
Thanked 242 Times in 221 Posts
2010 C300 4MATIC
Does it get louder when you go faster
Adi-Benz is online now  
Old 01-09-2019, 08:41 PM
  #3  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
Not at all, I only hear when I'm coasting down to around 40mph. Anything under 40 and it goes away
ethanr24 is offline  
Old 01-09-2019, 11:11 PM
  #4  
Super Member
 
Join Date: Mar 2011
Location: Bay Area, CA
Posts: 624
Thanked 6 Times in 6 Posts
2011 C300 Sport, P1, MM, Wood, Heated FS, DIY rearview camera. 2002 QX4
The other way around: when you slowly speed up from below 40 mph to above, do you hear that? "Slowly" to minimize engine/exhaust running noise so it will not cover the whining noise.
C300CA is offline  
Old 01-09-2019, 11:16 PM
  #5  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
I don't hear it at all when speeding up
ethanr24 is offline  
Old 01-09-2019, 11:27 PM
  #6  
Super Member
 
Join Date: Mar 2011
Location: Bay Area, CA
Posts: 624
Thanked 6 Times in 6 Posts
2011 C300 Sport, P1, MM, Wood, Heated FS, DIY rearview camera. 2002 QX4
When whining occurs, if you shift to N, do you still hear it? I assume your 'coasting' was in D.
C300CA is offline  
Old 01-09-2019, 11:29 PM
  #7  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
it stops when in N, must mean something with the transmission
ethanr24 is offline  
Old 01-09-2019, 11:38 PM
  #8  
Newbie
 
Join Date: Jan 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
C250
It could be the rear differential resonating at a certain RPM as well. They're known to whine when no power is applied. If you press the gas and keep it at 40, as opposed to only when you're winding down, does it still make noise? If you have a long hill nearby (any incline should be good) try putting cruise control to 40mph and see if you still hear it when it's under load.
JimmyKudo is offline  
Old 01-10-2019, 12:01 PM
  #9  
Super Member
 
Funkwagen's Avatar
 
Join Date: Oct 2014
Location: London, Ontario, Canada
Posts: 610
Thanked 76 Times in 57 Posts
2009 C63 AMG, 2010 C250 4Matic Sport
Can you tell if the whine is coming from the front or rear of the car?

It's pretty common to have a minor whine at certain speeds with no load and I think it comes from the front diff or prop shaft. Not sure which, but I've had that noise come and go for over 150,000km with no issue.
Funkwagen is offline  
Old 01-10-2019, 03:10 PM
  #10  
Newbie
 
Join Date: Dec 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300 4Matic
Im having the same issue with my car (2010 c300 4matic aswell). It began noticing it when I put new wheels on my car, so im not sure if its something to do with that or something else. Sounds like the whine is coming from the front passenger side
Jayd3n is offline  
Old 01-11-2019, 01:01 AM
  #11  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
I went out and tested for a bit, can confirm the noise is still there when I shift into N. Hope that narrows it down.
ethanr24 is offline  
Old 01-11-2019, 01:02 AM
  #12  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
Sounds like it’s coming from behind and below the center controls.

Last edited by ethanr24; 01-11-2019 at 01:03 AM. Reason: Wording
ethanr24 is offline  
Old 01-11-2019, 01:09 AM
  #13  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
It’s not as loud but I still hear when cc on 40
ethanr24 is offline  
Old 01-11-2019, 10:39 AM
  #14  
Senior Member
 
Join Date: Nov 2016
Posts: 470
Thanked 82 Times in 76 Posts
2008 C300 Sport
I don't think its the transfer case because it would always whine(Hum/grind), regardless of speed and would continue to do so even if put in neutral. Does the whine happen when you let of the gas and start coasting at 40mph ?

If so, I had this issue once, a really faint whine only from 42-45mph when letting off the throttle. I did some research and all I found what a TSB on the clip holding the shifter linkage. I went under and saw the clip holding the shifter lever was crooked ( Must have reinstalled it poorly when changing transfer case bearings). I removed it and installed it correctly and the whine never came back.
ltwargssf is offline  
Old 01-11-2019, 10:53 AM
  #15  
Super Member
 
xsever's Avatar
 
Join Date: Aug 2013
Posts: 947
Thanked 63 Times in 59 Posts
2012 C300 4MATIC Sport - 2005 CLK 320
Originally Posted by ltwargssf View Post
I don't think its the transfer case because it would always whine(Hum/grind), regardless of speed and would continue to do so even if put in neutral. Does the whine happen when you let of the gas and start coasting at 40mph ?

If so, I had this issue once, a really faint whine only from 42-45mph when letting off the throttle. I did some research and all I found what a TSB on the clip holding the shifter linkage. I went under and saw the clip holding the shifter lever was crooked ( Must have reinstalled it poorly when changing transfer case bearings). I removed it and installed it correctly and the whine never came back.
Would you happen to have the TSB saved still to share it with us?
xsever is offline  
Old 01-11-2019, 11:01 AM
  #16  
Senior Member
 
Join Date: Nov 2016
Posts: 470
Thanked 82 Times in 76 Posts
2008 C300 Sport
Originally Posted by xsever View Post
Would you happen to have the TSB saved still to share it with us?

Unfortunately I can't seem to find it right now, here is the thread where we discussed the same issue;
https://mbworld.org/forums/c-class-w...eleration.html
ltwargssf is offline  
Old 01-11-2019, 11:33 AM
  #17  
Newbie
Thread Starter
 
Join Date: Oct 2018
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2010 C300
I'm hearing the same noise your describing. I can also hear when in cc around that speed. Ill have my service tech look into it and post back with the results when I can
ethanr24 is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Whining noise around 40mph


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: