Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C Class (W205)
COMAND 10.25" Screen Upgrades >

COMAND 10.25" Screen Upgrades

Notices
C Class (W205) C 180 BlueTec,C 200 BlueTec,C 220 BlueTec,C 220 BlueTec BlueEfficiency,C 250 BlueTec,C 300 BlueTec Hybridplus,C 180,C 180 BlueEfficiency,C 200,C 250,C 300,C 400 Plug-in Hybrid,C 400

COMAND 10.25" Screen Upgrades

 
Old 07-31-2016, 10:01 PM
  #51  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by ItchyTasty View Post
dumb that they would ship products to the USA with chinese UI
You're thinking like this is a brand name product from a big corporation. It is not. It's not even an official aftermarket part. It is more like a small shop operation. While I don't praise their Chinese menu, I do appreciate their innovation. It's not easy coming up with an idea like that and turn it into a product, not knowing how much you're going to make money from it.
huyuci is offline  
Old 08-01-2016, 01:48 PM
  #52  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Originally Posted by huyuci View Post
If you have 2015 w205, most likely it'd work. If you have 2016, based on my experience, there's a chance that the software interface won't be compatible. I'm keeping my finger crossed.
I do have a 2016. Hopefully it works. I see that you got yours in. That's awesome. Mine should be in today. Someone asked for a video so I'll post one up too. I tried funding that module you talked about for mirroring but couldn't find the thread. Do you remember the title? Thanks
JafG is offline  
Old 08-01-2016, 04:06 PM
  #53  
Junior Member
 
Join Date: Jun 2016
Posts: 24
Thanked 0 Times in 0 Posts
W205
Funny thread. What they should have done is remove the black borders around the 8.4 so that it's stretched fully, that would look very nice and sufficient in size.
cptobvious64 is offline  
Old 08-01-2016, 04:51 PM
  #54  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by JafG View Post
I do have a 2016. Hopefully it works. I see that you got yours in. That's awesome. Mine should be in today. Someone asked for a video so I'll post one up too. I tried funding that module you talked about for mirroring but couldn't find the thread. Do you remember the title? Thanks
Here's the link to what I bought. Hey, let me know how your installation go. For the life of me I couldn't get sound from playing video. Everything else works for me.

http://www.aliexpress.com/item/Unive...08.0.55.tpvhVp
huyuci is offline  
Old 08-01-2016, 05:50 PM
  #55  
Member
 
Join Date: Sep 2015
Posts: 243
Thanked 6 Times in 6 Posts
2015 C300 Sport
Originally Posted by huyuci View Post
Here's the link to what I bought. Hey, let me know how your installation go. For the life of me I couldn't get sound from playing video. Everything else works for me.

http://www.aliexpress.com/item/Unive...08.0.55.tpvhVp

the engrish is horrible, but they mentioned something about that in the description

"SINCE NTG 5 HAVEN'T THE AUX INPUT , NOW JUST CAN USE THE RADIO TO OUTPUT THE SOUND"
ItchyTasty is offline  
Old 08-01-2016, 06:06 PM
  #56  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by ItchyTasty View Post
the engrish is horrible, but they mentioned something about that in the description

"SINCE NTG 5 HAVEN'T THE AUX INPUT , NOW JUST CAN USE THE RADIO TO OUTPUT THE SOUND"
No, that's for aux audio.
huyuci is offline  
The Following User Says Thank You to huyuci For This Useful Post:
56kabrio (04-23-2018)
Old 08-01-2016, 06:35 PM
  #57  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Ok guys. I don't have a lot of pictures but I do have a video I'm trying to upload.
The screen works on my 2016 without an issue. I figured out how to put the menu in english too.
I was going to do a write up but there is nothing really to write up. Unscrew the old screen, unplug, plug the new screen rescrew. So i'm going to dump a bunch of pictures.
Quick impression, it looks really really good! I haven't lost any functionality from the car.















JafG is offline  
The Following 4 Users Say Thank You to JafG For This Useful Post:
benzdude (11-10-2018), medkm (09-15-2016), NJC63Fan (03-03-2019), rustycruiser (08-01-2016)
Old 08-01-2016, 07:10 PM
  #58  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
If you noticed when you're on the entertainment side on the right the temperature isn't displayed at the bottom.
Also you'll see in my video that i played around with the setting and had a hiccup because my car side screen froze and wouldn't work. All is good now.

Here's a quick video: https://drive.google.com/open?id=0B-...jRwMDdYblYtVmc
JafG is offline  
The Following 4 Users Say Thank You to JafG For This Useful Post:
Elicalbenz (08-03-2016), kowyzg0moo (08-02-2016), NJC63Fan (03-03-2019), rustycruiser (08-01-2016)
Old 08-01-2016, 07:28 PM
  #59  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
were you able to play video with audio?
huyuci is offline  
Old 08-01-2016, 07:29 PM
  #60  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Originally Posted by huyuci View Post
were you able to play video with audio?
I didn't try. But I have a feeling that you and I got a different system (or software). I couldn't get to your option screen. how did you get there?
JafG is offline  
Old 08-01-2016, 07:33 PM
  #61  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by JafG View Post
I didn't try. But I have a feeling that you and I got a different system (or software). I couldn't get to your option screen. how did you get there?
No, it's the same. When you touch the screen and hold a few seconds, the menu appears like GPS, Video, HDMI, Command. Select GPS. In there, there'll be menu for Entertainment. Select Videos. Please try and let me know if you have the same problem. You didn't seem to connect one of the supplied cables to the back of the monitor though. My bet is you won't definitely get sound from video. If you do, that would be very odd.
huyuci is offline  
Old 08-02-2016, 09:19 AM
  #62  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Quick update: my wife (who's very very skeptical of mods) really liked the screen and she would have thought it looked like it came with the car as an option. Coming from her it's saying something.
I can confirm the "speedometer" doesnt work ( I didn't expect it to) but to be fair I didn't plug all of the cables since I want to first ensure i don't lose any capabilities before exploring further.
I'll try the video when I get home but was thinking of plugging in a chromecast I have lying around. I just need a mini hdmi to hdmi adapter.
I'll update when I do.
JafG is offline  
Old 08-02-2016, 10:28 AM
  #63  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by JafG View Post
Quick update: my wife (who's very very skeptical of mods) really liked the screen and she would have thought it looked like it came with the car as an option. Coming from her it's saying something.
I can confirm the "speedometer" doesnt work ( I didn't expect it to) but to be fair I didn't plug all of the cables since I want to first ensure i don't lose any capabilities before exploring further.
I'll try the video when I get home but was thinking of plugging in a chromecast I have lying around. I just need a mini hdmi to hdmi adapter.
I'll update when I do.
The speedopener works. You'd just need to connect the GPS antenna to the back of the monitor. If you have Igo, it'll will also work as navigation.
huyuci is offline  
Old 08-02-2016, 10:30 AM
  #64  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Originally Posted by huyuci View Post
The speedopener works. You'd just need to connect the GPS antenna to the back of the monitor. If you have Igo, it'll will also work as navigation.
That makes sense. I already have navigation ( via SD card) so I don't really need Navi on this.
I actually have a spare oem Navi SD card if anyone wants to buy it for cheap lol.

I'll plug in the antenna. Do you know how to change it to mph?
JafG is offline  
Old 08-02-2016, 01:14 PM
  #65  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by JafG View Post
That makes sense. I already have navigation ( via SD card) so I don't really need Navi on this.
I actually have a spare oem Navi SD card if anyone wants to buy it for cheap lol.

I'll plug in the antenna. Do you know how to change it to mph?
I don't think it's changeable. I tried all the menus and didn't see anything that would change it. It's probably hardcoded.
Anyway, I got the sound to work. It's actually thru the FM channel you set in the menu. So, I got a package that has a huge high def touch screen that can play videos and can also do GPS navigation. It's a "huugge" bargain

I'm loving it. Here's my video. I'll upload another when I put everything together with screen mirror and TV tuner.

Last edited by huyuci; 08-02-2016 at 01:16 PM.
huyuci is offline  
The Following 7 Users Say Thank You to huyuci For This Useful Post:
cfourfifty_2016 (12-04-2017), Elicalbenz (08-03-2016), gtnotoriouz (01-20-2019), ionz13 (04-17-2018), ItchyTasty (08-02-2016), JafG (08-03-2016), ~ BENZ~ (01-22-2017)
Old 08-03-2016, 02:05 AM
  #66  
Junior Member
 
Join Date: Apr 2015
Posts: 53
Thanked 2 Times in 2 Posts
C400
Is it always split screen or can you "full screen" a video? I know the aspect ratio probably won't be right for most vids.
Stupidnewbie is offline  
Old 08-03-2016, 04:12 AM
  #67  
Junior Member
 
Join Date: Sep 2015
Location: WA state
Posts: 19
Thanked 0 Times in 0 Posts
2015 C300 sport 4Matic
Originally Posted by JafG View Post
That makes sense. I already have navigation ( via SD card) so I don't really need Navi on this.
I actually have a spare oem Navi SD card if anyone wants to buy it for cheap lol.

I'll plug in the antenna. Do you know how to change it to mph?
Great job by the way and it looks great, now time to save some money in order to buy one. May you PM me how much you are selling your spare SD card? It hasn't been inserted on your car has it? Thanks.
Elicalbenz is offline  
Old 08-03-2016, 09:08 AM
  #68  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Originally Posted by Elicalbenz View Post
Great job by the way and it looks great, now time to save some money in order to buy one. May you PM me how much you are selling your spare SD card? It hasn't been inserted on your car has it? Thanks.
I'll send you a pm. No it hasn't. I actually ordered it when I bought my car that was being transferred (without a gaps SD card) but the dealership had a mix up. They ended up ordering another car with extra options for me at no cost to me. That's how I ended up with 2.
JafG is offline  
Old 08-03-2016, 05:10 PM
  #69  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by Stupidnewbie View Post
Is it always split screen or can you "full screen" a video? I know the aspect ratio probably won't be right for most vids.
So far I haven't been able to make it full screen yet. According to the video I saw on FB, it's full screen when it's in phone mirror. I haven't had a chance to try it.
huyuci is offline  
Old 08-03-2016, 07:35 PM
  #70  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Originally Posted by huyuci View Post
No, it's the same. When you touch the screen and hold a few seconds, the menu appears like GPS, Video, HDMI, Command. Select GPS. In there, there'll be menu for Entertainment. Select Videos. Please try and let me know if you have the same problem. You didn't seem to connect one of the supplied cables to the back of the monitor though. My bet is you won't definitely get sound from video. If you do, that would be very odd.
Hey huyuci I tried it and it's not working. I do think we have different version of the software because if you look at your left screen COMAND (misspelled) is in all caps, but in mine it's small caps.
JafG is offline  
Old 08-03-2016, 07:43 PM
  #71  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
So i figured out to get the system to display the temp I had to plug a bridge cable (included) into the DVD unit.
The only issue is that it displays in Celsius and doesn't show auto when i have climate control on. It shows the actual fan speed and temp which is actually kinda nice since I still have the oem screen on the left (see picture)

JafG is offline  
The Following User Says Thank You to JafG For This Useful Post:
wogga (09-24-2017)
Old 08-03-2016, 11:52 PM
  #72  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by JafG View Post
Hey huyuci I tried it and it's not working. I do think we have different version of the software because if you look at your left screen COMAND (misspelled) is in all caps, but in mine it's small caps.
Look again. Mine is also in lower case. The only thing I don't know why is yours displaying Celsius and mine is Fahrenheit. And I didn't have to plug any cable. Plugging in the cable would give you control (return button) on the steering wheel. It didn't give me sound for the Aux like it's supposed to. But other than that, it's working fine.

So did you try pressing GPS? what did it say? Post a snapshot.
huyuci is offline  
Old 08-04-2016, 07:14 AM
  #73  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Originally Posted by huyuci View Post
So is it only in CAPS in chineses?
I'll take screen shots today. When I go into GPS it's just a white screen and nothing happens when I touch it.
JafG is offline  
Old 08-04-2016, 10:41 AM
  #74  
Super Member
 
Join Date: Dec 2014
Posts: 597
Thanked 37 Times in 28 Posts
c300
Originally Posted by JafG View Post
So is it only in CAPS in chineses?
I'll take screen shots today. When I go into GPS it's just a white screen and nothing happens when I touch it.
Yes. I looked at your video and it's in lower case when it's in English as in mine. When you see the white screen, look carefully. There's a cross hair. Touch on it wherever it moves, then finally ok. It's to calibrate the touch screen. After that, you should see the menu.
huyuci is offline  
The Following User Says Thank You to huyuci For This Useful Post:
JafG (08-04-2016)
Old 08-04-2016, 12:31 PM
  #75  
Junior Member
 
Join Date: Jul 2016
Posts: 33
Thanked 21 Times in 7 Posts
c300 w205
Originally Posted by huyuci View Post
Yes. I looked at your video and it's in lower case when it's in English as in mine. When you see the white screen, look carefully. There's a cross hair. Touch on it wherever it moves, then finally ok. It's to calibrate the touch screen. After that, you should see the menu.
Calibrating did it! Awesome thanks. I'm not sure why you didn't have to log in the extra cable... But now that I did it recognizes when the door is opened so that's great. I'm really happy with the system!
JafG is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: COMAND 10.25" Screen Upgrades


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:
You Rated this Thread: 5