Go Back  MBWorld.org Forums > Mercedes-Benz AMG Vehicles > C63 AMG (W204)
Transmission shifting problems >

Transmission shifting problems

Notices
C63 AMG (W204)
Sponsored by:
Sponsored by:

Transmission shifting problems

 
Old 06-02-2012, 06:22 PM
  #1  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Transmission shifting problems

For the last couple of days i noticed that my car shifts funny from first to secound, regardless if in S or M mode, feels almost like its slipping and the it engages a little harsh...
Has anyone had any transmission problems with their c63???
crazy1469 is offline  
Old 06-02-2012, 06:36 PM
  #2  
Banned
 
Join Date: Nov 2010
Posts: 955
Likes: 0
Received 1 Like on 1 Post
2008 C63 ,2009 SL 63 AMG, 2011 SLS AMG
Originally Posted by crazy1469 View Post
For the last couple of days i noticed that my car shifts funny from first to secound, regardless if in S or M mode, feels almost like its slipping and the it engages a little harsh...
Has anyone had any transmission problems with their c63???
are you sure it the transmission and not that your tires need replacement?
jacob502 is offline  
Old 06-02-2012, 07:01 PM
  #3  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Originally Posted by jacob502 View Post
are you sure it the transmission and not that your tires need replacement?
You make a good point but no my tires are still ok, and even at light throtle it still happens, and specially when the car is cold
crazy1469 is offline  
Old 06-02-2012, 09:03 PM
  #4  
Member
 
theturkster's Avatar
 
Join Date: Oct 2011
Location: Kuwait
Posts: 75
Likes: 0
Received 0 Likes on 0 Posts
2012 C63 Coupe
im having the same issue.. made a post about it too. not sure whats causing it. is your car Tuned?
theturkster is offline  
Old 06-02-2012, 09:20 PM
  #5  
Super Member
 
Join Date: Mar 2009
Location: Calgary, AB
Posts: 567
Likes: 0
Received 0 Likes on 0 Posts
2012 C63 AMG
I have this problem as well, it's the worst when I'm coasting slow towards a light, and then on the throttle when the light turns green before I come to a complete stop. It's a very abrupt jolt.
Illusive is offline  
Old 06-02-2012, 09:23 PM
  #6  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Lets hope some of the experts chime in on this isue.....most likely i will be taking it in to the dealer to have this looked at
crazy1469 is offline  
Old 06-02-2012, 09:39 PM
  #7  
Senior Member
 
Join Date: May 2012
Location: Chicago, IL
Posts: 402
Likes: 0
Received 0 Likes on 0 Posts
C63
Originally Posted by Illusive View Post
I have this problem as well, it's the worst when I'm coasting slow towards a light, and then on the throttle when the light turns green before I come to a complete stop. It's a very abrupt jolt.
The C63 actually downshifts pretty hard at times so coming to a complete stop can be a bit annoying.

It used to happen to me all the time in California when coming to a stop, but I haven't really felt it too much with the city driving in Chicago.

I'm curious about the shifting from 1st to 2nd though. I don't think I've ran across that issue before.
HoozyerdaddyC63 is offline  
Old 06-03-2012, 12:28 AM
  #8  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Originally Posted by theturkster View Post
im having the same issue.. made a post about it too. not sure whats causing it. is your car Tuned?
No my car is still on factory tune...
crazy1469 is offline  
Old 06-03-2012, 12:53 AM
  #9  
Member
 
Join Date: Jan 2011
Location: Everywhere
Posts: 204
Likes: 0
Received 0 Likes on 0 Posts
C63 AMG
My car does this from time to time after a lot of highway miles. I have found that reseting the trans adaptations by pulling the negative terminal on the battery for 10 minutes will fix the issue.
AMGFTW is offline  
Old 06-03-2012, 12:56 AM
  #10  
Super Member
 
Join Date: May 2007
Location: Ontario, Canada
Posts: 564
Likes: 0
Received 5 Likes on 4 Posts
W204 C63 R171
If your car is downshifting from 2nd to 1st hard in sport mode only you need to get your valve body replace and hope your car still has warranty on it... mine was downshifting hard from 2nd to 1st when it was cold approaching a stoplight and it was annoying... dealership under warranty replaced the value body in the transmission the problem has been fixed.
andrew c230k is offline  
Old 06-03-2012, 01:51 AM
  #11  
MBWorld Fanatic!
 
Join Date: Nov 2011
Posts: 1,466
Likes: 0
Received 1 Like on 1 Post
2012 C63 2015 C300 sport
For 2012 cars I think it's the mct. Keep it in comfort mode for city driving.
natman316 is offline  
Old 06-03-2012, 09:01 AM
  #12  
Senior Member
 
Join Date: May 2012
Location: Chicago, IL
Posts: 402
Likes: 0
Received 0 Likes on 0 Posts
C63
Originally Posted by andrew c230k View Post
If your car is downshifting from 2nd to 1st hard in sport mode only you need to get your valve body replace and hope your car still has warranty on it... mine was downshifting hard from 2nd to 1st when it was cold approaching a stoplight and it was annoying... dealership under warranty replaced the value body in the transmission the problem has been fixed.
Thanks for the heads up. My warranty is good through 2016 so I'll look into that.
HoozyerdaddyC63 is offline  
Old 06-03-2012, 12:11 PM
  #13  
Newbie
 
Join Date: Aug 2010
Location: Northwest Chicago
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
C63, BMW 540i6, Lexus RX330
K&N or carbon delete? My car acted like that especially when cold with K&N and carbon delete. Put stock filters back in and car is now smooth.
jims5 is offline  
Old 06-03-2012, 01:51 PM
  #14  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Originally Posted by jims5 View Post
K&N or carbon delete? My car acted like that especially when cold with K&N and carbon delete. Put stock filters back in and car is now smooth.
No, my car is completely stock...no mods.
gonna call the dealer tomorrow to book it in so they can have a look at it
crazy1469 is offline  
Old 06-05-2012, 06:30 PM
  #15  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
UPDATE:

I droped of the car at the dealer and there is definatly a problem with the transmissio, if its the valve body or in the tranny it self is not know yet....well let u huys know more as i know
crazy1469 is offline  
Old 06-05-2012, 08:04 PM
  #16  
MBWorld Fanatic!
 
Join Date: Jul 2009
Location: SoCal
Posts: 1,196
Likes: 0
Received 1 Like on 1 Post
2013 E63 AMG
Originally Posted by crazy1469 View Post
UPDATE:

I droped of the car at the dealer and there is definatly a problem with the transmissio, if its the valve body or in the tranny it self is not know yet....well let u huys know more as i know
Sorry to hear that. I'm sure you'll be taken care of promptly, and keep us posted as to the cause.
xtyper is offline  
Old 06-05-2012, 09:59 PM
  #17  
Senior Member
 
Join Date: Jan 2012
Location: Sydney
Posts: 477
Likes: 0
Received 15 Likes on 11 Posts
2015 E400 Coupe
thats why they have a warranty. Never hesitate to take the car into a dealer and get them to check/fix any little thing that arises.
Harold1898 is offline  
Old 06-06-2012, 04:56 PM
  #18  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Originally Posted by xtyper View Post
Sorry to hear that. I'm sure you'll be taken care of promptly, and keep us posted as to the cause.
Originally Posted by Harold1898 View Post
thats why they have a warranty. Never hesitate to take the car into a dealer and get them to check/fix any little thing that arises.
that's what i though that i would be taken care, specially being a mercedes and an AMG.....WRONG!!! the are no better than any other manufactor....always trying to get out of paying for anything under warranty.....
i am a cert automotive tech, i know the drill if a car came in with a trans problem, you know it aint going to fix it, but you sell the costumer that already spent a **** load of money to buy the car, you sell him a $600 tranny flush, and then a week later he comes back with the same problem because a fluid flush is not gonna fix ****, then the will replace what needs to be replaced....so as per manufactor reccomended maintnace shedule, a trans service is not deu untill 60k...my car only has 42k...so i told them to put the car together with no flush, and when the tranny drops they will then have no choice but to replace it...or will they try to sell me a flush then too????

ohh and the service adviser told me that they can see that the car has been driven "HARD"....i replied...ofcorse if i wanted to drive it normal i would have bought a C250 and not a C63....****in rediculous....stuff like this makes my blood boil.
crazy1469 is offline  
Old 06-06-2012, 05:00 PM
  #19  
Senior Member
 
Join Date: Jan 2012
Location: Sydney
Posts: 477
Likes: 0
Received 15 Likes on 11 Posts
2015 E400 Coupe
sorry to hear that. It is a bit different over here. I have had 3 MB cars and never had any issue with a dealer. All helpful and happy to do the work as it costs them nothing, it is underwritten and paid for by the factory who have a budget for such things. I used to work for a certain British maker of luxury vehicles and we allocated .5% of revenue to warranty.
Harold1898 is offline  
Old 06-06-2012, 05:07 PM
  #20  
MBWorld Fanatic!
 
SonnyakaPig's Avatar
 
Join Date: Aug 2010
Posts: 2,494
Likes: 0
Received 0 Likes on 0 Posts
MB
Originally Posted by crazy1469 View Post
that's what i though that i would be taken care, specially being a mercedes and an AMG.....WRONG!!! the are no better than any other manufactor....always trying to get out of paying for anything under warranty.....
i am a cert automotive tech, i know the drill if a car came in with a trans problem, you know it aint going to fix it, but you sell the costumer that already spent a **** load of money to buy the car, you sell him a $600 tranny flush, and then a week later he comes back with the same problem because a fluid flush is not gonna fix ****, then the will replace what needs to be replaced....so as per manufactor reccomended maintnace shedule, a trans service is not deu untill 60k...my car only has 42k...so i told them to put the car together with no flush, and when the tranny drops they will then have no choice but to replace it...or will they try to sell me a flush then too????

ohh and the service adviser told me that they can see that the car has been driven "HARD"....i replied...ofcorse if i wanted to drive it normal i would have bought a C250 and not a C63....****in rediculous....stuff like this makes my blood boil.
I really feel for you. I have the same experience with MB. They don't want to fix anything unless the problem is undeniable. And I agree, it would be very upsetting to hear that you have driven your car hard when the car is marketed to enthusiasts that like to drive. It's a very strange thing with MB, they like to sell performance cars but they don't want you to use the performance. If I told you have the **** I've heard from MB, you would know I understand where you're coming from.
SonnyakaPig is offline  
Old 06-06-2012, 05:22 PM
  #21  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Originally Posted by SonnyakaPig View Post
I really feel for you. I have the same experience with MB. They don't want to fix anything unless the problem is undeniable. And I agree, it would be very upsetting to hear that you have driven your car hard when the car is marketed to enthusiasts that like to drive. It's a very strange thing with MB, they like to sell performance cars but they don't want you to use the performance. If I told you have the **** I've heard from MB, you would know I understand where you're coming from.
i just got a call from the service manager and he told me that they are going ahead with the tranny service, and if that does not solve the issue that they will swallow the cost of it.
the problem is the most costumers don't know their rights...so you get taken advantage of...
crazy1469 is offline  
Old 06-06-2012, 05:24 PM
  #22  
Member
Thread Starter
 
crazy1469's Avatar
 
Join Date: Aug 2011
Location: toronto ontario
Posts: 145
Likes: 0
Received 0 Likes on 0 Posts
2010 C63
Originally Posted by Harold1898 View Post
sorry to hear that. It is a bit different over here. I have had 3 MB cars and never had any issue with a dealer. All helpful and happy to do the work as it costs them nothing, it is underwritten and paid for by the factory who have a budget for such things. I used to work for a certain British maker of luxury vehicles and we allocated .5% of revenue to warranty.
that is how it should be....you already pay enough money for the car, and that's why the have warranty...i bet any money that if the car was outside of warranty the would try to sell me a new transmission even before knowing whats wrong with it lol.
crazy1469 is offline  
Old 06-06-2012, 05:26 PM
  #23  
MBWorld Fanatic!
 
SonnyakaPig's Avatar
 
Join Date: Aug 2010
Posts: 2,494
Likes: 0
Received 0 Likes on 0 Posts
MB
Originally Posted by crazy1469 View Post
i just got a call from the service manager and he told me that they are going ahead with the tranny service, and if that does not solve the issue that they will swallow the cost of it.
the problem is the most costumers don't know their rights...so you get taken advantage of...
I'm glad to hear they are working with you. That's a positive.

Keep us updated.
SonnyakaPig is offline  
Old 08-10-2012, 11:45 PM
  #24  
MBWorld Fanatic!
 
Sincity's Avatar
 
Join Date: Feb 2003
Location: Vegas and Vancouver, BC
Posts: 5,945
Received 6 Likes on 6 Posts
.
So, did the service solve your problem?
Sincity is offline  
Old 08-22-2012, 11:57 AM
  #25  
Member
 
Join Date: Aug 2006
Location: Orange County, CA
Posts: 107
Likes: 0
Received 0 Likes on 0 Posts
2009 C63 AMG Steel Gray
I just yesterday experienced a very strange shift experience in my '09 C63. From a stop in a straight line I leaned on the accelerator pretty hard through second, and then let off the gas right around probably 6K RPM (when I expected it to shift to 3rd). I heard a loud engine/tranny sound and it very harshly (in a slowing manner, not accelerating) shifted the vehicle to 3rd. I quickly looked down and saw the hazard triangle (the one that flashes during ESP engagement) flash twice.

I was on dry flat pavement, and it was not a situation where there should have been any tire spin (especially since I was off the gas).

At this point I was already slowing down. I didn't get any CEL and the car was running fine after that, but the shift does concern me. It's not something a car should ever do. Has anyone seen this as a reproducible issue?
OCJeff is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Transmission shifting problems


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: