Go Back  MBWorld.org Forums > Mercedes-Benz Coupes & Cabriolets > CLS Coupe (C218)
Bluetooth sound quality issues? >

Bluetooth sound quality issues?

Notices

Bluetooth sound quality issues?

 
Old 03-27-2012, 12:21 AM
  #1  
Junior Member
Thread Starter
 
Ohji's Avatar
 
Join Date: Jul 2011
Location: Portland, OR
Posts: 73
Likes: 0
Received 2 Likes on 1 Post
2012 CLS550 4MATIC
Bluetooth sound quality issues?

Hi all,

I live in Oregon, and our highways are loud, loud, LOUD! I have never experienced highways so loud before. The roads are very uneven, creating a lot of road noise in the cabin when on the freeway, and I have found that no one can hear me when I use the bluetooth in the car. I have to repeat myself over and over, and the callers on the other end say they hear loud noises and that my voice sounds garbled and indistinct. I called my parents once when I was on the freeway while it was raining, and they thought I was inside a blender. I would simply attribute this to the noise of the rain/road, but my previous TL's Bluetooth sound quality was infinitely better. Also, if I hold my phone in my lap and use the speakerphone, everyone says it sounds a lot better.

Is MB's Bluetooth system just poorly designed, or do I have a potentially fixable issue?
Ohji is offline  
Old 03-29-2012, 07:21 PM
  #2  
Junior Member
Thread Starter
 
Ohji's Avatar
 
Join Date: Jul 2011
Location: Portland, OR
Posts: 73
Likes: 0
Received 2 Likes on 1 Post
2012 CLS550 4MATIC
I'm assuming that since no one replied, I am the only one with sound quality issues.

Anyway, just an update. I went to the engineering menu to see if there was a gain setting or anything that might explain my sound quality woes, and I found a setting in the telephone menu under SW settings that was something like "EC/NR." It was set as "Deact" so I changed it to active, and it seems like the quality is better now. I'm assuming EC/NR is "error correction/noise reduction" and I am surprised it was deactivated.

Anyway, I have yet to drive back on our loud highways in the rain, so I haven't fully tested the change, but I'll report back if it turns out that this is not the solution.

If anyone happens to be in the engineering mode, I'd be curious to know what your EC/NR setting is.
Ohji is offline  
Old 03-30-2012, 02:59 AM
  #3  
Senior Member
 
Join Date: Apr 2002
Location: Los Angeles, Ca
Posts: 311
Likes: 0
Received 0 Likes on 0 Posts
2012 CLS 550
If you want to let me know how you got into that engineering mode I will tell you tomorrow when I get my car back. My bluetooth audio calls are not that great either
tmushy is offline  
Old 03-30-2012, 04:21 AM
  #4  
Junior Member
 
Join Date: Dec 2011
Location: Oakland
Posts: 31
Likes: 0
Received 2 Likes on 1 Post
Cls550
Quote:
Originally Posted by Ali_E55
push these inputs in middle console (hang up phone button) + 1 + # the same time. you will be in engineering mode.

in engineering mode press ( hang up phone button ) + 4 + # the same time . you will be in another menu.

check the version in one of these menus.

you can also change some settings. __________________
Klanse is offline  
The following 2 users liked this post by Klanse:
Jan AMG (07-07-2019), Tbbt CLS (03-10-2019)
Old 03-30-2012, 01:02 PM
  #5  
Junior Member
Thread Starter
 
Ohji's Avatar
 
Join Date: Jul 2011
Location: Portland, OR
Posts: 73
Likes: 0
Received 2 Likes on 1 Post
2012 CLS550 4MATIC
Exactly as Klanse stated above, except you don't have to go into the second menu. Once you do the "hangup + pound + 1" for about 10 seconds, a menu will appear. Select SW options, then telephone info (or something like that), and you will see the setting for the EC/NR.
Ohji is offline  
The following 2 users liked this post by Ohji:
Jan AMG (07-07-2019), Tbbt CLS (03-10-2019)
Old 02-14-2019, 07:36 PM
  #6  
Newbie
 
Join Date: Feb 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
S212 e350 wagon
Reviving an old thread....
I just wanted to thank you for this great advice. My handsfree was essentislly useless till today. The missus confirmed that its a huge improvement.

The local mb dealer appears to be unaware of this setting. And why was it set this way to begin with???

Thanks again!
Windwagen is offline  
Old 03-08-2019, 03:20 AM
  #7  
haa
Member
 
Join Date: Feb 2006
Posts: 115
Received 49 Likes on 37 Posts
Anyone know how to get into engineering mode with the newer command modules that have no numerical buttons in the center console?
haa is offline  
Old 03-09-2019, 10:44 AM
  #8  
haa
Member
 
Join Date: Feb 2006
Posts: 115
Received 49 Likes on 37 Posts
Found it!

haa is offline  
Old 03-25-2019, 07:29 AM
  #9  
Junior Member
 
wmkizer's Avatar
 
Join Date: Aug 2018
Location: Nomadic
Posts: 33
Received 1 Like on 1 Post
2015 CLS550C4 (C218)
I'm going to my dealer this Wednesday (27 March). I had upgraded my CLS Comand to the 14U Smartphone integration package and ever since, my Bluetooth quality had gone downhill.

Thank you for this!
wmkizer is offline  
Old 03-27-2019, 10:57 AM
  #10  
Out Of Control!!
 
konigstiger's Avatar
 
Join Date: Jul 2003
Location: North Scottsdale, AZ
Posts: 10,374
Received 1,162 Likes on 979 Posts
'71 Pinto
Originally Posted by wmkizer
Would there be a "Service Sheet for Mercedes-Benz System (USA)" for the 2015 C218 CLS550 that I could trouble you for?
See attachment.
Attached Files
File Type: pdf
15 CLS.pdf (152.6 KB, 44 views)
konigstiger is offline  
Old 03-27-2019, 11:57 AM
  #11  
Junior Member
 
wmkizer's Avatar
 
Join Date: Aug 2018
Location: Nomadic
Posts: 33
Received 1 Like on 1 Post
2015 CLS550C4 (C218)
Originally Posted by konigstiger View Post
See attachment.
Hot Dog! Thank you very much..

Bill
wmkizer is offline  
Old 04-19-2019, 10:20 AM
  #12  
Junior Member
 
wmkizer's Avatar
 
Join Date: Aug 2018
Location: Nomadic
Posts: 33
Received 1 Like on 1 Post
2015 CLS550C4 (C218)
Originally Posted by wmkizer View Post
I'm going to my dealer this Wednesday (27 March). I had upgraded my CLS Comand to the 14U Smartphone integration package and ever since, my Bluetooth quality had gone downhill.

Thank you for this!
Ok I went to the dealer and they dicovered there was a Comand update to the fire=mware which they performed and they confirmed all noise cancelation was activated for the bluetooth so its night and day difference now. Thank you for this info...

Only negative now is when I connect via carplay, the volume is now reduced for phone calls. So next time I go for service I'll ask them to check on that.
wmkizer is offline  
Old 07-07-2019, 03:17 PM
  #13  
MBWorld Fanatic!
 
Jan AMG's Avatar
 
Join Date: Apr 2009
Location: Autobahn
Posts: 1,316
Received 74 Likes on 63 Posts
S63, CLS63S, 500SE
Great info, thanks.
Jan AMG is online now  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Bluetooth sound quality issues?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: