Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W210)
Sorting out E320 stalling problem >

Sorting out E320 stalling problem

Notices
E-Class (W210) 1995-2002: E 200, E 220D, E 240, E 290TD, E 300TD, E 200, E 240, E 280, E 320, E 420, E 430 (Wagon, Touring, 4Matic)
Old 06-15-2015, 02:47 PM
How-Tos on this Topic
Last edit by: IB Advertising
See related guides and technical advice from our community experts:

Browse all: Engine Diagnostics
Print Wikipost

Sorting out E320 stalling problem

 
Old 06-09-2014, 03:06 PM
  #76  
Newbie
 
Join Date: Jun 2014
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
2004 Mercedes-Benz E-Class
What is MAF?

Originally Posted by BlownV8 View Post
Probably a bad MAF. It will get progressively worse with time.
I have 2004 model E320 with same problem:intermittent shutdown at stop idle.
What should I do? Thanks for your help.
kevincdc is offline  
Old 06-10-2014, 01:29 PM
  #77  
Newbie
 
Thomas O'Keeffe's Avatar
 
Join Date: Jun 2014
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
2003 Mercedes e320
2003 e320 stalling

Have a 2003 e320 stuttering when idle, rpm dropping,, need to accelerate to keep it going,, stalls occasionally, drives perfectly apart from this issue, always starts,, any ideas?
Thomas O'Keeffe is offline  
Old 07-28-2014, 10:13 AM
  #78  
Newbie
 
Join Date: Jul 2014
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
2001 Mercedes Benz E 320
Hey folks im new and I was trying to figure out my problem is on my 2001 e 320 it cranks but no start unless I use starting fluid ounce it cranks the motor idles perfect until I press the gas I have a missfire on the right side of the motor it never goes over 3k rpm and it drops down in rpms as if it wants to cutt off and the check engine light flashes I have new spark plugs, wires, fuel pump, and front o2 sensors but my battery is on its last ride can anyone please help ?????
bchi205 is offline  
Old 07-10-2016, 12:00 AM
  #79  
Junior Member
 
ahmedhossame's Avatar
 
Join Date: Aug 2014
Posts: 59
Received 0 Likes on 0 Posts
1999 E320
Originally Posted by bchi205 View Post
Hey folks im new and I was trying to figure out my problem is on my 2001 e 320 it cranks but no start unless I use starting fluid ounce it cranks the motor idles perfect until I press the gas I have a missfire on the right side of the motor it never goes over 3k rpm and it drops down in rpms as if it wants to cutt off and the check engine light flashes I have new spark plugs, wires, fuel pump, and front o2 sensors but my battery is on its last ride can anyone please help ?????
Can you perform a compression test on each cylinder and report the pressure on each cylinder?
ahmedhossame is offline  
Old 07-10-2016, 12:02 AM
  #80  
Junior Member
 
ahmedhossame's Avatar
 
Join Date: Aug 2014
Posts: 59
Received 0 Likes on 0 Posts
1999 E320
I have a 99 E320 stalling when hot operating temp and then hard start up. I'm going to replace crank position sensor CPS and mass air flow sensor MAF and possibly camshaft position sensor.

If that doesn't fix I will be pointing fingers towards bad ECU. Any other ideas?
ahmedhossame is offline  
Old 07-10-2016, 12:04 AM
  #81  
Junior Member
 
ahmedhossame's Avatar
 
Join Date: Aug 2014
Posts: 59
Received 0 Likes on 0 Posts
1999 E320
Originally Posted by nelson76 View Post
I have a problem on a 1997 E320 it cranks and runs for 20 seconds the most then dies,usually it's more like 2 seconds running,i changed out the cps and it started and ran for almost a minute then just died again,i have fuel pressure and no codes,weird thing is if i step on the gas it instantly dies also i took off the MAF and it looks clean,left the MAF off and started the engine while blocking the intake hose and it ran for as long as i blocked the intake hose,anyone have any ideas?
Have you figured out what went wrong?
ahmedhossame is offline  
Old 07-11-2016, 01:06 PM
  #82  
Senior Member
 
Join Date: Aug 2010
Posts: 342
Likes: 0
Received 2 Likes on 2 Posts
2005 S55
I suggest CPS and possibly throttle position sensor...I had to replace the throttle body on my 2002 e430 and it has ran perfectly since..over a year.
Mike
mrbenzes is offline  
The following users liked this post:
ahmedhossame (07-11-2016)
Old 07-11-2016, 01:09 PM
  #83  
Junior Member
 
ahmedhossame's Avatar
 
Join Date: Aug 2014
Posts: 59
Received 0 Likes on 0 Posts
1999 E320
Originally Posted by mrbenzes View Post
I suggest CPS and possibly throttle position sensor...I had to replace the throttle body on my 2002 e430 and it has ran perfectly since..over a year.
Mike
I have ordered new CPS, MAF and just found that the ECU cooling fan is not working. So I'll need to order a new ECU cooling fan as well.

I'm looking into replacing fuel filter due to the age of the car.

I can see that the throttle position sensor car shut the car off, but my car shuts off when it reaches hot operating temp only.
ahmedhossame is offline  
Old 07-11-2016, 04:05 PM
  #84  
MBWorld Fanatic!
 
Join Date: Nov 2012
Posts: 4,945
Likes: 0
Received 579 Likes on 450 Posts
A gaggle of MB's
Please understand - with the "age" of this thread you would be better served in the future to start as new thread.

1) Then your "issue" most likely is to replace CPS sensor - key failure symptom is engine "cuts off" when hot, and long-hard-starting/or-no-start whem warm - then when "cold" no problem.

Replace CPS sensor with genuine Bosch CPS ONLY - and verify type (one-prong vrs 2-prong) by pulling old sensor and looking at connector type before ordering new genuine Bosch sensor.

2) Fuel filter - replace with genuine Bosch or Mann ONLY - the filter has a presure regulation function and other non/quasi-brand fuel filters generally can be poor on this critical function.

3) TPS sensor failure would have entirely different symptoms that you did not seem to have.

Keep the beat !
fabbrisd1 is offline  
The following users liked this post:
ahmedhossame (07-11-2016)
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Sorting out E320 stalling problem


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: