Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W213)
Live traffic not working and MBrace support useless >

Live traffic not working and MBrace support useless

Notices
E-Class (W213) 2016 -

Live traffic not working and MBrace support useless

 
Old 08-01-2018, 04:10 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Live traffic not working and MBrace support useless

Hi, I have a 2017 E300. My live traffic stopped working today. While the "Live Traffic" indicator shows up, the actual live traffic on the roads doesn't. MB support said the car has to be returned to the dealer for a software update. Crazy thing is - I had it in for the 20k service a few weeks ago. Has anybody else had a similar issue?
bizinsider is offline  
Old 08-02-2018, 08:46 AM
  #2  
Junior Member
 
Join Date: Dec 2015
Posts: 41
Likes: 0
Received 10 Likes on 9 Posts
2017 E300, 2019 GLC 300
Originally Posted by bizinsider View Post
Hi, I have a 2017 E300. My live traffic stopped working today. While the "Live Traffic" indicator shows up, the actual live traffic on the roads doesn't. MB support said the car has to be returned to the dealer for a software update. Crazy thing is - I had it in for the 20k service a few weeks ago. Has anybody else had a similar issue?
I have noticed this occasionally - typically early morning on my commute, later in the day all is fine, my sense in my case is it has to do with the traffic provider and not the vehicle
knoppe01 is offline  
Old 08-02-2018, 12:07 PM
  #3  
Senior Member
 
Join Date: Nov 2017
Location: Hermosa Beach, California
Posts: 250
Received 21 Likes on 20 Posts
2018 E400 Coupe
Originally Posted by bizinsider View Post
Hi, I have a 2017 E300. My live traffic stopped working today. While the "Live Traffic" indicator shows up, the actual live traffic on the roads doesn't. MB support said the car has to be returned to the dealer for a software update. Crazy thing is - I had it in for the 20k service a few weeks ago. Has anybody else had a similar issue?
I've also seen a couple of instances of this recently, generally during my morning drives.
The_Judge is offline  
Old 08-02-2018, 12:07 PM
  #4  
Newbie
 
Join Date: Sep 2014
Posts: 8
Received 16 Likes on 5 Posts
E63, 335d, C250
Same here - I've called Mbrace 3 times over a 40 day period. I believe the ROOT cause for Live Traffic not working is due to the car's built-in internet not starting after you turn the car on. You can prove this theory the next time Live Traffic fails to start by browsing over to the built-in weather app (or any webpage) in COMMAND. You'll see that there is NO internet connectivity. I notice it failing to start-up 2-3 days a week, usually mornings. I was told by Mbrace that I need to take the car in for service and have the system "reset" then upgraded. Interestingly, it WAS upgraded 5 months ago during the last service. I have a 2018 E400 (coupe).

Last edited by Benz44; 08-02-2018 at 12:09 PM. Reason: Add my model
Benz44 is offline  
The following users liked this post:
Cambridgehank (09-08-2018)
Old 08-02-2018, 01:37 PM
  #5  
MBWorld Fanatic!
 
ua549's Avatar
 
Join Date: Nov 2014
Location: Clearwater, Florida
Posts: 2,244
Received 242 Likes on 205 Posts
.
I've never had the car fail to connect to the internet except when there was no cell service of any kind available such as within a steel parking building. In the US a blue 4G indicator light in the upper right of the center display turns on when connected.
ua549 is offline  
Old 10-06-2018, 01:44 PM
  #6  
Newbie
 
Join Date: Oct 2018
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
MB E300
Originally Posted by bizinsider View Post
Hi, I have a 2017 E300. My live traffic stopped working today. While the "Live Traffic" indicator shows up, the actual live traffic on the roads doesn't. MB support said the car has to be returned to the dealer for a software update. Crazy thing is - I had it in for the 20k service a few weeks ago. Has anybody else had a similar issue?
Yes, I have a 2017 E300 as well. I've noticed this problem over the past few weeks. In my frustration, yesterday I took it to the MB dealer and they're thinking it might need a software update. I'm scheduled to do that on Monday. We will see if that provides the solution to the "Most advanced vehicle in the world."

I should also add that this is my 6th MB. It is by far the most technologically advanced car I've ever owned. It also has the worst navigation system I've ever owned. It constantly instructs me to leave the freeway, go to an intersection, make a u-turn, and return to the freeway I just left. It is just horrible in its accuracy. Once, it asked me to drive 40 miles out of my way to get to my home destination. When it instructed me to take the route, I told myself there is NO WAY that I'm going to take that route as it makes absolutely zero sense. Instead, I continued on the more direct route I was on and saved myself an extra hour of driving. Mercedes needs to do MUCH better as many "lesser" cars have vastly superior Nav systems.

Further, the hardware processor on the Comand system is woefully slow. I find myself hitting a command more than once thinking that it didn't "take." What actually happened is the processor just works very slowly. It's frustrating.

Last edited by Marty Johnson; 10-06-2018 at 01:51 PM.
Marty Johnson is offline  
Old 10-06-2018, 01:55 PM
  #7  
Newbie
 
Join Date: Oct 2018
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
MB E300
The traffic provider is SiriusXM. If it's them then MB should change how they provide traffic. I've not seen ANY other system have this problem other than Mercedes. As far as I'm concerned, it's their car; their problem. It will be clearly demonstrated that it's their problem when my lease is up and I move to Tesla or Lexus!
Marty Johnson is offline  
Old 10-06-2018, 02:15 PM
  #8  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Can't wait to hear if the update fixes it. I cancelled an appointment for the update after the traffic started working - only to have it crash so frequently now that I figure it's a broader, system-wide problem. That said, the new Google Maps on Car Play is a winner and a great substitute. If only it was wireless!!!
bizinsider is offline  
Old 10-10-2018, 10:51 AM
  #9  
Newbie
 
Join Date: Oct 2018
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
MB E300
Originally Posted by bizinsider View Post
Can't wait to hear if the update fixes it. I cancelled an appointment for the update after the traffic started working - only to have it crash so frequently now that I figure it's a broader, system-wide problem. That said, the new Google Maps on Car Play is a winner and a great substitute. If only it was wireless!!!
I took my E300 to Walter's Mercedes in So Cal. They did a thorough diagnostic to determine why the Live Traffic works intermittently. According to them, the hardware in the car is working perfectly. They suggested that the problem must be with SiriusXM. They said that on occasion the car is not receiving the signal and that is the source of the problem. My response to them was if it is a temporary problem with getting the signal, why would it not pick up the SiriusXM signal on a 60 mile drive? Further, it signal was refreshed numerous times along the route and still no Live Traffic. They didn't know the answer.

This is totally unacceptable from Mercedes. Frankly, I don't care if the source of the problem is SiriusXM. As far as I'm concerned, it's still Mercedes Benz' problem as they provide the car to me with a system that doesn't work properly. This is my 6th E-Class and I've never had a problem with my previous models with receiving Live Traffic. It's up to Mercedes to find a third party provider for Live Traffic that is more reliable. I don't appreciate MB throwing up their hands claiming there is nothing they can do. For a luxury car costing premium money my expectations are higher than they're delivering.

This will loom large when my my lease runs out next year. It will encourage me to look elsewhere for my next lease. Perhaps Lexus or Tesla.
Marty Johnson is offline  
Old 10-10-2018, 11:36 AM
  #10  
MBWorld Fanatic!
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,428
Received 294 Likes on 240 Posts
2019 E450 4Matic & 2018 E400 4Matic
Did you contact SiriusXM to see if they have any solution for you?
rbrylaw is offline  
Old 10-10-2018, 01:16 PM
  #11  
MBWorld Fanatic!
 
ua549's Avatar
 
Join Date: Nov 2014
Location: Clearwater, Florida
Posts: 2,244
Received 242 Likes on 205 Posts
.
I've never had an issue with live traffic, however I have a paid (12 for $60) SiriusXM subscription.
ua549 is offline  
Old 10-15-2018, 03:48 PM
  #12  
Newbie
 
Join Date: Oct 2018
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
e300
Funny... I just wrote that Sirius cancelled my traffic subscription, although per Mercedes its supposed to be included for 5 years.
sb45 is offline  
Old 10-15-2018, 03:51 PM
  #13  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Something is not adding up here. My traffic is spottier by the day. I have Sirius - and the five year live traffic, which I thought was provided by MB, not Sirius. Makes zero sense and the few of us cannot be the only ones to notice this.
bizinsider is offline  
Old 10-15-2018, 04:06 PM
  #14  
Newbie
 
Join Date: Oct 2018
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
e300
I just called the complaint into MB Corp. The say they are going to look into the problem. I guess we are the only ones Sirius is doing this to?
sb45 is offline  
Old 10-15-2018, 04:15 PM
  #15  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Keep us in the loop, if you don't mind. I've had zero success w/MB.
bizinsider is offline  
Old 10-16-2018, 12:03 PM
  #16  
Newbie
 
Join Date: Oct 2018
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
e300
Arrow answers for no traffic service

Originally Posted by bizinsider View Post
Hi, I have a 2017 E300. My live traffic stopped working today. While the "Live Traffic" indicator shows up, the actual live traffic on the roads doesn't. MB support said the car has to be returned to the dealer for a software update. Crazy thing is - I had it in for the 20k service a few weeks ago. Has anybody else had a similar issue?
I reached out to MB HQ customer service. They didn't know about issues with live traffic, but did investigate. Since 2017, MB dropped Sirius and it is now part of Embrace. They suggest pushing on its button in the car, and ask them to see whats wrong with their service.
sb45 is offline  
Old 10-16-2018, 12:06 PM
  #17  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Been there, done that. Left hand doesn't know what the right hand is doing. I know run-arounds when I see them and this is the ultimate run-around. Google Maps on Car Play is my new default.
bizinsider is offline  
Old 10-16-2018, 04:36 PM
  #18  
Newbie
 
Join Date: Mar 2018
Posts: 12
Likes: 0
Received 1 Like on 1 Post
2018 E43 AMG || 2018 Porsche GT3
Just chiming in. 2018 E43 here. On the command software from the factory. Live traffic is very intermittent. I'd say on 15-20% of my trips it doesn't work at all. Something tells me it times out on the initial connection and just never retries... because when it doesn't work it stays not working until the next hard rest of the car (4 hours parked). Pretty bad software writing if that's the case...
midwestamv8 is offline  
Old 10-16-2018, 04:38 PM
  #19  
MBWorld Fanatic!
 
ua549's Avatar
 
Join Date: Nov 2014
Location: Clearwater, Florida
Posts: 2,244
Received 242 Likes on 205 Posts
.
You can reboot COMAND using the on/off switch on the console.
ua549 is offline  
Old 10-16-2018, 04:41 PM
  #20  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Originally Posted by ua549 View Post
You can reboot COMAND using the on/off switch on the console.
I've tried it all - nothing works. Sometimes it works, sometimes it doesn't. Used to be very consistent. Adding insult to injury - when I call Mbrace they say I need to pay for the concierge service to troubleshoot it. I told them that's nonsense b/c plenty of people have this issue. My dealer said just yesterday they're hearing the Sirius issue. Who knows, but I think MB customers deserve better than this, certainly a good, honest answer.
bizinsider is offline  
Old 10-16-2018, 05:50 PM
  #21  
Newbie
 
Join Date: Oct 2018
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
e300
Av update

I’ve spent over an hour on the phone with their customer assistance trying to get traffic to work. I found out other things, like remote start, were also not working. They claim there should have been an update done, and they are attempting to do it. My dealer, Viti, did not even know about the update, so they are bringng it in. The other issue I found out about is that electrical issue in the 2017 E300 can short out some of the transmission features. The internet also does not work. I’ve had two instances when the car would not start, even though lights and everything else was working. I think they need to replace the electrical system in the car.
Fyi I also had an issue with the car brake dust being ridiculously heavy, when I got the car. They eventually changed the pads and the issue went away.
This E is an exciting car, but obviously has some issues.

Last edited by sb45; 10-17-2018 at 11:40 AM.
sb45 is offline  
Old 10-16-2018, 07:09 PM
  #22  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Originally Posted by sb45 View Post
Iíve spent over an hour on the phone with their customer assistance trying to get traffic to work. I found out other things, like remote start, were also not working. They claim there should have been an update done, and they are attempting to do it. My dealer, Viti, did not even know about the update, so they are brining it in. The other issue I found out about is that electrical issue in the 2017 E300 can short out dime of the transmission features. The internet also does not work. Iíve had two instances when the car would not start, even though lights and everything else was working. I think they need to replace the electrical system in the car.
Fyi I also had an issue with the car brake dust being ridiculously heavy, when I got the car. They eventually changed the pads and the issue went away.
This E is an exciting car, but obviously has some issues.
I hadn't tried the remote start - first it failed, then it started and stopped; tried again, same thing - message said there are issues. Seems you are onto something.
bizinsider is offline  
Old 10-27-2018, 06:59 PM
  #23  
Newbie
 
Join Date: Oct 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
e300 2017
Angry Traffic provider is TomTom not Sirius

I have E-300 2017. The Live Traffic provider is TomTom. In the Navigation Menu you can find the license information. It doesn't work, and it is a shame that MB is partner with such a bad company. MB support doesn't have a clue, which is unbelievable . Top models with such problems.

E-300 2017 TomTom Live Traffic provider.
eltatum is offline  
Old 10-27-2018, 07:02 PM
  #24  
Junior Member
Thread Starter
 
Join Date: Aug 2016
Location: San Diego, CA.
Posts: 44
Likes: 0
Received 2 Likes on 2 Posts
2017 e300
Oh, that's very interesting. I'll check it out. But I will say I took my car into the dealer to get a closer read on this. They claimed a control unit has to be replaced - which is happening this week. I will provide an update.
bizinsider is offline  
Old 10-27-2018, 07:02 PM
  #25  
Newbie
 
Join Date: Oct 2018
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
e300 2017
Many issues indeed. Command restart in the middle of the road, no live traffic, half of the lights on, really a shame MB puts ouy a car with such problems. Internet doesn't work...etc.
eltatum is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 5.00 average.

Quick Reply: Live traffic not working and MBrace support useless


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: