ML320 - Key fob issue - start error after battery change - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > M-Class (W163)
ML320 - Key fob issue - start error after battery change > ML320 - Key fob issue - start error after battery change
Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

ML320 - Key fob issue - start error after battery change

Reply

 
 
Old 02-07-2011, 09:08 PM
  #1
Newbie
Thread Starter
 
Join Date: Nov 2008
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
ml320
ML320 - Key fob issue - start error after battery change

Long and short.

Battery was on the fritz. Bought a new battery from Mercedes. Change the battery.

Started the car, put the key in the ignition- then got start error.
Car would turn but then stop right after.
Tried my other fob, same error.

Detached the battery, let it sit for 5 mins.

Put the key in and no more start error. Car turned, no problem.

Tried the other fob, and i still get the start error. Car would not turn.

Any thoughts?

I took it to Mercedes and they said I need a new fob. Not sure why. The broken fob can still lock/ unlock the doors.

Please help. A new fob in Canada costs $250. RIP OFF.
boomie is offline  
Reply With Quote
Old 02-08-2011, 08:32 AM
  #2
Junior Member
 
Geno777's Avatar
 
Join Date: Dec 2010
Location: Lake Ariel Pa.
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
2000/ML320 2005/Subaru Baja
Originally Posted by boomie View Post
Long and short.

Battery was on the fritz. Bought a new battery from Mercedes. Change the battery.

Started the car, put the key in the ignition- then got start error.
Car would turn but then stop right after.
Tried my other fob, same error.

Detached the battery, let it sit for 5 mins.

Put the key in and no more start error. Car turned, no problem.

Tried the other fob, and i still get the start error. Car would not turn.

Any thoughts?

I took it to Mercedes and they said I need a new fob. Not sure why. The broken fob can still lock/ unlock the doors.

Please help. A new fob in Canada costs $250. RIP OFF.

I don't know what a fob is, however when i change a battery on a car that has a radio that has to be reprogrammed with a battery change. I hook up my jumper battery to the cabels BEFORE I disconnect it and then change the battery, put the cables back on the battery then disconnect the jumper battery. Works like a charm, Jumper battery @ harb. fret. around $50.00 USD.
Geno777 is offline  
Reply With Quote
Old 02-10-2011, 10:06 AM
  #3
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Thanks: 0
Thanked 0 Times in 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
Mike's ML is offline  
Reply With Quote
Old 02-11-2011, 08:24 PM
  #4
Junior Member
 
c3212571's Avatar
 
Join Date: Sep 2010
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
2002 Mercedes c32 1998 Toyota tacoma 2002 Honda Cbr600f4i
Sounds like craks sensor going bad. or is bad!
!!!!!!!!!!!!always change tranny fluid!!!!!!!!!!!! on ML's!!!!!!!!!!!!
c3212571 is offline  
Reply With Quote
Old 02-12-2011, 11:28 AM
  #5
Senior Member
 
Join Date: Jul 2004
Location: New England
Posts: 260
Thanks: 0
Thanked 0 Times in 0 Posts
1990 190E 2.6, ... 1998 ML320, 2005 ML500SE
Originally Posted by c3212571 View Post
Sounds like craks sensor going bad. or is bad!
!!!!!!!!!!!!always change tranny fluid!!!!!!!!!!!! on ML's!!!!!!!!!!!!
The CPS has different fault characteristics than indicated by the OP.
It is more likely the AAM/DAS key failure.

I have unfortunately experienced both failures in my 98ML.

There is a problem with jump starting the early ML's. If you leave the key in the ignition when trying multiple restarts it will render the key useless.
The Key's RFID chip has lost synchronization with the DAS (Drive Authorizing System). The only fix is to buy a new key and have it programmed into the AAM computer which contains the DAS. For some reason the old key can no longer be programmed into the DAS. Some refer this as Frying the key's RFID chip.
The 98ML's came with 3 keys. Did you try one of the other keys? They should still work.
The AAM can only be programmed with 8 keys maximum so I hope you still have one of the 5 remaining programming spaces left if you need a new key. If not a new AAM is very expensive. This can only be done at a Mercedes dealer.

In the future if the ML does not start, immediately REMOVE the key from the vehicle, charge the vehicles battery, than return the key to the vehicle and attempt another restart.

The Remote's battery has no function in an RFID DAS system. It's only for the remote entry & alrm system.

Good luck.
Mike
Mike's ML is offline  
Reply With Quote
Old 02-14-2011, 05:43 PM
  #6
Member
 
cmitch's Avatar
 
Join Date: Sep 2006
Location: Heart of Dixie
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
2002 ML320, 2006 ML350
A Start Error is most likely the DAS is fried. I've not known of a case where a bad key gave the start error but I could be wrong. The fact you got a start error on BOTH keys at first, then a start error just on one, tells me it's the DAS which is apart from the AAM in 2000 and up models. The fact you get a Start Error on the dash tells me you have a 2000 or up, right?

Please complete your profile and tell us what year model you have. It makes a HUGE difference.
cmitch is offline  
Reply With Quote
Old 08-19-2013, 12:06 PM
  #7
Newbie
 
mbenzml350's Avatar
 
Join Date: Aug 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
ml350
Hello, I have an '05 ML350 and when I went to start it up, it ran for five second and it cut off, I don't know what the problem is, and now, not even the remote to lock and unlock doesn't work. I need help. Thanks
mbenzml350 is offline  
Reply With Quote
Old 09-08-2014, 04:10 AM
  #8
Newbie
 
Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
ML270
This is done buy virgin the MCU inside the ECU. and than make initial startup with DAS
ssemmedo is offline  
Reply With Quote
Old 10-18-2014, 04:05 AM
  #9
Newbie
 
Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
ML270
anothre way to do it is to take all data from DAS and make new transponder with tango or similar tools.
ssemmedo is offline  
Reply With Quote
 
 
 

Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dmitry_sorokin
Mercedes Tech Talk
12
10-10-2017 08:02 AM
PizzaQuixote
Mercedes Tech Talk
8
10-08-2017 07:01 PM
IMEX1PCT
S-Class (W221)
2
06-29-2017 11:17 PM
OrginalBigDaddy
New Members Check In!
2
09-02-2015 11:57 AM
marc hanna
Mercedes Vehicles
0
09-02-2015 08:16 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 1 votes, 4.00 average.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:50 AM.


Copyright 2001-2012 InternetBrands, Inc. / MBWorld.org. All Rights Reserved.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:
You Rated this Thread: 4